> Tous les forums > Forum Linux
 Pas de connexion Wifi après installation Linux Mint 17.1Sujet résolu
Ajouter un message à la discussion
Pages : [1] 2 3 ... Fin
Page 1 sur 3 [Fin]
TANT PIS
  Posté le 05/01/2015 @ 22:03 
Aller en bas de la page 
Petit astucien

Bonsoir et Bonne et Heureuse Année à Toutes et Tous .

Je viens d'installer Mint 17.1 en remplacement de la version 16 . Tout s'est bien passé sauf que la connexion wifi est inactive ....

Au début de l'an 2014 j'avais installé Handy Linux pour remplacer Windows XP et j'avais eu ce même problème du à la carte Broadcom et sur le forum Handy Linux il y avait des manips qui avaient résolu le problème ... Ensuite et jusqu'à ce jour j'avais Mint 16 et tout fonctionnait bien en trio avec Windows XP .

J'ai essayé plusieurs astuces mais rien n'y fait dont celles utilisées avec Handy Linux ?

Merci aux utilisateurs Mint pour leurs conseils . Bonne soirée .

Ordinateur Acer 3003 WLMI

Publicité
Logicien
 Posté le 05/01/2015 à 22:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut/Bonjour/Bonsoir,

comme point de départ, affiche la sortie dans un terminal graphique de la commande

lspci -nn

Ça va nous dire exactement quel est le numéro du modèle et le numéro du vendeur de ta carte sans fil. Avec ces informations, on peut savoir comment le noyau Linux peut supporter ta carte sans fil en visitant le site

Welcome - Linux Wireless

La procédure demande surtout de la patience. Plusieurs cartes sans fil Broadcom sont supportées, mais pas automatiquement sans manipulations.

TANT PIS
 Posté le 05/01/2015 à 22:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir Logicien

Merci pour ta réponse

Ma carte est : Broadcom corporation BCM 4318 Air Force One

m_n
 Posté le 06/01/2015 à 02:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

dans synaptic , fait la recherche de : ( wicd )

Logicien
 Posté le 06/01/2015 à 04:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

m_n,

tu ne sais même pas si la carte sans fil est utilisable, alors que c'est connu que les cartes Broadcom ne sont pas fonctionnelles automatiquement. Alors, chercher à configurer le réseau avec Wicd est prématuré.

TANT PIS,

je veux la sortie de la commande précédente au complet. Toute la ligne.

TANT PIS
 Posté le 06/01/2015 à 10:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Logicien

Je te copie le résultat: 00:0b.0 Network controller [0280] : Broadcom corporation BCM4318 [Air Fotce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)

J'ajoute qu'avec Linux Mint 16 elle fonctionnait bien . Par contre comme j'avais déjà Handy Linux installé avant et que j'avais fait plusieurs manips je ne me souviens plus si j'avais été obligé de les refaire ou si çà avait

fonctionné de suite à l'installation de 16

Pour installer la version 17.1 j'ai tout viré avant et conservé seulement Windows XP en dual boot . J'ai la wifi avec xp ....

Comme je suis un peu perdu avec 17 je te fais entière confiance car je ne me sert pas souvent de cet ordinateur (c'est plus en cas de panne de l'autre qui est avec Windows 8.1 ) Je penses qu'ensuite je vais m'y mettre

plus sérieusement .

Merci de tes conseils

Bonne journée .

Logicien
 Posté le 06/01/2015 à 11:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Tu vas devoir avoir accès à Internet autrement qu'avec ta carte sans fil présentement avec Linux Mint. Par exemple, avec ta carte Ethernet filiaire. Sans accès Internet avec Mint, il va être plus difficile d'installer les firmwares manquants au module b43 qui pilote ta carte sans fil.

À l'aide du gestionnaire de paquets Synaptic, il faudrait que tu installes le paquet

firmware-b43-installer

Ou bien depuis un terminal, exécuter la commande

sudo apt-get install firmware-b43-installer

Avec ce paquet installé, suivi d'un redémarrage de Linux Mint, ta carte sans fil devrait être fonctionnelle et prête à utiliser.



Modifié par Logicien le 06/01/2015 11:05
TANT PIS
 Posté le 06/01/2015 à 13:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re bonjour Logicien .

Bien effectuée ta manip et ô miracle LOL la wifi est revenue .

Avec tous mes remerciements pour ton aide je te souhaite un bon après-midi .

Je coche en résolu .

P.S maintenant il me reste à découvrir un peu plus cette nouvelle version ....

DB2
 Posté le 07/05/2015 à 16:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

J'ai exactement le même problème : un portable qui fonctionnait parfaitement et qui n'a plus d'accès wifi depuis le remplacement de la mint 16 par la 17.1

voila la copie demandée du fichier log :

[code]

>> cat /etc/lsb-release

DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=17.1
DISTRIB_CODENAME=rebecca
DISTRIB_DESCRIPTION="Linux Mint 17.1 Rebecca"

>> lsusb

Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 0424:5534 Standard Microsystems Corp.
Bus 003 Device 002: ID 0424:5534 Standard Microsystems Corp.
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 04f2:b3ca Chicony Electronics Co., Ltd
Bus 002 Device 004: ID 8087:07dc Intel Corp.
Bus 002 Device 003: ID 0424:2134 Standard Microsystems Corp.
Bus 002 Device 008: ID 03f0:2512 Hewlett-Packard OfficeJet Pro L7300
Bus 002 Device 007: ID 192f:0416 Avago Technologies, Pte. ADNS-5700 Optical Mouse Controller (3-button)
Bus 002 Device 006: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 002 Device 002: ID 0424:2134 Standard Microsystems Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

>> lspci -k -nn | grep -A 3 -i net

00:19.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection I218-LM [8086:155a] (rev 04)
Subsystem: Hewlett-Packard Company Device [103c:1991]
Kernel driver in use: e1000e
00:1b.0 Audio device [0403]: Intel Corporation Lynx Point-LP HD Audio Controller [8086:9c20] (rev 04)
--
02:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 73)
Subsystem: Intel Corporation Dual Band Wireless-N 7260 [8086:4060]
Kernel driver in use: iwlwifi
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader [10ec:5227] (rev 01)

>> sudo lshw -C network

*-network
description: Ethernet interface
product: Ethernet Connection I218-LM
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: eth0
version: 04
serial: fc:15:b4:eb:65:c2
size: 100Mbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.3-4 ip=147.100.18.107 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:62 memory:d0700000-d071ffff memory:d073e000-d073efff ioport:3080(size=32)
*-network
description: Wireless interface
product: Wireless 7260
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 73
serial: ac:7b:a1:60:32:22
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-37-generic firmware=22.24.8.0 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
resources: irq:65 memory:d0500000-d0501fff

>> lsmod

Module Size Used by
arc4 12608 2
hp_wmi 14062 0
sparse_keymap 13948 1 hp_wmi
rfcomm 69160 12
intel_rapl 18773 0
x86_pkg_temp_thermal 14205 0
intel_powerclamp 14705 0
bnep 19624 2
coretemp 13435 0
kvm 451552 0
crct10dif_pclmul 14289 0
crc32_pclmul 13113 0
ghash_clmulni_intel 13216 0
uvcvideo 80885 0
videobuf2_vmalloc 13216 1 uvcvideo
snd_hda_codec_idt 54718 1
aesni_intel 55624 0
iwlmvm 189813 0
videobuf2_memops 13362 1 videobuf2_vmalloc
snd_hda_codec_hdmi 46368 1
mac80211 630653 1 iwlmvm
aes_x86_64 17131 1 aesni_intel
lrw 13286 1 aesni_intel
gf128mul 14951 1 lrw
glue_helper 13990 1 aesni_intel
ablk_helper 13597 1 aesni_intel
cryptd 20359 3 ghash_clmulni_intel,aesni_intel,ablk_helper
snd_hda_intel 56451 5
videobuf2_core 40664 1 uvcvideo
snd_hda_codec 192906 3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep 13602 1 snd_hda_codec
videodev 134688 2 uvcvideo,videobuf2_core
snd_pcm 102099 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_seq_midi 13324 0
snd_seq_midi_event 14899 1 snd_seq_midi
snd_rawmidi 30144 1 snd_seq_midi
joydev 17381 0
iwlwifi 169932 1 iwlmvm
serio_raw 13462 0
rtsx_pci_ms 18151 0
lpc_ich 21080 0
memstick 16966 1 rtsx_pci_ms
cfg80211 484040 3 iwlwifi,mac80211,iwlmvm
snd_page_alloc 18710 2 snd_pcm,snd_hda_intel
snd_seq 61560 2 snd_seq_midi_event,snd_seq_midi
mei_me 18627 0
mei 82276 1 mei_me
btusb 32412 0
bluetooth 391136 22 bnep,btusb,rfcomm
snd_seq_device 14497 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 29482 2 snd_pcm,snd_seq
snd 69322 21 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
soundcore 12680 1 snd
hp_accel 26012 0
lis3lv02d 20156 1 hp_accel
input_polldev 13896 1 lis3lv02d
tpm_infineon 17372 0
hp_wireless 12637 0
parport_pc 32701 0
intel_smartconnect 12619 0
ppdev 17671 0
mac_hid 13205 0
lp 17759 0
parport 42348 3 lp,ppdev,parport_pc
hid_generic 12548 0
usbhid 52659 0
hid 106148 2 hid_generic,usbhid
rtsx_pci_sdmmc 23274 0
i915 783805 5
psmouse 106678 0
i2c_algo_bit 13413 1 i915
e1000e 254433 0
drm_kms_helper 55071 1 i915
ahci 25819 3
drm 303102 4 i915,drm_kms_helper
libahci 32716 1 ahci
rtsx_pci 46202 2 rtsx_pci_ms,rtsx_pci_sdmmc
ptp 18933 1 e1000e
pps_core 19382 1 ptp
wmi 19177 1 hp_wmi
video 19476 1 i915
[/code]
[code]

>> iwconfig

wlan0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off


>> ifconfig -a

eth0 Link encap:Ethernet HWaddr fc:15:b4:eb:65:c2
inet adr:147.100.18.107 Bcast:147.100.63.255 Masque:255.255.192.0
adr inet6: fe80::fe15:b4ff:feeb:65c2/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:1310431 erreurs:0 :0 overruns:0 frame:0
TX packets:168738 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:544548796 (544.5 MB) Octets transmis:14554739 (14.5 MB)
Interruption:20 Mémoire:d0700000-d0720000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:65536 Metric:1
Packets reçus:11674 erreurs:0 :0 overruns:0 frame:0
TX packets:11674 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:3003832 (3.0 MB) Octets transmis:3003832 (3.0 MB)

wlan0 Link encap:Ethernet HWaddr ac:7b:a1:60:32:22
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)


>> sudo iwlist scan

wlan0 No scan results


>> uname -r -m

3.13.0-37-generic x86_64

>> cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

>> nm-tool


NetworkManager Tool

State: connected (global)

- Device: wlan0 ----------------------------------------------------------------
Type: 802.11 WiFi
Driver: iwlwifi
State: disconnected
Default: no
HW Address: AC:7B:A1:60:32:22

Capabilities:

Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points


- Device: eth0 [Connexion filaire 1] ------------------------------------------
Type: Wired
Driver: e1000e
State: connected
Default: yes
HW Address: FC:15:B4:EB:65:C2

Capabilities:
Carrier Detect: yes
Speed: 100 Mb/s

Wired Properties
Carrier: on

IPv4 Settings:
Address: 147.100.18.107
Prefix: 18 (255.255.192.0)
Gateway: 147.100.0.211

DNS: 147.100.66.234
DNS: 147.100.66.235
DNS: 147.100.66.242



>> sudo rfkill list

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
[/code]

j'espère qu'il est possible de réparer sans réinstaller car je viens de le faire 2 fois déjà (xfce et kde) ...

Merci d'avance



Modifié par DB2 le 07/05/2015 16:26
Publicité
Logicien
 Posté le 07/05/2015 à 19:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

pourrais-tu afficher la sortie des commandes

ifconfig

dmesg | grep -i -e firm -e iwlwifi -e micro -e wlan

find /lib/firmware -iname *iwlwifi*

Il est important de savoir si tous les fichiers firmwares dont a besoin le module iwlwifi sont bien disponibles quand il se charge en mémoire vive.

Si ta carte sans fil wlan0 n'est pas visible dans la sortie de la première commande, alors, il faut l'activer par

sudo ifconfig wlan0 up

pour pouvoir l'utiliser.



Modifié par Logicien le 07/05/2015 19:24
DB2
 Posté le 09/05/2015 à 03:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonsoir et merci

je ne peux plus faire cette commande dans des conditions qui donneraient une information car à force de chercher, j'ai vu que nous étions assez nombreux à avoir des soucis avec ce "produit" et la version 14.04 de Ubuntu (la 17.1 de mint est basée sur cette version d'ubuntu

Après 3 essais différents, j'ai donc installé une 4ème distrib : la LMDE de mint et là, le wifi fonctionne.

Par contre, je changeais parce que mon portable redémarrait seul (et ça avait effectivement réglé le pb) et de ce coté là, je suis revenu à la case départ ...

Je ne sais pas trop si j'aurai le courage de refaire l'instal du début pour retester cette solution

En plus je me dis que se baser sur une LMDE, ça doit etre un gage de stabilité !

merci encore



Modifié par DB2 le 09/05/2015 03:51
DB2
 Posté le 09/05/2015 à 03:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

je suis trop curieux finalement de voir si on peut corriger ce bug avec ce post ci et ce que j'ai trouvz sur le forum ubuntu

On verra demain ...

DB2
 Posté le 11/05/2015 à 13:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

~ $ ifconfig
eth0 Link encap:Ethernet HWaddr fc:15:b4:eb:65:c2
inet adr:147.100.18.107 Bcast:147.100.63.255 Masque:255.255.192.0
adr inet6: fe80::fe15:b4ff:feeb:65c2/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:1982242 erreurs:0 :0 overruns:0 frame:0
TX packets:169257 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:596522364 (596.5 MB) Octets transmis:15301554 (15.3 MB)
Interruption:20 Mémoire:d0700000-d0720000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:65536 Metric:1
Packets reçus:8351 erreurs:0 :0 overruns:0 frame:0
TX packets:8351 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:1349041 (1.3 MB) Octets transmis:1349041 (1.3 MB)

wlan0 Link encap:Ethernet HWaddr ac:7b:a1:60:32:22
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)


~ $ dmesg | grep -i -e firm -e iwlwifi -e micro -e wlan
[ 0.175367] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 2.463660] microcode: CPU0 sig=0x40651, pf=0x40, revision=0x16
[ 2.463666] microcode: CPU1 sig=0x40651, pf=0x40, revision=0x16
[ 2.463674] microcode: CPU2 sig=0x40651, pf=0x40, revision=0x16
[ 2.463681] microcode: CPU3 sig=0x40651, pf=0x40, revision=0x16
[ 2.463724] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[ 4.559567] usb 2-1.1: ep 0x81 - rounding interval to 128 microframes, ep desc says 192 microframes
[ 4.652648] usb 2-1.3: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
[ 6.037554] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq
[ 6.055069] iwlwifi 0000:02:00.0: irq 65 for MSI/MSI-X
[ 6.064672] iwlwifi 0000:02:00.0: loaded firmware version 22.24.8.0 op_mode iwlmvm
[ 6.090650] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless N 7260, REV=0x144
[ 6.090698] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.090914] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.218389] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
[ 7.749777] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 7.749997] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 7.761335] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7.761612] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7525.594345] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready


find /lib/firmware -iname *iwlwifi*
/lib/firmware/iwlwifi-3160-8.ucode
/lib/firmware/iwlwifi-2030-6.ucode
/lib/firmware/iwlwifi-105-6.ucode
/lib/firmware/iwlwifi-3160-9.ucode
/lib/firmware/iwlwifi-7260-8.ucode
/lib/firmware/iwlwifi-7265-9.ucode
/lib/firmware/iwlwifi-2000-6.ucode
/lib/firmware/iwlwifi-1000-5.ucode
/lib/firmware/iwlwifi-3945-2.ucode
/lib/firmware/iwlwifi-6050-5.ucode
/lib/firmware/iwlwifi-6000-4.ucode
/lib/firmware/iwlwifi-6000g2a-6.ucode
/lib/firmware/iwlwifi-135-6.ucode
/lib/firmware/iwlwifi-3160-7.ucode
/lib/firmware/iwlwifi-5000-5.ucode
/lib/firmware/iwlwifi-7265-8.ucode
/lib/firmware/iwlwifi-6000g2a-5.ucode
/lib/firmware/iwlwifi-100-5.ucode
/lib/firmware/iwlwifi-6000g2b-6.ucode
/lib/firmware/iwlwifi-5150-2.ucode
/lib/firmware/iwlwifi-7260-7.ucode
/lib/firmware/iwlwifi-4965-2.ucode
/lib/firmware/iwlwifi-7260-9.ucode



Modifié par DB2 le 11/05/2015 17:02
DB2
 Posté le 11/05/2015 à 14:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

http://www.intel.com/support/wireless/wlan/sb/CS-034398.htm

https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-7260-ucode-22.15.8.0.tgz

https://downloadcenter.intel.com/download/17045/Intel-Drivers-for-Linux-

sur ces sites, j'ai téléchargé le paquet conseillé en fonction de mon noyau :

uname -sr
Linux 3.13.0-37-generic

puis j'ai copié le fichier en question à l'endroit désigné

~ $ sudo cp iwlwifi-*.ucode /lib/firmware

il y est bien, je le vois via un navigateur mais la commande

find /lib/firmware -iname *iwlwifi*

ne renvoie plus rien alors que tout à l'heure elle envoyait bien une liste !

Je recherche le tutoriel unbuntu qie j'avais trouvé l'autre fois.

Mais là, c'est qd même étrange car ça me semblait un poil résolu ...

reivillo
 Posté le 11/05/2015 à 14:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour DB2.

il y est bien, je le vois via un navigateur mais la commande
find /lib/firmware -iname *iwlwifi*

Et avec cette Commande:
find /lib/firmware -iname *iwlwifi* -print
ou...
sudo find /lib/firmware -iname *iwlwifi* -print

Reivillo.

DB2
 Posté le 11/05/2015 à 15:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Avec celle là, ça remarche ...

~ $ find /lib/firmware -iname *iwlwifi* -print
/lib/firmware/iwlwifi-3160-8.ucode
/lib/firmware/iwlwifi-2030-6.ucode
/lib/firmware/iwlwifi-105-6.ucode
/lib/firmware/iwlwifi-3160-9.ucode
/lib/firmware/iwlwifi-7260-8.ucode
/lib/firmware/iwlwifi-7265-9.ucode
/lib/firmware/iwlwifi-2000-6.ucode
/lib/firmware/iwlwifi-1000-5.ucode
/lib/firmware/iwlwifi-3945-2.ucode
/lib/firmware/iwlwifi-6050-5.ucode
/lib/firmware/iwlwifi-6000-4.ucode
/lib/firmware/iwlwifi-6000g2a-6.ucode
/lib/firmware/iwlwifi-135-6.ucode
/lib/firmware/iwlwifi-3160-7.ucode
/lib/firmware/iwlwifi-5000-5.ucode
/lib/firmware/iwlwifi-7265-8.ucode
/lib/firmware/iwlwifi-6000g2a-5.ucode
/lib/firmware/iwlwifi-100-5.ucode
/lib/firmware/iwlwifi-6000g2b-6.ucode
/lib/firmware/iwlwifi-5150-2.ucode
/lib/firmware/iwlwifi-7260-7.ucode
/lib/firmware/iwlwifi-4965-2.ucode
/lib/firmware/iwlwifi-7260-9.ucode

je corrige mon commentaire précédent : le firmware y est bien en fait!

c'est le cinquième

Faut juste que l'ordi s'en rende compte maintenant !!!



Modifié par DB2 le 11/05/2015 16:00
DB2
 Posté le 11/05/2015 à 16:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Finalement, je suis allé voir les captures plus haut : il y était déjà

Je n'ai rien ajouté du tout on dirait



Modifié par DB2 le 11/05/2015 16:22
Publicité
DB2
 Posté le 11/05/2015 à 17:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bon, je vais faire un point car j'ai fait plein de choses dont un update et un upgrade.

Plus qqes autres commandes trouvées ici ou là pour des cas similaires.

À la différence du début, il semble que le pb soit identifié et finalement assez fréquent.

Ça ne le résoud pas pour autant mais ça rassure de savoir que l'on n'est pas seul.

Je voulais supprimer les captures précédentes mais je me suis dit que ça pouvait servir.

Donc dans l'ordre, à cette adresse :

https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-7260-ucode-22.15.8.0.tgz

on peut voir que

The following devices are supported (since kernel version):

Intel® Wireless 7265 (3.13)
Intel® Wireless 7260 (3.10)

il y a un pb de compatibilité

j'ai le 7260 avec un noyau 3.13 ...

dpkg -l | grep -Ei "linux-headers|linux-image"

ii linux-headers-3.13.0-37 3.13.0-37.64 all Header files related to Linux kernel version 3.13.0
ii linux-headers-3.13.0-37-generic 3.13.0-37.64 amd64 Linux kernel headers for version 3.13.0 on 64 bit x86 SMP
ii linux-image-3.13.0-37-generic 3.13.0-37.64 amd64 Linux kernel image for version 3.13.0 on 64 bit x86 SMP
ii linux-image-extra-3.13.0-37-generic 3.13.0-37.64 amd64 Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP

ifconfig

eth0 Link encap:Ethernet HWaddr fc:15:b4:eb:65:c2
inet adr:147.100.18.107 Bcast:147.100.63.255 Masque:255.255.192.0
adr inet6: fe80::fe15:b4ff:feeb:65c2/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:1821953 erreurs:0 :0 overruns:0 frame:0
TX packets:109753 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:381647387 (381.6 MB) Octets transmis:10601531 (10.6 MB)
Interruption:20 Mémoire:d0700000-d0720000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:65536 Metric:1
Packets reçus:17455 erreurs:0 :0 overruns:0 frame:0
TX packets:17455 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:4475168 (4.4 MB) Octets transmis:4475168 (4.4 MB)

wlan0 Link encap:Ethernet HWaddr ac:7b:a1:60:32:22
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

$ iwconfig


eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11abg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

si j'appuie sur le bouton de marche arret du wifi, on voit qu'il se passe qqe chose car ça devient :

wlan0 IEEE 802.11abg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Donc il est bien allumé

sudo ifconfig wlan0 up

ne renvoie aucun message et a l'air de bien s'exécuter ...

dmesg | grep -i -e firm -e iwlwifi -e micro -e wlan
[ 0.175407] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 2.471453] microcode: CPU0 sig=0x40651, pf=0x40, revision=0x16
[ 2.471459] microcode: CPU1 sig=0x40651, pf=0x40, revision=0x16
[ 2.471467] microcode: CPU2 sig=0x40651, pf=0x40, revision=0x16
[ 2.471474] microcode: CPU3 sig=0x40651, pf=0x40, revision=0x16
[ 2.471518] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[ 4.556093] usb 2-1.1: ep 0x81 - rounding interval to 128 microframes, ep desc says 192 microframes
[ 4.649096] usb 2-1.3: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
[ 5.922707] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq
[ 5.989271] iwlwifi 0000:02:00.0: irq 67 for MSI/MSI-X
[ 6.016723] iwlwifi 0000:02:00.0: loaded firmware version 22.24.8.0 op_mode iwlmvm
[ 6.051265] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
[ 6.054712] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless N 7260, REV=0x144
[ 6.054764] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.054987] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.813930] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.814145] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.825768] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6.826079] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 5882.587348] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 5882.587586] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 5882.598365] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 9609.439314] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 9609.439550] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 9609.450013] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

il la voit bien ...

find /lib/firmware -iname *iwlwifi* -print

/lib/firmware/iwlwifi-3160-8.ucode
/lib/firmware/iwlwifi-2030-6.ucode
/lib/firmware/iwlwifi-105-6.ucode
/lib/firmware/iwlwifi-3160-9.ucode
/lib/firmware/iwlwifi-7260-8.ucode
/lib/firmware/iwlwifi-7265-9.ucode
/lib/firmware/iwlwifi-2000-6.ucode
/lib/firmware/iwlwifi-1000-5.ucode
/lib/firmware/iwlwifi-3945-2.ucode
/lib/firmware/iwlwifi-6050-5.ucode
/lib/firmware/iwlwifi-6000-4.ucode
/lib/firmware/iwlwifi-6000g2a-6.ucode
/lib/firmware/iwlwifi-135-6.ucode
/lib/firmware/iwlwifi-3160-7.ucode
/lib/firmware/iwlwifi-5000-5.ucode
/lib/firmware/iwlwifi-7265-8.ucode
/lib/firmware/iwlwifi-6000g2a-5.ucode
/lib/firmware/iwlwifi-100-5.ucode
/lib/firmware/iwlwifi-6000g2b-6.ucode
/lib/firmware/iwlwifi-5150-2.ucode
/lib/firmware/iwlwifi-7260-7.ucode
/lib/firmware/iwlwifi-4965-2.ucode
/lib/firmware/iwlwifi-7260-9.ucode

Le bon firmware est bien là

$ dmesg | grep wifi
[ 5.989271] iwlwifi 0000:02:00.0: irq 67 for MSI/MSI-X
[ 6.016723] iwlwifi 0000:02:00.0: loaded firmware version 22.24.8.0 op_mode iwlmvm
[ 6.054712] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless N 7260, REV=0x144
[ 6.054764] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.054987] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.813930] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 6.814145] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 5882.587348] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 5882.587586] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 9609.439314] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 9609.439550] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S

ça se ressemble avec la précédente mais dans le doute, je colle aussi !

J'avais fait ça aussi

echo "options iwlmvm power_scheme=1" | sudo tee /etc/modprobe.d/iwlmvm.conf
echo "options iwlwifi bt_coex_active=N swcrypto=1 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

Les deux fichiers en question ne contiennent donc bien que leur unique ligne

sudo lshw -C network
*-network
description: Ethernet interface
produit: Ethernet Connection I218-LM
fabriquant: Intel Corporation
identifiant matériel: 19
information bus: pci@0000:00:19.0
nom logique: eth0
version: 04
numéro de série: fc:15:b4:eb:65:c2
taille: 100Mbit/s
capacité: 1Gbit/s
bits: 32 bits
horloge: 33MHz
fonctionnalités: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.3-4 ip=147.100.18.107 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
ressources: irq:61 mémoire:d0700000-d071ffff mémoire:d073e000-d073efff portE/S:3080(taille=32)
*-network
description: Interface réseau sans fil
produit: Wireless 7260
fabriquant: Intel Corporation
identifiant matériel: 0
information bus: pci@0000:02:00.0
nom logique: wlan0
version: 73
numéro de série: ac:7b:a1:60:32:22
bits: 64 bits
horloge: 33MHz
fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-37-generic firmware=22.24.8.0 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
ressources: irq:67 mémoire:d0500000-d0501fff

Voilà, j'ai un peu fait le tour de l'état actuel

J'en suis à ma 6 eme install complète.

Seule la Mint LMDE fonctionnait parfaitement en wifi mais comme les distribs que j'avais avant, j'ai un soucis d'arret du portable (il se rallume indéfiniment ou presque) que je ne supporte plus.

Sinon, toutes les autres, kde, 15.04, xfce, ... basée sur la 14.04 avaient le même problème.

Je suis donc revenue à ma case départ ...

Merci de votre aide

hido
 Posté le 11/05/2015 à 17:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

j'ai un soucis d'arret du portable (il se rallume indéfiniment ou presque) que je ne supporte plus.

Il me semble que quelqu'un a déjà eu ce probleme, mais je sais pas si ça a été résolu.

Si je me souviens bien c'est milou32 mais je suis pas sûr, essaie de chercher ses topics ou bien envoie lui un MP pour lui demander

milou32
 Posté le 11/05/2015 à 19:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Hido et tous

C'est bien moi qui ait ce problème, mais il n'est toujours pas résolu...

Logicien m'a fait rajouter une ligne arrêter dans mon 40_custom, que je sélectionne quand le portable reboote, et qui me permet de l'arrêter

Message édité

La ligne rajoutée dans 40_custom

menuentry "Arrêter" {

halt

}

Une fois sélectionnée dans le menu, je peux arrêter le portable proprement avec le bouton d'alimentation.



Modifié par milou32 le 11/05/2015 19:14
reivillo
 Posté le 11/05/2015 à 20:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Et avec la ligne de Commande ci-dessous:( à tester )

sudo shutdown -P now

Bien sûr il va demander le Mot de Passe...
Mais! si cela Fonctionne, on pourra supprimer la demande du Mot de Passe.
Puis il suffira d'ajouter un Bouton avec cette Commande, pour arrêter le PC d'autorité.

Donc, j'attends les Retours de Tests...

milou32
 Posté le 11/05/2015 à 21:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Reivillo

Pour moi ça ne marche pas, j'ai essayé toutes les commandes shutdown , halt, en terminal et console virtuelle, il reboote quand même

reivillo
 Posté le 11/05/2015 à 21:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir milou32.

Donc c'est l'Alimentation du PC qui ne peut pas être ARRÊTER.( sous Batterie peut-être! )
Comme tu aimes bien faire des Tests...Essaye la Commande avec la Batterie enlevée.
Attends quand même quelques minutes, avant de Démarrer sur le bloc d'Alimentation sans la Batterie pour voir...

milou32
 Posté le 11/05/2015 à 21:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

On avait essayé cette méthode aussi, et l'inverse aussi uniquement sur batterie, après avoir trouvé cette astuce sur un forum.
C'est pour cette raison que Logicien m'a fait ajouter cette ligne, c'est la seule méthode qu'on ait trouvé.

Ce qui est bizarre c'est que si tu recherches sur Internet de plus en plus de PC ont ce problème

Par contre les quatre jours où j'avais essayé windows, il s'arrêtait normalement....



Modifié par milou32 le 11/05/2015 21:26
reivillo
 Posté le 11/05/2015 à 22:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Donc si je comprends bien, il Reboot Intempestivement?

En en désactivant la WIFI, avant d'Éteindre le PC?

milou32
 Posté le 11/05/2015 à 22:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Oui il reboote systématiquement. J'ai rarement le wifi, uniquement le cable éthernet, essai débranché négatif aussi.

C'est pour ça que j'ai abandonné

Publicité
Pages : [1] 2 3 ... Fin
Page 1 sur 3 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Arrière-plan d'écran de connexion Linux Mint
wifi sous linux mint cinnamon
installation linux mint
Handy Linux plus de connexion Wifi
installation linux mint
Boot trop long apres installation Linux
Pas d'affichage après installation linux
Installation d'une carte WIFI sous LINUX
Démarrer Linux après son installation [résolu]
Linux mint internet pas reconnu sur un ordinateur
Plus de sujets relatifs à Pas de connexion Wifi après installation Linux Mint 17.1
 > Tous les forums > Forum Linux