> Tous les forums > Forum Linux
 pas de démarrage sur linux mint dans le grub w10/linux mint
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
maxfélix
  Posté le 15/01/2020 @ 17:38 
Aller en bas de la page 
Petit astucien

Bonsoir

J'ai eu un problème de dual boot w10/linux mint qui a été traité par Ikewdu en son temps avec succès; voir l'url ici:

https://forum.pcastuces.com/sujet.asp?page=-1&f=8&s=16075&REP_ID=6098406

Mais voilà que je ne peux plus démarrer linux mint dans grub alors qu'il est bien présent; mon disque ssd m2 sur lequel est installé linux mint est bien reconnu dans gestion des disques de w10.

Je serai heureux que Ikewdu ou quelqu'un d'autre qui aurait quelque idée du problème puisse revenir à mon secours pour solutionner ce problème car tout fonctionnait correctement jusqu'ici.

Merci de votre attention

Publicité
enigma7
 Posté le 15/01/2020 à 20:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Le plus simple tu installes easybcd 2.4 sous windows et tu refais le dual boot W10 / linux depuis la partition Windows.

Pour le menu Mint tu mets Grub2 et autodetect (attention ne laisse pas de clée usb bootable linux dans le pc)

Ikewdu_
 Posté le 15/01/2020 à 22:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

enigma7 a écrit :

Le plus simple tu installes easybcd 2.4 sous windows et tu refais le dual boot W10 / linux depuis la partition Windows.

Pour le menu Mint tu mets Grub2 et autodetect (attention ne laisse pas de clée usb bootable linux dans le pc)

Perso, je ne m'y risquerais pas. Easybcd ne peut pas gérer le démarrage dun dual-boot en uefi, car bootmgfw.efi est incapable de lancer le fichier grubx64.efi ou shimx64.efi.

@Maxfelix,

Fais un nouveau rapport boot-info et explique ce qu'il se passe au démarrage.

maxfélix
 Posté le 16/01/2020 à 11:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour ikewdu

Voici ce qui se passe au démarrage:

j'ai bien le menu Grub avec w10 que j'ai placé en premier et qui lance correctement l'OS en état de fonctionnement; mais si je choisis Ubuntu j'ai un écran noir.

Si je fais apparaitre avec F11 le menu de choix j'ai 10 choix:

1) choix ubuntu qui donne écran noir sur ssd M2 samsung

2) choix w 10 opérationnel. sur le meme ssdM2 samsung.

3 Choix UEFI sandisk où est l'iso de linux mint(c'est ma clé USB live cd montée avec Rufus que j'ai du refaire car la précédente ne bootait pas); donc voici l'URL du rapport boot info correspondant:

Normal 0 21 false false false FR X-NONE X-NONE /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Tableau Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; mso-hyphenate:none; text-autospace:ideograph-other; font-size:12.0pt; font-family:"Liberation Serif",serif; mso-bidi-font-family:"Lohit Devanagari"; mso-font-kerning:1.5pt; mso-ansi-language:EN-US; mso-fareast-language:ZH-CN; mso-bidi-language:HI;}

http://paste.ubuntu.com/p/JBgSW5v54w/

les autres choix sont mes 3 sata 1 3 et 4; les 2 ssd M2 samsung et ldlc; encore ma clé USB sandisk; et le choix 10 d'entrée dans les réglages.

J'ignore ce qui a pu se passer.Merci pour ton aide; je n'ai rien fait concernant easybcd.

Ikewdu_
 Posté le 16/01/2020 à 17:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Je ne vois absolument rien d'anormal, mais comme la première fois, on n'a pas tout pour cause de disque Nvme. Le problème semble venir d'Ubuntu, et non du démarrage. Une mise à jour s'est-elle produite sur cet OS ? Essaie de monter la partition Linux et la partition efi ainsi :

sudo mkdir /mnt/efi
sudo mkdir /mnt/ubuntu
sudo mount /dev/nvme0n1p2 /mnt/efi
sudo mount /dev/nvme1n1p2 /mnt/ubuntu

Et résultat de


cat /mnt/ubuntu/etc/fstab
ls /mnt/efi

On va déjà vérifier que les UUID sont correctes par rapport à blkid... Mais j'avoue ne pas avoir d'idée précise pour l'instant.

maxfélix
 Posté le 16/01/2020 à 23:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir

J'ai fait des MAJ de linux mint chaque fois que je l'utilisais; mais je n'ai pas noté sur quoi elles portaient.

Je pense avoir fait les bons résultats que voici:

Normal 0 21 false false false FR X-NONE X-NONE /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Tableau Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; mso-hyphenate:none; text-autospace:ideograph-other; font-size:12.0pt; font-family:"Liberation Serif",serif; mso-bidi-font-family:"Lohit Devanagari"; mso-font-kerning:1.5pt; mso-ansi-language:EN-US; mso-fareast-language:ZH-CN; mso-bidi-language:HI;}

mint@mint ~ $ cat /mnt/ubuntu/etc/fstab

# /etc/fstab: static file system information.

#

# Use 'blkid' to print the universally unique identifier for a

# device; this may be used with UUID= as a more robust way to name devices

# that works even if disks are added and removed. See fstab(5).

#

# <file system> <mount point> <type> <options> <dump> <pass>

# / was on /dev/nvme1n1p2 during installation

UUID=394100cd-e646-41e4-8233-9d12abca1b9d / ext4 errors=remount-ro 0 1

# /boot/efi was on /dev/nvme0n1p2 during installation

UUID=4C19-BBC8 /boot/efi vfat umask=0077 0 1

# /home was on /dev/nvme1n1p4 during installation

UUID=772528ad-d51f-4797-b8b0-42988ea27f36 /home ext4 defaults 0 2

# swap was on /dev/nvme1n1p3 during installation

UUID=1331cb30-7bcf-4020-a6a0-76ee001b91d1 none swap sw 0 0

mint@mint ~ $ ls /mnt/efi

Ikewdu_
 Posté le 16/01/2020 à 23:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Les uuid sont OK. Que retourne

ls /mnt/efi

maxfélix
 Posté le 17/01/2020 à 00:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Normal 0 21 false false false FR /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Tableau Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; line-height:107%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri",sans-serif; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:Calibri; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;}

Cela retourne ceci.

mint@mint ~ $ ls /mnt/efi

ls: cannot access '/mnt/efi': No such file or directory

mint@mint ~ $ ^C

mint@mint ~ $

Ikewdu_
 Posté le 17/01/2020 à 07:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Tu as bien monté la partition auparavant ?

sudo mkdir /mnt/efisudo mount /dev/nvme0n1p2 /mnt/efi

Car ls /mnt/efi devrait renvoyer un contenu, à savoir un dossier efi. Je veux connaître le contenu de grub.cfg avant de te proposer des pistes de réparation. On va essayer autrement. Tu vas essayer de créer depuis Windows une clé bootable avec Refind en suivant ce sujet :

http://ikewdu.free.fr/creer-une-cle-usb-de-depannage-refind-ou-supergrub2-disk/

Ce sont les points I et II. La technique de création de la clé fonctionne, j'en ai la confirmation ici. Le but va être de pouvoir booter sur la clé et de lancer ton Ubuntu depuis refind sans passer par grub, et ce afin de voir si c'est lui le coupable ou non. De plus, ça lancera ta version installée, et ça facilitera à la fois les tests et les réparations éventuelles.



Modifié par Ikewdu_ le 17/01/2020 07:11
Publicité
maxfélix
 Posté le 17/01/2020 à 19:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir

j’ai fait la clé comme indiqué au paragraphe I et II; elle boot normalement trouve ubuntu mint et un autre ; possède uèn menu avec infos, redémarrage, fermeture etc

Si je clique sur Mint j'ai une série de chargement de données puis écran noir. Donc pas d'accès à mon linux mint.

Je n'ai pas essayé le paragraphe III

Ikewdu_
 Posté le 17/01/2020 à 22:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Donc, ce n'est pas un problème de démarrage et GRUB n'est probablement pas en cause.

Peut-être une mise à jour qui a engendré un problème graphique. Essaie de redémarrer sur GRUB, et lorsque tu es sur la ligne Ubuntu, tu tapes la lettre e. Ça ouvre un éditeur. Avec les flèches bas et droit, tu vas à la fin de la ligne comportant "quiet splash", et tu ajoutes nomodeset en fin de ligne. (no,odeset en qwerty).

Et tu tentes de booter comme ça (tu as les touches de fonction indiquées en bas de page -CTRL x ou F10, en principe).



Modifié par Ikewdu_ le 17/01/2020 22:19
maxfélix
 Posté le 18/01/2020 à 00:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Cela a fonctionné ; j'ai accès à mon Linux mint; il y a simplement une mention concernant l'accélération de la carte graphique quer je n'ai pas eu le temps de noter.

Que me faut iol faire à présent?

Ikewdu_
 Posté le 18/01/2020 à 07:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ok. Vois si le gestionnaire de pilotes te propose une possibilité d'installation de pilote de carte graphique. Précise-moi de quelle carte il s'agit.

maxfélix
 Posté le 18/01/2020 à 18:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir

Il a fallu de nouveau éditer et rajouter "nodemeset" pour accéder à linux Mint; je pensais que cela avait corrigé une bonne fois pour touet le problème; au fait que fait ce rajout?

Le gestionnaire de pilotes me répond que "aucun pilote propriétaire n'est utilisé".

ma carte graphique est une "MSI RX550 AERO ITX" dont LDLC me dit que c'est une antiquité!!(pas sympa!!)

Ikewdu_
 Posté le 18/01/2020 à 23:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

L'option nomodeset désactive les accélérations et autres atouts de ta carte graphique (qui est cause de ton souci). On peut rendre l'option permanente (ce qui est assez facile), mais avant cela, essaie de booter en ajoutant cette fois :

amdgpu.vm_fragment_size=9

Sait-on jamais.

------------------------------

Autre piste possible, installer le pilote AMD de ta carte graphique qu'on trouve ici (sauf erreur, car la liste est interminable) :

https://www.amd.com/fr/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-550

L'explication de l'installation est là : https://www.amd.com/en/support/kb/faq/gpu-635

Perso, ça me semble compliqué à faire, surtout à distance, et je te conseille de t'adresser à un spécialiste des cartes graphiques sur le forum Ubuntu si l'option nomodeset te semble insuffisante pour tes besoins. Moi, je ne suis plus compétent pour t'aider si tu choisis d'installer ce pilote AMD.



Modifié par Ikewdu_ le 19/01/2020 00:06
maxfélix
 Posté le 20/01/2020 à 00:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir ikwedu

J'ai d’abord ajouté le "amdgpu.vm_fragment_size=9" sans le "
nomodeset" et évidemment cela m'a donné un écran noir.

J'ai ajouté les deux à la suite et j'ai obtenu Mint avec une amélioration de l'affichage(moins grand et plus lisible); faudra t il à chaque démarrage rajouter ces deux mentions? sans doute.

J'ai eu droit à la même mention dans un encadré "cinnamon fonctionne sans pouvoir utiliser les capacités d'accélération du processeur graphique de la carte vidéo, cela peut entraîner une suractivité du processeur principal.

Il pourrait y avoir un problème avec les pilotes ou quelque autre problème. Pour une expérience optimale, il est recommandé de n'utiliser que ce mode pour objectifs de dépannage"

Quand au pilote AMD il me semble que ma carte graphique soit une MSI; à moins que ce ne soit le pilote du processeur qui règle le comportement de cette carte graphique MSI; comme je maîtrise mal le sujet , j'attends ton retour pour faire quoi ce soit.

En tout cas merci pour ce second dépannage qui a défaut de tout régler me permet de progresser dans la connaissance des problèmes.

Ikewdu_
 Posté le 20/01/2020 à 12:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Tu peux ajouter l'option nomodeset dans le fichier grub qui se trouve dans le dossier /etc/default. Comme tu as Cinnamon, ton éditeur de texte est probablement "xed" (sinon, tu adaptes avec gedit ou autre). Donc, tu ouvres en administrateur le fichier grub (attention, car là, tu modifies un fichier important. Dans le doute, fais-en une copie de sauvegarde) :

sudo xed /etc/default/grub

Tu cherches la ligne qui ressemble à ceci :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Et tu ajoutes derrière quiet splash (entre les guillements) ce qui convient pour que tu puisses démarrer. Par exemple :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Et tu valides via un

sudo update-grub

C'est bien entendu une solution très provisoire qui t'évitera de passer par "e".

Je me doutais que le pilote n'était pas le bon, mais je n'ai pas trouvé mieux dans cette page. Mieux vaut aller sur le forum Linux Mint et poster une demande d'aide dans une rubrique dédiée aux soucis de cartes graphiques. Moi, je ne traite pas ce genre de souci.... sauf sur mes PC si le souci se pose. Et je fais comme toi... Je passe par une aide si je ne m'en sors pas.

Tu aurais peut-être aussi la possibilité de revenir au noyau précédent qui fonctionnait bien avec ta carte si ce noyau a changé. C'est une autre piste à envisager...



Modifié par Ikewdu_ le 20/01/2020 12:12
Publicité
Logicien
 Posté le 20/01/2020 à 14:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

je suit le sujet et je me demande si l'écran noir est lié au fait que le module radeon de Linux n'est pas dans l'initramfs.Il faut s'assurer que le paquet linux-firmware est bien installé ainsi que les paquets qui contiennent le mot-clé firmware surtout s'ils concernent les cartes graphiques AMD/ATI.

Un test qui peut être fait est d'enlever le paramètre nomodeset du fichier /etc/default/grub et refaire

sudo update-grub

Puis faire

sudo echo radeon >> /etc/initramfs-tools/modules

sudo update-initramfs -k all -u

La commande update-initramfs affiche un message s'il manque des fichiers firmwares. Le module radeon de Linux étant dans l'initramfs avec les bons fichiers firmwares il y a plus de chances d'éviter l'écran noir sans avoir à désactiver le Kernel Mode Setting (KMS) avec l'option nomodeset.

Si cela ne fonctionne pas, tu remet le paramètre nomodeset dans /etc/default/grub et tu es au même point après

sudo update-grub

et redémarrage.



Modifié par Logicien le 20/01/2020 15:18
maxfélix
 Posté le 20/01/2020 à 17:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir logicien

Je n'ai pas encore mis "nomodeset" en permanence dans grub comme me l'a proposé ikwedu plus haut.

Qu'est ce que cela change dans tes propositions?

Logicien
 Posté le 20/01/2020 à 19:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Cela change que le module radeon qui pilote pleins de cartes graphiques AMD/ATI est disponible plus rapidement au démarrage de Mint parce-qu'il est inclus dans l'initramfs. Sinon, Linux doit monter la vrai partition racine avant de pouvoir avoir accès au module radeon et aux fichers microcodes (firmwares).

En créant un initramfs qui inclus le module radeon et ses microcodes, dès que Linux est chargé en mémoire et qu'il a monté l'initramfs comme système de fichiers racine provisoire, il peut piloter la carte graphique AMD/ATI. C'est une des premières choses que je fais quand j'installe un distribution Linux. J'inclus le bon module framebuffer pour la carte graphique, ici radeon, dans l'initramfs pour avoir la résolution native de l'écran le plus tôt possible au démarrage. Cela aide aussi à ce que l'interface graphique et le bureau s'affichent normalement.

Si le problème est ailleurs, tu ne perd rien à inclure le module radeon dans l'initramfs. Avant de faire la manipulation dont je parle, regarde si le module radeon est déjà listé dans le fichier /etc/initramfs-tools/modules. Si oui ce n'est pas pertinent de faire la manipulation et le problème doit être ailleurs.



Modifié par Logicien le 21/01/2020 00:10
maxfélix
 Posté le 20/01/2020 à 23:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci astucien

Je vais regarder cela à tète reposée demain.

Ikewdu_
 Posté le 02/02/2020 à 19:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Suite du sujet ici :

https://forum-francophone-linuxmint.fr/viewtopic.php?f=18&t=14790

(toujours non résolu).

Perso, j'aurais creusé l'idée du retour au noyau précédent (qui fonctionnait).



Modifié par Ikewdu_ le 02/02/2020 20:12
enigma7
 Posté le 02/02/2020 à 19:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Faut peut être poster sur l'autre forum : https://forums.linuxmint.com/

Me semble plus pro, j'ai vu qu'il y a une section francophone aussi mais pas très active, c'est la section anglaise qui tourne le +

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
13,88 €Carte mémoire microSDXC UHS-I U3 SanDisk Extreme 64 Go (jusqu'à 160 Mo/s) à 13,88 €
Valable jusqu'au 03 Mars

Amazon fait une promotion sur la carte mémoire microSDXC UHS-I U3 SanDisk Extreme 64 Go qui passe à 13,88 €. Cette carte mémoire offre des vitesses jusqu'à 160 Mo/s et est idéale pour les téléphones, caméras et appareils photo HD. Elle est compatible GoPro, Switch et est accompagnée d'un adaptateur SD.


> Voir l'offre
34,99 €Disque dur Toshiba P300 1 To à 34,99 €
Valable jusqu'au 23 Février

Cdiscount propose actuellement le disque dur Toshiba P300 1 To à 34,99 €. On le trouve ailleurs à partir de 45 €. Ce disque dur interne de 1 To est SATA 6 Gbps, possède 64Mo de cache et dispose d'une vitesse de rotation de 7200 tpm. La livraison est gratuite. 


> Voir l'offre
113,60 €SSD SanDisk Ultra 3D 1 To à 113,60 €
Valable jusqu'au 26 Février

En cette période de forte remontée des prix des SSD, Amazon fait une belle promotion sur le SSD SanDisk Ultra 3D d'une capacité de 1 To qui passe à 113,60 € livré gratuitement. On le trouve ailleurs autour de 160 €. Une bonne affaire pour ce SSD performant qui offre des débits de 560 Mo/s en lecture et 530 Mo/s en écriture. Cette version est garantie 3 ans.


> Voir l'offre

Sujets relatifs
DualBoot - Pas de démarrage auto sur W10 après suppression de Linux
Changer l'ordre de démarrage grub linux Mint 7
linux mint et timeshift - pas de partition linux.
icône pc astuces sur le bureau linux mint
Pas de wi-fi sous linux Mint
Pas de connexion Wifi après installation Linux Mint 17.1
[TUTO]Linux Mint 17, et l'affichage du Menu Grub au Démarrage.
Pas de son avec linux mint 8 helena
pas de son sous linux Mint 8
absence de grub au dual boot Mint W10 19 09:
Plus de sujets relatifs à pas de démarrage sur linux mint dans le grub w10/linux mint
 > Tous les forums > Forum Linux