> Tous les forums > Forum Bureautique
 Pb formules open office calc complexes
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Floboww
  Posté le 06/02/2012 @ 11:15 
Aller en bas de la page 
Nouvel astucien

Bonjour,

Actuellement en train de concevoir des outils informatiques, je me suis retrouvé dans une impasse pour l'accumulation de certaines formules..

Je m'explique :

Je souhaite que dans une certaine cellule, le calcule soit différents selon des critères, en français ça donnerait :

"Si B9=1 alors dans la cellule concernée on aura le résultat de E6*(1/4) ou sinon 0". Ca je l'ai traduit par : =SI(B9=1;E6*(1/4);0) Pour l'instant ça va

Ca c'est assez simple... maintenant ce que je voudrais rajouter pour cette même cellule ;

"SI B9=1 et que B8=B10=B11=0 alors la cellule concernée (E8) = (E6) A MOINS QUE SI B9=1 et que B8=0 mais que B10+B11 = 1, dans ces cas là E(8)=(1/4)*E6

A MOINS QUE B10+B11=2, dans ces cas là, E(8)=(1/2)*E6"

Voilà, j'aimerai rentrer tout ça dans une seule cellule mais je ne sais pas quelles formules utilisées ni comment les accumuler...

Je remercie d'avance les personnes pouvant se pencher sur la question et espère avoir été assez clair !

Flo

Publicité
DjiDji59430
 Posté le 06/02/2012 à 11:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

=SI(ET(B9=1;B8=0;B10=0;B11=0);E6;SI(ET(B9=1;B8=0;B10+B11=1);E6/4;SI(B10+B11=2;E6/2;"")))

On ne dit pas "a moins que", mais "sinon", ni "mais que" mais "et que"

Si ta phrase avait été formulée correctement , la formule t'aurais sauté aux yeux.

SI B9=1 et B8=0 et B10=0 et B11=0 alors E8 = E6 sinon, SI B9=1 et B8=0 et B10+B11 = 1,alors E8= E6/4, sinon si B10+B11=2 alors E8=E6/2 sinon rien



Modifié par DjiDji59430 le 06/02/2012 11:53
philou_10120
 Posté le 06/02/2012 à 14:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Voici ma solution j'espére répondre à votre besoin

=SI(ET(B9=1;B8=B10=B11=0);E6;SI(ET(B9=1;B8=0;B10+B11=1);E6/4;SI(B10+B11=2;E6/2;SI(B9=1;E6/4;0))))

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
12,12 €Clé USB 3.0 Sandisk Ultra 64 Go à 12,12 €
Valable jusqu'au 28 Juillet

Amazon propose la clé USB Sandisk Ultra d'une capacité de 64 Go qui passe à 12,12 €. Cette clé USB 3.0 est compatible USB 2.0 et offre de bons débits d'environ 100 Mo/s en lecture et en écriture. Le connecteur est rétractable pour éviter qu'il prenne la poussière.


> Voir l'offre
106,99 €Perceuse sans-fil Bosch Prol GSB 12V-15 percussion + 39 accessoires + 2 Batteries 2 AH à 106,99 €
Valable jusqu'au 28 Juillet

Amazon fait actuellement une belle promotion sur la perceuse sans fil Bosch Professional GSR 12V-15 avec percussion avec 2 batteries 12V 2.0 AH au lithium, sa pochette et 39 pièces d'accessoires à 106,99 € livrée gratuitement alors qu'on la trouve ailleurs à partir de 140 €.


> Voir l'offre
83,79 €Disque dur externe portable Toshiba Canvio Basics 4 To USB 3.0 à 83,79 €
Valable jusqu'au 28 Juillet

Amazon propose actuellement le disque dur externe portable Toshiba Canvio Basics 4 To USB 3.0 à 83,79 € seulement ! Avec ses 4 To et sa connectique USB 3.0 compatible USB 2.0, vous aurez de quoi stocker rapidement et emporter avec vous vos photos, vos films, etc.  La livraison est gratuite.


> Voir l'offre

Sujets relatifs
Formules Open Office Calc
Open office 4 (Calc)
Open Office Calc - Copier & Coller.
soustraction dans cellules Open Office Calc
bug open office sur calc
Formules calcul avec Open Office
Décimale "0" Calc Open Office
format conditionnel calc open office
Calculer les heures sous open office calc
copier coller dans open office calc
Plus de sujets relatifs à Pb formules open office calc complexes
 > Tous les forums > Forum Bureautique