> Tous les forums > Forum Bureautique
 Pb formules open office calc complexes
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Floboww
  Posté le 06/02/2012 @ 11:15 
Aller en bas de la page 
Nouvel astucien

Bonjour,

Actuellement en train de concevoir des outils informatiques, je me suis retrouvé dans une impasse pour l'accumulation de certaines formules..

Je m'explique :

Je souhaite que dans une certaine cellule, le calcule soit différents selon des critères, en français ça donnerait :

"Si B9=1 alors dans la cellule concernée on aura le résultat de E6*(1/4) ou sinon 0". Ca je l'ai traduit par : =SI(B9=1;E6*(1/4);0) Pour l'instant ça va

Ca c'est assez simple... maintenant ce que je voudrais rajouter pour cette même cellule ;

"SI B9=1 et que B8=B10=B11=0 alors la cellule concernée (E8) = (E6) A MOINS QUE SI B9=1 et que B8=0 mais que B10+B11 = 1, dans ces cas là E(8)=(1/4)*E6

A MOINS QUE B10+B11=2, dans ces cas là, E(8)=(1/2)*E6"

Voilà, j'aimerai rentrer tout ça dans une seule cellule mais je ne sais pas quelles formules utilisées ni comment les accumuler...

Je remercie d'avance les personnes pouvant se pencher sur la question et espère avoir été assez clair !

Flo

Publicité
DjiDji59430
 Posté le 06/02/2012 à 11:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

=SI(ET(B9=1;B8=0;B10=0;B11=0);E6;SI(ET(B9=1;B8=0;B10+B11=1);E6/4;SI(B10+B11=2;E6/2;"")))

On ne dit pas "a moins que", mais "sinon", ni "mais que" mais "et que"

Si ta phrase avait été formulée correctement , la formule t'aurais sauté aux yeux.

SI B9=1 et B8=0 et B10=0 et B11=0 alors E8 = E6 sinon, SI B9=1 et B8=0 et B10+B11 = 1,alors E8= E6/4, sinon si B10+B11=2 alors E8=E6/2 sinon rien



Modifié par DjiDji59430 le 06/02/2012 11:53
philou_10120
 Posté le 06/02/2012 à 14:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Voici ma solution j'espére répondre à votre besoin

=SI(ET(B9=1;B8=B10=B11=0);E6;SI(ET(B9=1;B8=0;B10+B11=1);E6/4;SI(B10+B11=2;E6/2;SI(B9=1;E6/4;0))))

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
84,99 €SSD Samsung 870 QVO 1 To à 84,99 €
Valable jusqu'au 21 Septembre

Amazon fait une promotion sur le SSD Samsung 870 QVO 1 To qui passe à 84,99 € au lieu de 100 €. Ce SSD offre des vitesses de 560 Mo/s en lecture et 530 Mo/s en écriture. Il est garanti 3 ans.


> Voir l'offre
-5 €5€ de réduction immédiate dès 15€ d'achats sur les produits vendus et expédiés par Amazon
Valable jusqu'au 26 Septembre

Amazon offre actuellement 5 € de réduction immédiate dès 15 € d'achats sur les produits vendus et expédiés par Amazon. Cette offre est limitée et n'est pas valable pour tous les clients. Pour savoir si vous êtes éligible, rendez-vous sur cette page.


> Voir l'offre
59,99 €Casque sans fil Sony WH-CH700NL Bluetooth avec réduction de bruit active à 59,99 €
Valable jusqu'au 22 Septembre

Cdiscount fait une belle promotion sur le casque sans fil Sony WH-CH700NL Bluetooth qui passe à 59,99 € livré gratuitement alors qu'on le trouve ailleurs à plus de 120 €. Ce casque sans fil rechargeable (via micro USB) offre jusqu'à 35h d'autonomie. L'AINC (Artificial Intelligence Noise Cancelling) s'adapte à votre environnement, ce qui vous permet d'éliminer les bruits indésirables lors de vos voyages ou si vous êtes avec d'autres personnes dans une même pièce. Une très bonne affaire.


> Voir l'offre

Sujets relatifs
Formules Open Office Calc
Open office 4 (Calc)
Open Office Calc - Copier & Coller.
soustraction dans cellules Open Office Calc
bug open office sur calc
Formules calcul avec Open Office
Décimale "0" Calc Open Office
format conditionnel calc open office
Calculer les heures sous open office calc
copier coller dans open office calc
Plus de sujets relatifs à Pb formules open office calc complexes
 > Tous les forums > Forum Bureautique