× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 PB mise à jour des données avec une formuleSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Lorane_yx
  Posté le 05/08/2013 @ 15:50 
Aller en bas de la page 
Petite astucienne

Voici mon problème : j'ai créé sous excel une formule "=SI" de type "=SI(A2>B2;A2;B2", soit si la valeur dans la colonne A est supérieure à la valeur dans la colonne B (pour une ligne donnée) alors dans la colonne C, s'affiche la valeur A, sinon la valeur B s'affiche (sur la même ligne). J'ai dupliqué cette formule dans toute la colonne C : pour que sur chaque ligne les valeurs des colonnes A et B soit prises en compte, et que dans la colonne C, sur la même ligne, le montant de la valeur A ou de la valeur B s'affiche (suivant si A > B ou si B > A).

Cependant, si lors du copiage de la formule dans toute la colonne C, les valeurs souhaitées s'affichent dans la colonne C, lorsque je modifie une valeur dans la colonne A (ou dans la colonne B), la valeur de la colonne C (sur la même ligne) ne se met pas automatiquement à jour. Et ce, bien que j'aie vérifié que le calcul automatique soit activé, ainsi que l'itération des formules, et même si je mets les nombres (valeurs) en format standard ou en format nombre (ils étaient en format texte au départ). Je n'arrive pas à trouver de solution...

Ma configuration est : Windows 7 ; Microsoft Office Famille et étudiants 2010 ; excel 2010.

Je vous remercie de m'aider à trouver une solution.

Laurence.

Publicité
Aubagnais
 Posté le 05/08/2013 à 16:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Anonyme a écrit :

Salut

Pourquoi RESOLU (05/08/2013 à 16:29) ?

Anonyme

Anonyme

La colonne S respecte le test sur chaque ligne et affiche le nombre attendu.

Lorane_yx aura entre-temps trouvé le paramètre à modifier.

Aubagnais
 Posté le 05/08/2013 à 16:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

En fait, les colonnes Q et R contiennent des valeurs au format texte.

En les convertissant au format nombre, la colonne S variera bien lors des changements de valeurs ultérieures.

@+

ferrand
 Posté le 05/08/2013 à 19:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir,

Comme il vient d'être dit, les valeurs des colonnes Q et R ont été saisies comme texte, ce qui n'empêche pas d'obtenir un bon résultat en S avec la formule indiquée tant qu'on ne touche à rien en Q et R (que les 2 valeurs restent du texte). Mais si on modifie la valeur d'une colonne et pas l'autre, le résultat risque d'être faux !

Par exemple on a 9 en Q et 0 en R, la formule affiche 9 en S.
On modifie Q en tapant 8 (au lieu de 9, le 8 va se cadrer à droite indiquant qu'il s'agit alors d'un nombre) : la formule en S affichera alors 0, car l'opérateur de comparaison > (supérieur à) donne VRAI pour toute valeur texte comparée à un nombre.

Il y a 2 solutions, soit convertir le contenu des colonnes Q et R en nombres, soit modifier la formule en S :

=SI(CNUM(Q2)>CNUM(R2);Q2;R2)

Lorane_yx
 Posté le 05/08/2013 à 20:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

OK je vous remercie pour votre aide, je vais suivre les conseils indiqués ci-dessus, je pense que cela va résoudre mon pb.

Au revoir,

Laurence.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
74,58 €Ecouteurs intra-auriculaires sans fil Bluetooth Jabra Elite 65t à 74,58 € livrés
Valable jusqu'au 25 Novembre

Amazon Allemagne fait une promotion sur les écouteurs intra-auriculaires sans fil Bluetooth Jabra Elite 65t qui passent à 69,58 € (avec la TVA ajustée). Comptez 5 € pour la livraison en France soit un total de 74,58 € livrés. On les trouve ailleurs à partir de 100 €. Pensés pour vous permettre de vivre votre musique comme vous l'entendez et pour assurer des conversations d'une grande clarté, les écouteurs Jabra Elite 65t ont tout pour vous séduire ! Côté son, l'égaliseur personnalisable vous permet d'ajuster le rendu sonore tandis que la technologie avancée à quatre microphones supprime les bruits de fond lors des appels pour des conversations limpides. Au quotidien, ces écouteurs Jabra restent parfaitement en place et proposent même une fonction de commande vocale simplifiée. Enfin, vous apprécierez les 5 heures d'autonomie avec une seule charge, qui se transforment en 15 heures avec l'étui de recharge compact.  Le Jabra Elite 65t est certifié IP55 et offre une garantie de 2 ans contre l’humidité et la poussière. Où que vous soyez et quelle que soit votre activité, vous profitez d’une liberté absolue pour les appels et la musique. 


> Voir l'offre
35,99 €Clé USB 3.0 SanDisk Ultra Flair 256 Go à 35,99 €
Valable jusqu'au 26 Novembre

Amazon fait une promotion sur la clé USB 3.0 SanDisk Ultra Flair 256 Go qui passe à 35,99 € livrée gratuitement alors qu'on la trouve ailleurs à plus de 55 €.


> Voir l'offre
59,99 €Switch Netgear GS116, 16 ports à 59,99 €
Valable jusqu'au 25 Novembre

Amazon propose actuellement le commutateur 16 ports Netgear GS116E-200PES à 59,99 € livré gratuitement alors qu'on le trouve ailleurs à partir de 100 €. Ce switch bénéficie de 16 connexions Ethernet haut débit commutées à 10/100/1000 Mbps en full-duplex ce qui vous permet de transférer vos fichiers sur votre réseau local à une vitesse maximum sur chaque port (jusqu'à 2000 Mbits/s). Compatible VLAN, le Netgear GS116 vous permettra également de mettre en place des réseaux locaux virtuels à l'intérieur de votre réseau local afin de mieux répartir votre bande passante et mieux gérer les priorités. Le produit est garanti 5 ans !


> Voir l'offre

Sujets relatifs
copier coller avec mise à jour des données
Supprimer la confirmation de mise à jour des liens avec Excel
Copier feuille 1 dans feuilles 2 et 3 avec mise à jour
Mailing - Mise à jour de la Base de données
mise en forme conditionnel avec formule de calcule
mise a jour de données
Mise à jour de données Excel
mise à jour libre office
Mise à jour Libre Office
Macro...Date de Mise a jour
Plus de sujets relatifs à PB mise à jour des données avec une formule
 > Tous les forums > Forum Bureautique