> Tous les forums > Forum Les mains dans le cambouis
 Périphérique d'amorçage sur portable Asus X401USujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
fgondard
  Posté le 03/04/2018 @ 18:51 
Aller en bas de la page 
Grand Maître astucien

Bonjour,

J'ai hérité il y a quelques temps de ce portable (Windows 7 en anglais, batterie absente et clavier QWERTY mais à cheval donné on ne regarde pas les dents). Le seul manuel que j'ai trouvé est celui-ci.

Il est sous UEFI mais comme souvent sur les portables les menus de configuration sont sommaires.

Par exemple rien n'est prévu pour afficher les messages du POST à la place du logo Asus. Rien non plus pour se mettre en mode compatibilité BIOS.

Dans la section boot je n'ai pas d'autre choix que le boot manager de Windows. Si je le désactive, au démarrage j'arrive dans les menus de configuration de l'UEFI.

J'ai la possibilité d'ajouter d'autres options de démarrage mais on me demande un chemin d'accès !

J'aurais au moins voulu pouvoir mettre un Windows 7 en français mais il aurait fallu pour ça pouvoir amorcer sur un port USB (il n'y a pas de lecteur de CD sur une si petite machine).

Y'aurait-il un moyen de résoudre ce problème ?

Merci d'avance pour vos suggestions.

Publicité
capitainekirk
 Posté le 03/04/2018 à 19:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

salut,

dans l onglet "boot",

tu n as pas "launch csm", que tu mettrais sur "enabled" ?

onglet "securité", "secure boot control" sur "disabled"

pour le boot menu, laisse appuyer "esc" en meme temps que tu allumes

pour le bios, c est f2 appuyé et tu allumes

capitainekirk
 Posté le 03/04/2018 à 19:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

peut etre dans l autre sens ...

d abord, onglet securité, redemarré

reour dans le bios et l option launch csm sera apparu

pas oublier f10 entre chaque ^^

fgondard
 Posté le 03/04/2018 à 20:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Salut Capitaine,

Rien de tout ça. La touche F2 permet d'accéder directement aux menus de configuration et la touche Échap au menu de démarrage qui ne m'offre pas d'autre choix que le boot manager de Windows ou l'accès aux menus de configuration.

Quant à ajouter quelque chose comme ça m'est proposé, je suis comme une poule devant un couteau.

Au passage, merci pour la communication de ton nouveau lien pour XP.

Ikewdu_
 Posté le 03/04/2018 à 21:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut

Il est sous UEFI mais comme souvent sur les portables les menus de configuration sont sommaires.

Peux-tu faire une capture d'écran du gestionnaire de disque pour qu'on puisse s'assurer que c'est le cas et que ta clé est correctement formatée.

Par exemple rien n'est prévu pour afficher les messages du POST à la place du logo Asus. Rien non plus pour se mettre en mode compatibilité BIOS.

Précise si le bios ressemble à celui de la doc... Intel ou amd ?

Dans la section boot je n'ai pas d'autre choix que le boot manager de Windows. Si je le désactive, au démarrage j'arrive dans les menus de configuration de l'UEFI.

J'ai la possibilité d'ajouter d'autres options de démarrage mais on me demande un chemin d'accès !

C'est l'occasion pour toi de vérifier que ton support USB possède le dossier /efi/boot nécessaire, et à l'intérieur, le fichier bootx64.efi qui est nécessaire au démarrage.

J'aurais au moins voulu pouvoir mettre un Windows 7 en français mais il aurait fallu pour ça pouvoir amorcer sur un port USB (il n'y a pas de lecteur de CD sur une si petite machine).

Y'aurait-il un moyen de résoudre ce problème ?

Il n'y a pas de raison que ça ne puisse pas se faire, si le PC possède actuellement un W7.



Modifié par Ikewdu_ le 03/04/2018 21:29
triode94
 Posté le 03/04/2018 à 21:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonsoir.

Je ne sais pas sur le tien mais sur mon ASUS X73S, en appuyant sur ESC au boot, on peut choisir le support de démarrage. Ainsi j'ai pu booter à partir d'une mémoire d'APN !

Ikewdu_
 Posté le 03/04/2018 à 21:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je réponds pour lui....

Salut Capitaine,

Rien de tout ça. ... et la touche Échap au menu de démarrage qui ne m'offre pas d'autre choix que le boot manager de Windows ou l'accès aux menus de configuration.



Modifié par Ikewdu_ le 03/04/2018 21:38
capitainekirk
 Posté le 03/04/2018 à 22:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

il faut d abord desactiver le secure boot ...

Ikewdu_
 Posté le 03/04/2018 à 22:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Idem. Je doute qu'il soit activé si un W7 est installé sur le PC. W7 ne fonctionnerait pas.
Publicité
fgondard
 Posté le 03/04/2018 à 22:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Peux-tu faire une capture d'écran du gestionnaire de disque pour qu'on puisse s'assurer que c'est le cas et que ta clé est correctement formatée.

C'est un disque dur sur lequel j'ai monté un Unbutu autonome et sur lequel j'amorce sans problème sur mon PC de bureau qui lui est sous BIOS.

Précise si le bios ressemble à celui de la doc... Intel ou amd ?

AMD

C'est l'occasion pour toi de vérifier que ton support USB possède le dossier /efi/boot nécessaire, et à l'intérieur, le fichier bootx64.efi qui est nécessaire au démarrage.

Ce fichier se trouve bien dans M:\EFI\BOOT (M est la lettre d'unité du moment). J'ai aussi un répertoire x86_64-efi dans M:\boot\grub\x86_64-efi



Modifié par fgondard le 04/04/2018 11:31
Ikewdu_
 Posté le 03/04/2018 à 22:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Tu ne réponds pas à tout .

- La clé est bien formatée en fat32? Une clé NTFS ne boote pas en uefi. Idem pour un HDD.

- Tu dis pouvoir cibler un chemin d'accès dans le BIOS. Essaie de lancer ce fameux bootx64.efi.

- Dans la doc, on voit que l'uefi peut être désactivé dans l'onglet boot. Peux-tu le faire ?

- Je n'ai pas compris à ton histoire d'Ubuntu. Je croyais que tu avais un W7 en anglais....

- La présence dun GRUB m'étonne pour une clé d'installation de Windows. Explique.



Modifié par Ikewdu_ le 03/04/2018 22:45
fgondard
 Posté le 03/04/2018 à 23:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Je n'ai pas compris à ton histoire d'Ubuntu. Je croyais que tu avais un W7 en anglais....

Désolé, je ne voulais pas tout mélanger. C'était simplement parce que j'avais sous la main ce disque dur pour tester le démarrage sur support USB. Mais peu importe l'OS sur lequel je veux amorcer. J'ai d'ailleurs aussi essayé après avec ma clé USB qui contient le Win PE de yoyo et qui elle aussi a tout ce qu'il faut pour un UEFI.

La clé est bien formatée en fat32? Une clé NTFS ne boote pas en uefi.

Bien sûr

Dans la doc, on voit que l'uefi peut être désactivé dans l'onglet boot. Peux-tu le faire ?

Je n'ai pas cette possibilité. Seulement une ligne Windows Boot Manager dans la rubrique priorité et, comme je l'ai dit la possibilité, d'ajouter d'autres options mais j'ignore comment puisqu'on me demande un chemin.

La présence dun GRUB m'étonne pour une clé d'installation de Windows. Explique

Ben voir ci-dessus. Installer un Windows 7 en français n'était qu'une éventualité dans le futur.

Tu dis pouvoir cibler un chemin d'accès dans le BIOS. Essaie de lancer ce fameux bootx64.efi

Je vais essayer mais je suppose qu'il faut que je donne le chemin d'accès



Modifié par fgondard le 04/04/2018 11:32
fgondard
 Posté le 03/04/2018 à 23:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

EUREKA !

Il y a deux ports USB sur cette machine, un en USB2 et l'autre en USB3. J'avais tout naturellement connecté ma souris sur le port USB2 et connecté mon disque dur, ou ma clé USB, sur le port USB3.

J'ai eu l'idée d'inverser et ça fonctionne. Dans le menu de démarrage (touche Échap) mon périphérique USB apparaît et j'amorce aussi bien sur Ubuntu que sur Win PE.

Question quand même, est-ce un cas particulier ou bien faut-il, quelque soit la machine, n'utiliser qu'un port USB2 ?



Modifié par fgondard le 04/04/2018 11:33
Daneel Olivaw
 Posté le 04/04/2018 à 00:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Par exemple rien n'est prévu pour afficher les messages du POST à la place du logo Asus.

Ne serait-ce pas ici ?

Rien non plus pour se mettre en mode compatibilité BIOS.

Ce n'est pas ça ? Aussi pour le port USB 3 ?

capitainekirk
 Posté le 04/04/2018 à 02:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

salut,

il faut le pilote usb3 sur ton support bootable

j ai eu , comme toi, au debut de l usb3, des refus d installation de seven (la sampiternelle "manque un pilote ..."), lors du choix du disque à l installation

https://sospc.name/windows-7-sp1-mars-2017-usb3-goof/

toujours goof^^



Modifié par capitainekirk le 04/04/2018 02:07
enfermedehors
 Posté le 04/04/2018 à 07:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

il faut le pilote usb3 sur ton support bootable

Pour ça, il faut que la CM gère le boot sur USB 3 et mon live-Cd contient les pilotes USB 3.

Ikewdu_
 Posté le 04/04/2018 à 07:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Pour info, les options des BIOS aptio ou insydeh20 sont souvent limitées sur les portables. Il faut s'ajouter un MP superviseur pour en obtenir plus, voire faire des bidouillages plus ou moins dangereux. J'avoue n'avoir pas lu ta doc pour savoir si c'est le cas ici.

Quant à l'USB 3, il est effectivement fréquent que ce soit un problème avec les consoles winre. On conseille souvent d'utiliser un port USB 2, en effet.

Publicité
triode94
 Posté le 04/04/2018 à 09:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

fgondard a écrit :

UEREKA !

J'ai eu l'idée d'inverser et ça fonctionne. Dans le menu de démarrage (touche Échap) mon périphérique USB apparaît et j'amorce aussi bien sur Ubuntu que sur Win PE.

Qu'est-ce que j'avais dit ?



Modifié par triode94 le 04/04/2018 09:34
capitainekirk
 Posté le 04/04/2018 à 09:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

salut triode,

c est pas le fait d avoir appuyé sur echap qui lui a permis d arrriver au boot menu, mais le fait d avoir mis sa clé usb sur un port usb2 ....

et je l avais dit avant toi ....

triode94
 Posté le 04/04/2018 à 11:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Il faut effectivement que la clé de boot soit en place pour obtenir sa sélection par ESC au démarrage. Je confirme.

fgondard
 Posté le 04/04/2018 à 12:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Daneel :

j'avais bien vu ce paramètre mais quelle que soit l'option choisie ça ne change rien. Même ma touche de tabulation qui habituellement permet d'éclipser le logo constructeur est sans effet.

Je n'ai pas cette ligne, uniquement celle pour le démarrage via la carte réseau.

Enfermedehors :

Pour ça, il faut que la CM gère le boot sur USB 3 et mon live-Cd contient les pilotes USB 3.

C'est sans doute là le problème puisque ça ne décolle pas avec le tien (depan-yol_2.2.iso).

Triode et Capitaine :

Qu'est-ce que j'avais dit ?

....

c est pas le fait d avoir appuyé sur echap qui lui a permis d arrriver au boot menu, mais le fait d avoir mis sa clé usb sur un port usb2 ...

Les deux mon général. Depuis le début j'avais vu que c'était la touche Échap qui permettait d'accéder au menu de démarrage mais je n'avais pas d'autre choix que le disque dur en étant en USB3.

En fait c'est un peu plus compliqué. Sur le port USB3 ça marche avec un support d'amorçage non prévu pour un UEFI (testé avec un HBCD et une installateur de Windows 7). Su le port USB2 tout passe.

Ikewdu :

Pour info, les options des BIOS aptio ou insydeh20 sont souvent limitées sur les portables.

L'UEFI est d'American Megatrends avec Aptio en utilitaire de configuration. Et ce portable, à la frontière avec les ultra portables, est tout ce qu'il y a de plus rustique.

Je viens de me souvenir que j'avais déjà posé une question à propos de cette machine (ici) et c'est à cette occasion que j'avais crée ma clé USB à partir de l'ISO d'enfermedehors. À l'époque je n'avais pas eu de problème sans doute parce que j'avais, au hasard, utilisé le port USB2.

En tout cas merci à tous pour vos contributions.



Modifié par fgondard le 04/04/2018 14:10
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Portable Asus N53SV démontage lecteur dvd
Ecran vert, PC portable Asus Windows 8
Changement écran pc portable Asus k756uv-ty306t
Problème de batterie sur un portable Asus
Ori portable asus qui ne redémarre plus
portable Asus démarrage capricieux
asus pc portable
portable asus F7L
ordinateur portable asus
Cable alimentaion portable asus eepc 1000HE
Plus de sujets relatifs à Périphérique d''amorçage sur portable Asus X401U
 > Tous les forums > Forum Les mains dans le cambouis