> Tous les forums > Forum Linux
 Plugins Shockwave 11.2 et 19.0 co-habitentSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 27/10/2015 @ 13:16 
Aller en bas de la page 
Astucien

Bonjour,

Peu après l'installation de Jessie 8.2, j'ai installé le module Flashplayer (pour Firefox) en me rendant sur le site adobe.

Pour Linux, le module maximum et qui - selon adobe ne sera plus suivi - est Shockwave Flash 11.2.202.540.

En naviguant au hasard, j'ai trouvé un site permettant d'installer le module 19.0.0.226 et je l'ai fait (non sans mal).

J'ai donc maintenant les deux modules mais qui interagissent dans la mesure où, si je désactive le module 11.2, cela désactive automatiquement le 19.0 et vice et versa.

En visionnant des vidéos sur Youtube, j'ai cliqué droit sur la vidéo et un petit menu est apparu et j'ai pu constater que c'était bien le 19.0 qui fonctionnait.

Dans le petit menu, il y avait aussi une option "paramètres" qui m'a permis d'activer la lecture en html5.

Bref, maintenant, ce ne sont plus les plugins shockwave qui interviennent.

Pour une simple question de logique, je souhaiterais supprimer le 11.2 pour ne garder que le 19.0.

Comment le faire sans endommager le 19.0 ?

Merci d'avance pour vos avis éclairés.

Publicité
reivillo
 Posté le 27/10/2015 à 13:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Mimile.

Tu peux voir ou il se trouve via about:plugins, et renommer le libflashplayer.so en libflashplayer.so.old.
Et peut-être désinstaller flashplugin-installer via synaptic, ou/et mint-flashplugin pour Linux Mint.( si existe )

Et enfin, Redémarrer Firefox.

Reivillo.



Modifié par reivillo le 27/10/2015 13:53
Logicien
 Posté le 27/10/2015 à 15:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

c'est la raison pour laquelle je n'installe rien ou presque qui n'est pas dans la logithèque du gestionnaire de paquets. Ce dernier sait ce qu'il a installé et le désinstalle en conséquence. Présentement, j'utilise browser-plugin-freshplayer-pepperflash qui installe pepperflashplugin-nonfree qui sont dans la logithèque d'APT. Le greffon fonctionne correctement avec Iceweasel.

Puisqu'Adobe ne supporte plus le Flash pour Linux, j'utilise le version de Google. J'ai désinstallé

apt-get purge flashplugin-nonfree flashplugin-nonfree-extrasound

Je ne fonctionne plus qu'avec la version Google de Flash.

Dans ton cas Mimile, tu peux faire afficher le contenu d'un fichier tar.gz comme ceci

tar ftvz le-fichier.tar.gz

Il te s'agit de supprimer les fichiers affichés en sortie dans l'arborescence de Debian, normalement à partir de la racine / .



Modifié par Logicien le 27/10/2015 16:01
Mimile
 Posté le 27/10/2015 à 17:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour

@ reivillo : bien vu en me suggérant about:plugins

En effet, je soupçonnais bien que libflashplugin.so était celui du shockwave 11.2 et j'avais beau supprimer le lien symbolique pointant dans un dossier créé dans ma /home, le plugin 11.2 restait présent dans la liste.

about:plugins m'a permis de voir que libflashplugin.so se trouvait aussi (et ça je l'ignorais) dans /usr/lib/flashplugin-nonfree.

J'ai renommé les deux et maintenant, il n'y a plus que le plugin 19.0 qui apparaît.

Sujet résolu donc.

Merci à toi.

@ Logicien

Je dois avouer que je ne sais plus comment j'y suis arrivé à force d'arpenter le net, mais le fait est que finalement, j'ai maintenant le plugin shockwave flash 19.0.0.226.

Je crois me souvenir qu'il m'avait fallu installer chromium mais pour le reste ...

Cela dit, quand j'avais encore les deux plugins, j'ai testé en visionnant une vidéo sur youtube et en cliquant droit sur la vidéo, j'ai constaté que c'était bien le 19.0 qui fonctionnait.

Dans le menu déroulant, il y avait une option "préférences" (? pas sûr du nom), mais en cliquant dessus, j'ai pu activer la lecture en html5 et c'est maintenant lui qui fonctionne.

Ceci étant, je ne remarque pas de différence de qualité des images.

Cordialement à tous deux.



Modifié par Mimile le 27/10/2015 17:22
Slyvester
 Posté le 28/10/2015 à 09:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Mimile a écrit :

Dans le menu déroulant, il y avait une option "préférences" (? pas sûr du nom), mais en cliquant dessus, j'ai pu activer la lecture en html5 et c'est maintenant lui qui fonctionne.

... et plus avant :

Dans le petit menu, il y avait aussi une option "paramètres" qui m'a permis d'activer la lecture en html5.

Il y a plus simplement la possibilité - comme nous l'a indiqué Logicien il y a quelques temps - d'utiliser ce lien fort pratique pour définir par défaut HTML5 dans le navigateur : https://www.youtube.com/html5?hl=fr

P.S. : dommage que tu n'aies pas fourni le lien du site permettant d'installer le module 19.0.0.226 cité plus haut, Mimile ...

Mimile
 Posté le 28/10/2015 à 10:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Il me semble que je radote ... sans doute vu mon grand âge

En ce qui concerne html5, le lien de Logicien ne m'avait pas échappé et je l'ai appliqué sur Arch et Linux Mint 17.1, à une époque où je n'avais pas encore installé Jessie 8.2 stable.

Quand je l'ai installé (il y a peu), j'ai perdu de vue ce lien de Logicien.

En ce qui concerne l'installation du plugin Shockwave Flash 19.0.0.226, je dois avouer que j'ai consulté tellement de sites et effectué tant d'opérations qui ne menaient à rien que je ne saurais te dire comment, finalement, j'ai trouvé - à ma grande surprise - le fichier libfreshwrapper-pepperflash.so dans le répertoire /usr/lib/mozilla/plugins.

Je me souviens qu'il m'a fallu installer chromium (ou chrome) qui apparemment contient ce plugin et qu'on peut prélever pour l'installer dans /usr/lib/mozilla/plugins.

Au cours de mes recherches, j'ai marqué deux sites que je te donne mais sans certitude qu'ils soient les bons :

http://ubuntuforums.org/showthread.php?t=2299381

https://wiki.debian.org/fr/Freshplayerplugin#Installer_Freshplayerplugin

Tu pourrais peut-être t'inspirer de ce qu'a écrit Logicien mais je ne vois pas exactement comment il a procédé.

Ce qui est sûr, c'est que dans la logithèque de Jessie, il y a bien browser-plugin-freshplayer-pepperflash qui, chez moi, est mentionnée activée (carré vert) mais je ne me souviens pas l'avoir fait volontairement.

A propos de ce package, il est dit :

Flash plugin for Linux provided by adobe stopped at version 11.2; for
chrome/chromium users there is pepperflash plugin but it's not supported by
firefox/iceweasel/other browsers.

This package allows one to use the Pepper Flash plugin from Chrome
in NPAPI web browsers. (en l'occurrence chez moi Firefox)

Tu devrais voir de ce côté.

Amicalement,



Modifié par Mimile le 28/10/2015 10:29
Slyvester
 Posté le 28/10/2015 à 15:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Merci pour toutes ces précisions, Mimile. Personnellement, j'utilise plusieurs plugins, comme actuellement ici sur wattOS (dérivé de Ubuntu) sur le navigateur PaleMoon (dérivé/fork de Mozilla Firefox) :

1) Shockwave Flash 11.2 r202 ;

2) Shockwave Flash 13.1 r2 ;

3) Shockwave Flash 10.3 d180 , soit le ShockWave qui nous a été conseillé par Reivillo : https://forum.pcastuces.com/sujet.asp?f=8&s=14344

Sans oublier de définir le lecteur HTML5 par défaut : https://www.youtube.com/html5?hl=fr



Modifié par Slyvester le 28/10/2015 15:23
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
164,99 €SSD SanDisk Plus 2 To à 164,99 €
Valable jusqu'au 15 Mai

Amazon propose actuellement le SSD SanDisk Plus 2 To à 164,99 € livré gratuitement. Une très bonne affaire pour ce SSD très fiable et performant qui offre des débits de 530 Mo/s en lecture et 445 Mo/s en écriture. Il est garanti 3 ans. On le trouve ailleurs à partir de 200 €. 


> Voir l'offre
94,99 €SSD externe portable USB 3.1 SanDisk Extreme 500 Go NVME (1050 Mo/s) à 94,99 €
Valable jusqu'au 14 Mai

Amazon fait une promotion sur le SSD externe portable USB 3.1 SanDisk Extreme 500 Go NVME qui passe à 94,99 € alors qu'on trouve le SSD à 118 € ailleurs. Le disque SSD SanDisk Extreme NVME Portable 1 To permet, grâce à sa connectique USB 3.1, des haute vitesse de transfert pouvant aller jusqu'à 1050 Mo/s grâce au disque NVMe qu'il contient. Sa coque robuste et certifiée IP55 (eau et poussière) protège vos données partout où vous allez. Vous ne craindrez pas de l'emporter partout avec vous grâce à sa conception robuste et résistante avec un coeur de SSD résistant aux chocs. Le logiciel SanDisk inclu SecureAccess peut crypter vos fichiers personnels. Garantie 5 ans. Interface : USB 3.1 Type A et C.


> Voir l'offre
155,99 €SSD externe portable USB 3.1 SanDisk Extreme 1 To NVME (1050 Mo/s) à 155,99 €
Valable jusqu'au 14 Mai

Amazon fait une promotion sur le SSD externe portable USB 3.1 SanDisk Extreme 1 To NVME qui passe à 155,99 € alors qu'on trouve le SSD à 200 € ailleurs. Le disque SSD SanDisk Extreme NVME Portable 1 To permet, grâce à sa connectique USB 3.1, des haute vitesse de transfert pouvant aller jusqu'à 1050 Mo/s grâce au disque NVMe qu'il contient. Sa coque robuste et certifiée IP55 (eau et poussière) protège vos données partout où vous allez. Vous ne craindrez pas de l'emporter partout avec vous grâce à sa conception robuste et résistante avec un coeur de SSD résistant aux chocs. Le logiciel SanDisk inclu SecureAccess peut crypter vos fichiers personnels. Garantie 5 ans. Interface : USB 3.1 Type A et C.


> Voir l'offre

Sujets relatifs
Plugins de Leechcraft
ubuntu 8;04 et Shockwave flash player
HELP ! pour Shockwave Flash 9.0.r48 -> 9.0.r115 !
Firefox Plugins >> calculator
problème plugins mandriva 2006
Javascript, plugins Mandrake 10.0 [Résolu]
quels plugins installés ?
plugins manquant?
Pour Abourgeo :P tris entre les plugins son....
plugins pour firefox suite
Plus de sujets relatifs à Plugins Shockwave 11.2 et 19.0 co-habitent
 > Tous les forums > Forum Linux