> Tous les forums > Forum des Webmasters
 Problème avec Xampp - résolu ? si on veut !Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 23/10/2009 @ 09:40 
Aller en bas de la page 
Astucien

Bonjour,

Pour pouvoir tester en local la page Web que je suis en train de rédiger, j'ai installé voici quelques mois sur ma Debian Lenny Xampp version 1.7.0.

Je présume que, sur ce forum, tout le monde connaît ce logiciel ; toutefois, pour les autres, je les invite à aller voir ici. En résumé, le tar.gz permet l'installation dans un dossier /opt de tout ce qu'il faut :

extrait du site :

XAMPP est un kit d'installation d'Apache qui contient MySQL, PHP et Perl. XAMPP est réellement très facile à installer et à utiliser - vous n'avez qu'à le télécharger, le décompresser et le démarrer.

Ce kit pour les systèmes Linux (testé sous SuSE, RedHat, Mandrake and Debian) comprend : Apache, MySQL, PHP & PEAR, Perl, ProFTPD, phpMyAdmin, OpenSSL, GD, Freetype2, libjpeg, libpng, gdbm, zlib, expat, Sablotron, libxml, Ming, Webalizer, pdf class, ncurses, mod_perl, FreeTDS, gettext, mcrypt, mhash, eAccelerator, SQLite et IMAP C-Client.

Effectivement, c'est on-ne-peut-plus simple à installer (d'ailleurs, ça ne s'installe pas : il suffit de décompresser l'archive dans le dossier /opt) et je peux donc afficher avec mon navigateur ma page Web pour voir à quoi elle ressemble vraiment et y travailler efficacement (page Web qui utilise le xHTML, PHP, CSS et des scripts JAVA).

Ayant récemment ajouté Linux Mint 7 (variante d'Ubunut 9.04) sur mon PC, j'ai téléchargé et installé la version actuelle de Xampp (1.7.2) mais bizaremment, avec elle pas moyen d'afficher ma page (error 404 !) et ce ne doit probablement pas être un problème de mise à niveau puisqu'aucune installation de Xampp n'avait été installée sur Linux Mint auparavant.

En désespoir de cause, j'ai supprimé le dossier /opt contenant cette version et j'ai rapatrié le dossier /opt de ma Debian (donc la 1.7.0) en lieu et place.

Maintenant, ça fonctionne mais je me demande bien pourquoi la version 1.7.2 pose problème.

Une idée quelqu'un ?

Merci d'avance.

Amicalement,

EDIT : Après quelques recherches avec Google, j'ai constaté que cette version 1.7.2 posait problème à pas mal de gens qui utilisaient aupravant 1.7.0. Il semblerait que le responsable soit la nouvelle version de PHP (5.30) ...

Je me contenterai dès lors d'utiliser la version 1.7.0 jusqu'à ce que les éditeurs de Xampp apporte une réponse à ce problème pour lequel je pense qu'il doivent avoir pas mal de retours...

Je renseigne ce sujet comme résolu pour éventuellement attirer l'attention sur ce problème.



Modifié par Mimile le 23/10/2009 10:01
Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
103,54 €Tablette 8 pouces Galaxy Tab A 2019 (4 coeurs, 32 Go, Wifi, HD, RAM 2 Go) à 103,54 € livrée
Valable jusqu'au 13 Avril

Amazon Espagne fait une promotion sur la tablette 8 pouces Samsung Galaxy Tab A 2019 qui passe à 98,18 € (avec la TVA ajustée). Comptez 5,36 € pour la livraison en France soit un total de 103,54 € livrée. On la trouve ailleurs à plus de 150 €. Cette tablette possède un écran 8 pouces HD (1280x800 pixels), un processeur quad-core 2 GHz, 2 Go de RAM, un espace de stockage de 32 Go extensible par MicroSD, le WiFi, le bluetooth et tourne sous Android 10.

La tablette pourra être mise en français dès le premier démarrage et vous bénéficiez d'une garantie européenne de 2 ans. Vous pouvez utiliser votre compte Amazon France sur Amazon Espagne et il n'y a pas de douane.


> Voir l'offre
230,97 €Volant Logitech G29Driving Force + levier de vitesse pour PC, PS3, PS4, PS5 à 230,97 €
Valable jusqu'au 12 Avril

LDLC fait une belle promotion sur un ensemble comprenant le célèbre volant Logitech G29 Driver Force pour PC et PS3, PS4, PS5 avec son pédalier ainsi que le levier de vitesse Driving Force qui passe à 230,97 € avec le code FAST30 alors qu'on le trouve ailleurs à partir de 290 €. 


> Voir l'offre
20,85 €Clé USB Sandisk Ultra 128 Go à double connectique USB 3.1 Type A et C à 20,85 €
Valable jusqu'au 13 Avril

Amazon fait une promotion sur la clé USB Sandisk Ultra 128 Go à double connectique USB 3.1 Type A et C qui passe à 20,85 €. Cette clé USB  dispose d'un connecteur réversible USB Type C et d'un connecteur classique de type A. Grâce à elle, transférez en toute simplicité et rapidement (jusqu'à 150 Mo/s) vos fichiers entre vos smartphones, tablettes et ordinateurs. On la trouve ailleurs à plus de 40 €.

 


> Voir l'offre

Sujets relatifs
Sérieux problème avec filezilla (résolu)
Problème avec frontapge (problème résolu )
Problème avec IPB 1.3.1 (résolu)
Problème HTML et PHP (avec DW MX 2004 )(Résolu)
probleme avec frontpage office 2000 premium RESOLU
Probleme avec wanadoo (resolu)
probleme avec theme (resolu)
Problème avec free
problème avec fichier "xxx.klm"
problème avec google
Plus de sujets relatifs à Problème avec Xampp - résolu ? si on veut !
 > Tous les forums > Forum Forum des Webmasters