> Tous les forums > Forum Linux
 Probleme demarrage VistaSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
dedetoto
  Posté le 10/06/2010 @ 15:09 
Aller en bas de la page 
Petit astucien

Bonjour,

Sur mon PC j'ai deux DD un dédié à Vista et l'autre à Linux.Suite a une mise à jour d'Ubuntu passage à 10.04 j'ai du faire une fausse manip en remplissant la fenêtre relative au grub(mon anglais est approximatif) depuis je ne peux plus demarrer que sous Linux.Quelq'un peut-il venir a mon secours?Merci d'avance.

Publicité
dedetoto
 Posté le 10/06/2010 à 17:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'ai oublié de signaler que lorsque le grub s'affiche il y a la ligne Vista loader (on/dev/sda1) mais que quand je l'active j'ai un écran noir et je suis obligé d'eteindre et de rallumer.Et en dernière ligne j'ai Recovery environment(loader)(on/dev/sda2).Cette ligne n'existait pas auparavant.



Modifié par dedetoto le 10/06/2010 17:40
Logicien
 Posté le 13/06/2010 à 07:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

il se peut que Vista n'ait pas apprécié le coup de Grub que la mise-a-jour lui a donnée. À moins que tu aies commit des imprécisions en complétant les informations de la fenêtre de Grub.

D'abord, est-ce que tu sais ou tu as intallé Grub? Je suppose que c'est dans le MBR de ton disque dur principal, sinon, ce serait Windows qui démarrerais. Est-ce que tu connais comment ton disque dur est divisé? Normalement, la partition C de Windows est la première du disque et en est une dite principale ou primaire. Si tel est le cas, la partition C doit effectivement être nommée /dev/sda1 par Linux.

Alors, c'est dans le contenu de la ligne Vista loader (on/dev/sda1) qu'il y a un problème ou bien que le réinstallation de Grub ait indisposé Vista que ne se charge pas pour des raisons qui lui sont propres. Quand tu mets en surbrillance la ligne Vista loader (on/dev/sda1), appuie sur la touche e pour edit. Cela devrait te montrer les commandes utilisées par Grub pour charger Windows. Essai de les afficher ici. Si la touche e ne fonctionne pas, essai la touche Tab.

Il se peut que tu aies à réinstaller le chargeur de Vista dans le MBR, voir le secteur d'amorce de la partition C avec le cd d'installation ou autre média Windows, ce, si aucune solution pour faire démarrer Vista depuis Grub ne fonctionne.



Modifié par Logicien le 13/06/2010 07:13
dedetoto
 Posté le 13/06/2010 à 11:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut,

Mon grub est dans le MBR et effectivement la partition C de windows est nommée /dev/sda1 par Linux.

J'ai fait la manip que m'a décrite et cela donne:

insmod ntfs

set root= '(hd0,1)'

search --no--floopy--fs-vvid--set dcc28609c285e85a

chainloader+1

Attention j'ai recopié a la main et j'ai peut-être des erreurs dans les espaces.Si c'est important pour toi tu me le dis et je tacherai de relever plus finement la fenêtre a moins que tu m'indiques comment la copier directement.

Merci a toi de prendre mon pb en compte et à+

Mimile
 Posté le 13/06/2010 à 16:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Sauf erreur (Logicien - que je salue au passage - me reprendra s'il y a lieu) la ligne set root='(hd0,1)' indique que Grub pointe vers /dev/sda2 (c'est-à-dire la 2ème partition du premier disque dur = on commence à compter par zéro).

C'est plutôt étonnant dans la mesure où tu indiques dans ton poste que Linux se trouve sur le second disque dur de ton PC.

A moins que tu n'aies délibérément installé ton bootloader sur cette partition /dev/sda2, Grub devrait normalement pointer vers la partition racine qui devrait se trouver en /dev/sdb1 (ou hd1,0).

N'aurais-tu pas créé une partition de boot (environ 200 mo) au moment de la mise à jour ?

Pour retrouver Vista, il faudrait indiquer hd0,0 au lieu de hd0,1 mais dans ce cas, tu n'auras plus accès à Linux.

C'est donc au niveau du fichier de configuration de Grub (/boot/grub.grub.cfg) qu'il conviendrait d'intervenir.

Personnellement, je ne me suis pas encore intéressé au mode de fonctionnement et à la configuration de la version actuelle de Grub (2) vu que j'en suis resté à l'ancienne version (0.97) sur les deux distros que j'utilise.

En revanche, voici un tuto qui devrait te permettre de résoudre ton problème : ici.

Il y a aussi un excellent tuto très complet - mais en anglais - ici.

Le premier tuto indique que, pour avoir un dual boot Windows/Linux, il suffit d'ajouter au fichier /boot/grub/grub.cfg ceci :

# (2) Windows Vista
menuentry "Windows Vista" {
set root=(hd0,0) ----> hd0,0 : on suppose que Vista est installé sur la 1ère partition du 1er disque dur
chainloader +1
}

Le problème c'est que le tuto anglais indique que le fichier /grub.cfg n'est pas sensé être édité même en root (The main menu file, /boot/grub/grub.cfg, is not meant to be edited, even by 'root'.)

Pour configurer ses propres entrées, il faut agir sur le fichier /etc/grub.d/40_custom !

Cela dit, comme je l'indique plus haut, je ne suis pas du tout familiarisé avec Grub 2, donc attends éventuellement d'autres avis

Amicalement,



Modifié par Mimile le 13/06/2010 17:34
dedetoto
 Posté le 13/06/2010 à 18:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut mimile,

J'ai vérifié mon Grub qui m'indique que vista se trouve à set root='(hd0,1)' et ubuntu à set root='(hd1,1)'.Ubuntu demarre normalementSi comme tu me l'indiques je mets un 0 à la place du 1 le problème ne serait-il pas résolu?Je n'ai pas osé le faire car mes connaissances sont limitées.Heureusement que nous avons PCastuces et des gens comme vous patients et sympas.

Merci et à+



Modifié par dedetoto le 13/06/2010 18:40
Logicien
 Posté le 13/06/2010 à 21:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour Mimile et rebonjour dedetoto,

il y a Grub 1 et Grub 2. Avec Grub 1, les disques et partitions commencent à être nommés à partir de zéro (0). La partition C, première partition du disque maître sur le premier contrôleur (IDE ou SCSI) se nomme (hd0,0) et pour Linux /dev/sda1 ou plus rarement maintenant /dev/hda1. Avec Grub 2, les disques continuent à être nommés à partir de zéro, mais les partitions d'un disque elles commencent à partir de 1. Ce qui donne pour ta partition C (hd0,1) et toujours /dev/sda1 pour Linux. Voilà pour un détail de versions.

Les commandes que tu donnes dedetoto, sont celles de Grub 2. Elles sont bonnes. Il y a peut-être un espace entre chainloader et +1 . Chez moi set root=(hd0,1) fonctionne. Quand tu édites la ligne Vista loader (on/dev/sda1) avec la touche e , emène ton curseur à la fin de la dernière ligne, fait Entrée pour commencer une nouvelle ligne et écrit le mot boot puis fait Ctrl+x pour dire à Grub2 d'exécuter ces commandes. Noter les messages de Grub et Windows s'il y en a. Je ne garantie pas que cela va régler le problème, chez moi je n'en ai pas de besoin. On se croise les doigts.

Je penche plutôt sur les caprices de Windows quand quelque chose est modifié après son installation, tables de partitions, MBR, etc. Si Grub échoue, d'abord réinstaller le secteur d'amorce de Vista dans la partition C puis voir avec Grub si ça démarre. Si le problème persiste, réinstaller le chargeur de Vista dans le MBR est à l'ordre du jour.

Si Grub est effacé du MBR du disque dur principal par Windows, tu ne pourras plus démarrer Ubuntu avec Grub à moins de le réinstaller sur le MBR du deuxième disque dur et dire au BIOS de démarrer sur ce disque. Cela pour éviter que le problème ne se répète.



Modifié par Logicien le 13/06/2010 21:45
Mimile
 Posté le 14/06/2010 à 08:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Avec Grub 2, les disques continuent à être nommés à partir de zéro, mais les partitions d'un disque elles commencent à partir de 1. Ce qui donne pour ta partition C (hd0,1) et toujours /dev/sda1 pour Linux.

A se demander ce que les concepteurs de Grub2 avaient fumé quand ils ont adopté cette façon hybride de numéroter disques et partitions...

Pourquoi ne pas définir aussi les disques en les numérotant à partir de "1" ?

Ce nouveau système est un exemple parfait de l'art d'embrouiller les esprits !

Désolé d'avoir failli t'induire en erreur dedetoto mais j'ignorais cette particularité de Grub 2.

Quoi qu'il en soit, merci à Logicien pour l'info.

Pour le surplus, j'ai relu le menu.lst (Grub 0.97) de ma Debian et j'ai observé :

a) qu'il y a effectivement un espace entre chainloader et +1

b) que juste avant "chainloader +1", il est écrit "makeactive" (sans les guillemets) mais j'ignore si cette instruction est encore valable pour Grub 2.

Amicalement

EDIT : un autre bon tuto ici (en anglais).

Ne voulant pas mourir idiot, je l'ai un peu examiné et finalement, pour ajouter un autre OS dans le menu de grub, j'ai compris qu'il fallait créer un script bash qu'on installe dans le dossier /etc/grub.d :

Il faut donc se loger dans ce répertoire : cd /etc/grub.d et créer un script bash (par exemple avec nano ou gedit précédés de "sudo") qui contiendra quelque chose ressemblant à ceci :

Il faut évidemment le modifier et remplacer Windows 8 par Windows Vista (ou tout autre nom de ton choix)

Il faut ensuite enregistrer le script en lui attribuant un nom qui commencera par un nombre qui lui donnera sa position dans le menu d'affichage (voir 1ère capture).

Par exemple, si tu veux que Vista apparaisse après Linux et avant memtest86+, tu donneras à ton script un nom du genre 15_Vista

Enfin, ce script doit évidemment être rendu exécutable :

En fait, chez toi : sudo chmod +x 15_Vista.

Enfin, pour que ce nouveau script soit intégré au fichier grub.cfg (qu'il ne faut pas éditer manuellement), il faut exécuter :

sudo update-grub

Voilà.

D'après ce que j'ai compris, le fichier grub.cfg est recréé (en fait, mis à jour) à chaque démarrage en fonction des différents scripts contenus dans /etc/grub.d et des paramètres personnels dans le fichier /etc/default/grub.



Modifié par Mimile le 14/06/2010 13:03
dedetoto
 Posté le 14/06/2010 à 21:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut vous deux,

J'ai faif ce que vous m'indiquiez mais toujours le même pb.Mimile a la fin lorsque j'ai fait "sudo update-grub" j'ai eu "Vista not found".J'ai l'impression que l'affaire se complique.

Merci et à+

Publicité
Mimile
 Posté le 14/06/2010 à 22:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si tu as suivi rigoureusement le tuto dont j'ai donné les extraits, la réponse de sudo update-grub est plutôt bizarre.

Juste une question : as-tu bien respecté les guillemets dans le script bash ?

Logicien
 Posté le 14/06/2010 à 23:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour info, l'option makeactive de Grub rendrait active ici la partitionn C de Vista. Ce n'est pas nécessaire puisqu'une partition active n'est utile que pour un chargeur qui se réfère à la partition active pour poursuivre le démarrage en chargeant le secteur d'amorce de cette partition. Grub n'en a pas de besoin. On lui dit autrement. la commande

sudo fdisk -l

va te dire si la partition C est déjà active s'il y a un * après /dev/sda1.

Si on essai de résumer, les variantes de commandes pour faire démarrer Vista mènent toutes à l'écran noir. Selon toutes évidences, Grub fait son travail de charger les 512 premiers octets (dit secteur d'amorce) de la partition C, ce que le chargeur de Vista ferait aussi s'il était dans le MBR quand la partition C est marquée comme active. C'est le secteur d'amorce de Vista qui possiblement rencontre un problème à trouver un ficher essentiel sur la partition C comme hal ou ntldr.

dedetoto (quel nom rigolo ),

Le script que tu as créé devrait être supprimé s'il ne fonctionne pas. Tu peux exécuter la commande

sudo dpkg-reconfigure grub-pc

pour revoir les paramètres que tu as passés à Grub2 lors de la mise-à-jour vers Ubuntu 10.4. Je pense que Vista doit être réparé tel que dit plus haut.



Modifié par Logicien le 14/06/2010 23:09
dedetoto
 Posté le 16/06/2010 à 18:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut,

Excusez-moi pour cette réponse tardive mais il faut aussi travailler{#}Je joins cette fenêtre du terminal avec cette ligne qui me parait bizarre

Si sda 1 est inconnu windows ne risque pas de marcher.Que dois-je faire?

Merci et à+

dedetoto@dedetoto-desktop:~$ sudo fdisk -l
[sudo] password for dedetoto:

Disque /dev/sda: 400.1 Go, 400088457216 octets
255 têtes, 63 secteurs/piste, 48641 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0xae3c4510

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 1 1045 8388608 27 Inconnu
/dev/sda2 * 1045 35552 277181792 7 HPFS/NTFS
/dev/sda3 35553 48641 105137392+ 5 Etendue
/dev/sda5 35553 48641 105137361 bc Inconnu

Disque /dev/sdb: 500.1 Go, 500107862016 octets
255 têtes, 63 secteurs/piste, 60801 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x0006f489

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdb1 1 2443 19623366 83 Linux
/dev/sdb2 2444 32845 244204065 83 Linux
/dev/sdb3 32846 33089 1959930 82 Linux swap / Solaris
dedetoto@dedetoto-desktop:~$

Mimile
 Posté le 17/06/2010 à 01:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir

Je ne vois pas trop à quoi correspondent les 27 blocs de /dev/sda1 formatés de manière "inconnue" (27 ne correspond à rien pour fdisk) ; il en est de même avec /dev/sda5 (bc ne correspond à rien non plus - à moins qu'il faille lire b et c qui correspondent à une partition de FAT).

dev/sda1 serait-elle Une partition genre "recovery" ? mais dans ce cas, elle devrait être formatée dans un système de fichier connu - sauf erreur de ma part.

Apparemment, la partition active de ton premier disque est en /dev/sda2 (celle qui est marquée d'une astérisque), ce qui correspond, dans la nouvelle numérotation de Grub, à hd0,2.

Donc, modifie le script en conséquence

...

set root=(hd0,2)

chainloader (hd0,2)+1

...

Peut-être que ça fonctionnera comme ça.

Cordialement,

Logicien
 Posté le 17/06/2010 à 07:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si on convertit 27 de la base décimale vers la base hexadécimale, cela donne 1b , le numéro ID (et non le nombre de blocs Mimile) d'une partition (Cachée W95 FAT32). C'est un type de partition fort probable pour la restauration de Windows. Ses 1045 cylindres multipliés par 8225280 octets, divisés par 1024, encore par 1024, donne 8 gigaoctets environ. C'est une taille suffisante pour une partition de restauration.

Quoiqu'il en soit, Grub s'est mis le doigt dans l'oeil (et moi aussi avec les caprices de Vista) en ciblant la partition de restauration comme celle où on peut amorcer Windows Vista. C'est fréquent il me semble que Grub prenne des partitions de type Windows de restaurations et de données pour la partition C ou un système Windows amorçable. D'autant plus que la partition de restauration est la première en standard maintenant, ce qui avant était la partition d'installation C de Windows.

C'est bien la deuxième partition qui est la partition C . Avec Grub 2 cela donne (hd0,2) et avec Linux, /dev/sda2. Quand on travaille à l'aveugle, on est bien naïf parfois. Le pire, c'est qu'on a le temps d'oublier de cette expérience avant de faire face à un cas similaire.

dedetoto, tu peux essayer de reconfigurer Grub 2 grâce à la commande sudo dpkg-reconfigure grub-pc afin de voir si tu peux modifier l'entrée pour démarrer Vista. Tu peux aussi utiliser le script que te propose Mimile. Si Vista démarre ce serait bien de marquer ton message comme résolu.



Modifié par Logicien le 17/06/2010 08:54
Mimile
 Posté le 17/06/2010 à 09:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

C'était effectivement idiot de ma part de considérer que "27" indiquait le nombre de blocs réservés à sda1 (cette ineptie étant sans doute due à l'heure tardive à laquelle j'ai rédigé mon message).

D'autant qu'ensuite, j'ai consulté fdisk (option m) pour voir à quoi pouvait correspondre "27" en tant que type de formatage et je ne l'y ai pas trouvé.

S'il faut convertir certaines valeurs indiquées par fdisk en hexadécimal, ça devient lourd ! Et comment deviner quand il faut le faire puisque les partitions Linux, par exemple, sont bel et bien identifiées 82 et 83 - ou NTFS identifiée 7 -sans qu'il faille opérer cette conversion ?

Et qu'en est-il de la partition sda5 de type "bc" ? (association de b et de c ?)

En tout état de cause, espérons que notre ami verra son problème réglé en indiquant hd0,2 comme partition de boot pour sa Vista.

Amicalement

dedetoto
 Posté le 17/06/2010 à 11:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Mimile je veux modifier mon script comme tu me le conseilles mais j'ai peur de faire des boulettes(je suis débutant sur linux).Peux-tu me décrire de manière détaillée ce que je dois faire?

Merci d'avance et à+

Mimile
 Posté le 17/06/2010 à 15:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

N'as tu pas essayé la méthode de Logicien ?

Pour ce qui me concerne, je t'indiquerai volontiers la marche à suivre pas-à-pas mais auparavant, pour éviter toute erreur de ma part, je voudrais que tu exécutes ceci en console :

  1. cd /etc/grub.d [enter]
  2. ls -l [enter] (pour éviter toute erreur, je précise qu'il s'agit de LS -L en minuscules - parfois on confond les l avec des i) ; cette commande va lister le contenu du répertoire /etc/grub.d ; fais un copier/coller de l'ensemble des lignes qui suivent "ls -l" et poste-le dans ta réponse.
  3. si tu as déjà créé ton script en suivant les indications d'une de mes réponses antérieures, exécute : cat 15_Vista [enter] (je pars du principe que tu as nommé ton script 15_Vista - sinon remplace 15_Vista par le nom que tu as indiqué à la place); fais un copier/coller des lignes qui apparaîtront et poste-les aussi.
  4. pour revenir dans ta partition /home, tape : cd ~ [enter]

A bientôt.

Cordialement,

Publicité
dedetoto
 Posté le 17/06/2010 à 16:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut Mimile,

Je poste ce que tu m'as demandé:

dedetoto@dedetoto-desktop:~$ cd /etc/grub.d
dedetoto@dedetoto-desktop:/etc/grub.d$ ls -l
total 48
-rwxr-xr-x 1 root root 4444 2010-04-29 09:08 00_header
-rwxr-xr-x 1 root root 1416 2010-04-29 08:45 05_debian_theme
-rwxr-xr-x 1 root root 4594 2010-06-14 18:27 10_linux
-rwxr-xr-x 1 root root 140 2010-06-14 21:13 15_Vista
-rwxr-xr-x 1 root root 918 2010-03-23 10:37 20_memtest86+
-rwxr-xr-x 1 root root 6605 2010-04-29 09:08 30_os-prober
-rwxr-xr-x 1 root root 214 2009-10-24 02:44 40_custom
-rw------- 1 root root 133 2010-06-14 18:46 nano.save
-rw-r--r-- 1 root root 483 2009-10-24 02:44 README
dedetoto@dedetoto-desktop:/etc/grub.d$

Par contre pour cat 15_Vista j'ai du merder qq part car voici la réponse:

dedetoto@dedetoto-desktop:~$ cat 15_Vista
cat: 15_Vista: Aucun fichier ou dossier de ce type
dedetoto@dedetoto-desktop:~$

Merci et à+

Mimile
 Posté le 18/06/2010 à 00:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

OK

J'ai l'impression que dans ma réponse précédente, tu as utilisé nano comme éditeur et que tu as sauvegardé le contenu dans nano.save.

Pas grave !

Pour ta facilité, on va ré-éditer 15_Vista avec gedit.

Donc, ouvre une console et exécute ceci :

cd /etc/grub.d [enter]

sudo gedit 15_Vista [enter]

A ce moment, l'éditeur gedit ouvre le fichier 15_Vista ; je ne sais pas ce que tu vas y trouver exactement mais au bout du compte, tu dois y écrire ceci (et rien d'autre) :

#!/bin/sh -e

echo "adding Windows Vista to GRUB 2 menu" (note que cette ligne n'a aucune importance ; elle n'apparaîtra que lorsque tu exécuteras la mise à jour de Grub - voir plus loin; ce qui est important, c'est ce qui suit, entre les deux "EOF")

cat << EOF

menuentry "Windows Vista" {

set root=(hd0,2)

chainloader (hd0,2)+1

}

EOF

Tu quittes en ayant bien soin d'enregistrer le fichier (fichier > quitter > enregistrer).

A tout hasard, tu rends ce fichier (script) exécutable ; pour cela, tu exécutes en console : sudo chmod +x 15_Vista [enter] (bien que je pense que ce ne soit plus nécessaire car tu as déjà rendu ce fichier exécutable précédemment d'après ce que je vois de ta précédente réponse, mais bon, ça ne peut pas faire de mal ).

Enfin, tu exécutes : sudo update-grub [enter]

A ce moment, tu rebootes et, en principe, tu devrais avoir retrouvé ton dual-boot (Linux en premier, Vista en second, memtest86 en troisième et peut-être encore d'autres bidules ).

Quelques explications :

la commande "cd" permet de se loger dans le répertoire souhaité. Exemple : cd /usr/bin va te positionner dans le répertoire qui contient la plupart des logiciels de base du système Linux (/usr/bin).

Si à ce moment, tu exécutes : "cd .." (cd-espace-point-point) tu vas remonter d'un niveau dans l'arborescence, autrement dit, tu vas te retrouver dans /usr ; si tu répètes cette commande (cd ..), tu vas alors te retrouver dans la partition racine (/).

la commande "cd ~" (cd suivi d'un espace puis d'une tilde) te ramène directement dans ta partition /home (en l'occurence dans dedetoto@dedetoto-desktop).

Dans ton cas, la commande "cat 15_Vista" n'a rien donné parce que tu es retourné dans ta partition /home avant d'exécuter cat 15_Vista

dedetoto@dedetoto-desktop:~$ cat 15_Vista
cat: 15_Vista: Aucun fichier ou dossier de ce type

Et fatalement, la commande "cat" n'a pas trouvé dans ta partition /home le fichier "15_Vista" qui se trouve en fait dans /etc/grub.d.

Il fallait donc rester dans /etc/grub.d pour que "cat" puisse trouver 15_Vista - relis bien mon message précédent : le point 3 précède le point 4 ).

Pour ta gouverne, la commande "cat" permet d'afficher le contenu du fichier cible qu'on lui indique mais pour cela, il faut être logé dans le répertoire où ce fichier se trouve, c'est-à-dire dans le cas présent, dans /etc/grub.d ou alors, il faut indiquer le chemin complet "cat /etc/grub.d/15_Vista".

Par ailleurs, si le script 15_Vista (que tu as créé en te référant à mon précédent poste) pointait vers hd0,1 , il est normal que la commande sudo update-grub t'ait renvoyé le message "Vista not found" puisque nous avons compris, dans l'intervalle, que Vista se trouve en fait en "hd0,2".

Si tu suis exactement ce qui précède, tu devrais normalement retrouver ton dual-boot.

Bonne chance et bonne nuit.

Amicalement



Modifié par Mimile le 18/06/2010 00:25
dedetoto
 Posté le 18/06/2010 à 11:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut Mimile,

j'ai bien suivi tes consignes(voir copier/coller du terminal)mais malheureusement je ne suis toujours pas en dual-boot.Dans le grub aprés les lignes de Linux il s'est crée une ligne Windows Vista avec quand je fais e :

set root=(hd0,2)

chainloader (hd0,2)+1

mais cette ligne est inactive

Plus bas j'ai tj:

Windows Vista (loader) on /dev/sda1

mais qui evidemment ne donne rien puisque tj avec (hd0,1)

dedetoto@dedetoto-desktop:~$ cd /etc/grub.d
dedetoto@dedetoto-desktop:/etc/grub.d$ sudo gedit 15_Vista
[sudo] password for dedetoto:
dedetoto@dedetoto-desktop:/etc/grub.d$ sudo chmod +x 15_Vista
dedetoto@dedetoto-desktop:/etc/grub.d$ sudo update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-22-generic
Found initrd image: /boot/initrd.img-2.6.32-22-generic
Found linux image: /boot/vmlinuz-2.6.31-22-generic
Found initrd image: /boot/initrd.img-2.6.31-22-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows Vista (loader) on /dev/sda1
Found Windows Recovery Environment (loader) on /dev/sda2
done
dedetoto@dedetoto-desktop:/etc/grub.d$


Je regrette de te donner encore du travail.Merci et à+



Modifié par dedetoto le 18/06/2010 11:02
Logicien
 Posté le 18/06/2010 à 11:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Il faut voir dans la conversion décimale/hexadécimale que j'ai faite, seulement une hypothèse. Autre hypothèse, comme le disque dur sda n'a pas pas été partitionné par Linux, mais éventuellement en usine avec d'autres outils, il se peut que Fdisk ait peine à comprendre la table de partitions, ce qui n'est pas le cas pour sdb partitionné par Ubuntu.

Fdisk affiche maintenant ce message à l'ouverture:

WARNING: DOS-compatible mode is deprecated. It's strongly recommended to
switch off the mode (command 'c') and change display units to
sectors (command 'u').

Je ne connais pas tous les outils de partitionnements, mais on sent que chacun fait et interprète les choses à sa manière.



Modifié par Logicien le 18/06/2010 11:11
Mimile
 Posté le 18/06/2010 à 11:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Ca devient un vrai casse-tête !

A tout hasard, pourrais-tu poster le contenu de nano.save en excutant : cat /etc/grub.d/nano.save

Cela dit, j'ai poursuivi mes recherches et j'ai trouvé ce poste qui correspond pile-poil à ton problème, à savoir que pour une raison qui reste indéterminée, Grub2 se mélange les pinceaux vu qu'il croit voir Vista en /dev/sda1 et identifie /dev/sda2 comme étant la partition "recovery".

Donc, essaye ceci : reboote ton PC et dans le menu qui s'affiche, clique sur Vista recovery plutôt que sur Windows Vista.

Tu auras peut-être la joie de voir démarrer Vista normalement (ce qui se produit effectivement dans l'autre poste).

Seul désagrément, il faut cliquer sur "recovery" pour démarrer Vista mais ce n'est pas insurmontable ... et du moment que ça fonctionne ...

Amicalement,

EDIT : Si ça ne marche toujours pas, il reste une solution (voir tout à la fin du poste auquel mon lien renvoit) et qui suggère qu'on peut ajouter d''autres OS au menu Grub en les incluant dans le fichier /etc/grub.d/40_custom (à éditer en suivant la marche-à-suivre pour le script 15_Vista)

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.

menuentry "Windows Vista" {
set root=(hd0,1)
chainloader +1
}

Dans ce cas-là, pour éviter tout interférence, il vaudrait mieux supprimer le script 15_Vista (sudo rm /etc/grub.d/15_Vista) puis exécuter : sudo update-grub



Modifié par Mimile le 18/06/2010 11:51
dedetoto
 Posté le 18/06/2010 à 11:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour vous deux,

Voici le résultat:

dedetoto@dedetoto-desktop:~$ cat /etc/grub.d/nano.save
cat: /etc/grub.d/nano.save: Permission non accordée
dedetoto@dedetoto-desktop:~$

Et malheureusement Vista recovery ne donne rien

Merci et à+

Logicien
 Posté le 18/06/2010 à 19:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

dedetoto,

essai ça

sudo rm -fr /etc/grub.d/nano.save

sudo echo 'menuentry "Windows Vista manuel" {' >> /etc/grub.d/40_custom

sudo echo 'set root=(hd0,2)' >> /etc/grub.d/40_custom

sudo echo 'chainloader (hd0,2)+1' >> /etc/grub.d/40_custom

sudo echo '}' >> /etc/grub.d/40_custom

sudo grub-mkconfig -o /boot/grub/grub.cfg

et redémarre en utilisant l'entrée Windows Vista manuel

dedetoto
 Posté le 18/06/2010 à 20:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Logicien,

J'ai un pb de permission avec la commande que tu me donnes:

dedetoto@dedetoto-desktop:~$ sudo rm -fr /etc/grub.d/nano.save
dedetoto@dedetoto-desktop:~$ sudo echo 'menuentry "Windows Vista manuel" {' >> /etc/grub.d/40_custom
bash: /etc/grub.d/40_custom: Permission non accordée
dedetoto@dedetoto-desktop:~$
dedetoto@dedetoto-desktop:~$

En espérant que tu as une solution bonsoir et à+

Logicien
 Posté le 18/06/2010 à 21:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Essai

sudo chmod 777 /etc/grub.d/40_custom

et reprend à partir de la deuxième commande que je t'ai donnée.

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Probleme Ubuntu et W7 "Demarrage"
Problème démarrage conky
Probléme démarrage Ubuntu dur DisqueDur Externe ?
Problème affichage écran au démarrage avec 10.10
Problème de démarrage WIndows XP
Problème démarrage Ubuntu
grub erreur 21 au démarrage de windows vista
Problème démarrage, Minimal Bash-like, Ubuntu
probleme de lancement de windows vista (+mandriva)
petit Problème lors du démarrage de mon pc
Plus de sujets relatifs à Probleme demarrage Vista
 > Tous les forums > Forum Linux