> Tous les forums > Forum Les mains dans le cambouis
 problème démarrage XP après changement carte mèreSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
basnor2
  Posté le 26/02/2013 @ 12:06 
Aller en bas de la page 
Petit astucien

Bonjour,Suite à une panne matérielle,j'ai changé la carte mère de mon ordinateur.

J'ai conservé les 2 disques durs fonctionnant avec Windows xp et ubuntu(L'un d'eux me sert de sauvegarde).

J'avais installé sur le disque principal Windows XP et Ubuntu ,et sur l'autre windows XP.

Au démarrage de mon ordinateur (avant remplacement CM) , le Grub s'affichait,me permettant ainsi de choisir XP ou Ubuntu.

La nouvelle carte est une gigabyte GA 78LMT S2P.

La séquence de démarrage est la suivante:

invite Bios (qq secondes le temps d'appuyer éventuellement sur DEL pour rentrer dans le bios).

page dos (2s)

Grub(permettant le choix Ubuntu ou XP (disque Sb1 ou Sb2)

---si je choisis ubuntu :pas de problème de lancement (cependant la connexion internet ne fonctionne pas ,mais c'est ,je pense lié à une précédente mise à jour de ubuntu et donc indépendant du changement de carte mère)

--si je choisis windows (mon DD principal):

ouverture de la fenêtre Windows de chargement ,quelques secondes puis apparition une fraction de seconde d'une page bleu et fond noir.

la séquence recommence

invite bios

grub

--si je choisis XP

cette fois,une fenêtre dos m'indique que windows n'a pas démarré normalement et me propose des choix de démarrage .

Si je choisis Démarrage sans échec avec réseau:Windows s'ouvre et la connexion internet fonctionne.

En résumé ,c'est le démarrage normal Windows qui coince.

J'ai utilisé une image.iso de ubuntu 12 pour accéder à un outil de réparation du Grub (outil n'existant pas sur ma version 11)

Malgré la réparation du grub ,le problème de démarrage normal de windows subsiste.

Autres informations:

Lorsque j'ai relancé l'ordinateur la première fois après changement de la carte mère ,je n'ai pas utilisé le CD gigabyte joint (ce n'est pas clairement indiqué dans le mode d'emploi de la carte)

J'ai eu les problèmes décrits ci-dessus.

J'ai ensuite utilisé le CD gigabyte et des drivers ont été chargés.Cela n'a pas amélioré la situation .

Cependant,si j'utilise à nouveau le CD gigabyte (après ouverture de windows sans échec) ,le CD bugue si je veux le lancer (message "open driver handle failure).

Merci pour vos conseils si vous avez eu le courage de lire tout ça!

Publicité
DEGANO
 Posté le 26/02/2013 à 12:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

normal que windows ne démarre pas sur une nouvelle carte mère.

Si la configuration entre les 2 cartes mères est trop différente au niveau des chipsets,

les pilotes ne correspondent plus et ça plante systématiquement.

Il y a possibilité de tout reprendre normalement, je ne connais pas spécialement

la manip. mais elle n'est pas des plus simple.

En général, la réinstallation de windows s'impose d'elle-même pour éviter tout problème.

Concernant ubuntu et la connexion internet, vérifie que l'adresse MAC de la carte réseau

soit correctement prise en compte.

Quel était ton ancienne carte mère ?

fgondard
 Posté le 26/02/2013 à 13:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour,

Après un changement de carte mère ayant un jeu de puce différent tu n'es pas obligé de ré-installer Windows à partir de zéro. Tu as deux solutions.

La première consiste à ré-installer Windows "par dessus" donc sans perte de données ni des logiciels installés. Tu démarres sur le CD de Windows puis tu réponds installer à la première demande et réparer à la seconde. Si ton disque dur est du type SATA il faut appuyer sur F6 quand cela t'es proposé et founir le pilote ad hoc sur disquette. Si tu n'as pas de lecteur de disquette il faut au prélable fabriquer un CD XP incorporant ce pilote avec le logiciel Nlite. Il faudra néanmoins repasser par la case Windows Update pour refaire toutes les mises à jour.

L'autre solution consiste à utiliser le Hiren's boot CD. Dans son mini XP il y a un outil prévu pour injecter le pilote du contrôleur SATA dans Windows.

FG

basnor2
 Posté le 26/02/2013 à 17:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonjour,

merci pour les conseils.Dans un premier temps je vais essayer hiren's bootCd car en réparant à partir de mon CD windows (SP1) il va falloir pas mal de mise à jour et aussi je vais peut-être avoir un problème de validation par microsoft..L'utilisation de Hiren's m'évitera peut-être ce soucis.

J'ai crée le disque à partir de l'image .iso.

Le PC a bien booté sur ce CD et j'ai ouvert le mini XP.

Par contre je ne sais pas quoi choisir pour l'injection du pilote sata.Un coup de pouce serait bienvenu.

Auparavant j'avais une carte asrock avec un socket devenu obsolète (il portait un pentium 4).C'est pourquoi j'ai dû aussi changer de processeur (Athlon 2).

fgondard
 Posté le 26/02/2013 à 18:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Voir ici.

Cependant en cas de réinstall par dessus il me semble bien qu'on ne repasse pas par la case activation. De toute façon, sauf N° de licence blacklisté par Microsoft, par téléphone ça passe à tous les coups.

FG



Modifié par fgondard le 26/02/2013 18:26
basnor2
 Posté le 26/02/2013 à 19:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

merci pour le lien.

J'ai fait le choix M (Update MassStorage drivers) cependant je suis bloqué dès la validation de cette option

Je lis

" fix_hdc.cmd: Fix for some stop 0X0000007B errors based on http://support.microsoft.com/Kb/314082/

-M:Massstorage mode

-R:Restore mode

s :source folder to txtsetup

t : target_root (for example c:\windows)

Error :target_root not set

press any key to continue..."

cette action me fait sortir du programme.

que dois - je faire à part choisir l'autre méthode (réparation windows) ?

Merci

fgondard
 Posté le 26/02/2013 à 19:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

En fait je n'ai jamais utilisé cette méthode donc je ne pourrais pas t'en dire plus. Attention le clavier est par défaut en QWERY, donc le M est sur la touche virgule.

Par aileurs je ne sais pas si ça fonctionne pour les disques SATA.

FG

basnor2
 Posté le 26/02/2013 à 21:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonsoir

cela ne s'arrange pas....

J'ai opté pour la méthode de réparation de windows XP avec le CD .

Une fois les différentes opérations exécutées,um message m'informe qu'il faut retirer le Cd avant redémarrage.

Ceci étant fait ,le Pc redémarre avec la séquence suivante

invite bios

page dos

grub

si je choisis XP, la page de démarrage windows apparait puis bloque comme initialement.

redémarrage du système ,mais ,à la différence de la situation initiale ,je n'ai plus de choix vers le mode sans échec!

Mes disques sont SATA et je n'ai pas le souvenir d'avoir vu une invite pour appuyer sur F6.

J'ai essayé de faire démarrer sur le CD Gigabyte,mais dans ce cas c'est le programme de backup qui s'ouvre et non pas le menu avec la mise à jour des drivers.

J'avais fait préalablement un back up de mes disques (avec l'outil gigabyte) .Je dois pouvoir revenir à la situation initiale,mais je n'en vois pas l'intéret puisque ça ne marchait pas .

Que faire maintenant?Désinstaller le grub?

Je ne pensais pas rencontrer autant de difficultés.

Ambro
 Posté le 26/02/2013 à 21:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

concernant le problème sous XP, le fait d'y accéder malgré quelques problèmes au démarrage, ne provient pas forcement du changement de la CM. Car si c'était le cas le démarrage n'irai pas loin et un bel "BSOD" apparaîtrait!

je pense qu'il y a un problème sur le fichier boot.ini ou sur le NTLDR. ou sur le boot XP/Linux

1ere solution: réparer XP avec son CD, voir ICI

2ème solution: utiliser HirenBCD, j'avais expliqué la méthode ICI, le PC démarrera en mode VGA, puisque aucun driver ne sera chargé. Il faut donc insérer le CD de la nouvelle CM pour mettre à jours les pilotes

Si le dual boot est corrompu ou à disparu, il faudra utiliser EasyBCD, pour le remettre en place.

Publicité
basnor2
 Posté le 26/02/2013 à 22:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

merci pour ton avis.

comme je l'ai expliqué dans mon message de 19 heures,l'utilisation de Fix HDC n'a pas abouti.

J'ai ensuite essayé la réinstallation de XP (mon dernier message )

Ce que je ne comprends pas ,c'est pourquoi le CD gigabyte démarre sur un logiciel de back up et non sur la table des matières qui comporte ,entre autres,un outil d'installation des drivers.

J'avais avant tous ces essais réinstallé le grub avec un Cd iso de ubuntu (Version 12);

Je me demande si ce grub n'empêche pas la réparation xp.

Ambro
 Posté le 26/02/2013 à 22:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Pour utiliser FIX HD il faut savoir que par défaut sous Dos le clavier est en Qwerty, donc au debut il demande de taper T pour Target, là pas de problème, dans la seconde phase il faut il faut taper sur la touche M, pour "Modify" si tu tapes M sur ton clavier cela correspond au Point virgule en Azerty

Donc pour M, il faudra appuyer sur ", " Virgule.

Concernant le démarrage il y a de forte chance que le Grub soit corrompu. Si XP démarre il faut installer EasyBCD, supprimer les entrées existantes et recréer le Dual Boot

La plupart des CD ou DVD livré avec les CM récentes poposent un menu au démarrage, il faut choisir dans ce menu l'onglet qui correspond aux drivers!



Modifié par Ambro le 26/02/2013 22:49
basnor2
 Posté le 01/03/2013 à 12:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonjour,

je n'ai pas résolu le démarrage de windows.

il semble que le problème soit dû à un bug pendant l'installation des pilotes fournis par le CD accompagnant la CM.

Actuellement le PC démarre en mode sans échec mais il y a un pb signalé dans le gestionnaire de périphériques par ? ,au niveau lecteurs CD-DVD.Je n'ai donc plus accès au lecteur ,en mode sans échec.

par contre ,ce CD boote bien au démarrage si je fait booter le PC sur CD (et non hard disk).Par contre il ne s'ouvre pas sur le menu mais sur un utilitaire de back up .(Je n'ai aucun autre choix)

Curieusement ,je ne parviens pas à explorer ce CD avec le lecteur de mon portable .(Pourtant celui-ci fonctionne bien avec d'autres CDROM d'installation)

Le technicien a essayé mon CD .Il n' a pas décelé de problème.

Avant de me résoudre à réinstaller totalement windows,je voudrais encore tenter une réparation .

j'ai téléchargé les drivers correspondant à ma carte mère,je les ai dézipés .J'ai les dossiers suivants

MSHDQFE (motherboard_driver_audio_microsoft.exe)

audio

chipset-xp_vistchipset-xp_vista

Atheros (LAN)

8series_VGA

Par contre je ne sais pas comment installer ces drivers dans le gestionnaire.

Merci pour les conseils.

fgondard
 Posté le 01/03/2013 à 13:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

basnor2 a écrit :

Mes disques sont SATA et je n'ai pas le souvenir d'avoir vu une invite pour appuyer sur F6.

XP ne sait pas sinstaller sur disque SATA, sauf si celui-ci a été déclaré en mode IDE dans le Bios. Ça n'existait pas quand le programme d'installation a été écrit.

Dès le début de l'installation (ou de la ré-installation) il est proposé d'appuyer sur F6 pour ajouter un pilote SCSI. C'est ce qu'il faut surveiller et ne pas louper. La demande de la disquette où figure le pilote n'est faite que beaucoup plus tard.

Si le pilote a été injecté sur le CD avec Nlite (obligatoire s'il n'a a pas de lecteur de disquette) F6 ne sert à rien.

FG

basnor2
 Posté le 01/03/2013 à 14:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

merci pour les détails.

J'ai lu le tutoriel sur Nlite de PC astuces,mais il faut que le lecteur de CD fonctionne ,ce qui n'est pas mon cas.

D'autre part,je ne comprend pas la subtilité IDE sata.

Il est vrai que mon bios ne comporte dans la partie Standard CMOs Features que des rubriques IDE Channel 0,1,2 en master ou slave.

Pourtant mes disques sata et le CDRom ont bien été reconnus.

fgondard
 Posté le 01/03/2013 à 15:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Dans les menus de configuration du Bios des cartes mères comportant des ports SATA on trouve habituellement des options pour le fonctionnement des ports SATA, AHCI ou compatibilité IDE.

En mode compatibilité les périphériques continuent d'être vus comme s'il s'agissait de modèles IDE. En contrepartie on ne bénicifie pas des améliorations apportées par l'AHCI (voir ici). XP peut être installé sans précaution spécifique.

En AHCI XP ne peut pas être installé sans fournir le pilote ad hoc.

FG

basnor2
 Posté le 01/03/2013 à 16:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Finalement j'ai opté pour une réinstallation complète de Xp.

Le système redémarre correctement.

J'en suis aux réinstallations des mises à niveau de microsoft.

Pour le moment update ne fonctionne pas...

A suivre

DEGANO
 Posté le 01/03/2013 à 18:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

windows update ne fonctionnera qu'après mise en place du SP3.

Tu oeux l'avoir à cette adresse : http://www.microsoft.com/fr-fr/download/details.aspx?id=24

Publicité
basnor2
 Posté le 01/03/2013 à 19:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

merci pour ton avis.

Pour le moment ,je n'ai pas d'anti virus.

Est- ce que je peux me connecter à IE pour aller à l'adresse que tu indique?

C'est au moment de la mise à jour de IE (pour IE 8) qu'un message m'a indiqué qu(il manquait des updates...

J'ai téléchargé avec un autre ordinateur un fichier iso de sp3 ,mais il faudrait que je le grave .

Si un téléchargement direct peut faire l'affaire,ce sera plus simple.

DEGANO
 Posté le 02/03/2013 à 09:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

un téléchargement direct depuis un autre pc avec le lien que je t'ai donné

que tu mets ensuite sur une clé USB pour l'installer sur ton pc ne posera pas

de problème. L'avantage avec le cd iso, tu le grave une fois, tu es sur d'avoir le SP3

avec toi en permanence.



Modifié par DEGANO le 02/03/2013 09:59
basnor2
 Posté le 02/03/2013 à 13:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

l'installation de sp3 a réglé le problème.

Il y avait 120 mises à jours!

merci pour l'aide.

Ambro
 Posté le 02/03/2013 à 19:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Content pour toi que cela soit réglé!

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Demarrage pc après changement pile carte mère
probleme apres changement carte mere
problème après changement de carte mère
probleme re demarrage apres new carte mére
Problème CPU après changement carte-mère
Problème d'écran après changement de carte mère
problème après changement de carte mère
problème d'ordi après changement de carte mère
Toshiba Satellite ne démarre plus après changement carte mère
windows ne redemarre pas apres changement carte mere
Plus de sujets relatifs à problème démarrage XP après changement carte mère
 > Tous les forums > Forum Les mains dans le cambouis