> Tous les forums > Forum Linux
 problème installation logiciels sous xfceSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Nico34
  Posté le 09/11/2010 @ 00:36 
Aller en bas de la page 
Petit astucien

Bonjour à tous, cela faisait un momment que je n'avais pas posté ici...

J'ai actuellement besoin de pouvoir utiliser un environement léger sur une machine assez agée je dois dire (pentium II).

J'ai donc installé DEBIAN GNU/Linux ver. 5.0.6 net install sur ce pc, puis xfce4. (Là, comme on dit, pas de quoi se taper le cul par terre...)

Le problème viens du fait que je ne parviens pas à installer firefox:l'éxecutable de son install refuse de s'éxectuer... peut-être dois-je installer quelque soft avant vu le fait que xfce soit "dépouillé"? De même, lorsque j'éxecute "aptitude install firefox-3.5" ou "apt-get install firefox" en ligne de commande: il me répond que le packet est inexistant sur ce serveur... (je ne sais pas comment on change le serveur par défaut...). Il faut aussi ajouter que je ne trouve pas le "gestionnaire de packets" sous xfce. (Il n'est pas dans xfce,accessoire...faut-il là aussi que je l'installe séparément?)

J'éspère que ma description du problème vous parlera...

Je précise aussi que c'est la première fois que je vais utiliser linux... (faut bien un début à tout...)

Publicité
Mori
 Posté le 09/11/2010 à 00:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

# aptitude install iceweasel iceweasel-l10n-fr synaptic

et si tu veux avoir une version plus récente de iceweasel (version de firefox "libérée", au sens du debian mephisto manifesto, du logo et du nom propriétaire de mozilla foundation), tu peux utiliser les lenny-backports

http://www.backports.org/dokuwiki/doku.php?id=instructions

# aptitude -t lenny-backports install iceweasel iceweasel-l10n-fr

n'oublie pas la configuration du bas de page :

Package: *

Pin: release a=lenny-backports

Pin-Priority: 200

rq : sous debian, il vaut mieux utiliser aptitude (qui gère mieux les dépendances). donc quand tu verras sur le net : apt-get install ou apt-get remove tu remplaces apt-get par aptitude

rq 2 : pentium II ? avec quoi comme RAM et horloge de processeur ?

xfce est peut-être trop lourd (même sûrement... j'ai fini de configurer un pentium III 127 Mo de RAM et 1 MHz d'horloge... je trouvais même lxde un peu lent. c'est dire). tu as plutôt intérêt à utiliser openbox, fluxbox ou fvwm-crystal ... sauf le dernier, qui a plein de scripts déjà configurés, il y a des manips à faire pour que l'environnement reste convivial.

rq 3 : iceweasel risque d'être trop lourd pour ton système. préfère hazehakase comme navigateur, qui est dans les dépôts.

rq 4 : commencer sous gnu linux par debian et sur un vieux coucou... chapeau ! mais, il te faudra de la patience et fouiller dans le wiki de debian. http://wiki.debian.org/PageD'Accueil



Modifié par Mori le 09/11/2010 01:26
Nico34
 Posté le 09/11/2010 à 16:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci pour ta réponse Mori qui m'a grandement aidé! Je précise que le pc est un compaq pentium II 400MHz avec 640Mo de RAM (512+128) et 40Go de disque.

Est-ce que je peut mettre à jour le navigateur avec la commande aptitude update?

Maintenant, ce serait pas mal que j'installe un antivirus adapté (çi possible gratuit...) dessus, mais je ne connait ni ce dit antivirus, ni la ligne de commande pour y accéder... De plus, il me faudrait un équivalent du pack office genre open office... Je vais tenter de trouver ça avec leur commande sur le net ce soir.

Nico34
 Posté le 09/11/2010 à 21:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je viens de parcourir ton lien que je trouve fort interressant, je le relirai en détail demain ou aprés demain.

Je viens d'installer openoffice et vlc avec succés; et Clamantivirus par contre celui ci n'est présent qu'en ligne de commande, il n'apparait pas dans le menu de xfce. Est-ce normal?; De plus faut-il le mettre à jour souvent avec freshclam ou le fait-il tout seul?

De plus, j'ai absolument besoin d'adobe flash player, et je ne parviens pas à l'installer...ni en ligne de commande ni aprés avoir téléchargé les version .deb, .rpm, .gz sous mozilla depuis le site d'adobe. En effet, quand je clique sur le .deb, il me demande un logiciel approprié pour l'ouvrir; quand je tape la commande "rpm -uvh<install_flash_player>" pour l'extension .rpm, cela se solde par un échec; de même pour la version .gz. Là je suis planté ... (Je précise que j'ai évidemment éssayé en root.)

Si je pouvais trouver le package pour ouvrir directement les .deb je pense que ça marcherai ; à moins que quelqu'un connaisse la ligne de commande à saisir pour réccupérer le paquet de flashplayer...

Mori
 Posté le 09/11/2010 à 22:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

$ su

# cd /home/ton_nom/dossier_ou_est_le_deb_de_adobe_flash_téléchargé

# dpkg -i *.deb

# exit (ou CTRL D)

openoffice.org est trop lourd pour ta configuration. garde openoffice.org-impress pour lire les powerpoint

mais installe abiword et gnumeric (pour le writer et le calc)

tu n'as pas besoin d'antivirus sous gnu linux. à la limite tu peux installer rkhunter pour tester si tu es infesté par des rootkits et tu check en ligne de commande # rkhunter -c

sinon le frontend de clam-antivirus est clamtk. # aptitude install clamtk

mais il n'a pas de programme de détection automatique en tache de fond. ce qui ne présente pas d'intérêt.

je persiste à dire que vu ta configuration, xfce doit vraiment ramer.

Mimile
 Posté le 10/11/2010 à 09:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Je suis sous Debian Lenny + KDE, mais comme Icewaesel a pas mal de retard sur Firefox, j'ai installé ce dernier.

Pour cela, il m'a suffi de télécharger le fichier (version Linux bien entendu) sur le site Firefox, de décompresser le fichier obtenu, ce qui a donné un dossier complet dans lequel on trouve l'exécutable.

Au premier lancement de Firefox, j'ai été agréablement surpris d'y trouver automatiquement tous les signets, thèmes, extensions etc... de Iceweasel.

Cela dit, question performance, j'ai installé Debian Lenny + XFCE sur un ordinosaure ( cpu 500 Mhz et 192 Mo de RAM) et Iceweasel 3.0.6 y tourne sans problème (je n'ai pas installé Firefox sur ce PC pour ne pas encombrer le disque qui est plutôt riquiqui mais je pense qu'il pourrait y fonctionner sans problème).

Amicalement,

Nico34
 Posté le 10/11/2010 à 21:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je suis parvenu à obtenir le plugin flash player et à l'installer! Cela fonctionne, mais effectivement, Icewaesel doit avoir du retard sur Firefox. Ce qui me permet de dire ça, c'est que j'ai de petits souci pour utiliser "Tell Me More Online" et d'autre sites (même si globalement ça tourne, j'ai des problèmes d'affichage de boîtes de dialogue sur certains sites.)... Je devrai donc installer plutôt firefox? D'autant que comme ça j'aurait tous les plugin d'office. Je pensait qu'il n'existait pas firefox pour debian mais que Iceweasel était son équivalent (c'est à dire que je pensaisqu'il portait un autre nom pour debian en quelque sorte.)

Je précise que j'utilise déjà firefox sur le pc en question qui est aussi sous win 2000; et je n'est pas noté de lenteur extrème. (Comparé à IE6...)

Par contre, je pense que tu as raison Mori, je vais plutôt utilisé gnumeric comme "suite" bureautique.

Je tente d'installer mozilla pour linux et je vous tiens au courant! (Maintenant que j'ai acces à internet via Iceweasel, je le récupèrerai directement sur leur site, et si c'est une archive .deb, je suivrai la même procédure que m'as indiqué Mori pour installer flashplayer.)

A plus tard donc j'espère! D'ici là, bonne soirée!!

Nico34
 Posté le 10/11/2010 à 21:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je ne m'étais pas rendu compte de la taille de la police de mon message, je vous le renvoie donc en version "qui préservera vos yeux":

Je suis parvenu à obtenir le plugin flash player et à l'installer! Cela fonctionne, mais effectivement, Icewaesel doit avoir du retard sur Firefox. Ce qui me permet de dire ça, c'est que j'ai de petits souci pour utiliser "Tell Me More Online" et d'autre sites (même si globalement ça tourne, j'ai des problèmes d'affichage de boîtes de dialogue sur certains sites.)... Je devrai donc installer plutôt Firefox? D'autant que comme ça j'aurait tous les plugin d'office. Je pensait qu'il n'existait pas Firefox pour debian mais que Iceweasel était son équivalent (c'est à dire que je pensaisqu'il portait un autre nom pour debian en quelque sorte.)

Je précise que j'utilise déjà Firefox sur le pc en question qui est aussi sous win 2000; et je n'est pas noté de lenteur extrème. (Comparé à IE6...)

Par contre, je pense que tu as raison Mori, je vais plutôt utilisé Gnumeric comme "suite" bureautique.

Je tente d'installer Mozilla pour linux et je vous tiens au courant! (Maintenant que j'ai acces à internet via Iceweasel, je le récupèrerai directement sur leur site, et si c'est une archive .deb, je suivrai la même procédure que m'as indiqué Mori pour installer flashplayer.)

A plus tard donc j'espère! D'ici là, bonne soirée!!

alaixi
 Posté le 11/11/2010 à 16:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Salut,

Pourquoi n'essaies tu pas de voir si linux mint xfce est compatible avec ton ordinateur ? ( tu vas moins galérer.... ).

Publicité
alaixi
 Posté le 11/11/2010 à 16:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien
Nico34
 Posté le 11/11/2010 à 18:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ca y est, tous mes problèmes se sont arrangés avec mozilla!!

Donc là, tout fonctionne impeccablement! Merci donc à tous de votre précieuse aide; je vais donc me mettre à découvrir ce nouvel environement via des tutorats.

En réponse à alaixi, vu que maintenant que tout fonctionne, je crois que je vais garder xfce, si je vois que je galère trop pour faire un truc, je passerai à la version mint. (Je ne connaissais pas cette version vu que je m'initie à linux)

Par contre, c'est peut être une question naîve, mais y'a t'il une possibilité de voir une partition windows avec linux?

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Problème installation Mafia II sous PlayOnLinux
Problème installation Wifi sous Ubuntu [SUITE]
probleme de logiciels sous mepis !!!
Problème d'installation de programmes sous Linux
probleme installation Firefox sous MDK 9.2
Problème VirtualBox sous Debian
Problème son qui grésille depuis installation nouveau kernel Debian
Logiciels de nettoyage sous linux ubuntu 14.04 ?
Plex media server sous Linux Suse, problème
probleme d'affichage avec mozilla sous manjaro
Plus de sujets relatifs à problème installation logiciels sous xfce
 > Tous les forums > Forum Linux