> Tous les forums > Forum Linux
 Problème montage floppy diskSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 01/11/2012 @ 01:14 
Aller en bas de la page 
Astucien

Bonjoiur,

OS = archlinux


J'ai fait aujourd'hui une grosse mise à jour système (157 paquets) après quoi, au redémarrage, je vois apparaître ce message :

Image

Auparavant, j'entendais clairement lors du boot qu'il y a avait une tentative d'accès au lecteur de floppy (un petit clac) et le boot continuait normalement.

C'est toujours le cas, mais j'ai systématiquement ce message qui apparaît.

Ce qui est gag c'est que si j'insère une disquette et que je clique sur "floppy Disk" (toujours pas monté) dans la colonne des emplacements, il affiche le contenu de la disquette !

Je précise que je suis bien dans le groupe "floppy".

Si ça peut aider :

[okapi@Archibald ~]$ ls /dev/fd*
/dev/fd0

/dev/fd:
0 1 2 3
[okapi@Archibald ~]$ dmesg | grep fd0
[ 0.944364] Floppy drive(s): fd0 is 1.44M
[ 56.013437] end_request: I/O error, dev fd0, sector 0
[ 56.036765] end_request: I/O error, dev fd0, sector 0
[ 57.483430] end_request: I/O error, dev fd0, sector 0
[ 57.506842] end_request: I/O error, dev fd0, sector 0



dmesg (lecteur non monté, pas de disquette) :

[ 51.536721] end_request: I/O error, dev fd0, sector 0
[ 51.560062] end_request: I/O error, dev fd0, sector 0
[ 53.996732] end_request: I/O error, dev fd0, sector 0
[ 54.020043] end_request: I/O error, dev fd0, sector 0
[ 112.091395] [drm] nouveau 0000:01:00.0: Error creating object: -22 (2/0xbeef0001)
[ 610.766674] end_request: I/O error, dev fd0, sector 0
[ 610.790012] end_request: I/O error, dev fd0, sector 0



dmesg (lecteur monté, disquette insérée, contenu visible)

[ 53.996732] end_request: I/O error, dev fd0, sector 0
[ 54.020043] end_request: I/O error, dev fd0, sector 0
[ 112.091395] [drm] nouveau 0000:01:00.0: Error creating object: -22 (2/0xbeef0001)
[ 610.766674] end_request: I/O error, dev fd0, sector 0
[ 610.790012] end_request: I/O error, dev fd0, sector 0
[okapi@Archibald ~]$



tail /var/log/message (avec disquette insérée)

Oct 31 16:26:26 localhost udisksd[653]: Mounted /dev/fd0 at /run/media/okapi/disk on behalf of uid 1000



Image

Une idée ?



Modifié par Mimile le 01/11/2012 08:31
Publicité
Tasgarth
 Posté le 01/11/2012 à 13:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Mimile,

De mémoire... Le montage ne s'effectue que si une disquette est déja dans son logement.

C'est ici le cas ,il me semble. Mais à vérifier, cela remonte au siècle... passé....

A+

Mimile
 Posté le 01/11/2012 à 14:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Tasgarth

Ca faisait un bon moment ...

Il est exact que quand j'insère une disquette dans le lecteur, le montage s'opère et je peux voir le contenu de la disquette sans toutefois pouvoir y écrire (ro)

Cela dit, je dois dire que je me contrefiche de ce lecteur de disquette (qui fonctionne toujours très bien sous Win) mais que je n'utilise plus depuis au mois 8 ans.

A la limite, il pourrait encore me servir pour réparer un MBR endommagé mais bon ...

Auparavant, au démarrage de gnome (restreint), j'entendais clairement un petit "clac" qui indiquait qu'un quelconque logiciel cherchait à vérifier le contenu du lecteur puis, n'y trouvant rien, le boot se poursuivait normalement.

En fait, ce qui m'énerve le plus, c'est ce message qui apparaît à chaque boot d'Arch et qui ne se produisait pas avant la grosse mise à jour que j'ai faire hier.

A défaut de résoudre le problème, je serais preneur d'une solution qui désactiverait cette tentative d'accès au lecteur ce qui, en toute logique, ne générerait plus le message d'erreur casse-pied.

En désespoir de cause, je pourrais aussi laisser une disquette en permanence dans le lecteur mais ce ne serait pas vraiment une solution.

Depuis cette satanée mise à jour, je n'arrive même plus à écouter un CD audio, quel que soit le lecteur utilisé (manque probablement un codec mais j'ignore lequel ; en revanche, je peux écouter les mp3 que j'ai sur mes DD.

En revanche pas de problème avec les DVD vidéo.

Autre bizarrerie : les partitions qui sont montées par fstab s'ouvrent les une après les autres et je suis obligé de les fermer manuellement pour retrouver mon bureau normal.

Décidément, je regrette d'avoir fait cette mise à jour alors que j'avais un sustème qui marchait nickel.

A la prochaine et amicalement à toi.

Tasgarth
 Posté le 01/11/2012 à 17:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Pour écrire sur la disquette voir si la disquette n'est pas vérouillée physiquement...

Pour le 'clac' au lancement ce n'est pas un logiciel mais à mon avis le Bios qui cherche pour booter....

Une solution ? Voir dans le Bios les lecteurs indiqués pour la recherche du boot et décocher celui de ... la disquette!

Ou la mettre en dernier.... Encore un réglage du siècle passé qui traine dans ton Bios....

A+

Logicien
 Posté le 02/11/2012 à 01:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir Messieurs,

Tasgarth pointe le BIOS Mimile. Si tu peux désactiver la disquette dans le BIOS, Linux ne la détectera pas et aucune tentative de la monter ne peut réussir.

Il faut quand même regarder dans /etc/fstab afin de vérifier s'il y a une ligne qui concerne la disquette. Une telle ligne peut être à l'origine du message de Gnome.

Sous Gnome, dans les Préférences ou le Centre de Contrôle de Gnome, on peut gérer le comportement de Gnome face aux médias amovibles, les périphériques de masses, etc. Tu peux lui interdire de les monter automatiquement.

Depuis la version 3, je n'utilise plus Gnome. Je suis presque toujours sous Lxde avec Compiz comme gestionnaire de fenêtres. Je vais voir Kde4 à l'occasion.

Je t'incite à continuer à faire tes mise-à-jours Mimile, les bons logiciels s'adaptent à l'évolution qui elle-même se fait souvent en dents de scie.

{#}



Modifié par Logicien le 02/11/2012 01:03
Mimile
 Posté le 02/11/2012 à 16:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour les amis,

je vais essayer de répondre à vos suggestions.

précision préalable : le BIOS est configuré pour accéder en premier lieu au lecteur DVD, puis au lecteur floppy et enfin au disque dur (vu l'âge de mon PC : pas d'autre option genre clef USB).

J'allume le PC ; le lecteur de disquette ne contient pas de disquette : les témoins des lecteurs CD/DVD (j'en ai deux) s'allument brièvement puis j'entends un petit "clac" qui correspond probablement au retrait de la tête de lecture du floppy ; le boot se poursuit -- et enfin le le menu Grub apparaît.

Je choisis Arch et comme je suis en full systemd, je vois défiler à toute allure une kyrielle de lignes - toutes précédées de [OK] - ce qui est sympathique (pas de [FAIL] en vue.

Lorsque la dernière ligne du boot s'affiche, GDM m'affiche son rideau bleu et me demande mon mot de passe (je suis en gnome restreint - metacity) ; l'écran passe brièvement au noir puis affiche mon bureau.

A ce stade, il se passe deux choses qui ne se produisaient pas auparavant :

1) j'entends à nouveau le même "clac" qu'au début et je vois aussitôt apparaître ce message :

2) gnome-tweak-tool est configuré en sorte qu'apparaissent sur le bureau les volumes montés (par fstab) - Je précise qu'il n'y a aucune ligne relative à mon lecteur de disquette dans fstab (/dev/fb0)

Auparavant, arrivé à ce stade, mon bureau ressemblait à ceci :

https://i.imgur.com/0Uy56.jpg

(trop grand pour la fenêtre : cliquez sur le lien).

Or, depuis la dernière mise à jour, chaque volume est ouvert automatiquement (comme si nautilus prenait la main), si bien que je me retrouve avec 9 fenêtres que je dois fermer une à une pour retrouver mon bureau tel qu'il apparaît ci-dessus.

J'ai beau chercher dans gnome-tweak-tool une option qui empêcherait l'ouverture systématique des volumes mais je n'en trouve pas.

Je vais modifier l'ordre de démarrage du BIOS et reléguer le lecteur Floppy en dernière position.

Je reviens dans 3 minutes pour vous dire quel sera l'effet de cette manip.

....

EDIT : me revoilà : le lecteur de floppy est en 3ème position ; plus de clac au démarrage mais manifestement, gnome-tweak-tool cherche à le monter (clac) et le message d'erreur revient.

Je précise enfin que les différents volumes continuent d'être ouverts un par un.

Ultime indication : quand il y a une disquette dans le lecteur : pas de message d'erreur et contenu de la disquette accessible mais en ro.



Modifié par Mimile le 02/11/2012 16:19
Mimile
 Posté le 03/11/2012 à 13:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Problème résolu

J'ai ajouté dans fstab :

/dev/fd0 /media/floppy auto defaults,user,noauto,nofail 0 0

Au boot, fini le message d'erreur même si le lecteur de floppy est vide

Si j'insère une disquette, un double clic sur son icône dans la colonne de gauche (là où se trouvent tous les volumes montés par fstab) fait apparaître une icône sur le bureau :

puis le contenu de la disquette apparaît :

Ne soyez pas étonnés du contenu de la disquette : il s'agissait d'une disquette vierge que j'avais oubliée dans le lecteur hier lors de mes multiples tentatives ; or, j'ai eu la brillante idée d'arrêter mon PC en optant pour "hiberner" plutôt que "éteindre" et je pense que c'est suite à ça que ces fichiers ont été écrits sur la disquette.

Quand j'ai voulu redémarrer le PC, écran noir avec une ligne genre "syslinux" mandrakelinux (sic) et une invite : boot.

J'ai relaté ce problème sur ce poste (voir ici) et la solution était toute bête : comme l'ordre de démarrage du BIOS donnait le lecteur de floppy en 1er, j'avais beau indiqué la partition de démarrage du disque dur (/dev/sda9), la réponse était d'office kernel not found.

Le fait d'avoir ajouté "nofail" à la ligne dans fstab fait en sorte que je n'ai plus de message d'erreur à aucun moment.

Voilà au moins un point réglé du moins partiellement car je n'accède à la disquette qu'en lecture ... (malgré le rw que j'ai ajouté à la figne du fstab).

Reste la question de savoir pourquoi les autres volumes affichent systématiquement leurs contenus ...



Modifié par Mimile le 03/11/2012 14:20
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Problème nom de point de montage (Résolu)
problème CDROM. montage ?
distribution slackware 10 - probleme montage cd
Problème de montage avec SAMBA 3
Probleme scan disk
plein de problème !!! montage et acquisition video
plein de problème !!! montage et acquisition video
Problème montage périph sous KDE
Problème navigateur sur Debian 7
Problème de boot avec handy linux
Plus de sujets relatifs à Problème montage floppy disk
 > Tous les forums > Forum Linux