> Tous les forums > Forum Bureautique
 recherche sur excel!!!!!! la suite en image!Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
victor_simth2
  Posté le 24/06/2006 @ 18:24 
Aller en bas de la page 
Petit astucien
Bonjour, Bon voila pour ceux qui ont lu mon precedent poste je vais radoter m'enfin.... [birthday] Bon voilà j'ai une colonne (la colonne A) de dates au format date. J'ai rentré une condition dans la colonne B pour que lorsque j'ai une date commencant par "22/##/####" il me mette 60€ dans cette colonne B. Je voudrais rajouter une condition, la suivante: cette condition est vrai à condition que la date soit anterieur au 01/01/2007. Ma formule initiale dans la colonne B est la suivante: =SI(JOUR(A5)=22;60;"")il me reste une condition merci d'avance!!! [idee]
Publicité
galopin01
 Posté le 24/06/2006 à 18:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
tu aurais pu rester sur le même post ! m'enfin... =SI(ET(JOUR(A5)=22;ANNEE(A5)<2007);60;"") A+
victor_simth2
 Posté le 24/06/2006 à 18:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
En effet! Bien merci Galopin...... je crois que je vais prendre un abonnement chez toi... [approuve]
victor_simth2
 Posté le 24/06/2006 à 19:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Il y a juste un probleme dans ma condition car je veux que la date limite soit 02 2007. Je dois donc mettre annee(A5)<2008 et mois(A5)<02. Le soucis c'est que du coup meme en mars 2006 j'ai rien du tout. Moi je veux que ce soit < à 2008 et exclusivement pour 2007< à fevrier!!!!! Bon j'espere avoir été clair.....; Merci d'avance!! [hello]
galopin01
 Posté le 24/06/2006 à 19:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
Pour B1 : =SI(ET(JOUR(A1)=22;A1<DATE(2007;2;1));60;"") A+
victor_simth2
 Posté le 24/06/2006 à 19:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
ok merci je vais tester!!!!!! [happy]
victor_simth2
 Posté le 24/06/2006 à 19:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Ca marche super!!!!! [clindoeil] decidemment cet outil est tres pratique! Merci a toi!!!

Modifié par victor_simth2 le 24/06/2006 19:23
galopin01
 Posté le 24/06/2006 à 19:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
[chinois]
victor_simth2
 Posté le 24/06/2006 à 20:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Bon je voulais juste une dernière reponse je veux bien la valeur 60€ sauf pour une seule date! exple 22/03/2006. quelle est la fonction logique qui tient compte des exceptions??? [chinois] merci d'avance!
Publicité
victor_simth2
 Posté le 24/06/2006 à 20:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Je ne sais pas si j'ai été assez clair? En gros il y a une seule date pour laquelle la valeur correspondante ne sera pas 60 mais 65?? [grincheux] des idees??
galopin01
 Posté le 24/06/2006 à 20:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
Il suffit d'emboiter les SI... =SI(ET(JOUR(A1)=22;A1<>DATE(2007;3;22));60;SI(JOUR(A1)=22;65;"")) Si on est un 22 (mais pas le 22/3/2007) Alors... Mettre 60 Sinon Si on est un 22 Alors... c'est qu'on est le 22/3/2007 Mettre 65 Sinon rien A+

Modifié par galopin01 le 24/06/2006 20:41
victor_simth2
 Posté le 24/06/2006 à 20:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
OK j'ai pigé c'était la dernière question du jour merci Galopin pour ton aide!!! [hello] @++
galopin01
 Posté le 24/06/2006 à 20:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
Il y a aussi des trucs magiques : Tu te mets sur la cellule B1 : Tu fais Insertion / Nom / Définir Dans la boite de dialogue tu entres Nom dans le classeur : Cond Dans la zone se réfère à tu écris : =JOUR(A1)=22 et tu valides. Ensuite tu modifies la formule de la cellule B1 comme suit : =SI(ET(Cond;A1<>DATE(2007;3;22));60;SI(Cond;65;"")) et tu recopies (incrémentée) Cette méthode permet d'emboiter de nombreuses conditions SI... A+

Modifié par galopin01 le 24/06/2006 22:36
victor_simth2
 Posté le 24/06/2006 à 21:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Alors là je suis sans voix! Dis je vais manger un bout et je test ton truc magique......[bierre]
galopin01
 Posté le 24/06/2006 à 22:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
Sorry, [crazy] il y avait une petite erreur (corrigée depuis en rouge) Pour me faire pardonner je te le fais en couleur : Tu te mets sur la cellule B1 : Tu fais Insertion / Nom / Définir Dans la boite de dialogue tu entres Nom dans le classeur : Galopin Dans la zone se réfère à tu écris : =SI(ET(JOUR(A1)=22;A1<>DATE(2007;3;22));60;SI(JOUR(A1)=22;65;"")) et tu valides. Ensuite tu modifies la formule de la cellule B1 comme suit : =Galopin et tu recopies (incrémentée) la démo [url="http://cjoint.com/?gywMh6WPzW"]ici[/url] Ok ?

Modifié par galopin01 le 24/06/2006 22:43
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
9,99 €Windows 10 Pro 32/64 bits OEM à 9,99 €
Valable jusqu'au 16 Juin

Le vendeur sérieux Digital FR propose sur Amazon la clé d'activation pour Windows 10 professionnel en français 32 bits / 64 bits à 9,99 €. Cette clé livrée par email fonctionne avec l'outil d'installation et de création de support de Microsoft que vous pouvez télécharger ici ou directement avec l'ISO de Windows 10 Pro. De quoi installer légalement Windows 10 Pro sur un PC. Pour en savoir plus sur l'achat et l'installation d'une clé OEM de Windows 10, suivez les indications de notre dossier pratique.


> Voir l'offre
60,99 €SSD PNY XLR8 CS3030 500 Go (NMVe M.2, 3500 Mo/s) à 60,99 €
Valable jusqu'au 15 Juin

Amazon fait une promotion sur le SSD PNY XLR8 CS3030 500 Go (NMVe M.2) qui passe à 60,99 € alors qu'on le trouve ailleurs à partir de 80 €. Ce SSD utilise une interface M.2 NVMe PCIe Gen3 x 4 pour une connexion simple et des performances exceptionnelles : jusqu’à 3500 Mo/s en lecture séquentielle et jusqu’à 2000 Mo/s en écriture séquentielle.

Le SSD est doté de la technologie 3D TLC NAND haute densité offrant une endurance d’écriture durable et assorti d’une garantie de cinq ans.


> Voir l'offre
24,99 €Clavier sans fil Logitech Wireless Desktop K400 Plus avec pavé tactile à 24,99 €
Valable jusqu'au 16 Juin

Amazon fait une promotion sur le clavier sans fil Logitech Wireless Desktop K400 Plus à 24,99 €. Ce clavier sans fil dispose d'un large pavé tactile de 9 cm avec navigation multipoint pour un pointage à un doigt simplifié et un défilement vertical à deux doigts. Idéal pour contrôler votre ordinateur à distance, s'il est connecté à une TV par exemple. On le trouve ailleurs à partir de 40 €. 


> Voir l'offre

Sujets relatifs
Comment supprimer recherche Laoscript au démarrage Excel ?
convertir un graphique Excel en image .JPG
Excel: longue colonne, recherche d'un chiffre
Excel formule ou autre recherche mot => construction graphique
Recherche d'une fonction dans EXCEL
Marges Excel pbl suite changement uc
Recherche d'une suite bureautique.
image en filigrane sur un tableau excel
Pause dans macros dans Excel (Suite)
Image déformée sur excel
Plus de sujets relatifs à recherche sur excel!!!!!! la suite en image!
 > Tous les forums > Forum Bureautique