> Tous les forums > Forum Bureautique
 Recherche valeur => comment éviter les #N/A??
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Frangipane
  Posté le 17/05/2006 @ 21:10 
Aller en bas de la page 
Petit astucien
Bonjour, Je dois faire des recherches valeurs. Or, quand ça ne trouve pas, ça affiche un #N/A pas joli du tout. J'ai essayé d'intégrer la recherche valeur dans une formule de SI, genre si valeur trouvée = valeur cherchée => écrire "oui", sinon, écrire "non" => ça met "oui" quand ça trouve, mais #N/A quand ça trouve pas C'est mieux avec un exemple : =SI(RECHERCHEV($A4;Feuil2!A:C;1;FAUX)=$A4;"oui";"non") => le "non" se transforme en #N/A => des idées? merci!
Publicité
sam²
 Posté le 17/05/2006 à 21:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Slt tu peux utiliser la mise en forme conditionnelle pour ne plus faire apparaitre les N/A.
Frangipane
 Posté le 17/05/2006 à 21:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
sam² a écrit :
Slt tu peux utiliser la mise en forme conditionnelle pour ne plus faire apparaitre les N/A.
Oui, je l'ai déjà fait, mais en fait, je ne veux pas les cacher, mais réellement mettre autre chose à la place, genre "non", etc... Merci en tt cas
sam²
 Posté le 17/05/2006 à 22:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
re Le #N/A est justement là pour arrêter les calculs. ce qui veut dire que tout calcule avec cette valeur ou test logique renverra #N/A. C'est un moyen pour ne pas propager une erreur. dans ce principe je doute qu'il soit possible de le remplacer facilement par une valeur. Excel est fait pour faire du calcul et à donc des outil dans ce sens, et donc pas forcémént estétique. Perso, entre avoir N/A et non, je ne trouve pas qu'il y a une grosse différence. Sauf si tu réutilise cette donnée dans le tableau.
Bérylion
 Posté le 18/05/2006 à 00:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut voir [url="https://forum.pcastuces.com/sujet.asp?SUJET_ID=271823"]la[/url] et [url="https://forum.pcastuces.com/sujet.asp?SUJET_ID=271644"]la[/url]
y.bli
 Posté le 18/05/2006 à 10:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien
Bonjour, Pour résumer, si A1/A2 te donne un message d'erreur, tu mets la formule : =SI(ESTERR(A1/A2);"";A1/A2) pour ne pas voir le message Evidemment, tu peux mettre autre chose entre les guillements. @+
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
299,00 €Ecran 27 pouces HP 27f (IPS, 4K) à 299 €
Valable jusqu'au 29 Octobre

Amazon fait une promotion sur l'écran HP 27f qui passe à 299 € livré gratuitement. On le trouve ailleurs à partir de 399 €. L'écran HP 27f 4K (3840x2160) dispose d'une dalle anti-reflets sans bordure à LED IPS de 27 pouces et d'une connectique 2xHDMI et DP. 


> Voir l'offre
85,30 €Kit de 16 Go (2x8 Go) de mémoire DDR4 Corsair Vengeance RGB Pro 3600 MHz à 85,30 € livré
Valable jusqu'au 29 Octobre

Amazon Allemagne fait une promotion sur le kit de 16 Go (2x8 Go) de mémoire DDR4 Corsair Vengeance RGB Pro 3600 MT/s CL18 à 80,57 € (avec la TVA ajustée). Comptez 4,73 € pour la livraison en France soit un total de 85,30 € livré alors qu'on le trouve ailleurs autour de 110 €. Vous pourrez personnaliser la palette de couleurs directement depuis le logiciel Corsair iCU.

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douane.


> Voir l'offre
17,99 €Micro clé USB 3.1 Sandisk Ultra Fit 128 Go à 17,99 €
Valable jusqu'au 30 Octobre

Amazon fait une promotion sur la micro clé USB Sandisk Ultra Fit d'une capacité de 128 Go qui passe à 17,99 €. La minuscule taille de cette clé USB va vous permettre de la laisser brancher en permanence sur votre portable, votre TV ou votre autoradio sans qu'elle dépasse de manière disgracieuse. Sa compatibilité USB 3.1 lui permet d'atteindre des débits jusqu'à 130 Mo/s. 


> Voir l'offre

Sujets relatifs
Comment aller recherche les X dernière valeur d'une colonne
Comment supprimer recherche Laoscript au démarrage Excel ?
Recherche valeur
comment pour corriger cette erreur #VALEUR!
Excel Recherche 1 valeur à l'intersection col lign
Recherche de la dernière valeur d'une ligne
Comment éviter de planter Word
comment donner une valeur a une lettre
comment indexer mon site dans moteur de recherche
Recherche valeur maxi (hh:mm) avec critère
Plus de sujets relatifs à Recherche valeur => comment éviter les #N/A??
 > Tous les forums > Forum Bureautique