> Tous les forums > Forum Windows XP
 Redémarrage en boucle après arrêt intempestifSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
fgondard
  Posté le 20/01/2019 @ 20:12 
Aller en bas de la page 
Grand Maître astucien

Bonjour,

Il me semble avoir déjà évoqué ce problème à une autre occasion et aujourd'hui j'ai tenté de le creuser un peu.

Fixés sous mon bureau j'ai l'interrupteur d'un boîtier multiprise et celui des enceintes. Il m'arrive trop fréquemment de couper le jus au lieu d'éteindre les enceintes. Quand je redémarre Windows, après exécution du chkdsk, je pars dans une boucle sans fin de redémarrages, Windows narrivant pas au terme de son chargement. Si j'intercepte le message d'erreur j'ai seulement : Uncknowed hard error, \%systemroot%\system32\ntdll.dll.

Démarrer en mode sans échec ou sur la dernière bonne configuration est sans effet. J'en suis quitte pour restaurer la partition système à partir d'une image.

J'ai cherché sur la toile si une solution avait été trouvée pour ce problème mais sans vraiment rien trouver de convaincant. À part ce problème ça Windows fonctionne très bien.

Je sais que je peux faire une réinstall par dessus mais derrière il y a quand même du boulot en perpective et j'aimerais éviter. Je sais aussi qu'il faudrait que je quitte mais gants de boxe avant d''aventurer ma main sous la table mais bon ...

Dans le journal des événement, jai vu une erreur qui pourrait correspondre : Le périphérique \Device\Ide\IdePort1 n'a pas répondu dans le délai imparti. J'ai deux lecteurs optiques en IDE, seraient-ils responsables ? À tout hasard j'ai désinstallé les pilotes IDE qui se sont réinstallés au démarrage mais sans que cela change quoi que ce soit.

Si quelqu'un a une piste je suis preneur.

Merci d'avance pour vos suggestions.



Modifié par fgondard le 20/01/2019 20:34
Publicité
capitainekirk
 Posté le 20/01/2019 à 20:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

salut fgondard,

on procede par elimination

debranche tes lecteurs et remets tes gants de box ....^^

tu seras fixés

fgondard
 Posté le 20/01/2019 à 20:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

debranche tes lecteurs

C'est la prochaine étape. D'autant plus que je viens de retouver la même erreur dans le journal des événement que j'avais purgé auparavant.

Mais cette recherche est fastidieuse puisquà chaque fois je dois restaurer ma partition.

regedice
 Posté le 20/01/2019 à 22:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je me demande si ton bios ne prend pas dans la tronche aussi ?

J'irais dans le bios et je changerais 1-2 paramètres, sauver -> retourner et remettre les paramètres comme avant, sauver, tenter le boot normal.

Des condos pas en forme sur la mobo qui n'aiment pas qu'on coupe le courant ainsi ?

Il y a des pistes

fgondard
 Posté le 21/01/2019 à 15:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Si j'avais réfléchi un peu plus je n'aurais pas eu besoin de faire le test avec mes deux lecteurs optiques débranchés, qui bien sûr n'a rien révélé, puiqu'à chaque fois que je restaure ma partition système je reprend le journal des événements figurant dans l'image, lequel ne peut donc rien contenir sur l'incident de redémarrage.

Il faudrait que je trouve un lecteur qui me permette de lire le journal de mon choix après avoir démarré sur mon Win PE. Je viens de tester sans succès Windows Event Viewer Plus.

Test avec le Win PE de la camarade Yolande : lecteur de journal natif absent !



Modifié par fgondard le 21/01/2019 17:21
Daneel Olivaw
 Posté le 22/01/2019 à 19:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je ne pense pas que les lecteur aient quelque chose à voir.

Personnellement, je ferai une sauvegarde de Ntdll.dll, et après le crash, je le restaurerais avec un WinPe quelconque.

Il serait peut-être utile de sauvegarder aussi hal.dll.

Pour lire le journal d''vènement d'un autre PC, l'Observateur d'évènements de Windows suffit :

En démarrant sur un WinPe :

Action ---> Se connecter à un autre ordinateur.

Cocher Un autre ordinateur, Parcourir. Spécifier le Groupe de travail et cliquer sur Avancé. Cliquer sur Rechercher et cliquer sur l'Ordinateur désiré et Ok.

Ou taper le nom de l'ordinateur directement dans la première fenêtre.

--

Et Voilà. À partir d'une MV windows 10 (VBOX-PC-10), j'ai accéder aux journaux du PC Hôte (HOME-PC):

--

fgondard
 Posté le 22/01/2019 à 19:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Je ne pense pas que les lecteur aient quelque chose à voir.

Tout à fat d'acord. Comme je le disais les messages d'ano vus dans le journal arrivent forcément sur un démarrage normal et j'ai fait mon test pour rien.

Pour le reste, avec Eventviewer de Windows ou d'autres logiciels alternatifs, on ne peut lire le journal d'un autre OS que si celui-ci tourne ce qui n'est pas le cas ici.

J'ai pensé contouner le problème en prenant une copie du fichier journal dans une machine virtuelle (le répertoire de la machine hôte ayant été déclaré comme ressource partagée dans Virtualbox) mais ça n'a pas fonctionné. Ce qui confirme ce que j'avais lu : on ne peut lire qu'un fichier sauvegardé, pas un fichier supposé actif. Je n'arrive pas à retrouver le fil traitant d'un problème identique où il était dit que modifier le contenu d'un seul octet suffisait à changer le statut du fichier.

Daneel Olivaw
 Posté le 22/01/2019 à 20:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour le reste, avec Eventviewer de Windows ou d'autres logiciels alternatifs, on ne peut lire le journal d'un autre OS que si celui-ci tourne ce qui n'est pas le cas ici.

Très juste. J'avais oublié que le XP ne tournais pas.

fgondard
 Posté le 23/01/2019 à 22:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

J'ai imaginé un scénario diabolique pour ariver à lire ce fichier journal. Après avoir provoqué l'incident de démarrage, je mets mon disque dans un boîtier USB, Je le connecte sur une autre machine tournant sur XP mais que je démarre sur le mini XP du HBCD. Là je copie le journal à la place de celui propre à cette machine et je là redémarre sur son propre OS. Logiquement Eventviewer n'y verra que du feu.

En ce moment je ne suis pas chez moi mais en retrant je m'y attelle.

Publicité
fgondard
 Posté le 29/01/2019 à 18:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Je viens de réaliser la manip en simplifiant la procédure (au lieu de balader le disque, redémarrage sur HBCD / min XP et copie du journal pour le transférer d'une machine à l'autre). Rien ! Et pourtant j'étais passé par le menu de démarrage (F8) et demandé l'enregistrement des événements de démarrage dans le journal.

Soit c'est un autre journal que SysEvent.Evt, soit le plantage a lieu avant que l'erreur ait pu être journalisée.

Là je me demande quelle piste suivre. Je peux essayer le coup de ntdll.dll et hal.ddl mais je doute que ces fichiers soient impactés par un arrêt brutal. S'agissant de dll ils ne sont que lus.

Quand le problème se produit, le chenillard de chargement s'arrête brusquement avant d'arriver à son terme et ça redémarre au POST. Je ne vais dans la phase chkdsk que sur le premier redémarrage. Dans le fonctionnement standardl Windows commence par lever un drapeau et l'abaisse quand on l'arrête. Au redémarrage Windows teste l'état de ce drapeau. Après un arrêt brutal, le drapeau est resté levé ce qui déclenche le chkdsk. Cela signifie qu'ici Windows ne vas même pas jusqu'à ce test.



Modifié par fgondard le 29/01/2019 19:30
Daneel Olivaw
 Posté le 29/01/2019 à 18:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je peux essayer le coup de ntdll.dll et hal.ddl mais je doute que ces fichiers soient impactés par un arrêt brutal. S'agissant de dll ils ne sont que lus.

Ça ne coûte rien d'essayer (sauf un peu de temps). Au moins, tu auras une certitude qu'ils ne sont pas corrompus.

fgondard
 Posté le 03/02/2019 à 20:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

J'ai essayé mais ça ne donne rien.

Je suis passé à la réinstallation par dessus mais là je rencontre ses soucis et je pose une nouvelle question pour ça.

Merci à tous pour vos suggestions.

beagles
 Posté le 04/02/2019 à 01:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir

Regarde le menu d'un HBCD --> NTDLL missing (manquant)

Tu lances et ton XP se relance, enlève le cd. Après Ton reboot il se relancera normalement sans autre intervention.

De mémoire. Ces histoires de ntdll manquant sont dûs à un arrêt brutal, une entrée du boot saute, une liaison d'autentification...

C'est 15 ans derrière...

fgondard
 Posté le 04/02/2019 à 17:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Sauf erreur de ma part je n'ai rien trouvé dans le HBCD concernant ntdll.dll. Je pense que tu confonds avec ntldr (nt loader).

J'ai refait un test: copie de ntdll.dll ailleurs, reproduction du défaut et remplacement par sa sauvegarde à l'aide de Win PE. Malgré ça toujours le même problème et donc restauration à partir de mon image.

Ceci montre que ce n'est pas ntdll.dll qui est en cause. Comme le suggère le message d'erreur, il est victime.

Je souçonne de plus en plus un problème de matériel. Depuis le début j'ai des déboires avec cette carte mère (voir ma config) : ports SATA 3 et ports USB3 inutilisables malgré tous mes essais de pilotes (ils ne sont pas gérés nativement par le chipset mais par des puces additionnelles). Et la nouvelle question que j'ai posée ici me conforte dans cette idée.

À toutes fins utiles j'ai passé Memtest mais aucune erreur n'a été détectée.

Merci quand même de t'être intéressé à mon problème.

capitainekirk
 Posté le 04/02/2019 à 17:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

salut fg,

t a essayé le nouvel xp que je t ai passé par mail ?

beagles
 Posté le 04/02/2019 à 19:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut

C'est pas un problème de fichier manquant. C'est plus un problème d'adressage (himem ou mbr ou autre ? je sais plus) lors du boot système; en gros il ne sait plus à quelle adresse trouver le fichier sur le disque dur (adresse hexa si je me souviens encore un peu), l'adresse a sauté lors de l'arrêt du disque, la perte de courrant électrique. Désolé pour ce peu d'information qu'il me reste du problème que j'ai rencontré maintes fois en service et assez commun. Le Fix étant plus simple à utiliser !

Ceci dit, vieux problème = vieille version

Mais j'ai trouvé le Fix dans la HBCD 15.1 et précédentes probablement.
----------------------------------
Others Tools
----------------------------------
.
.
Fix NTLDR is missing - Fix 'NTLDR is missing, Press any key to restart' for Windows Xp. (Dos Freeware)

Usb3 ? C'est donc pas une vieille carte-mère sortie sous Xp !

fgondard
 Posté le 04/02/2019 à 19:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Fix NTLDR is missing

Ce n'est pas NTLDR qui est en cause, en tout cas ce n'est pas ce que dit le message, mais ntdll.dll qui signale une erreur.

Uncknowed hard error, \%systemroot%\system32\ntdll.dll.

Je sais me dépanner rapidement en restaurant une image à partir du WinPe de la camarade Yolande. Le problème n'est pas là mais pourquoi ça arrive alors qu'après l'inévtable chkdsk ça devrait repartir comme en 14 dans la majorité des cas. Et, autant qu'il me souvienne, je n'ai pas toujours eu ce problème.

C'est donc pas une vieille carte-mère sortie sous Xp

Effectivement mais elle commence à avoir de la bouteille. J'avais cru dénicher l'oiseau rare disposant du SATA 3 et de l'USB 3 mais aussi de connecteurs disquette et IDE. Ce que je n'avais pas deviné c'est que le SATA 3 et l'USB 3 étaient gérés par des puces à part.

t a essayé le nouvel xp que je t ai passé par mail ?

Pas eu le temps, autres essais effectués. Voir le nouveau fil.

Publicité
beagles
 Posté le 06/02/2019 à 22:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut

Apprenti s'abstenir

fgondard je te signale un outils http://rweverything.com/

This utility access almost all the computer hardware, including PCI (PCI Express), PCI Index/Data, Memory, Memory Index/Data, I/O Space, I/O Index/Data, Super I/O, Clock Generator, DIMM SPD, SMBus Device, CPU MSR Registers, ATA/ATAPI Identify Data, Disk Read Write, ACPI Tables Dump (include AML decode), Embedded Controller, USB Information, SMBIOS Structures, PCI Option ROMs, MP Configuration Table, E820, EDID and Remote Access. And also a Command Window is provided to access hardware manually.

À toi de voir si tu peux y voir

fgondard
 Posté le 07/02/2019 à 17:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

je te signale un outil

J'ai téléchargé et installé cet outil mais apès avoir regardé tous les rapports qu'il produisait je n'ai pas bien compris ce qu'il pouvait m'apporter.

fgondard
 Posté le 08/02/2019 à 18:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Alors que j'en étais à mon nième test de réinstallation (voir ici), tout d'un coup, plus moyen d'utiliser l'un de mes lecteurs optiques (IDE).

Après moultes tentatives (changement de nappe, essai d'une floppée de lecteurs en réserve, inversion mâitre/esclave, etc.) j'en arrive au constat : le BIOS n'est plus capable de détetecter la présence que d'un seul périphérique sur la nappe IDE et seulement quand il est en MA ou CS.

J'ai téléchargé et installé un BIOS plus récent et mes deux lecteurs sont de nouveau détectés. J'ai du mal à comprendre comment le BIOS a pu être corrompu, sans compter qu'à un moment la machine ne démarrait plus du tout (plus de mise en route de l'alim).

Mais en ce qui concerne le redémarrage en boucle, statu quo ! Sans toujours pouvoir trancher entre un problème de matériel ou de logiciel.

fgondard
 Posté le 16/03/2019 à 15:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour nateliv,

Merci pour ton intervention mas il ne s'agissait pas d'un problème d'arrêt en cours de fonctionnement mais d'impossibilité d'aller au terme du chargement de Windows. Depuis j'ai résolu le problème en réinstallant à partir de zéro. Voir ce fil.

Je clos celui-ci que j'avais gardé ouvert en attenfant de voir si cette réinstallation avait eu un effet sur ce problème spécifique. C'est bien le cas mais j'en ai eu d'autres.



Modifié par fgondard le 25/03/2019 11:52
MartinLaura
 Posté le 25/03/2019 à 10:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

Bonjour,

Merci pour tous ces messages qui informent et donnent des solutions pratiques

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
redémarrage en boucle après réparation xp
Arrêt et redémarrage intempestif de XP
redemarrage pc après arrêt avec freebox
Rédemarrage après arret de windows
Arret et redemarrage intempestif avec XP
redémarrage pc après arrêt normal
Redémarrage du pc en boucle
Arrêt intempestif d'un PC sous XP
Redémarrage en boucle de Win XP
probleme de redemarrage apres le post
Plus de sujets relatifs à Redémarrage en boucle après arrêt intempestif
 > Tous les forums > Forum Windows XP