> Tous les forums > Forum Windows XP
 [Réglé] XPro: "Cette copie de windows doit être activée..." BoucleSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
SPhoenix
  Posté le 26/08/2017 @ 18:25 
Aller en bas de la page 
Petit astucien

Bonjour à tous !

Le deuxième de mes trois XPro (SP4) refuse de s'activer : "Cette copie de Windows doit être activée auprès de Microsoft avant de pouvoir ouvrir une session, voulez-vous activer Windows maintenant ?" Oui/Non.

Que l'on choisisse oui ou non, le bureau s'affiche tout nu pendant qqe secondes et retourne sur la page de login avec la même invitation d'activation !

Quelqu'un a-t-il de l'expérience avec ce genre de problème ?

Merci d'avance pour votre aide,

SPhoenix



Modifié par SPhoenix le 26/08/2017 20:58
Publicité
mrsalbert1964_pca
 Posté le 26/08/2017 à 18:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Bonjour,le Sp4 pour xp n'existe pas fait attention en plus des bug

El Magnifico
 Posté le 26/08/2017 à 19:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

mrsalbert1964_pca a écrit :

Bonjour,le Sp4 pour xp n'existe pas fait attention en plus des bug

C'est une compilation non officiel => http://assiste.com/Windows_XP_SP4.html

Comme SP2 pour W7.

SPhoenix

Ton XP n'est pas reconnu comme authentique je pense, l'est il ?



Modifié par El Magnifico le 26/08/2017 19:05
mrsalbert1964_pca
 Posté le 26/08/2017 à 19:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Je reviens sur ton problème comme toujours sans voir, regarde bien que la clé est bonne sinon je te conseil de refaire une nouvelle insta et ne mets pas ce sp4 reste avec le 3 c'est mieux bien a toi.

SPhoenix
 Posté le 26/08/2017 à 20:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à tous !

El Magnifico est bien informé: SP4 viens de la compilation de assiste.com

C'EST RÉGLÉ !!!

Après des siècles de jachère, j'ai résolu aujourd'hui :

1- J'ai eu plusieurs problèmes de partiions

2- J'ai fait un clone de C: qui a pris la lettre E: dans le XPro récalcitrant

3- J'ai tout essayé en mode sans échec (MSÉ) :

  • copier un wpa.dbl et un data.dat valide sur la partition courante sans succès
  • copier différentes copies de wpa.dbl et data.dat sans succès
  • supprimer le wpa.dbl et le data.dat sans succès
  • modifier la valeur HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WPAEvents > oobeTimer sans succès
  • supprimer oobeTimer sans succèes
  • faire des combinaisons des précédents sans succès
  • exécuter rundll32 syssetup,SetupOobeBnk sans succès
  • refait les précédents dans le désordre sans succès
  • supprimé tous les fichier system32\wga*.* et viré la clé HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\WgaLogon ce qui a réglé 50% de mon problème
  • revisité la clé oobeTimer et remarqué qqe chose

4- J'ai remarqué que HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion > SystemRoot="E:\WINDOWS" (où E: se trouve le clone de C:) au lieu de la lettre de la partition courante ! Je remarque ensuite que beaucoup d'autres valeurs de chemin système pointaient vers E:\ !

5- À l'aide d'un logiciel évolué de gestion de registre j'ai modifié toutes les valeurs E:\ par I:\ dans le registre et ré-exécuté rundll32 syssetup,SetupOobeBnk... et VOILÀ !!! Je suis revenu sur mon bureau dont je n'ai pas vu le beau papier peint depuis des siècles !

À partir d'ici, je crois que je vais réussir à activer mon OS (SE) qui avait un os dans la moulinette...

.

Merci de votre présence et votre attention,

SPhoenix



Modifié par SPhoenix le 27/08/2017 21:57
El Magnifico
 Posté le 26/08/2017 à 20:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

Chapeau

bon dimanche

SPhoenix
 Posté le 26/08/2017 à 21:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Idem



Modifié par SPhoenix le 26/08/2017 21:11
Daneel Olivaw
 Posté le 26/08/2017 à 22:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

La procédure est expliquée dans le lien que je t'avais passé dans l'autre fil et si tu avais dit que la lettre du lecteur système avait changée :

https://forum.pcastuces.com/windows_xp_est_alle_sinstaller_dans_la_partition_f-f1s193158.htm?page=1&#5689507

SPhoenix
 Posté le 26/08/2017 à 23:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Daneel Olivaw

c'est pas ce lien-là que tu m'as passé dans mon autre fil !!!

Merci quand même et je suis heureux de constater que tu t'y connais en partition ! J'en ai une difficile pour toi : sais-tu comment changer la lettre d'une partition système secondaire vu par elle-même, ainsi que les autres partitions autour ? C'est sûr que C:\ va rester C:\ partout et... évidemment ça s'exécute en dehors du SE concerné mais encore...

.

PS : faudrait-il que je bidouille une clé dans MountedDevice après le changement de valeur de E:\ à F:\ que j'ai effectué dans le registre comme indiqué dans mon post "C'EST RÉGLÉ" ?

sPhoenix



Modifié par SPhoenix le 26/08/2017 23:55
Publicité
Daneel Olivaw
 Posté le 26/08/2017 à 23:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Non. Je parle de ce lien :

https://support.microsoft.com/fr-fr/help/914232/you-may-receive-error-code-0x80004005-or-other-error-codes-when-you-tr

Celui-la résume comment changer la lettre de la partition système.

https://forum.pcastuces.com/windows_xp_est_alle_sinstaller_dans_la_partition_f-f1s193158.htm?page=1&#5689507

Quand à ta dernière question, j'avoue ne pas avoir bien compris.

Partitition secondaire vue par elle même, ça veut dire un autre OS sur une seconde partition sur laquelle tu bootes ?

SPhoenix
 Posté le 27/08/2017 à 00:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

En effet !

J'explique : J'ai 5 partitions P1 à P5

P1=C:\ (XPro0)

P2=D:\ (XPro1)

P3=E:\

P4=F:\ (XPro2)

P5= (clone e C:\)

...

Mais quand je change de SE et entre dans XPro1, les lettre changent et vues de l'intérieur de XPro1 ça ressemble à :

P1=C:\ (XPro0)

P2=I:\ (XPro1)

P3=F:\

P4=D:\ (XPro2)

P5=E:\ (clone de C:\)

.

J'aimerais que la présentation vu de l'intérieur de XPro1 soit la même que dans XPro0, d'où ma demande précédente...

sPhoenix

PS: tu m'as écrit pendant que j'ai modifié mon précédent message. Prends en connaissance et désolé pour la collision...



Modifié par SPhoenix le 27/08/2017 00:16
Daneel Olivaw
 Posté le 27/08/2017 à 00:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si j'ai bien compris tu veux que lorsques tu boote sur XPro1, le disque système soit vu comme C: alors qu'il est vu comme I:

Si quand tu as installé à l'origine c'etait C: et qu'il a changé à I: après redémarrage, alors la méthode que j'ai donné ici rechangera à C:\ :

https://forum.pcastuces.com/windows_xp_est_alle_sinstaller_dans_la_partition_f-f1s193158.htm?page=1&#5689507

Mais après les bidouilles que tu as faites, les résultats peuvent êtres imprévisibles, c'est à dire rendre le système non bootable ou impossible à arriver au login.

Ce que je te conseille :

À partir de XPro0, tu sauvegardes la BDR de XPro1 ou tu fais une image système (c'est mieux)

Tu bootes sur XPro1 et tu fais les modifs :

1 - Aller à la clé HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

dans la colonne de droite, double-clique sur Userinit et modifie la valeur pour ne conserver que Userinit.exe et valider par OK.

2 - Aller à la clé HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

Cliquer dessus avec le bouton droit et sélectionner Autorisations dans le menu contextuel. Sélectionnez la ligne Administrateurs, vérifiez que les Administrateurs disposent bien d’un contrôle total, l'autoriser au besoin.

3 - dans la colonne de droite faire un clique droit et renommer la valeur \DosDevices\C: en \DosDevices\X:

4 - renommer la valeur \DosDevices\I: en \DosDevices\C:

5 - Redémarrer.

Si le système n'arrive pas au login, tu pourras restaurer la BDR à partir de XPro0.

SPhoenix
 Posté le 27/08/2017 à 01:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Mes bidouilles n'ont rien endommagée et je peux entrer et venir dans XPro1 sans problèmes...

Tu as mal compris pour le reste:

1- P1=C:\ (XPro0) est le XP original et sa lettre C:\ doit le rester pour tous les autre OS

2- Dans XPro0, la P2 (XPro1) a la lettre D:\ et je veux qu'à l'intérieur de tous les autres OS ce soit de même XPro1=D:\

3- idem pour XPro2

En résumé, dans chaque OS, je veux qu'on voit les lettres des partitions de la même façon que dans XPro0.

C'est plus clair ?

sPhoenix



Modifié par SPhoenix le 27/08/2017 01:06
SPhoenix
 Posté le 27/08/2017 à 01:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Dit autrement:

Dans XPro1:

C est resté C

D est devenu I

E est devenu F

F est devenu D

Caché est devenu E

Je ne veux pas que ces changements aient lieu

sPhoenix

Daneel Olivaw
 Posté le 27/08/2017 à 01:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Donc tu veux que dans XPro1 tu ais :

P1=C:\ (XPro0)

P2=D:\ (XPro1)

P3=E:\

P4=F:\ (XPro2)

P5=\ (clone de C:\)

Dans la Gestion des disques, tu peux supprimer la lettre attribuée à P5 (E:), et renomme P3 et P4 en E: et F:.

Le problème, c'est de renommer I: en D:, étant donné que ce n'est pas la lettre originale attribuée à l'installation.

C'est toujours la même méthode :

Aller à la clé HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

et modifier la valeur Userinit en ne conservant que : Userinit.exe.

Dans la clé HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices renommer la valeur \DosDevices\I: en \DosDevices\D:

Mais cela peut rendre le système non bootable.

Donne-moi un peu de temps pour tester ça avec une machine virtuelle.



Modifié par Daneel Olivaw le 27/08/2017 01:57
SPhoenix
 Posté le 27/08/2017 à 04:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

C'est ce que je veux !

Changer les lettre des autres partition c'est facile. Changer Sa propre lettre, ÇA c'est le défi car il faut comprendre que seulement changer la lettre c'est pas tout : il faut voir si le système est assez intelligent pour changer toutes les références des chemins systèmes dans la base de registre !?

Si tous les chemins systèmes étaient référencés avec les variable d'environnement ça serait relativement facile de rétablir la base de registre mais c'est pas le cas.

sPhoenix



Modifié par SPhoenix le 27/08/2017 04:05
Daneel Olivaw
 Posté le 27/08/2017 à 04:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Non le système n'est pas assez intelligent pour le faire, pour la simple raison qu'il y a des centaines (milliers ?) d'occurences de C:\

Alors j'ai réussi. Voilà comment :

Mon disque système est C:

J'ai téléchargé cet utilitaire qui change toutes les occurences d'une valeur en une seule fois :

http://bladesdev.com/regreplace.htm

J'ai ouvert la base de registre sur la clé : HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

Avec le logiciel, j'ai remplacé toutes les occurences de C:\ en I:\

Quand il a terminé, j'ai renommé \DosDevices\C: en \DosDevices\I:

Alors là, plus rien ne fonctionne, aucun programme ne démarre, rien. Même shutdown ne fonctionne pas. Il faut éteindre à la sauvage.

Mais au démarrage, tout fonctionne normalement et le disque système est devenu I: comme on peut le constater :



Modifié par Daneel Olivaw le 27/08/2017 04:20
Publicité
SPhoenix
 Posté le 27/08/2017 à 05:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

WOW !!!

Champion...

J'essaierai ça et rapporterai le désastre ou le succès

Merci beaucoup

sPhoenix

SPhoenix
 Posté le 27/08/2017 à 22:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

À la demande (légitime) de Daneel, j'ai édité mon message no... ? (les messages sont pas numérotés ici ? hummm ! ), mon 2ième message.

> ...j'ai modifié toutes les valeurs E:\ par I:\ dans le registre...

sPhoenix

Daneel Olivaw
 Posté le 27/08/2017 à 22:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Merci, mais cela amène alors une autre question :

La lettre I a été attribuée par toi dès le début de l'installation ou bien était-ce C: qui a basculé inopinément à I: ?

Windows donne toujours la lettre C: à la partition système, quelque soit la partition (ou le DD) où tu l'installes. D'où est venue cette lettre I ?

SPhoenix
 Posté le 28/08/2017 à 16:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

C'est pas moi !!!

Enfin... oui et non :

Avant d'ajouter mes XP supplémentaires, j'avais 5 partitions (ou 4). Quand j'ai ajouté les OS supplémentaires, je les ai dirigés vers les partitions spécifiques donc, leur lettres étaient prédéfinies mais... il en ai résulté que leur lettre ont finalement été modifiées par l'installation et ont perdu leur lettre originale. J'ai vécu avec depuis lors (plus d'une quinzaine). J'avais pensé faire le changement présentement en cours mais me suis laissé convaincre que c'était impossible.

Depuis les 3-5 dernières années, j'ai eu des problèmes important de partitions (overlap) en créant des clés USB bootables, et ai rétabli l'ordre finalement au bout de peine et misères, et en reliquat, mes OS secondaires ont été inaccessibles (écran noir indiquant que le HAL.dll était corrompu ou manquant ), et il m'est resté sur les bras un lecteur DVD fantôme J qu'il faut que je vire un jour. Et j'ai réalisé le mois passé où j'ai réussi à réanimer mes OS secondaires que le deuxième avait hérité de la lettre... "I" !!!???

Les deux OS demandaient une réactivation. Ce fut facile pour le deuxième, mais impossible pour celui qui nous préoccupe présentement. Ce à quoi nous nous affairons présentement.

Voilà ! c'est toute l'histoire.

sPhoenix

PS: Daneel était bien, en effet (j'avais oublié) le personnage de la quadrilogie FANTASTIQUE "Fondation" d'Azimov que j'ai savouré il y a ±40 ans dans mes ±20 ans (je trahis mon âge ici). Si t'es amateur, je te suggère chaleureusement la trilogie épique 'Hypérion" de Dan Simons... Un autre FANTASTIQUE chef-d’œuvre.



Modifié par SPhoenix le 28/08/2017 17:03
Daneel Olivaw
 Posté le 28/08/2017 à 17:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si cela a changé inopinément, alors il faudrait d'abord restaurer la lettre C: normale avant de songer à en mettre une autre.

La méthode que j'ai indiqué et testé en dernier concerne un XP sain qui a la lettre C: d'origine et où toutes les références aux logiciels pointent sur C:\.....

Si XP a basculé de lui-même sur une autre lettre, Toutes les occurences de C:\ dans la BDR n'on probablement pas changées.

Il faudrait commencer par faire une recherche dans la BDR sur toutes les occurences de C:\ et I:\



Modifié par Daneel Olivaw le 28/08/2017 17:15
SPhoenix
 Posté le 28/08/2017 à 19:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'ai donc mal expliqué :

Situation de départ:

5 partitions et un OS (XPro0) sur C:\.

J'ai ensuite installé mon premier OS secondaire XPro1 sur D:\ qui s'est réveillé avec la lettre "E" (pour XPro1)... et récemment mystérieusement devenu... "I". C:\ est toujours resté C:\ partout pour tout le monde. En devenant mystérieusement "I", les chemin systèmes du registre ne pointaient plus sur "I" mais "E"; j'ai donc fait le point 5 de mon deuxième message :

5- À l'aide d'un logiciel évolué de gestion de registre j'ai modifié toutes les valeurs E:\ par I:\ dans le registre...

sPhoenix



Modifié par SPhoenix le 28/08/2017 20:40
Daneel Olivaw
 Posté le 28/08/2017 à 20:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

J'avais bien compris. C'est XP qui a, par deux fois, changé la lettre du lecteur système.

C'est un bogue connu de XP qui peut arriver notemment quand on clone un DD, mais pas seulement.

Il faudrait d'abord revenir à la lettre C: par la première méthode que j'ai donné, mais ça reste risqué avec toutes ces modifications.

Il n'y a pas d'autre choix que de faire une image système et de tenter la chose.

Fais une recherche dans la BDR pour savoir s'il y a des occurences de C:\, de E:\ et de I:\ pour savoir quelle méthode employer.

SPhoenix
 Posté le 28/08/2017 à 20:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Il faudrait d'abord revenir à la lettre C:

Pourquoi ? C:\ n'a JAMAIS changé !

sPhoenix

SPhoenix
 Posté le 28/08/2017 à 21:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Dit autrement :

XPro0 est sur P1= C:\ et il voit P2 comme D:\

XPro1 est sur P2= D:\ mais est vu par lui-même comme E:\ (originalement) puis maintenant comme I:\

XPro1 voit C:\ comme C:\ et rien ne change pour C:\

Je ne comprends pas pourquoi tu parles de C:\ en rapport avec XPro1 ?

Ce qu'on veut : que XPro1 devienne D:\ pour lui-même, mais avant on doit l'activer en le stabilisant avec la lettre I et en réussissant à installer IE8.

En fait, on a travaillé à l'envers : au lieu de tout changer les chemins systèmes de E en I dans le registre, on aurait dû changer la lettre du DD de I en E avec ta suggestion du MountedDevices. C'est peut-être ça qui cause un problème à IE8...

Je devrais avoir une copie du registre. Est-ce qu'on essaie ?

sPhoenix

PS: collision de message possible. Je vais attendre que tu prennes connaissance de la présente...



Modifié par SPhoenix le 29/08/2017 03:34
Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Cette copie de windows n'est pas originale
Comment réparer cette erreur dans Windows XP ?
Activer une copie de Windows SP3
Boucle sur Windows Update
Windows XP, cette bombe à retardement...
Windows Update en boucle !!!
reboot pc en boucle sur pc fixe Windows XP SP3
copie non authentique Windows XP
restauration partition windows copie sous linux
windows xp pro boucle au démarrage
Plus de sujets relatifs à [Réglé] XPro: "Cette copie de windows doit être activée..." Boucle
 > Tous les forums > Forum Windows XP