> Tous les forums > Forum Linux
 [réglé]debian squeze comment activer effets bureau
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
klipper
  Posté le 10/06/2011 @ 20:17 
Aller en bas de la page 
Petit astucien

Bonjour,

J'ai installé les pilotes nvidia, mais je n'ai pas le cube, ni le choix des fenêtres en gélatine ou autre.

Comment faut-il faire ?



Modifié par klipper le 12/06/2011 10:28
Publicité
Logicien
 Posté le 10/06/2011 à 23:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

un petit préliminaire serait de t'assurer que le Direct Rendering fonctionne en exécutant dans un terminal graphique la commande

glxinfo | grep "direct rendering"

Il faudrait d'abord savoir avec quel environnement de bureau tu veux activer les effets. Kwin, le gestionnaire de fenêtres de Kde peut gérer les effets 3D du bureau. Il faut activer les effets du bureau dans la Configuration du système et choisir les effets désirés.

Si tu veux utiliser Compiz-Fusion en remplacement du gestionnaire de fenêtres de Kde, Gnome 2 ou Xfce par exemple, le plus facile d'après moi, est de presser le raccourci clavier Alt+F2 sous Gnome ou Kde et d'exécuter la commande

fusion-icon -n

Avec l'option -n, tu auras une icône qui apparaîtra dans la barre des tâches sans que Compiz soit lancé. La première chose à faire est de cliquer droit sur cette icône et de lancer Settings Manager, le gestionnaire des effets de Compiz. Dans la fenêtre qui s'ouvre, activer impérativement dans la section Effets, Décoration de la fenêtre et dans la section Gestion des fenêtres, Déplacer la fenêtre et Redimensionner la fenêtre. Nécessaire si tu veux pouvoir travailler quand Compiz sera lancé.

En cliquant toujours droit sur l'icône Fusion-Icon, dans le menu Select Window decorator tu peux choisir le décorateur de fenêtres. Emerald n'est pas dans les dépôts officiels de Debian. Tu devras utiliser Kde ou Gtk window-decorator.

Dans le menu Compiz Option, n'active rien pour le moment sauf si tu as des lenteurs, alors les deux options peuvent être utilisées pour essayer de résoudre des problèmes d'affichage.

Dans le menu Select Window Manager, tu choisis Compiz s'il ne l'est pas. Dans ce cas, Compiz sera lancé immédiatement. Si Compiz est déjà le choix actif, tu clics sur Reload Window Manager pour lancer Compiz. À partir du moment ou Compiz fonctionne, tu peux personnaliser ta configuration de Compiz avec Settings Manager, en français le Gestionnaire de Configuration CompizConfig. Les changements sont pris en compte immédiatement et la configuration générale préservée à la fermeture de Compiz.

Compiz a une configuration séparée pour Gnome et Kde. Par défaut rien n'est activé dans les effets. Si tu as des problèmes avec Compiz, tu peux avec Fusion-Icon revenir à Kwin de Kde ou Metacity de Gnome. Sinon, il faut exécuter une des commandes

kwin --replace

metacity --replace

pour remplacer Compiz par kwin ou Metacity.

Lorsque ta configuration de Compiz est au point, il est possible de lancer automatiquement Compiz à l'ouverture de session. D'abord, il faut mettre au point et Fusion-Icon est pratique pour ça. Avec Synaptic, c'est assez facile d'installer tous les paquets nécessaires à l'utilisation de Compiz-Fusion et Fusion-Icon.



Modifié par Logicien le 11/06/2011 04:53
klipper
 Posté le 11/06/2011 à 19:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

re-merci Logicien, pour nvidia, j'ai fait des recherches et j'ai trouvé le paquetage hwinfo qui m'a permis de voir que j'ai une carte GT 440, et comme synaptique est bien commenté, je pense avoir fait le bon choix de drivers parmis tous ceux proposés.(d'ailleurs j'ai pas eu de bug au reboot)

Pour tes commandes aussi, j'ai eu à en installer les paquetages, et malheureusement j'ai à priori un problème:

klipper@klipper:~$Xlib : extension GLX missing (comment on fait copier/coller avec Iceweasel ?)

klipper
 Posté le 12/06/2011 à 10:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

réglé: il fallait des drivers 32 bits (la plupart des cartes graphiques sont 32bits)

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
comment activer choix bureau Gnome ou KDE (RESOLU)
Debian 8.0 Jessie - Comment exécuter un programme demandant une élévation
Comment activer le simple clic - Mint 17 Cinnamon
Comment mettre la corbeille sur le bureau avec Zorin os
icône sur bureau: comment lzs "supprimer" Suse 13.
Comment installer une source-list sur Debian ?
Raccourcis dossier sur le bureau sous Debian LXDE
Comment activer mon clavier durant le Grub ?
[réglé]Debian & squid
Comment activer mon lecteur de carte SD ?
Plus de sujets relatifs à [réglé]debian squeze comment activer effets bureau
 > Tous les forums > Forum Linux