> Tous les forums > Forum Linux
 sortie de veille portable sous manjaro 0.8.13
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Taras_Boulba
  Posté le 12/07/2015 @ 13:36 
Aller en bas de la page 
Astucien

salut à tous,

petit topic pour partager une info sur la dernière mouture de manjaro.

si comme moi (lenovo flex 10) votre portable freeze et redémarre en sortie de veille, vous pouvez résoudre le problème en changeant de noyau.

par défaut, sur la 0.8.13 c'est le 3.18.17-1 qui est installé, ouvrez le gestionnaire de paramètre de manjaro et installez le kernel 3.14.47-1 (lts), redémarrez et bootez sur le nouveau kernel.

a+

ps: j'ai ce bug de sortie de veille sur debian 8 et son noyau 3.16.7, sur lmde 2 (basée sur jessie) et sur mint 17.2 (mais pas sur la 17.1)



Modifié par Taras_Boulba le 13/07/2015 11:07
Publicité
Logicien
 Posté le 12/07/2015 à 14:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

ce n'est pas intéressant en ce qui me concerne de rétrograder vers une version inférieure du noyau Linux pour résoudre un problème. De ce que j'ai lu dans la Documentation du noyau, il est dit que la mise-en-veille est expérimentale.

Je ne suis pas chez moi et je suis sous Cromebook. J'ai une commande pour la mise-en-veille. Je n'utilise pas d'interface graphique pour la mise-en-veille. C'est d'ailleurs mieux ainsi. Je l'afficherai après un nouveau test de fonctionnalité.

Taras_Boulba
 Posté le 12/07/2015 à 15:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

ok suis preneur. je préférerais ne pas avoir à rétrograder aussi... en même temps, le 3.14 est un lts, un moindre mal donc.

m_n
 Posté le 12/07/2015 à 15:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Petite question en passant :

Avais-tu essayé (( Light Locker Settings )) ??



Modifié par m_n le 12/07/2015 15:31
Taras_Boulba
 Posté le 12/07/2015 à 16:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

je suis sous manjaro en français, je ne vois pas à quoi peut correspondre Light Locker Settings

mais de toute façon, mon problème n'est pas la mise en veille mais la sortie de veille (d'où mon scepticisme sur la commande de logicien... )

Logicien
 Posté le 12/07/2015 à 17:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Rebonjour,

mise en contexte:

- principe élémentaire à respecter, ne pas utiliser un autre système d'exploitation que celui qui hiberne et restaure entre le moment de l'hibernation et de la restauration.

- test fait sous Debian Jessie ... stable.

- le noyau Linux doit avoir été démarré avec l'option resume=/dev/sda1 avant l'hibernation (et avec d'autres options dans mon cas, à adapter). Si la partition d'hibernation n'est pas spécifiée ou que le noyau est démarré avec l'option noresume avant l'hibernation ou au moment de la restauration, rien ne va fonctionner. Donc, il faut préciser la partition et ne pas utiliser noresume avant et pendant.

- session graphique utilisateur fermée, retour à Gdm

- aller à un terminal en mode caractères avec Ctrl+Alt+F1 (Debian) Ctrl+Alt+F2 (ArchLinux) et ouvrir une session root.

- pour hiberner avec redémarrage, exécuter la commande

echo reboot > /sys/power/disk && echo disk > /sys/power/state

- pour hiberner avec arrêt, exécuter la commande

echo shutdown > /sys/power/disk && echo disk > /sys/power/state

Après redémarrage ou démarrage de l'ordinateur, à l'écran de Grub2, il faut avoir une entrée qui dit quel est le noyau et l'initrd à démarrer avec la seule option resume=/dev/sda1 (mon cas). Exemple d'une entrée avant l'hibernation et une au moment de la restauration dans le menu de Grub2:

menuentry "Debian/GNU/Linux amd64: Pour hibernation" {
set root=(hd0,3)
linux /vmlinuz consoleblank=0 enable_mtrr_cleanup fbcon=scrollback:1024k loglevel=0 nohz=off pcie_aspm=off resume=/dev/sda1 root=/dev/sda3 rw video=uvesafb
initrd /initrd.img
}

menuentry "Debian/GNU/Linux amd64: Pour restauration" {
set root=(hd0,3)
linux /vmlinuz resume=/dev/sda1
initrd /initrd.img
}

Comme les systèmes de type Unix sont à l'origine orientés serveurs, la mise-en-veille et l'hibernation ne sont peut-être pas aussi importants que pour un poste de travail orienté client tel le bureau.

Toujours est-il qu'après la restauration, j'ai récupéré l'invite root en tty1, qu'Internet fonctionne et que Gdm est prêt à ouvrir une session graphique utilisateur. Je n'ai pas couru le risque de laisser une session graphique utilisateur ouverte au moment de l'hibernation, mais la restauration devrait fonctionner aussi dans ce cas.



Modifié par Logicien le 12/07/2015 17:51
Taras_Boulba
 Posté le 13/07/2015 à 11:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

re logicien,

merci pour tes explications mais l'hibernation ne n'intéresse pas.
j'ai remplacé le disque d'origine par un ssd et manjaro démarre en 4 ou 5 secondes et s'éteint en 2 ou 3... donc, plutôt que d'hiberner, j'éteins mon ordi.

c'est la veille qui m'intéresse et plus particulièrement la sortie de veille qui me pose un problème avec tous les derniers kernels des distros.

Logicien
 Posté le 13/07/2015 à 18:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Très bien. Je veux seulement te dire que j'ai découvert des anomalies dans le fonctionnement de Jessie après restauration. Mon invite de commandes root en tty1 était décalée vers la droite. En passant à tty2 et en revenant à tty1, ça c'est replacé.

Plus grave, mon point d'accès sans fil Linux sous Jessie ne fonctionnait plus. Le plus curieux, c'est que la sortie audio HDMI tournait au ralenti, vraiment ridicule. Après un redémarrage normal, tout est rentré dans l'ordre.

Je n'utilise pas la mise-enveille ni l'hibernation au quotidien. Ma dernière expérience me dit de continuer comme ça. D'ailleurs, quand je redémarre c'est souvent pour démarrer un autre système d'exploitation. Impossible dans ce cas d'hiberner avant redémarrage.

Taras_Boulba
 Posté le 14/07/2015 à 14:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

oui et bien je vais faire comme toi... laisser tomber pour le moment la mise en veille
en attendant un correctif peut être, je viens de voir une maj du noyau sous manjaro, qui sait...

merci pour le partage de tes précieuses connaissances

Publicité
Logicien
 Posté le 14/07/2015 à 19:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Sous ArchLinux, je ne vois rien pour la mise-en-veille, mais il y a un hook qui se nomme resume qui peut être ajouté à l'initramfs en éditant le fichier /etc/mkinitcpio.conf et en ajoutant le mot resume à la ligne HOOK à la fin des autres hooks. Il reste ensuite à créer l'initramfs. En root

mkinitcpio -p linux

Ce hook est sensé permettre l'hibernation et la restauration. Je pense qu'il faut que le noyau soit lancé avec l'option resume=/dev/sda1 (mon cas) pour indiquer sur quelle partition d'échange doit se faire la copie de la mémoire vive lors de l'hibernation. Les noyau doit aussi être lancé avec la seule option resume=/dev/sda1 lors de la restauration.

J'ai essayé de faire une hibernation depuis Xfce4 avec cette option lors de l'écran de fin de session. L'hibernation semble s'être faite normalement, l'ordinateur s'éteint après quelques secondes, mais la restauration ne s'est pas faite à cause que le hook resume n'était pas installé et que l'option resume=/dev/sda1 n'avait pas été passée avant l'hibernation.

On peut connaître les hooks disponibles par

mkinitcpio -L

et connaître ce que fait un hook par exemple pour resume par

mkinitcpio -H resume

Sous Manjaro, ça doit fonctionner de la même manière.



Modifié par Logicien le 14/07/2015 19:18
Taras_Boulba
 Posté le 15/07/2015 à 14:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bon à savoir... je regarderai ça, suis pas chez moi

Logicien
 Posté le 15/07/2015 à 20:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Note aussi que Systemd a une commande pour l'hibernation et une pour la mise-en-veille. Je ne les ai pas essayées. Valable pour ArchLinux, Manjaro, Debian Jessie et plusieurs autres distributions telles Fedora, Mageia et OpenSuse.

systemctl hibernate

systemctl suspend

Il y a des pages de manuels qui correspondent à ces commandes

man systemd-hibernate.service

man systemd-suspend.service

et d'autres encore.



Modifié par Logicien le 15/07/2015 20:12
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
mouchards sur portable lenovo. Y at'il un risque sous Linux ?
sous linux manjaro impossible reconnaissance clavier sans fil
probleme d'affichage avec mozilla sous manjaro
Sortie d'une Manjaro Lxde-QT
Sortie de Manjaro 0.8.9 finale
Sortie de la Manjaro 0.8.7
Sortie de la Manjaro 0.8.6
Sortie d'une Manjaro KDE 4.10
Sortie officielle de la Linux Manjaro 0.8.5
Sortie d'une Manjaro OpenBox Lite
Plus de sujets relatifs à sortie de veille portable sous manjaro 0.8.13
 > Tous les forums > Forum Linux