> Tous les forums > Forum Windows 10
 SSD qui apparait comme disque éjectableSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
Hyportatif
  Posté le 04/10/2019 @ 08:48 
Aller en bas de la page 
Grand Maître astucien

à Tous

Voilà, j'ai mon SSD qui apparait comme disque éjectable, comme je possède aussi deux DD Sata interne pour mes données et sauvegarde, ces deux DD apparaissait aussi comme éjectable, donc j'ai fait ceci: https://www.seeyar.fr/fixer-disque-dur-interne-apparaissant-disque-ejectable/, les deux DD n'y sont plus, mais il reste le SSD, auriez vous une idée du problème. Merci d'avance

voici le rapport sfc /scannow .

https://www.cjoint.com/c/IJdtNlksRT2

Publicité
Hyportatif
 Posté le 04/10/2019 à 11:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

J'ai changer de port Sata sur mon SSD, je les interverti avec un de mes disques de données, et maintenant, c'est le disque de données qui est éjectable, celui là je peux l'éjecter mais c'est pas normal .

Dans stratégie, pour quoi mes deux disques dur de données sont différents ? Merci

En Fait, si je l'éjecte ce DD, dans la gestion des disques il n'y est plus, ainsi que dans l'explorateur



Modifié par Hyportatif le 04/10/2019 13:06
Daneel Olivaw
 Posté le 04/10/2019 à 15:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

C'est dans le BIOS qu'il faut désactiver, pour les ports SATA, le HOT PLUG (Branchement à chaud). Chaque port SATA est indépendant.

De toute façon, pour un disque système, Windows refusera de l'éjecter.

C'est quoi la carte mère ?

Foxamarch
 Posté le 04/10/2019 à 16:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

salut,

Dans la base de registre rechercher :

HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device
Créer une Clé : « valeur de chaines multiples » nommée « TreatAsInternalPort »
Dans « données de valeur » indiquer le ou les n° de Bus du ou des disk(s) à désactiver du support éjectable.
Dans mon cas 0 et 1 pour 2 SSD.
(voir panneau de config system = référence « Bus Number », « Channel » étant absent)
Pour finir reboot

Hyportatif
 Posté le 04/10/2019 à 18:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

La CM c'est une MSI MPG X570 GAMING PLUS, dans le BIOS tout les HOT PLUG sont désactivé, devant le disque en question, il n'y à rien correspondant au Hot Plug, donc je peux pas désactivé.

Le DD je les mis en second sur un autre PC, quans je vais dans l'explorateur pour l'ouvrir, c'est toutes les partitions qu'il y a dessus qui s'ouvre ( 5 au total ), mais la je n'ai pas éjectable par contre

Voir disque 1



Modifié par Hyportatif le 04/10/2019 18:46
Daneel Olivaw
 Posté le 04/10/2019 à 18:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Page 50 du manuel :

Hyportatif
 Posté le 04/10/2019 à 21:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Je met quelques captures du BIOS

Comme j'ai dit, le DD je les mis sur un autre PC, je l'ai formaté, j'ai recréer une partition sur tout le disque, j'ai remis ensuite le DD sur mon PC, au reboot j'ai cette page, suivi de ce message, même quand je clique sur la corbeille, même message

La lettre D correspond au DD qui pose problème , je suis obligé de passer par le gestionnaire des tâches, pour fermer l'explorateur, car sur la page blanche ( première capture ), si je clique sur la croix, la fenêtre ne se ferme pas

Je sais pas si je vais pas le virer ce DD , ça m'embête car il fait 1 To, et il est correct avec CrystalDiskInfo



Modifié par Hyportatif le 04/10/2019 21:11
Daneel Olivaw
 Posté le 04/10/2019 à 21:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Pour le hot plug, c'est désactivé. C'est Ok.

Mais je ne vois pas SATA 0,1 et 2.

Pour le disque D:, le mieux c'est de faire un scan approfondi : chkdsk /f /r D:

Tu sauras à quoi t'en tenir.

Si des blocks défectueux viennent d'apparaitre, il ne sont pas encore détecté par le firmware, d'ou un SMART propre pour le moment.



Modifié par Daneel Olivaw le 04/10/2019 21:24
Hyportatif
 Posté le 04/10/2019 à 21:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Mais je ne vois pas SATA 0,1 et 2. regarde sur la troisième capture au début , Sata 0 il n'existe pas, 6 Port Sata sur la CM

Publicité
Daneel Olivaw
 Posté le 04/10/2019 à 21:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Ok. Pas de SATA 0. Mais SATA 1 et 2 où sont-ils, puisqu'il y a des disques branchés dessus ?

Hyportatif
 Posté le 04/10/2019 à 21:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Re

Comment ou sont-il, je comprends pas trop ta demande, désolé

Daneel Olivaw
 Posté le 04/10/2019 à 21:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Pourquoi ils n'apparaissent pas ici dans Hot Plug ?

Hyportatif
 Posté le 04/10/2019 à 21:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Je sais pas pauvre

Même en remettant le BIOS par défaut, ça change rien, dans MSInfo32, je suis en Mode BIOS Hérité



Modifié par Hyportatif le 04/10/2019 21:48
Hyportatif
 Posté le 04/10/2019 à 22:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Re

Je les reformater sur mon PC, puis supprimé le volume, ensuite nouveau volume sur la totalité du disque, donc maintenant en ouvrant ma corbeille, c'est tout bon, mais il reste le phénomène Hot Plug, et éjecter, le DD apparait aussi dans périphériques et imprimantes

Daneel Olivaw
 Posté le 04/10/2019 à 22:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Il est possible que les SATA 1 et 2 ne puissent pas être en hot plug.

Sur quels ports SATA sont les disques qui peuvent être éjectés ?

Hyportatif
 Posté le 04/10/2019 à 22:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Re

Je sais pas, j'ai vu 6 port Sata, et j'ai branché, c'est marqué dessus ?

Daneel Olivaw
 Posté le 04/10/2019 à 22:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Re

Publicité
Hyportatif
 Posté le 04/10/2019 à 22:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Re

J'ai regardé sur mon manuel de la CM, voici

Foxamarch
 Posté le 04/10/2019 à 23:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Continue à chercher,

je t'ai fourni la solution

Daneel Olivaw
 Posté le 05/10/2019 à 01:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Foxamarch a écrit :

Continue à chercher,

je t'ai fourni la solution

Ta solution est bonne et valide, mais si Windows considère le disque comme amovible, c'est bien parce que le BIOS le déclare amovible.

Si on peut déclarer le disque comme non-hotplug dans le BIOS, c'est une solution définitive et je cherche à comprendre pourquoi le réglage n'existe pas pour les SATA 1 et 2 dans sa carte mère.

Foxamarch
 Posté le 05/10/2019 à 02:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Beaucoup de personnes cherches pourquoi et moi itou.

pour l'instant pas d'explications valables n'a été trouvée

Il semblerait que les controleurs SATA AHCI soient en cause

J'ai le probléme sur mes 4 PC à chaque fois que je les reformate



Modifié par Foxamarch le 05/10/2019 02:45
Daneel Olivaw
 Posté le 05/10/2019 à 02:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Apparemment c'est courant pour cette carte mère.

Ici, 2 personnes, l'un les ports 1 et 2, l'autre 5 et 6.

https://forum-en.msi.com/index.php?topic=322571.0

Peut-être qu'une mise à jour du BIOS ?

Foxamarch
 Posté le 05/10/2019 à 03:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Non rien à voir, ce sont les pilotes

Hyportatif
 Posté le 05/10/2019 à 10:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Sur ces CM, le BIOS est mis à jour automatiquement pour les nouveau processeur 3600 comme le mien, c'est ce que ma dit le type au télép...avant de commander je lui est posé la question

PS: Foxamarch, tu dis: (voir panneau de config system = référence « Bus Number », « Channel » étant absent) , je comprends pas là, mon bus est à 0

Hyportatif
 Posté le 05/10/2019 à 11:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Voilà mon DD qui pose souci, Bus Number 0

Hyportatif
 Posté le 05/10/2019 à 12:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

C'est tout bon pour le disque éjectable, je les mis sur le port sata 5, et la bingo, plus rien dans retirer le périphérique............

Dans l'explorateur, c'est différent le placement du disque D , par rapport à la gestion des disques ( voir capture )

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Fixer disque dur interne apparaissant comme disque éjectable
Disque externe qui apparaît en double
Fenêtre qui apparait à chaque démarrage
Disque ssd par intermittence
Disque ssd plein
Augmenter la RAM ou utiliser un disque dur interne SSD
Cloner windows 10 sur disque dur SSD
SSD + disque dur 1 To
Conseil achat disque ssd
disque dure ssd
Plus de sujets relatifs à SSD qui apparait comme disque éjectable
 > Tous les forums > Forum Windows 10