× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Windows 10
 AHCI POUR SSD AVEC WINDOWS 10
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
FIFI03
  Posté le 29/10/2018 @ 20:40 
Aller en bas de la page 
Petit astucien

Bonjour à toutes et tous,

J'ai installé un SSD que j'utilise sous Windows 10 professionnel. Je ne parviens pas a activer le mode AHCI sur mon SSD malgré de nombreuses tentatives. J'ai effectué les modifications dans la base de registre. En visitant le gestionnaire de périphériques il est possible de vérifier que le mode AHCI n'est pas actif puisque contrôleurs IDE ATA/ATAPI sont présents (voir pièce jointe).
Mes recherches dans le Bios de mon ordi qui est un PC de bureau ne donne rien. Sauf à ne pas avoir regarder au bon dans le Bios je n'ai trouvé aucune indication dans le Bios qui me permet d'activer AHCI. Ma carte est une gigabyte.

Dans l'attente de vous lire.

Bien cordialement.

FIFI



Publicité
Daneel Olivaw
 Posté le 29/10/2018 à 21:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

C'est quoi comme carte mère ? Marque et modèle ?

Il ne faut pas que le mode Compatibilité IDE soit activé dans le BIOS, mais le mode SATA, ou AHCI ou SATA/AHCI.

Certain constructeur fusionnent le mode AHCI avec le mode RAID comme Dell par exemple.

FIFI03
 Posté le 30/10/2018 à 18:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Daneel Olivaw a écrit :

C'est quoi comme carte mère ? Marque et modèle ?

Il ne faut pas que le mode Compatibilité IDE soit activé dans le BIOS, mais le mode SATA, ou AHCI ou SATA/AHCI.

Certain constructeur fusionnent le mode AHCI avec le mode RAID comme Dell par exemple.

Bonsoir,

Merci de votre réponse.

En réponse à votre question: Ma carte mère est de la marque GIGABYTE le modèle GA-EG41MF-US2H

Je vous confirme que le mode IDE est actif dans le bios et je ne parviens à modifier pour passer en SATA ou SATA/AHCI.

Daneel Olivaw
 Posté le 30/10/2018 à 20:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Il faut aller dans le menu Integrated peripherals et mettre tous les SATA ports sur Enhanced.

FIFI03
 Posté le 31/10/2018 à 20:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

Je viens de faire la modification dans le bios de mon ordi selon vos recommandations. Il se trouve qu'au redémarrage de Windows 10 un écran bleu se présente si je laisse l'ordinateur redémarrer il tourne en boucle pour revenir sur le même écran bleu avec le message suivant:

Code d'arrêt: INACCESSIBLE BOOT DEVICE. Ce qui signifie que le dispositif de démarrage donc l'OS n'est pas accessible.

Pour redémarrer mon ordi j'ai du retourner dans le bios pour annuler les modifications.

Que puis-je faire pour remédier à cela.

Bien cordialement.



Modifié par FIFI03 le 31/10/2018 20:51
Daneel Olivaw
 Posté le 31/10/2018 à 21:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Après avoir activé le SATA dans le BIOS, il faut redémarrer une première fois en mode sans échec.

Désactive le SATA et rentre dans Windows.

Dans Exécuter tape msconfig.

Onglet Démarrer ---> Coche Démarrage sécurisé et minimal ---> Appliquer et redémarre

Avant que Windows ne se lance rentre immédiatement dans le BIOS et rechange en mode SATA AHCI et continue dans Windows.

Une fois Windows démarré, retape msconfig et décoche Démarrage sécurisé ---> appliquer er redémarre.

FIFI03
 Posté le 01/11/2018 à 20:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Hello l'ami,

Avec ton aide et conseils je viens réussir à activer le mode AHCI sur mon PC . Je te remercie.

Bonne soirée.

FIFI03
 Posté le 08/11/2018 à 19:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Je reviens vers toi lors de mon dernier message du 1 novembre 2018 je suis allé trop vite en besogne. Au moment ou je travaille dans bios de mon ordi j'ai un appel téléphonique qui m'annonce une mauvaise nouvelle et j'ai fermé le bios sans effectuer l'enregistrement des modifications que tu me conseilles. Je n'ai pas non plus vérifié dans le gestionnaire de périphériques si le mode AHCI est actif pensant qu'il était.

Aujourd'hui, en démarrant mon PC j'ai vérifié dans le gestionnaire de périphériques et dans le bios le mode AHCI n'est pas activé.

J'ai effectué quelques vérifications qui donne les indications suivantes:

  • Quand Windows démarre sans que le mode AHCI ou ENHANCED pour moi selon tes conseils ne soit pas activé je remarque sur la PHOTO 1 qui suit dans cadre rouge de cette photo les infos suivantes sont: IDE Channel 0 Master: Samsung SSD 850 EVO etc....qui est le disque SSD pour lequel je veux que le mode AHCI ou ENHANCED pour moi soit actif.

    IDE Channel 0 Slave: St2000DX001
    etc....qui est mon second disque dur.


    Les autres mentions indique la présence de deux lecteurs/graveurs de CD/DVD.

    Cette image PHOTO 1 montre que deux disques le SSD en Master ou le second disque dur en Slave sont présents en premier au démarrage de Windows quand le mode AHCI ou ENHANCED pour moi n'est pas activé dans le bios.

    Ce qui n'est le cas, quand le mode AHCI ou ENHANCED pour moi est activé dans le bios photo 2. Au démarrage de Windows ou l'on voit, que se sont mes deux lecteurs/graveurs de CD/DVD qui se trouvent en premier à la place du SSD et du second disque dur et que malgré l'activation du mode sans échec pour obliger Windows a démarrer une première fois en mode sans échec quand le mode AHCI ou ENHANCED pour moi est activé dans le bios mon PC redémarre et je me trouve avec l'écran bleu de Windows voir photo 3



    PHOTO 1

PHOTO 2


PHOTO 3

Avant l'activation dans le bios du mode AHCI ou ENHANCED pour moi, le bios donne les infos suivantes dans la photo 4:

  • PATA IDE Set To Ch. 1 Master/Slave
  • SATA Port 0/2 Set To Ch. 0 Master/Slave
  • SATA Port 1/3 Set To Disable

PHOTO 4

Après l'activation dans le bios du mode AHCI ou ENHANCED pour moi, le bios donne les infos suivantes dans la photo 5:

  • PATA IDE Set To Ch. 0 Master/Slave

  • SATA Port 0/2 Set To Ch.2 Master/Slave

  • SATA Port 1/3 Set To Ch.3 MasterSlave
    PHOTO 5


Quel est ton avis sur la situation?

Que dois-je faire pour arriver enfin à activer le mode AHCI ou ENHANCED pour moi?

Dans l'attente de te lire.

Bien cordialement.

Daneel Olivaw
 Posté le 09/11/2018 à 04:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Le manuel est pourtant clair :

En mode Enhanced, tous les ports SATA opèrent en SATA et non en IDE.

Que se passe-t-il quand tu mets sur Enhanced ?

Mets une photo.

Publicité
FIFI03
 Posté le 09/11/2018 à 13:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Je suis d'accord le manuel est limpide.
Appliqué à mon matériel la solution du manuel semble bonne lorsque l'on voit la photo du bios selon moi (photo 1 du bios jointe...). Quand penses tu ?

Après avoir activé ENHANCED et malgré la programmation du mode sans échec Windows ne redémarre dans ce mode mais arrive là (photo 2).

photo 1 du bios


photo 2

Daneel Olivaw
 Posté le 09/11/2018 à 17:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Je ne comprends pas.

Une fois que tu as mis On chip SATA mode sur Enhanced, tu dois pouvoir modifier SATA Port 0/2 et SATA Port 1/3 et les mettre sur SATA.

Tu as essayé de cliquer dessus ?

FIFI03
 Posté le 09/11/2018 à 19:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Oui j'ai bien effectué la manipulation que tu évoques. J'obtiens ce qui apparaît sur les photos qui suivent:

PHOTO 1 LE BIOS ON CHIP SATA MODE N'EST PAS SUR ENHANCED

Quand je clique sur Auto dans le bios pour faire la modification et mettre sur ENHANCED la modification obtenue est qui apparaît sur la photo 2 est la suivante:

PHOTO 2 LE BIOS ON CHIP SATA MODE EST SUR ENHANCED


Une fois les modifications faites je les enregistrent et là Windows devrait logiquement redémarrer la première fois en mode sans échec mais ce n'est pas le cas, l'OS mouline 2 à 3 minutes pour arriver sur ce qui apparaît sur la photo 3 l'écran bleu et la, si je veux pourvoir utiliser mon ordi je dois au redémarrage aller dans le bios supprimer les modifications faites c'est dire supprimer ENHANCED et windows redémarre parce qu'il réglé pour cela en mode sans échec. Je supprime le démarrage en mode sans échec et au redémarrage je suis de nouveau avec un windows dont les contrôleurs sont en modes IDE ATA/ATAPI comme indiqué photo 4

PHOTO 3

PHOTO 4

Daneel Olivaw
 Posté le 09/11/2018 à 21:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Une fois les modifications faites je les enregistrent et là Windows devrait logiquement redémarrer la première fois en mode sans échec mais ce n'est pas le cas,

Non, c'est toi qui doit activer le mode sans échec la premier démarrage, puis le désactiver pour redémarrer normalement.

Ce que je ne comprends pas, c'est que ça avait fonctionné la première fois et tu avais marqué en résolu.

FIFI03
 Posté le 10/11/2018 à 10:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J’active le mode sans échec avant de faire les modifications dans le bios. Oui j'avais marqué comme résolu sans avoir vérifié. En réalité mon matériel n'a jamais fonctionné en mode SATA.



Modifié par FIFI03 le 10/11/2018 16:27
Daneel Olivaw
 Posté le 10/11/2018 à 20:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Si tu désactives l'IDE qu'est-ce qui se passe ?

Daneel Olivaw
 Posté le 10/11/2018 à 20:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Et as-ty installé le dernier BIOS ?

Selon tes captures, tu es sur le BIOS F2 et cést F5 le dernier.

https://www.gigabyte.com/fr/Motherboard/GA-EG41MF-US2H-rev-10#support-dl-bios

FIFI03
 Posté le 11/11/2018 à 13:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Oui je suis bien en F2 pour le Bios. Je n'ai jamais pensé à faire de mise à jour. Une mise à jour du bios n'est-elle pas risquée?

Quelle procédure faut-il appliquer pour faire une mise à jour la moins risquée?

Bon dimanche.

Merci.



Modifié par FIFI03 le 11/11/2018 22:41
Publicité
FIFI03
 Posté le 17/11/2018 à 20:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

De retour après quelques jours de repos. J'ai effectué la mise à jour aujourd'hui de mon bios comme tu me le conseillais opération réussit . Par contre et malgré la mise à jour du bios je ne parviens toujours pas à faire accepter à mon matériel le mode ENHANCED . Lorsque j'active ENHANCED au redémarrage Windows ne redémarre pas en mode sans échec mais je me retrouve avec l'écran qui suit:

Devant la difficulté je ne sais plus quoi faire. Que me conseille tu???

Bon week-end

Daneel Olivaw
 Posté le 19/11/2018 à 21:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Du nouveau ?

Je ne t'ai pas oublié, mais je n'ai rien trouvé d'autre à proposer.

Le manuel dis une chose et ton BIOS affiche autre chose.

FIFI03
 Posté le 19/11/2018 à 22:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je suis d'accord. Je suis face à un difficulté et je ne sais pas comment la résoudre.

Je te remercie de ton aide.

Je vais poursuivre mes recherches....

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
29,99 €SSD PNY CS900 240 Go à 29,99 €
Valable jusqu'au 22 Octobre

Amazon fait une promotion sur le SSD PNY CS900 240 Go qui passe à 29,99 €. Ce SSD offre des vitesses d'écriture de 515 Mo/s et de lecture à 550 Mo/s. Il est garanti 3 ans. La livraison est gratuite.


> Voir l'offre
36,39 €RAVPower FileHub à 36,39 € (via coupon)
Valable jusqu'au 22 Octobre

Amazon fait une vente flash sur le RAVPower FileHub qui passe à 36,39 € livré gratuitement au lieu de 59,99 €. Pour profiter de cette offre, activez le coupon de réduction présent sur la page du produit. Cet appareil multifonction va vous permettre de créer un réseau sans fil et de transférer les photos, les films, la musique et les fichiers entre vos différents appareils via le WiFi et sur un disque dur externe ou une clé USB via le port USB présent. Un lecteur de carte mémoire est même intégré, ce qui peut être pratique pour décharger vos photos de manière autonome sur un disque dur. La batterie de 6700 mAh intégrée vous permettra de réaliser vos transferts sans ordinateur et sans alimentation. Elle vous permettra également si besoin de recharger un appareil mobile. Très utile en vacances !


> Voir l'offre
GratuitJeu PC Kingdom New Lands gratuit
Valable jusqu'au 22 Octobre

Epic Game Store offre actuellement le jeu PC Kingdom New Lands. Des histoires circulent sur des îles lointaines, pleines de mystères à découvrir. Les souverains auront besoin de tous leurs sujets pour partir en mer. 


> Voir l'offre

Sujets relatifs
problème avec les mise a jour Windows 10
Activation Windows 10 Pro, je me retrouve avec Win10 Entreprise !
Encore un bug pour Windows 10 1809
mise à jour windows 10 pour plusieurs pc
Quel réglage pour le type de démarrage de windows update
Comment installer un Windows avec les droits Total (Administrateur)
Reboot avec un iso de Windows 10
Mise à jour cumulative pour Windows 10 Version 1803 x64 (KB4346783)
Programme d'installation pour les modules windows problème.
Possible de redimenssioner partitions avec iso de Windows 10 ?
Plus de sujets relatifs à AHCI POUR SSD AVEC WINDOWS 10
 > Tous les forums > Forum Windows 10