> Tous les forums > Forum Bureautique
 Renvoi de données d'une base vers autre feuille
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
lazoue
  Posté le 17/06/2006 @ 21:25 
Aller en bas de la page 
Nouvelle astucienne
Bonjour. Je dispose d'une liste : en colonne A, la réf des produits en colonne B : le poids en colonne C : le prix au kg Je voudrais que dans la feuille 2, en tapant la référence du produit, s'affiche automatiquement dans les cellules d'à côté : le poids et le prix. J'envisage ainsi à partir d'une liste de produits, de créer une facture automatisée. D'avance, merci pour vos réponses. Lazoue.
Publicité
galopin01
 Posté le 17/06/2006 à 21:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
bonjour et bienvenue sur PCA tu peux le faire avec des formules à l'aide de RECHERCHEV Consulte l'aide Excel à ce sujet c'est très clair. Sinon, ça peut se faire à base de macro, mais ça suppose déjà une bonne expérience. A+
lazoue
 Posté le 17/06/2006 à 21:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne
galopin01 a écrit :
bonjour et bienvenue sur PCA tu peux le faire avec des formules à l'aide de RECHERCHEV Consulte l'aide Excel à ce sujet c'est très clair. Sinon, ça peut se faire à base de macro, mais ça suppose déjà une bonne expérience. A+
Merci pour cette réponse rapide mais je ne suis pas du tout experte des fonctions d'Excel et j'avais bien trouvé cette fonction sans parvenir à un résultat satisfaisant. Si tu as un exemple de syntaxe, je suis preneuse ! Merci Lazoue
galopin01
 Posté le 17/06/2006 à 22:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
il existe de nombreuses variantes... Dans cet exemple il est supposé que ta table de référence va de A1 à C25 Dans la feuille 2 si tu entres une référence en A8 par exemple voici la formule à mettre en B8 pour renvoyer la deuxième colonne de Feuil1 : =RECHERCHEV(A8;Feuil1!A$1:C$25;2) voici la formule à mettre en C8 pour renvoyer la troisième colonne de Feuil1 : =RECHERCHEV(A8;Feuil1!A$1:C$25;3) Cette formule peut être recopié par incrémentation ou par copier coller sur les cellules en dessus ou en dessous. L'inconvénient de cette formule est que si la colonne A1 n'est pas rempli la formule te renvoie une valeur d'erreur. Ce qui fait mauvaise impression sur une facture. Pour éviter l'affichage de valeur d'erreur sur les lignes vides, on utilise la formule suivante : Pour B8 : =SI(ESTNA(RECHERCHEV(A2;Feuil1!A$1:C$25;2));"";RECHERCHEV(A2;Feuil1!A$1:C$25;2)) Pour C8 : =SI(ESTNA(RECHERCHEV(A8;Feuil1!A$2:C$25;3));"";RECHERCHEV(A8;Feuil1!A$2:C$25;3)) Il y a encore quelques petites astuces, mais tu peux déjà commencer à faire tes premières armes la-dessus. A+
lazoue
 Posté le 17/06/2006 à 22:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne
galopin01 a écrit :
il existe de nombreuses variantes... Dans cet exemple il est supposé que ta table de référence va de A1 à C25 Dans la feuille 2 si tu entres une référence en A8 par exemple voici la formule à mettre en B8 pour renvoyer la deuxième colonne de Feuil1 : =RECHERCHEV(A8;Feuil1!A$1:C$25;2) voici la formule à mettre en C8 pour renvoyer la troisième colonne de Feuil1 : =RECHERCHEV(A8;Feuil1!A$1:C$25;3) Cette formule peut être recopié par incrémentation ou par copier coller sur les cellules en dessus ou en dessous. L'inconvénient de cette formule est que si la colonne A1 n'est pas rempli la formule te renvoie une valeur d'erreur. Ce qui fait mauvaise impression sur une facture. Pour éviter l'affichage de valeur d'erreur sur les lignes vides, on utilise la formule suivante : Pour B8 : =SI(ESTNA(RECHERCHEV(A2;Feuil1!A$1:C$25;2));"";RECHERCHEV(A2;Feuil1!A$1:C$25;2)) Pour C8 : =SI(ESTNA(RECHERCHEV(A8;Feuil1!A$2:C$25;3));"";RECHERCHEV(A8;Feuil1!A$2:C$25;3)) Il y a encore quelques petites astuces, mais tu peux déjà commencer à faire tes premières armes la-dessus. A+
Un super merci à toi, Galopin, je vais expérimenter ces formules de ce pas. Lazoue
dixit
 Posté le 17/06/2006 à 23:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
bonsoir, voir sur mon site perso deux fichiers excel avec exemple a+
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
64,99 €Assistant vocal Amazon Echo Show 8 avec Alexa à 64,99 € [Amazon Prime]
Valable jusqu'au 22 Juin

Pour ses membres Prime, Amazon fait une promotion sur l'assistant vocal Amazon Echo Show 8 qui passe à 64,99 € (au lieu de 129,99 €). L'appareil piloté par la voix et vos doigts fonctionne avec Alexa, l’intelligence artificielle développée par Amazon. Vous pourez avec elle écouter de la musique, interagir avec vos appareils domotiques, écouter les infos, des livres audio la radio, connaître la météo et d’accéder à des milliers d’autres possibilités grâce aux Skills : recettes de cuisine, petits jeux, etc. Grâce à son écran HD de 8 pouces, vous pourrez également regarder des séries, des films, des photos, afficher des recettes de cuisine, appeler vos amis en visio, contrôler vos caméras de sécurité, etc...


> Voir l'offre
899,90 €Ultrabook HONOR MagicBook 14 (Core i7, 16 Go, 512 Go SSD) à 899,90 € [Amazon Prime]
Valable jusqu'au 22 Juin

Pour ses membres Prime, Amazon fait une promotion sur son ultrabook HONOR MagicBook 14 qui passe à 899,90 € au lieu de 999 €. Cet ordinateur portable possède un écran 14 pouces Full HD IPS, un processeur Intel Core i7-1165G7, 16 Go de mémoire DDR4, un SSD 512 Go PCIe NVME, le WiFi6 / Bluetooth 5.1, un lecteur d'empreintes, une webcam, un clavier rétro éclairé, une batterie 56 Wh (jusqu'à 10h d'autonomie) et ne pèse que 1,38 kg. Il fonctionne sous Windows 10. Une très bonne affaire pour une machine compacte et puissante.


> Voir l'offre
339 €Ecran PC 34 pouces Samsung S34J552WQR ultralarge (WQHD, 4 ms, 75Hz) à 339 € [Amazon Prime]
Valable jusqu'au 22 Juin

Amazon fait une promotion sur l'écran PC 34 pouces Samsung S34J552WQR ultralarge qui passe à 339 € au lieu de 399 €. Cet écran possède une dalle VA de résolution 3440x1440 à 75 Hz (compatible FreeSync). La fonction Picture-by-Picture intégrée (PBP) permet l'affichage de deux sources différentes côte à côté à leur résolution native. Entrées HDMI et DP.


> Voir l'offre

Sujets relatifs
Copier plage de celules vers autre feuille sous condition
Copier tableaux vers autre feuille sous condition
CREATION BASE DE DONNEES AVEC 1 AUTRE FICHIER EXCE
validation de données liste sur une autre feuille
Validation des données d'autre autre feuille
Filtre Elaboré vers une autre feuille
Filtre Elaboré vers une autre feuille
copie de colonne vers une autre feuille avec condi
Combinaison de 2 base de données comparatives
Excel 2007 Copier/Coller d’une feuille à l’autre Dans un même classeur.
Plus de sujets relatifs à Renvoi de données d''une base vers autre feuille
 > Tous les forums > Forum Bureautique