× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 sélectionner une ligne sur deux dans une formule
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
mm91
  Posté le 17/11/2007 @ 07:03 
Aller en bas de la page 
Astucien
Bonjour,

Dans un très long tableau Excel , je voudrai sélectionner une ligne sur deux (ou sur trois…) pour en faire la somme (ou une formule quelconque). Sans avoir à sélectionner ces cellules à la main.

Merci pour votre aide
Publicité
galopin01
 Posté le 17/11/2007 à 08:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

bonjour,

rappel : Les formules ne "font" rien : donc elles ne peuvent sélectionner à ta place ! C'est le domaine des macros.

Néanmoins si j'ai bien saisi l'esprit de ta demande, pour la plage A1:A10, cette formule fait la somme des lignes impaires.

=SOMMEPROD(A1:A10*(MOD(LIGNE(A1:A10);2)=1))

Cette autre fait la somme des lignes paires :

=SOMMEPROD(A1:A10*(MOD(LIGNE(A1:A10);2)=0))

A+

galopin01
 Posté le 17/11/2007 à 09:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Ces autres font le même travail avec une ligne sur 3

=SOMMEPROD(A1:A10*(MOD(LIGNE(A1:A10);3)=1))

=SOMMEPROD(A1:A10*(MOD(LIGNE(A1:A10);3)=2))

=SOMMEPROD(A1:A10*(MOD(LIGNE(A1:A10);3)=0))

En fait, sur ce principe et avec un peu de patience les SOMMEPROD combinés avec des tas de truc donnent des tas de résultats différents...

MOYENNE, MAX, NB.SI... Y suffit de savoir ce qu'on cherche !

A+



Modifié par galopin01 le 17/11/2007 09:15
mm91
 Posté le 17/11/2007 à 09:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci beaucoup Galopin01 pour tes réponses claires et précise.

Les formules proposées correspondent parfaitement à ma demande, cependant Excel me signale que la formule contient une erreur.

galopin01
 Posté le 17/11/2007 à 10:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

mm91
 Posté le 17/11/2007 à 10:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
galopin01 a écrit :


Les as-tu essayées ?

g
 Posté le 17/11/2007 à 12:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

mm91 a écrit :

galopin01 a écrit :


Les as-tu essayées ?


Moi oui, et elles fonctionnent à merveille.

Bonne journée.

galopin01
 Posté le 17/11/2007 à 12:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Autres solutions équivalentes :

=SOMME(SI(MOD(LIGNE(A1:A10);2)=0;A1:A10;""))+N("somme lignes paires")

=SOMME(SI(MOD(LIGNE(A1:A10);2)=1;A1:A10;""))+N("somme lignes impaires")

=SOMME(SI(MOD(LIGNE(A1:A10);3)=0;A1:A10;""))+N("somme premières lignes 1/3")

=MOYENNE(SI(MOD(LIGNE(A1:A10);2)=0;A1:A10;""));""))+N("Moyenne lignes paires")

=MOYENNE(SI(MOD(LIGNE(A1:A10);2)=1;A1:A10;""))+N("Moyenne ...")

=MOYENNE(SI(MOD(LIGNE(A1:A10);3)=0;A1:A10;""))

Attention formules matricielles (à valider par Ctrl+Maj+Entr)

A+

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
54,99 €Microsoft Flight Simulator à 54,99 €
Valable jusqu'au 27 Novembre

Amazon fait une promotion sur le tout nouveau Microsoft Flight Simulator sur PC qui passe à 54,99 € livré gratuitement au lieu de 69,99 €. La boite contient les 10 DVD du jeu.


> Voir l'offre
23,99 €Jeu PC Star Wars Jedi: Fallen Order à 23,99 €
Valable jusqu'au 27 Novembre

Amazon propose actuellement le tout nouveau jeu PC Star Wars: Fallen Order à 23,99 €. Le code du jeu vous serra envoyé par email et vous pourrez le télécharger sur Origin. Dans le cadre de cette histoire authentique de STAR WARS, les fans vont plonger dans une galaxie récemment saisie par l’Empire. En tant que héros Jedi devenu fugitif, les joueurs auront besoin de se battre pour survivre tout en explorant les mystères d’une civilisation disparue depuis longtemps avec un effort pour reconstruire les restes de l’ordre Jedi que l’empire cherche à effacer complètement les Jedi.


> Voir l'offre
119,99 €SSD externe portable Samsung T5 1 To + carte mémoire MicroSD Evo Plus 64 Go à 119,99 €
Valable jusqu'au 29 Novembre

Fnac fait une promotion sur le SSD externe portable Samsung T5 1 To qui passe à 119,99 € alors qu'on trouve le SSD à 160 € ailleurs. Le disque SSD Samsung T5 portable est plus de deux fois plus petit que la taille de votre smartphone et fournit jusqu'à 5 fois la vitesse d'un disque dur portable. Apprenez à travailler en quelques secondes, transférez de grandes bibliothèques de vidéos et de photos à des vitesses pouvant atteindre 550 Mo/s. Vous ne craindrez pas de l'emporter partout avec vous grâce à sa conception robuste et résistante avec un coeur de SSD résistant aux chocs. Grâce à son interface USB-C, vous pouvez le brancher sur votre ordinateur, mais également sur un smartphone ou une tablette. Un câble USB-C vers USB-A (prise USB classique) est fourni. Une carte mémoire MicroSD Samsung EVO Plus de 64 Go vous est également offerte.

 


> Voir l'offre

Sujets relatifs
insérer un retour ligne dans une formule excel
Trier une ligne sur deux dans Excel 2003
Sélectionner une ligne sur deux
nb de liens dans une plage appartennant à la même ligne Horiz. ou verti...
Figer colonne ou ligne dans excell
Garder valeur dans copie de formule
Selectionner valeur dans tableau (vba)
De-selectionner des lignes dans un groupe sous Excel
Excell 2007: erreur dans formule
formule pas visible dans la zone de saisie
Plus de sujets relatifs à sélectionner une ligne sur deux dans une formule
 > Tous les forums > Forum Bureautique