> Tous les forums > Forum Bureautique
 Fonction en VBA
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
GuySarthe
  Posté le 04/11/2008 @ 21:36 
Aller en bas de la page 
Petit astucien

Bonjour,

Sub Controle1()
[AO42:AS42].Select
Selection.Copy
[N42].Select
Selection.PasteSpecial Paste:=xlPasteFormats

Est-il possible de mettre ces fonctions en VBA dans cette macro.

=SI(N40=$BB$12;N40;"")

=SI(P40=$BD$12;P40;"")

=SI(R40=$BF$12;R40;"")


End Sub

Merci de votre aide

Publicité
Bérylion
 Posté le 04/11/2008 à 21:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Message original par GuySarthe

Bonjour,

Sub Controle1()
[AO42:AS42].Select
Selection.Copy
[N42].Select
Selection.PasteSpecial Paste:=xlPasteFormats

Est-il possible de mettre ces fonctions en VBA dans cette macro.

=SI(N40=$BB$12;N40;"")

=SI(P40=$BD$12;P40;"")

=SI(R40=$BF$12;R40;"")


End Sub

Merci de votre aide

où, quand, comment, avec qui, pourquoi faire, et si oui combien ???

tu veux faire quoi :

- insérer une formule dans une cellule par du code ?

- utiliser les valeurs des cellules pour conditionner la copie ?

faut détailler un poil, paske le fremen ( à toi,) y m'a pas rendu la boule de cristal...

on veut encore bien aider (sinon on serait pas la ), mais si y faut faire les questions en plus des réponses...

GuySarthe
 Posté le 04/11/2008 à 22:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Bérylion,

Je ne pensais pas que cela poserait question.

Je souhaiterais transformer ces trois fonctions en VBA pour pouvoiru tiliser les valeurs de ces cellules pour continuer la copie.



Modifié par GuySarthe le 04/11/2008 22:50
Mytå
 Posté le 04/11/2008 à 22:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut le forum

GuySarthe, essaye avec ceci

Sub Controle1()
[AO42:AS42].Copy
[N42].PasteSpecial Paste:=xlPasteFormats
Range("N42").FormulaR1C1 = "=IF(R[-2]C=R12C54,R[-2]C,"""")"
Range("P42").FormulaR1C1 = "=IF(R[-2]C=R12C56,R[-2]C,"""")"
Range("R42").FormulaR1C1 = "=IF(R[-2]C=R12C58,R[-2]C,"""")"
End Sub

ou cela

Sub Controle1()
[AO42:AS42].Copy
[N42].PasteSpecial Paste:=xlPasteFormats
Range("N42").Formula = "=IF(N40=$BB$12,N40,"""")" '=SI(N40=$BB$12;N40;"")
Range("P42").Formula = "=IF(P40=$BD$12,P40,"""")" '=SI(P40=$BD$12;P40;"")
Range("R42").Formula = "=IF(R40=$BF$12,R40,"""")" 'SI(R40=$BF$12;R40;"")
End Sub

Pour avoir le résulat des formules

Sub Controle1()
[AO42:AS42].Copy
[N42].PasteSpecial Paste:=xlPasteFormats
a = Evaluate("=IF(N40=$BB$12,N40,"""")") '=SI(N40=$BB$12;N40;"")
b = Evaluate("=IF(P40=$BD$12,P40,"""")") '=SI(P40=$BD$12;P40;"")
c = Evaluate("=IF(R40=$BF$12,R40,"""")") 'SI(R40=$BF$12;R40;"")
End Sub

Mytå



Modifié par Mytå le 04/11/2008 23:05
Bérylion
 Posté le 04/11/2008 à 22:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

GuySarthe a écrit :

Bonjour Bérylion,

Je ne pensais pas que cela poserait question.

Je souhaiterais transformer ces trois fonctions en VBA pour pouvoiru tiliser les valeurs de ces cellules pour continuer la copie.

re-

j'ai toujours pas compris...

y manque quelque chose dans ta question !

tu veux les coller où, tes formules ??

GuySarthe
 Posté le 04/11/2008 à 23:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Dans la macro

Sub Controle1()
[AO42:AS42].Select
Selection.Copy
[N42].Select
Selection.PasteSpecial Paste:=xlPasteFormats

ici

End Sub

Mytå
 Posté le 04/11/2008 à 23:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re le forum

GuySarthe, remonte un peu je t'ai fourni 3 solutions.

Je n'ai pas mis l'écriture en blanc, sur fond blanc pourtant

En plus j'aimais pas les .Select

Mytå



Modifié par Mytå le 04/11/2008 23:13
GuySarthe
 Posté le 04/11/2008 à 23:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

fth
 Posté le 05/11/2008 à 00:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Guy...c'est vrai qu'en ce moment la température dégringole, que les temps sont durs (les taons également, surpris par l'eau glaciale de l'étang) et que pour des soucis d'économie on met des moufles pour pouvoir baisser le chauffage ce qui ne rend pas la saisie au clavier très aisée...mais...ne fusse qu'avec 2...soyons fous...3 mots, il serait respectueux, selon les règles de bienséance, de répondre à Myta en lui expliquant le pourquoi du comment ce qu'il te propose ne te convient pas.

Publicité
Mytå
 Posté le 05/11/2008 à 01:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

salut le forum

Deux solutions

Juste des formules, ou juste des macros.

Je crois que ton MasterMind sera plus souple d'utilisation.

Je passe la main, n'ayant pas eu de retour à mes solutions....

A vous relire

Mytå

Mytå
 Posté le 06/11/2008 à 00:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re le forum

Guy, ne le prends pas si mal quand même.

De plus, ton fichier je ne suis pas capable de le télécharger.

Internet Explorer ne peut pas afficher cette page Web

A te relire

Mytå



Modifié par Mytå le 06/11/2008 00:44
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Fonction RANG
Comment choisir la "fonction" de mes mails ?
EXCEL: Fonction DATEDIF
VBA Excel valeur en fonction de cellules
Fonction Si ou Macro ?
tarif en fonction de la date
Compteur d'impression en fonction destinataire
afficher une cellule en fonction d'une autre cellule
fonction SI avec trois critères - cellule en format [h]mm
Somme en fonction du N° de semaine
[Excel 2007] Fonction NB.SI - problème
Plus de sujets relatifs à Fonction en VBA
 > Tous les forums > Forum Bureautique