> Tous les forums > Forum Bureautique
 formule excel 2007Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
ninda
  Posté le 20/04/2011 @ 11:21 
Aller en bas de la page 
Nouvel astucien

Bonjour,

j'ai une petit soucis avec une formule excel :

Le sujet est un dépanneur gagne entre 18 h et 22 h, 50 euros au prorata par heure pour le dépannage et 100 euros au prorata pas heure entre 22 h et 6 h du matin :

a b c d e f

Nom dépanneur heure debut heure fin 18 h 22 h 22 h 6 h total 21 0 30 1 2,3 280 18 22 4 200

En fait j'ai une formule suivante =SI(D2<=4;D2*50)+SI(E2<=8;E2*100) qui marche super

Je voudrais une formule qui marche avec mes colonnes b et c pour pouvoir supprimer les colonnes d et e mais j'arrive pas a trouver une formule qui marche

merci de votre aide

Publicité
ninda
 Posté le 20/04/2011 à 11:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

a b c d e f

Nom dépanneur heure debut heure fin 18 h 22 h 22 h 6 h total

21 0 30 1 2,3 280

pardon j'ai raté le tableau

qmike549
 Posté le 20/04/2011 à 12:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

Pour une meilleur compréhension de ton problème

essais de poster un exemple de fichier sur :

http://www.cijoint.fr/

ninda
 Posté le 20/04/2011 à 14:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien
ferrand
 Posté le 20/04/2011 à 15:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Si les heures saisies de début et de fin sont au format horaire d'Excel.

En considérant que la "journée" de travail débute à 06:00 pour se terminer à 06:00 le lendemain (nb: la plage 06:00-18:00 étant neutralisée, on considèrera que le début est postérieur à 06:00 [pour éviter qu'en notant début=06:00 et fin=06:00, on ne prenne en compte un écart de 24 h qui validerait la totalité de la plage tarifée]).

En ce qui concerne la première plage tarifée (18:00 - 22:00), les valeurs tant de B2 que de C2 doivent être ramenée à cette plage, soit : si >06:00 ET <18:00 => 18:00 ; si >22:00 OU <=06:00 => 22:00 ; [leur valeur si >=18:00 et <=22:00]. Si C2>B2, on applique le tarif à (C2-B2)*24 [les heures étant au format horaire].

Pour la deuxième plage tarifée (22:00 - 06:00), les valeurs doivent aussi être ramenée dans la plage, soit : si >06:00 ET <22:00 => 22:00 ; si <=06:00 => la valeur + 1 (+24 heures, puisqu'on sera le lendemain) ; la valeur si >=22:00. Si C2>B2, on applique le tarif à (C2-B2)*24 (comme pour l'autre plage).

Ces considérations devraient aboutir à la formule suivante (si je n'ai rien loupé) :

=SI(SI(OU(C2>22/24;C2<=6/24);22/24;SI(ET(C2<18/24;C2>6/24);18/24;C2))>SI(OU(B2>22/24;B2<=6/24);22/24;SI(ET(B2<18/24;B2>6/24);18/24;B2));SI(OU(C2>22/24;C2<=6/24);22/24;SI(ET(C2<18/24;C2>6/24);18/24;C2))-SI(OU(B2>22/24;B2<=6/24);22/24;SI(ET(B2<18/24;B2>6/24);18/24;B2));0)*24*50+SI(SI(ET(C2>6/24;C2<22/24);22/24;SI(C2<=6/24;C2+1;C2))>SI(ET(B2>6/24;B2<22/24);22/24;SI(B2<=6/24;B2+1;B2));SI(ET(C2>6/24;C2<22/24);22/24;SI(C2<=6/24;C2+1;C2))-SI(ET(B2>6/24;B2<22/24);22/24;SI(B2<=6/24;B2+1;B2));0)*24*100

Bon courage

nb: La scinder offrant plus de visibilité, on pourrait mettre:

en D2: =SI(OU(C2>22/24;C2<=6/24);22/24;SI(ET(C2<18/24;C2>6/24);18/24;C2))-SI(OU(B2>22/24;B2<=6/24);22/24;SI(ET(B2<18/24;B2>6/24);18/24;B2))

en E2: =SI(ET(C2>6/24;C2<22/24);22/24;SI(C2<=6/24;C2+1;C2))-SI(ET(B2>6/24;B2<22/24);22/24;SI(B2<=6/24;B2+1;B2))

en F2: =SI(D2>0;D2*24*50;0)+SI(E2>0;E2*24*100;0)

ninda
 Posté le 20/04/2011 à 16:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

j'ai opté pour la formule scinder car je la comprends

merci beaucoup ferrand

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
58,99 €SSD WD Blue SN550 500 Go (NMVe M.2, 2400 Mo/s) à 58,99 €
Valable jusqu'au 12 Mai

Amazon fait une promotion sur le SSD WD Blue SN550 500 Go (NMVe M.2) qui passe à 58,99 € livré alors qu'on le trouve ailleurs à partir de 75 €. Ce SSD utilise une interface M.2 NVMe PCIe Gen3 x 4 pour une connexion simple et des performances exceptionnelles : jusqu’à 2 400 Mo/s en lecture séquentielle et jusqu’à 1 950 Mo/s en écriture séquentielle. Le SSD est doté de la technologie 3D TLC NAND haute densité offrant une endurance d’écriture durable et assorti d’une garantie de cinq ans. 


> Voir l'offre
169,99 €Ecouteurs intra-auriculaire sans-fil Sony WF-1000XM3 à réduction de bruit active à 169,99 €
Valable jusqu'au 10 Mai

Amazon fait une belle promotion sur les écouteurs intra-auriculaire sans-fil Sony WF-1000XM3 avec réduction de bruit active qui passent à 169,99 € livrés gratuitement alors qu'on les trouve ailleurs à plus de 220 €. Performants, confortables et modernes, les écouteurs True Wireless Sony WF-1000XM3 s'inviteront naturellement dans votre quotidien. Livrés avec un boîtier de charge/transport, ils bénéficieront d'une autonomie maximale de 24 heures tout en assurant une écoute de haute qualité grâce à la puce Bluetooth 5.0. Gérez facilement votre lecture avec les commandes tactiles sur l'oreillette, prenez des appels dans les meilleures conditions avec les deux microphones intégrés et discutez facilement sans avoir besoin de retirer vos écouteurs grâce à la fonction Quick Attention.


> Voir l'offre
249,99 €SSD externe portable USB 3.1 SanDisk Extreme 2 To à 249,99 €
Valable jusqu'au 11 Mai

Amazon fait une promotion sur le SSD externe portable USB 3.1 SanDisk Extreme 2 To qui passe à 249,99 € livré gratuitement alors qu'on le trouve à 300 € ailleurs. Le disque SSD SanDisk Extreme portable est plus de deux fois plus petit que la taille de votre smartphone et fournit jusqu'à 5 fois la vitesse d'un disque dur portable. Apprenez à travailler en quelques secondes, transférez de grandes bibliothèques de vidéos et de photos à des vitesses pouvant atteindre 550 Mo/s. Vous ne craindrez pas de l'emporter partout avec vous grâce à sa conception robuste et résistante avec un coeur de SSD résistant aux chocs. Le logiciel SanDisk inclu SecureAccess peut crypter vos fichiers personnels. Garantie 3 ans. Résiste à l'eau (IP55). Interface : USB 3.1 Type A et C.


> Voir l'offre

Sujets relatifs
Formule excel 2007
Formule Excel 2007
excel 2007 formule
formule excel 2007 ou autres
formule excel 2007
Excel 2007 formule somme dont 2 chiffres ds cellul
Créer une formule de calcul avec excel 2007
Formule pour un tableau excel 2007
HELP => Formule conditionnelle dans Excel 2007
Excel 2007 résultat formule dans une autre cellule
Plus de sujets relatifs à formule excel 2007
 > Tous les forums > Forum Bureautique