> Tous les forums > Forum Bureautique
 Faire reconnaitre des minutes Excel 2007Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
spring
  Posté le 04/05/2011 @ 19:55 
Aller en bas de la page 
Petite astucienne

Bonjour!

j'exporte des données d'une source données externe vers Excel 2007.

Ça donne:

:30 pour 30 secondes,

12:00 pour 12 minutes.

Mes données ne vont jamais au delà de 59 minutes

Bien sûr dans Excel c'est reconnu comme du texte... comment expliquer à Excel qu'il s'agit de durées sur lesquelles je veux calculer?

Spring



Modifié par spring le 04/05/2011 19:56
Publicité
papouclo
 Posté le 04/05/2011 à 22:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Excel 2007 (chez moi) considère bien l’entrée au clavier :30 comme du texte ; par contre, il considère l’entrée 12 :00 (ou même 12 :) comme la durée 12h00mn avec le formatage personnalisé hh :mm.

Pas gênant sauf pour entrer la durée 35mn qui lorsqu’on rentre 35 : affiche dans la cellule 11 :00 (et dans la barre de saisie 1/01/1900 11 :00 :00). Ce problème se règle en choisissant le formatage personnalisé [h] :mm.

Reste la question de :30 . S’il n’y a que quelques durées de ce genre, cela peut se régler en remplaçant « : » soit manuellement, soit avec la commande remplacer.

Si les entrées importées sont toutes dans une même colonne, on peut récupérer des données numériques dans une autre colonne (formatée [h] :mm) avec une formule :

Entrée en A1 ; formule en B1 =SI(ESTNUM(A1) ;A1 ;CNUM(0&A1))

Cordialement

ferrand
 Posté le 05/05/2011 à 01:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Hello !

Juste une petite adaptation pour avoir l'heure exacte : =SI(ESTNUM(A1);A1/60;CNUM(0&A1)/60)

Pour une conversion directe lors de l'importation, il faudrait savoir comment est organisée ta feuille.

rj390111
 Posté le 05/05/2011 à 07:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à tous,

Pour avoir le résultat en minutes secondes décimalisées

Ex : 12:45 = 12,75 ou :30 = 0,5

Utilisé la formule de ferrand autrement toujours en A2

=SI(ESTNUM(A1);A1*24;CNUM(0&A1)*24)

papouclo
 Posté le 05/05/2011 à 09:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut tout le monde,

1. Peu satisfait par une 1ère réponse trop rapide, j’allais proposer la modification déjà donnée par Ferrand qui a l’avantage de mettre dans les cellules les durées exactes.
Formatage : m :ss pour avoir les affichages 12 :00 et 0 :30
ou m "mn" ss "s" pour avoir les affichages 12mn 00s et 0mn 30s

2. 12 :00 est directement considéré comme une durée par Excel lorsqu’on entre manuellement la donnée mais il se peut que l’importation donne raison à Spring (12 :00 considéré comme texte).
L’ennui est que CNUM(0& A1) avec A1 contenant le texte 12 :00 (obtenu en entrant ="12 :00") renvoie l’erreur #VALEUR !.
Cela devrait des régler avec une formule prévoyant les trois cas (12 :00 durée, 12 :00 texte, :30)
=SI(ESTNUM(A1);A1/60;SI(GAUCHE(A1;1)=":";CNUM(0&A1)/60;CNUM(A1)/60))
En fait, cette 2ème formule suffit peut-être : =SI(GAUCHE(A1;1)=":";CNUM(0&A1)/60;CNUM(A1)/60)

Cordialement

ferrand
 Posté le 05/05/2011 à 19:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Impec !

La proposition de rj390111 peut être utile aussi, si l'on veut des valeurs décimales en minutes. On peut aussi les obtenir en heures ou en secondes...

Ne reste plus à spring qu'à préciser son propos...

spring
 Posté le 06/05/2011 à 17:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

héhé, Spring a été réquisitionnée ailleurs, désolée pour le délai de réponse!

Merci à tous les 3, vos réponses sont super !

Papouclo, ta formule=SI(GAUCHE(A1;1)=":";CNUM(0&A1)/60;CNUM(A1)/60) est la plus aboutie pour mon problème...

Comme on me demandait on réponse urgente et que je ne connais pas CNUM (mais je vais corriger ça très vite), j'ai bricolé un truc avec une colonne intermédiaire:

En colonne B:

=SI(GAUCHE(A1;1)=":";CONCATENER("00:00";A1);SI(STXT(A1;2;1)=":";CONCATENER("00:0";A1);CONCATENER("00:";A1)))

En colonne C:

=TEMPS(0;STXT(B1;4;2);DROITE(B1;2))

Bref, pourquoi faire simple quand on peut faire compliqué, pas vrai?

Je vais de ce pas corriger mon fichier avec vos solutions...

Encore merci!

Spring

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
140,71 €Kit de 32 Go (2x16Go) de mémoire DDR4 Corsair Vengeance RGB Pro 3200 MHz à 140,71 € livré
Valable jusqu'au 25 Septembre

Amazon Allemagne fait une promotion sur le kit de 32 Go (2x16  Go) de mémoire DDR4 Corsair Vengeance RGB Pro 3200 MT/s CL16 qui passe à 135,98 € (avec la TVA ajustée) grâce à un coupon de réduction automatiquement appliqué au panier. Comptez 4,73 € pour la livraison en France soit un total de 140,71 € livré. Vous pourrez personnaliser la palette de couleurs directement depuis le logiciel Corsair iCU. On le trouve ailleurs à partir de 165 €.


> Voir l'offre
229,00 €Smartphone Poco X3 Pro (6,67 pouces 120 Hz, Snapdragon 860, 6 Go/ 256 Go) à 229 €
Valable jusqu'au 25 Septembre

Amazon fait une belle promotion sur le tout récent smartphone Poco X3 Pro qui passe à 229 € au lieu de 299 €. Il est équipé du tout dernier processeur Qualcomm Snapdragon 860 (8 coeurs), de 6 Go de RAM, de 256 Go de stockage et d’un écran de 6,67 pouces ultra fluide 120 Hz.

Il comprend aussi une Quad-Caméra de 48 MP avec IA et une caméra selfie poinçonnée de 20 MP. Il comprend une grande batterie de 5160 mAh, pour une utilisation sur plusieurs jours (supporte la charge rapide de 33W). Le POCO X3 Pro dispose également d'un capteur d’empreinte digitale sur le côté et une prise jack 3,5 mm pour vous permettre de brancher vos haut-parleurs ou vos écouteurs filaires.

Avec GPS, NFC, Bluetooth 5, WiFi, USB C. Le tout tourne sous Android 10.

Notez qu'il a été élu meilleur smartphone à moins de 300 € par le magazine UFC Que Choisir.


> Voir l'offre
50 € | 130 €Carte cadeau bonifiée Fnac / Darty de 60 € pour 50 €, 150 € pour 130 €
Valable jusqu'au 25 Septembre

La FNAC propose de nouveau la carte cadeau Fnac / Darty d'une valeur de 60 € à 50 € seulement. Cette e-Carte Cadeau Fnac-Darty est utilisable jusqu'au 31 Octobre 2021 au plus tard, s'utilise en une ou plusieurs fois dans les magasins Fnac, Darty, les agences Fnac Voyages, sur fnac.com (hors voyages, abonnements presse, tirages photo et Marketplace). Une carte de 150 € pour 130 € est également disponible. Maximum 2 cartes de 150 € et 2 cartes de 60 € par compte.


> Voir l'offre

Sujets relatifs
menu contextuel excel 2007 ne fonctionne plus
Faire un tableau sur Excel avec des sauts de lignes
Excel 2007 Copier/Coller d’une feuille à l’autre Dans un même classeur.
EXCEL 2007-stdole32.tlb-WIN7 SP1x64
Formule excel 2007
Excel 2007, insertion ligne vierge en automatique
Récupération dates dans tableau excel 2007
mettre a jour liason feuille excel 2007
besoin d'une macro excel 2007
EXCEL 2007
Plus de sujets relatifs à Faire reconnaitre des minutes Excel 2007
 > Tous les forums > Forum Bureautique