> Tous les forums > Forum Bureautique
 B50211 Problème de guillemets avec Word 2007Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
PierreR
  Posté le 11/02/2015 @ 20:57 
Aller en bas de la page 
Petit astucien

Bonjsoiur,

Tout à coup soudainement et inopinément, dans Word 2007 (clavier Fr belge) la correction ”automatique des " en « et » ne se fait plus.

A la place, j'obtiens les guillemets anglo-saxons : ” exclusivement (et pas “ !).

Qui c'est qui peut m'aider, sachant que j'ai procédé en vain à la "réparation Office" au moyen du CD ?

Un grand merci d'avance.

PierreR



Modifié par PierreR le 11/02/2015 20:58
Publicité
cseguenot
 Posté le 11/02/2015 à 23:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Dans la fenêtre des paramètres de correction automatique de Word (Fichier \ Options \ Vérification, puis bouton "Options de correction automatique"), sous l'onglet "Lors de la frappe", la première case à cocher (celle qui permet précisément de remplacer les guillemets) est-elle bien cochée ?

Autre point : es-tu sûr que tu n'as pas changé la langue par défaut du clavier sans faire exprès ? (ça arrive lorsqu'on appuie sur MAJ + ALT). Tu peux vérifier dans Panneau de configuration\Horloge, langue et région\Langue...

PierreR
 Posté le 11/02/2015 à 23:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

@ cseguenot,

  1. Merci, oui, la première case à cocher (celle qui permet précisément de remplacer les guillemets) est bien cochée.
  2. Sous w8.1 je ne retrouve pas les options "Panneau de configuration\Horloge, langue et région\Langue".

  3. Mais j'ai supprimé toutes les langues hors "FR belge 'point' ".
  4. Résultat toujours pareil...

Merci en tout cas.

PS : J'ai rebouté, vérifié la case à cocher "remplacer les guillemets" : cochée.

J'ai décoché, ouvert Word, même résultat. Puis re-coché : aucun changement !

PR



Modifié par PierreR le 12/02/2015 00:10
Gabrilou
 Posté le 12/02/2015 à 08:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Essai plutôt de décocher Lors de la frappe

Puis aller dans Correction automatique

Cocher Correction en cours de frappe

Et

Remplacer " par » en n'oubliant pas de faire l'espace insécable (CTRL Shift Barre d'espace)

Après le premier " et avant le »

PierreR
 Posté le 12/02/2015 à 13:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

gabrilou :

Essaie plutôt de décocher Lors de la frappe

Puis aller dans Correction automatique

Cocher Correction en cours de frappe

Et

Remplacer " par » en n'oubliant pas de faire l'espace insécable (CTRL Shift Barre d'espace)

Après le premier " et avant le »

En ce cas, je remplace nécessairement la 1ère correction de " en « (alt-0171) par la seconde » (alt-0187) !

La correction que tu suggères ne permet pas de faire la distinction entre le 1er et le deuxième ".

Merci quand même.

PierreR

Gabrilou
 Posté le 12/02/2015 à 14:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Gabrilou a écrit :

Et

Remplacer " par » en n'oubliant pas de faire l'espace insécable (CTRL Shift Barre d'espace)

Après le premier " et avant le »

Je me suis un peu trompée dans mes explications.

Ce que je voulais dire :

Tu remplaces le premier " par Alt 0171 suivi de Alt 0186

et le deuxième " par Alt 0186 suivi de Alt 0187

Est-ce que c'est mieux ?

PierreR
 Posté le 12/02/2015 à 14:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ce que je voulais dire :

Tu remplaces le premier " par Alt 0171 suivi de Alt 0186

et le deuxième " par Alt 0186 suivi de Alt 0187

Est-ce que c'est mieux ?

est-ce dans "correction en cours de frappe" que je dois faire ces remplacements ?

Alors on tourne en rond.

Ce que veux récupérer, c'est le remplacement automatique du 1er " par « et le second par ».

Par ailleurs, alt-0186 donne º ...

Merci quand même.

Gabrilou
 Posté le 12/02/2015 à 15:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Je l'avais pourtant spécifié :

Edit : Tu remplaces évidement tes guillemets anglo-saxons par Alt 0171 et Alt 0187



Modifié par Gabrilou le 12/02/2015 16:09
PierreR
 Posté le 12/02/2015 à 17:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

@ Gabrilou,

C'est bien gentil, mais le 1er remplacement de " par alt-171 alt-186, -> «º (que vient faire ce º ?)

Et si je recrée une nouvelle correction du même " par alt-0186 alt-0187, -> º», la 1ère correction est remplacée par la seconde...

Merci de m'expliquer, à 69 piges (à Pâques) je suis devenu dur de comperdichure.

PierreR

PierreR
 Posté le 12/02/2015 à 17:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je ne sais pas comment j'ai fait mais le problème est résolu.

Merci quand même Gabrilou pour le temps passé à me répondre.

Je suis passé par les Paramètres de langues et ai supprimé toutes celles sauf le « français (belge point). »

ll me reste à restaurer les autres langues (néerlandais, allemand, grec, arabe, anglais (US) et anglais UK...)

Note : Pour écrire sur ailleurs que dans Office 2007, j'utilise Clavier+ : «ctrl <» -> « et «ctrl-maj >» -> »

PierreR

Gabrilou
 Posté le 12/02/2015 à 17:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

On a de la misère à se comprendre,

Tu remplaces tes guillemets anglais par des guillemets français.

Pour le Alt 0186, il s'agit d'une espace insécable. Tu es libre de l'utiliser où pas.

Je te colle la définition de Wikipédia :

------

Une espace insécable est un caractère typographique consistant en une espace que l’on intercale entre deux mots (ou un mot et une ponctuation)
qui ne doivent pas être séparés par un éventuel retour à la ligne automatique. L’espace insécable permet d’éviter qu’un mot ou une ponctuation soit
rejeté et isolé en début de ligne lorsque cela nuirait à la fluidité de la lecture.

Le code typographique français recommande, contrairement à d’autres langues telles que l’anglais, une espace insécable[1] devant les signes de
ponctuation doubles (point-virgule, point d’interrogation, point d’exclamation, deux-points), entre les guillemets et le texte qu’ils renferment,
ainsi que comme séparateur des groupes de caractères (séparateur de groupes de trois chiffres dans les nombres par tranches de mille pour la
partie entière et la partie décimale[2], séparateur sans valeur facilitant la lecture des numéros de téléphone[3] ou des numéros et codes d’identification, etc.).

Gabrilou
 Posté le 12/02/2015 à 17:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Ok, merci pour le suivi

Bonne fin de journée

PierreR
 Posté le 12/02/2015 à 17:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

C'est vrais que c'est difficile de se comprendre !

Je connais parfaitement les commandes ctrl-maj espace ->insécable et ctrl-maj tiret (= tiret soudé) mais alt-0186 -> º et non l'espace insécable...

Ensuite, le problème est revenu... avant même d'avoir réinstallé les autres langues...cela dépend du vent sans doute .

Quand à :

Tu remplaces tes guillemets anglais par des guillemets français.

Je n'en connais pas la procédure. Par ailleurs, jai autant besoin des guillemets français que des anglais (dans des citation incluses par ex.)

Merci Gabrilou.



Modifié par PierreR le 12/02/2015 17:48
PierreR
 Posté le 13/02/2015 à 20:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

@Gabrilou,

Le code ANSI pour l'espace insécable est alt-255...

Cordialement.

PierreR

Gabrilou
 Posté le 13/02/2015 à 22:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Merci Pierre, j'apprécie ton suivi. J'espère que tu as pu avancer pour résoudre tes récents problèmes de corrections automatiques.

Je suis sincèrement désolée de n'avoir pu t'aider davantage.

À bientôt peut-être...

PierreR
 Posté le 14/02/2015 à 00:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

C'est Clavier+ qui fou le brdl. incompréhensible car auparavant c'était totalement compatible avec µ$Office !

J'attends la réponse du concepteur..

Sinon, j'utiliserai systématiquement les raccourcis que j'ai créés sur Clavier+ :

ctrl< -> «

ctrl-maj-< -> »

Merci pour ton aide patiente et ton amabilité.

PierreR



Modifié par PierreR le 14/02/2015 00:17
m@rina
 Posté le 25/02/2015 à 03:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Bonjour,

Tu parles d'installation ou de désinstallation de langue, etc.

Tu as vu juste car cela dépend de la langue, mais pas du langue du clavier. Cela dépend de la langue de la vérification orthographique.

L'option des guillemets est un package linguistique. Si la langue sélectionnée pour la saisie est la langue anglaise, tu auras des guillemets anglais. Et ça ne touche pas que les guillemets. Essaie par exemple de choisir la langue espagnole, et tape un ? en début de phrase, tu verras qu'il se mettra automatiquement à l'envers.

Vérifier la langue choisie par défaut n'est pas suffisant. C'est dans le document qu'il faut faire la vérification, car un document peut être saisi en plusieurs langues. Donc, on sélectionne tout le texte, et on regarde la langue de correction sous l'onglet Révision, Langue => Définir la langue de vérification.

Le plus sûr moyen de ne plus avoir de problèmes de ce type lorsqu'on tape toujours ou dans la majorité des cas dans une langue (par exemple dans ton cas le français belge), consiste à modifier le style Normal et de lui affecter la langue en question et de cocher par défaut pour que ça s'enregistre dans le normal.dotm.

Et pour ceux qui font des documents bilingues, eh bien on peut créer un autre style avec une autre langue définie.

PierreR
 Posté le 27/02/2015 à 09:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

PierreR a écrit :

C'est Clavier+ qui fou le brdl. incompréhensible car auparavant c'était totalement compatible avec µ$Office !

J'attends la réponse du concepteur..

Sinon, j'utiliserai systématiquement les raccourcis que j'ai créés sur Clavier+ :

ctrl< -> «

ctrl-maj-< -> »

En fait j'ai oublié de marquer comme résolu, désolé :(

J'ai analysé le fichier clavier.ini.

Depuis l'installation de la màj de Clavier+, clavier.ini contenait une foultitude de commandes absconses avec parfois des commandes doublées avec d'autres définitions.

Merci m@rina et désolé du retard : débordé, ton message était enteré dans la noria des ‘non lus’...

Je mets en ‘résolu’.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
SOLDESLes soldes d'hiver 2022
Valable jusqu'au 08 Février

Les soldes commencent ce Mercredi 12 Janvier dans la plupart des départements Retrouvez ici la liste des pages dédiées à cet évènement chez les différents revendeurs high-tech afin de trouver la bonne affaire qui vous intéresse. Nous vous proposerons aussi les bons plans que nous aurons dénichés.


> Voir l'offre
91,17 €Webcam Logitech StreamCam à 91,17 €
Valable jusqu'au 20 Janvier

RueDuCommerce fait une promotion sur la Webcam Logitech StreamCam qui passe à 91,17 €. On la trouve ailleurs à partir de 130 €. 

La Logitech StreamCam diffuse et enregistre des vidéos saisissantes et réalistes avec des mouvements fluides et des détails nets en Full HD 1080p à 60 fps. De plus, elle offre la possibilité de passer instantanément en mode portrait afin de filmer en format 16:9. Offrant de nombreuses possibilités, elle est idéale pour filmer sur Twitch, Facebook ou encore Instagram.

Intégrant la reconnaissance faciale pilotée par l'IA, vous obtenez une mise au point et une exposition nettes, quelle que soit votre position. L'exposition automatique est réglée avec précision pour vous montrer sous un jour flatteur dans des conditions d'éclairage variées.


> Voir l'offre
1349,99 €Acer Predator (15,6 pouces IPS 144 Hz, Core i7, 16Go/512 Go, RTX 3070) à 1349,99 €
Valable jusqu'au 24 Janvier

Cdiscount fait une belle vente flash sur l'ordinateur portable Acer Predator PH315-53-785U qui passe à 1349,99 €. Ce portable dédié aux joueurs dispose d'un écran 15,6 pouces IPS FHD 1920 x 1080 IPS 144 Hz, d'un processeur Intel Core i7 10750H, de 16 Go de mémoire RAM, d'un SSD de 512 Go (+ emplacements M.2 et SATA libres) et surtout d'une carte graphique Nvidia GeForce RTX 3070 qui vous permettra de profiter de vos jeux de manière fluide en haute résolution. Le tout tourne sous Windows 10 que vous pourrez passer gratuitement à Windows 11.


> Voir l'offre

Sujets relatifs
Gros problème avec Word 2007
problème avec word 2007 sur windows xp
Problème avec Word illisible ..pour moi
fichier créé sur word 2007...illisible avec word 2002...
Probleme avec word
Probleme d'enregistrement avec excel 2007
Problème avec le modèle par défaut dans Word
Problème avec fichiers Word et Excel
Problème avec Outlook 2007
Comment centrer un texte avec Word 2007
Plus de sujets relatifs à B50211 Problème de guillemets avec Word 2007
 > Tous les forums > Forum Bureautique