> Tous les forums > Forum Bureautique
 formule de calcul excelSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
rudika
  Posté le 21/02/2019 @ 13:40 
Aller en bas de la page 
Petite astucienne

Bonjour les astuciens,

imaginons que j'aie 2 colonnes A et B

Je suis en ligne 2, en colonne A mes références commençant par REF.020 en colonne B le nom du produit.

Dès lors que en colonne B de ma ligne 3, je saisis des données, cela incrémente automatiquement en colonne A : REF.020.001

en ligne 4, je saisis des données, cela incrémente automatiquement en colonne A : REF.020.002

etc..

quelle est la formule ? =SI(C5<>"";$B$4&".001";"") ne fonctionne que pour la 1ère ligne. pas pour les suivantes.

Quelqu'un saurait-il m'aider ?

Merci

Cordialement.

Publicité
DjiDji59430
 Posté le 21/02/2019 à 16:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

En ligne 3

=SI(C3<>"";$B$4&"."&TEXTE(LIGNES($1:1);"000");"")


Crdlmt

Debrief
 Posté le 22/02/2019 à 08:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Dans ta formule =SI(C5<>"";$B$4&".001";"") je comprends pas trop ce qu'est ce $B$4 puisque tu es sensée y saisir des données.

De plus tu invoques la colonne C alors que tu dis saisir en colonne B.

...

En tous cas, si tu saisis en colonne B et que tu veux que la référence en colonne A évolue:

Selon ce que tu veux avoir en A2: REF.020 ou REF.020.000 ?

Si REF.020: Je proposerais en A2 =SI(LIGNE() = 2; "REF.020"; SI($B2 <> ""; $A$2 & "." & TEXTE(LIGNE()-2;"000"); "")) à étendre sur les cellules concernées suivantes de la colonne A.

Si REF.020.000: Je proposerais en A2 =SI($B2 <> ""; "REF.020." & TEXTE(LIGNE()-2;"000"); "") à étendre sur les cellules concernées suivantes de la colonne A.

Cordialement,
D.

Edit: ou si tu as du mal à étendre la formule:

Si REF.020: Je proposerais en A2 =SI(LIGNE() = 2; "REF.020"; SI(INDIRECT("$B" & LIGNE()) <> ""; $A$2 & "." & TEXTE(LIGNE()-2;"000"); "")) à placer sur les cellules concernées de la colonne A.

Si REF.020.000: Je proposerais en A2 =SI(INDIRECT("$B" & LIGNE()) <> ""; "REF.020." & TEXTE(LIGNE()-2;"000"); "") à placer sur les cellules concernées de la colonne A.



Modifié par Debrief le 22/02/2019 08:38
rudika
 Posté le 22/02/2019 à 09:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonjour DjiDji59430,

je n'ai qu'un mot à dire, magnifique. Et merci.

Puis-je abuser en vous demandant de bien vouloir m'expliquer cette partie de la formule : &TEXTE(LIGNES($1:1) ?Si je le comprends, je pourrai adapter pour d'autres besoins.

Cordialement.

rudika

&TEXTE(LIGNES($1:1)

DjiDji59430
 Posté le 22/02/2019 à 11:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re

Pour pouvoir incrémenter de 1, il faut une variable.

Ici on choisit lignes($1:1) qui vaut 1 au départ (nombre de lignes dans la plage $1:1)

quand on "descend' le $1 reste constant, mais le 1 passe au 2 on a donc ligne($1:2) qui vaut 2 (nombre de lignes dans la plage $1:2)

etc ....

ici on remplit une colonne

Si on avait voulu une ligne, on aurait pris pour incrémenter colonnes($a:a) qui vaut 1 pour les mêmes raisons que citées plus haut

Ça c'est pour lignes($1;1)

et TEXTE(LIGNES($1:1);"000") on formate le résultat de lignes() pour qu'il ait 3 chiffres d'où 001, 002,etc ...


Crdlmt



Modifié par DjiDji59430 le 22/02/2019 11:41
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
79,99 €Alimentation modulaire Corsair RM650 80+ Gold à 79,99 €
Valable jusqu'au 22 Septembre

Cdiscount propose actuellement l'alimentation modulaire Corsair RM650 à 79,99 €. Cette alimentation de 650W est certifiée 80+ Gold et est garantie 10 ans. Entièrement modulaire, vous pourrez brancher uniquement les câbles (fournis) dont vous avez besoin. On la trouve ailleurs à partir de 100 €. 


> Voir l'offre
44,99 €Nintendo Game & Watch The Legend of Zelda à 44,99 €
Valable jusqu'au 22 Septembre

Amazon propose en précommande la Game & watch The Legend of Zelda à 44,99 € livrée gratuitement. Avis aux nostalgiques : après avoir été vendue à plus de 43 millions d’exemplaires dans le monde, Game & Watch fait son grand retour ! Avec Game & Watch : The Legend of Zelda, profitez des grands classiques The Legend of Zelda, The Legend of Zela II : The Adventure of Link, et The Legend of Zelda : Link#146;s Awakening ainsi que d’une version spéciale du jeu Vermin. Ce nouvel appareil fait également office d’horloge avec 35 animations disponibles, pour tous les amoureux du rétro-gaming. 

La console sort le 12 novembre. Vous serez débité au moment de l'expédition.


> Voir l'offre
162,11 €SSD Interne M.2 NVMe PCIe 4.0 Samsung 980 PRO 1 To à 162,11 € livré
Valable jusqu'au 22 Septembre

Amazon Allemagne fait une promotion sur le SSD Interne M.2 NVMe PCIe 4.0 Samsung 980 PRO 1 To qui passe à 157,50 € (avec la TVA ajustée). Comptez 4,61 € pour la livraison en France, soit un total de 162,11 € livré en France. On le trouve ailleurs à partir de 190 €. Ce SSD offre des taux de transfert de 7000 Mo /s en lecture et 5100 Mo/s en écriture. Une excellente affaire.

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douane. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre

Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique