× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 Formule excelSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
cdr
  Posté le 16/05/2019 @ 15:34 
Aller en bas de la page 
Petit astucien

Bonjour,

j'ai besoin d'utiliser la fonction =RECHERCHEV(C$5;....) en remplaçant "C$5" par une fonction puisque la référence "C$5" est susceptible de changer.

J'aurais besoin que "C$5" deviennent "C$" & EQUIV("blabla";Plage;0).

"EQUIV("blabla";Plage;0)" renvoie la valeur "5" dans ce cas là.

Je ne sais pas comment rédiger la formule.

J'ai essayé "=RECHERCHEV("C$"&EQUIV("blabla";Plage;0);..." mais ça ne marche pas.

Merci de votre aide.

Très cordialement,

CDR

Publicité
poussebois
 Posté le 16/05/2019 à 15:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Assez de blabla . Si tu pouvais joindre un fichier exemple via www.cjoint.com, on comprendrait sûrement mieux

@ +

Debrief
 Posté le 17/05/2019 à 10:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour les Excel Sieurs,

Oui, c'est toujours plus facile à résoudre sur une base concrète et donc un exemple de fichier.

Cependant, peut-être que cdr trouvera la solution en utilisant =RECHERCHEV(INDIRECT("C$"&EQUIV("blabla";Plage;0));..." ou encore =RECHERCHEV(DECALER(C1;EQUIV("blabla";Plage;0) - 1; 0);...

Cette 2ème formulation (DECALER) étant moins explicite mais plus efficace car elle s'adapte aux insertions / suppressions de lignes / colonnes alors que ce qui est entre quottes dans l'INDIRECT est bien sûr invariable (*).

Cordialement,
D.

Edit: (*) Encore qu'il y ait moyen de se passer d'une chaine de caractères invariable dans INDIRECT pour désigner la colonne C: =RECHERCHEV(INDIRECT(GAUCHE(CELLULE("adresse";C1);3)&EQUIV("blabla";Plage;0));...

ou encore =RECHERCHEV(INDIRECT(ADRESSE(EQUIV("blabla";Plage;0);COLONNE(C1)));...

Finalement, la dernière formulation ci-dessus reste assez explicite tout en étant sensible aux insertions / suppressions dans la feuille.



Modifié par Debrief le 17/05/2019 14:29
cdr
 Posté le 20/05/2019 à 08:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

oui, je comprends le besoin d'avoir un fichier joint pour illustrer les propos.

Néanmoins, la réponse "Indirect" et "Decaler" fonctionne, merci :).

Bonne journée.

CDR

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
94,75 €SSD externe portable USB 3.1 SanDisk Extreme PRO 500 Go (1050 Mo/s) à 94,75 € livré
Valable jusqu'au 26 Septembre

Amazon Allemagne fait une promotion sur le SSD externe portable USB 3.1 SanDisk Extreme PRO 500 Go qui passe à 89,99 €. Comptez 4,76 € pour la livraison en France soit un total de 94,75 € livré alors qu'on trouve le SSD à 160 € ailleurs. Le disque SSD SanDisk Extreme Pro Portable 500 Go permet, grâce à sa connectique USB 3.1, des haute vitesse de transfert pouvant aller jusqu'à 1050 Mo/s grâce au disque NVMe qu'il contient. Sa coque robuste et certifiée IP55 (eau et poussière) protège vos données partout où vous allez. Vous ne craindrez pas de l'emporter partout avec vous grâce à sa conception robuste et résistante avec un coeur de SSD résistant aux chocs. Le logiciel SanDisk inclu SecureAccess peut crypter vos fichiers personnels. Garantie 3 ans. Interface : USB 3.1 Type A et C.

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douane. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre
25,99 €Chargeur panneau solaire RAVPower USB (21W, 2 ports USB, pliable, étanche) à 25,99 € via coupon
Valable jusqu'au 27 Septembre

Amazon fait une promotion sur le chargeur panneau solaire RAVPower 21W qui passe à 25,99 € via un coupon de réduction de 40% alors qu'on le trouve ailleurs à partir de 40 €. Ce panneau solaire est résistant et étanche, est équipé de 4 crochets pour l'accrocher partout et possède 2 ports USB capables d'atteindre 2,4 A chacun pour un total de 4,8 A. 2 câbles micro usb sont fournis. Pour profiter de l'offre, cochez la case Coupon : utiliser le coupon de réduction de 35%. Le prix passera à 25,99 €.


> Voir l'offre
213,29 €Disque dur externe Western Digital Elements Desktop USB 3.0 12 To à 213,29 € livré
Valable jusqu'au 24 Septembre

Amazon Allemagne propose actuellement le disque dur externe Western Digital Elements Desktop USB 3.0 12 To à 206,89 €. Comptez 6,40 € pour la livraison en France soit un total de 213,29 € livré. On le trouve ailleurs à partir de 260 €. Ce disque dur dispose d'un grande capacité de stockage (12 To) et d'une connectique USB 3.0 qui vous offrira des transferts rapides. Il est compatible USB 2.0. Une très bonne affaire. 

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douane. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre

Sujets relatifs
Excel formule
excel 2016 références circulaires dans une formule fait référence à sa prop
Formule excel
Formule Excel
formule de calcul excel
Formule pourcentage Excel
formule excel
formule excel
Comment copier une formule Excel sur une colonne
Comment modifier une formule dans un TCD excel ?
Plus de sujets relatifs à Formule excel
 > Tous les forums > Forum Bureautique