> Tous les forums > Forum Bureautique
 Formule excelSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
cdr
  Posté le 16/05/2019 @ 15:34 
Aller en bas de la page 
Petit astucien

Bonjour,

j'ai besoin d'utiliser la fonction =RECHERCHEV(C$5;....) en remplaçant "C$5" par une fonction puisque la référence "C$5" est susceptible de changer.

J'aurais besoin que "C$5" deviennent "C$" & EQUIV("blabla";Plage;0).

"EQUIV("blabla";Plage;0)" renvoie la valeur "5" dans ce cas là.

Je ne sais pas comment rédiger la formule.

J'ai essayé "=RECHERCHEV("C$"&EQUIV("blabla";Plage;0);..." mais ça ne marche pas.

Merci de votre aide.

Très cordialement,

CDR

Publicité
poussebois
 Posté le 16/05/2019 à 15:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Assez de blabla . Si tu pouvais joindre un fichier exemple via www.cjoint.com, on comprendrait sûrement mieux

@ +

Debrief
 Posté le 17/05/2019 à 10:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour les Excel Sieurs,

Oui, c'est toujours plus facile à résoudre sur une base concrète et donc un exemple de fichier.

Cependant, peut-être que cdr trouvera la solution en utilisant =RECHERCHEV(INDIRECT("C$"&EQUIV("blabla";Plage;0));..." ou encore =RECHERCHEV(DECALER(C1;EQUIV("blabla";Plage;0) - 1; 0);...

Cette 2ème formulation (DECALER) étant moins explicite mais plus efficace car elle s'adapte aux insertions / suppressions de lignes / colonnes alors que ce qui est entre quottes dans l'INDIRECT est bien sûr invariable (*).

Cordialement,
D.

Edit: (*) Encore qu'il y ait moyen de se passer d'une chaine de caractères invariable dans INDIRECT pour désigner la colonne C: =RECHERCHEV(INDIRECT(GAUCHE(CELLULE("adresse";C1);3)&EQUIV("blabla";Plage;0));...

ou encore =RECHERCHEV(INDIRECT(ADRESSE(EQUIV("blabla";Plage;0);COLONNE(C1)));...

Finalement, la dernière formulation ci-dessus reste assez explicite tout en étant sensible aux insertions / suppressions dans la feuille.



Modifié par Debrief le 17/05/2019 14:29
cdr
 Posté le 20/05/2019 à 08:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

oui, je comprends le besoin d'avoir un fichier joint pour illustrer les propos.

Néanmoins, la réponse "Indirect" et "Decaler" fonctionne, merci :).

Bonne journée.

CDR

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Excel formule
excel 2016 références circulaires dans une formule fait référence à sa prop
Formule excel
Formule Excel
formule de calcul excel
Formule pourcentage Excel
formule excel
formule excel
Comment copier une formule Excel sur une colonne
Comment modifier une formule dans un TCD excel ?
Plus de sujets relatifs à Formule excel
 > Tous les forums > Forum Bureautique