> Tous les forums > Forum Bureautique
 Combinaisons de variable sur Excel
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
juju2582
  Posté le 24/05/2019 @ 10:59 
Aller en bas de la page 
Nouvelle astucienne


Bonjour,

J'ai crée un test avec 8 questions et 2 réponses par questions (A ou B) et j'aimerais pouvoir generer toutes les combinaisons possibles sur Excel.

Pourriez vous m'aider ?

Y a t'il une formule que je peux rentrer ?

Merci d'avance !

[Configuration automatique à compléter]
Système inconnu
Chrome 73.0.3683.103

Publicité
poussebois
 Posté le 24/05/2019 à 11:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour et bienvenue sur PC Astuces ,

Un sujet similaire ici.

Il y a la solution, tu adaptes en fonction de ce que tu as et de ce que tu veux !

@ +



Modifié par poussebois le 24/05/2019 11:29
juju2582
 Posté le 24/05/2019 à 13:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

Merci,

Mais justement en repartant de cela je n'arrive pas à générer mes combinaisons ... je dois avoir un problème de formule !

poussebois
 Posté le 24/05/2019 à 14:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

,

Je regarde ça ce soir. Peux pas avant .

poussebois
 Posté le 25/05/2019 à 06:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Comme je te l'ai dit, la solution était donnée dans le lien précédent.

La voici en image ci-dessous : tu écris la formule entourée de rouge en C1 et tu recopies jusqu'en C16.

@ +

galopin01
 Posté le 25/05/2019 à 09:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Ça dépend comment on comprend la réponse...

S'il s'agit de générer toutes les combinaisons de réponses possibles (il y en a 256) la rponse est dans le fichier joint.

A+

poussebois
 Posté le 25/05/2019 à 10:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

@ galopin01 ,

Oui tout dépend de l'interprétation que l'on fait !

Si les 8 questions forment un tout, il y a 2^^8 = 256 combinaisons possibles.

Étant sur smartphone actuellement, je ne peux vérifier ta réponse, mais je te fais confiance .

@ +

Debrief
 Posté le 25/05/2019 à 10:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Je ne suis pas sûr du résultat que tu veux obtenir car tu n'es pas allé jusqu'à donner un exemple qui n'aurait pas été superflu.

Est-ce que "générer toutes les combinaisons possibles" c'est un liste du genre:

AAAAAAAA
AAAAAAAB
AAAAAABA
Etc... ?

Si c'est bien ça que tu veux alors pour 8 questions à 2 réponses tu as 2 puissance 8 = 512 possibilités.
Tu peux construire ton tableau Excel de cette manière.

Formule en B1 =SI(MOD(A1;256)<2^7;"A";"B")
Formule en C1 =SI(MOD(A1;128)<2^6;"A";"B")
Formule en D1 =SI(MOD(A1;64)<2^5;"A";"B")
...
Formule en I1 =SI(MOD(A1;2)<2^0;"A";"B")

A étendre sur les 511 lignes restantes !

Pour obtenir la même chose en une seule cellule, il suffit de faire la concaténation des formules: =SI(MOD(A1;256)<2^7;"A";"B") & SI(MOD(A1;128)<2^6;"A";"B") & SI(MOD(A1;64)<2^5;"A";"B") & ... & SI(MOD(A1;2)<2^0;"A";"B")

.../...

A noter que dans cet exemple la valeur en colonne A va de 0 à 511 pour être plus explicite mais peut être remplacée par LIGNE() - LIGNE(1ère formule). Ici on aurait donc pu la remplacer par LIGNE() - LIGNE(B$1).

Et si ce n'est pas ça que tu veux, précise ta question.

Cordialement,
D.

poussebois
 Posté le 25/05/2019 à 11:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

@ Debrief ,

2 puissance 8 = 256, désolé .

@ +

Publicité
Debrief
 Posté le 25/05/2019 à 16:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

En effet poussebois, tu as parfaitement raison, 2 puissance 8 = 256, je me suis un peu laissé emporter par mon élan

Donc notre amie aura moins d'efforts à faire car les formules sont à "étirer" sur les 255 lignes restantes (au lieu de 511).

Merci pour cette correction.

D.

Edit: On peut écrire les formules en utilisant soit des puissances de 2 (2^x) ou leurs équivalents valeurs. Au-dessus j'ai fait un mix dû aux essais empiriques à remplacer par les formules ci-dessous.

Le plus "portable" c'est d'utiliser les puissances de cette manière:

En B1: =SI(MOD(LIGNE() - LIGNE(B$1);2^8)<(2^8)*(1/2);"A";"B")
En C1: =SI(MOD(LIGNE() - LIGNE(B$1);2^7)<(2^7)*(1/2);"A";"B")
En D1: =SI(MOD(LIGNE() - LIGNE(B$1);2^6)<(2^6)*(1/2);"A";"B")
Etc...
En I1: =SI(MOD(LIGNE() - LIGNE(B$1);2^1)<(2^1)*(1/2);"A";"B")

Car si on avait 8 questions avec 3 réponses, donc 3 puissance 8 = 6561 possibilités, il faudrait écrire:

En B1: =SI(MOD(LIGNE()-LIGNE(B$1);3^8)<(3^8)*(1/3);"A";SI(MOD(LIGNE()-LIGNE(B$1);3^8)<(3^8)*(2/3);"B";"C"))
En C1: =SI(MOD(LIGNE()-LIGNE(B$1);3^7)<(3^7)*(1/3);"A";SI(MOD(LIGNE()-LIGNE(B$1);3^7)<(3^7)*(2/3);"B";"C"))
En D1: =SI(MOD(LIGNE()-LIGNE(B$1);3^6)<(3^6)*(1/3);"A";SI(MOD(LIGNE()-LIGNE(B$1);3^6)<(3^6)*(2/3);"B";"C"))
Etc...
En I1: =SI(MOD(LIGNE()-LIGNE(B$1);3^1)<(3^1)*(1/3);"A";SI(MOD(LIGNE()-LIGNE(B$1);3^1)<(3^1)*(2/3);"B";"C"))

Et étendre sur les 6560 lignes restantes.



Modifié par Debrief le 26/05/2019 15:47
juju2582
 Posté le 28/05/2019 à 21:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

Merci beaucoup à tous, j'ai réussi à faire mes 256 combinaisons avec votre aide !!!

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
137,70 €Disque dur externe USB 3.0 Seagate 8 To à 137,70 € livré
Valable jusqu'au 20 Février

Amazon Allemagne propose actuellement le disque dur Seagate Expansion Desktop Drive 8 To à 131,09 € (avec la TVA ajustée). Comptez 6,61 € pour la livraison en France soit un total de 137,70 € livré alors qu'on le trouve ailleurs à partir de 200 €. Le disque est non soudé et vous pourez le récupérer pour l'utiliser dans un ordinateur, un NAS, etc. Connexion USB 3.0.

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douanes. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre
129,99 €Kit de 32 Go (2 x 16 Go) de mémoire DDR4 Crucial Ballistix Sport LT 3000 MHz à 129,99 €
Valable jusqu'au 22 Février

Amazon fait une promotion sur le kit de 32 Go (2x16 Go) de mémoire DDR4 Crucial Ballistix Sport LT 3000 MT/s CL15 qui passe à 129,99 € livré gratuitement alors qu'on le trouve ailleurs à plus de 170 €.


> Voir l'offre
116,60 €SSD WD Blue SN550 1 To (NMVe M.2, 2400 Mo/s) à 116,60 €
Valable jusqu'au 24 Février

Amazon fait une promotion sur le SSD WD Blue SN550 500 Go (NMVe M.2) qui passe à 116,60 € livré alors qu'on le trouve ailleurs à partir de 155 €. Ce SSD utilise une interface M.2 NVMe PCIe Gen3 x 4 pour une connexion simple et des performances exceptionnelles : jusqu’à 2 400 Mo/s en lecture séquentielle et jusqu’à 1 950 Mo/s en écriture séquentielle. Le SSD est doté de la technologie 3D TLC NAND haute densité offrant une endurance d’écriture durable et assorti d’une garantie de cinq ans.


> Voir l'offre

Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique