> Tous les forums > Forum Bureautique
 Combinaisons de variable sur Excel
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
juju2582
  Posté le 24/05/2019 @ 10:59 
Aller en bas de la page 
Nouvelle astucienne


Bonjour,

J'ai crée un test avec 8 questions et 2 réponses par questions (A ou B) et j'aimerais pouvoir generer toutes les combinaisons possibles sur Excel.

Pourriez vous m'aider ?

Y a t'il une formule que je peux rentrer ?

Merci d'avance !

[Configuration automatique à compléter]
Système inconnu
Chrome 73.0.3683.103

Publicité
poussebois
 Posté le 24/05/2019 à 11:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour et bienvenue sur PC Astuces ,

Un sujet similaire ici.

Il y a la solution, tu adaptes en fonction de ce que tu as et de ce que tu veux !

@ +



Modifié par poussebois le 24/05/2019 11:29
juju2582
 Posté le 24/05/2019 à 13:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

Merci,

Mais justement en repartant de cela je n'arrive pas à générer mes combinaisons ... je dois avoir un problème de formule !

poussebois
 Posté le 24/05/2019 à 14:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

,

Je regarde ça ce soir. Peux pas avant .

poussebois
 Posté le 25/05/2019 à 06:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Comme je te l'ai dit, la solution était donnée dans le lien précédent.

La voici en image ci-dessous : tu écris la formule entourée de rouge en C1 et tu recopies jusqu'en C16.

@ +

galopin01
 Posté le 25/05/2019 à 09:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Ça dépend comment on comprend la réponse...

S'il s'agit de générer toutes les combinaisons de réponses possibles (il y en a 256) la rponse est dans le fichier joint.

A+

poussebois
 Posté le 25/05/2019 à 10:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

@ galopin01 ,

Oui tout dépend de l'interprétation que l'on fait !

Si les 8 questions forment un tout, il y a 2^^8 = 256 combinaisons possibles.

Étant sur smartphone actuellement, je ne peux vérifier ta réponse, mais je te fais confiance .

@ +

Debrief
 Posté le 25/05/2019 à 10:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Je ne suis pas sûr du résultat que tu veux obtenir car tu n'es pas allé jusqu'à donner un exemple qui n'aurait pas été superflu.

Est-ce que "générer toutes les combinaisons possibles" c'est un liste du genre:

AAAAAAAA
AAAAAAAB
AAAAAABA
Etc... ?

Si c'est bien ça que tu veux alors pour 8 questions à 2 réponses tu as 2 puissance 8 = 512 possibilités.
Tu peux construire ton tableau Excel de cette manière.

Formule en B1 =SI(MOD(A1;256)<2^7;"A";"B")
Formule en C1 =SI(MOD(A1;128)<2^6;"A";"B")
Formule en D1 =SI(MOD(A1;64)<2^5;"A";"B")
...
Formule en I1 =SI(MOD(A1;2)<2^0;"A";"B")

A étendre sur les 511 lignes restantes !

Pour obtenir la même chose en une seule cellule, il suffit de faire la concaténation des formules: =SI(MOD(A1;256)<2^7;"A";"B") & SI(MOD(A1;128)<2^6;"A";"B") & SI(MOD(A1;64)<2^5;"A";"B") & ... & SI(MOD(A1;2)<2^0;"A";"B")

.../...

A noter que dans cet exemple la valeur en colonne A va de 0 à 511 pour être plus explicite mais peut être remplacée par LIGNE() - LIGNE(1ère formule). Ici on aurait donc pu la remplacer par LIGNE() - LIGNE(B$1).

Et si ce n'est pas ça que tu veux, précise ta question.

Cordialement,
D.

poussebois
 Posté le 25/05/2019 à 11:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

@ Debrief ,

2 puissance 8 = 256, désolé .

@ +

Publicité
Debrief
 Posté le 25/05/2019 à 16:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

En effet poussebois, tu as parfaitement raison, 2 puissance 8 = 256, je me suis un peu laissé emporter par mon élan

Donc notre amie aura moins d'efforts à faire car les formules sont à "étirer" sur les 255 lignes restantes (au lieu de 511).

Merci pour cette correction.

D.

Edit: On peut écrire les formules en utilisant soit des puissances de 2 (2^x) ou leurs équivalents valeurs. Au-dessus j'ai fait un mix dû aux essais empiriques à remplacer par les formules ci-dessous.

Le plus "portable" c'est d'utiliser les puissances de cette manière:

En B1: =SI(MOD(LIGNE() - LIGNE(B$1);2^8)<(2^8)*(1/2);"A";"B")
En C1: =SI(MOD(LIGNE() - LIGNE(B$1);2^7)<(2^7)*(1/2);"A";"B")
En D1: =SI(MOD(LIGNE() - LIGNE(B$1);2^6)<(2^6)*(1/2);"A";"B")
Etc...
En I1: =SI(MOD(LIGNE() - LIGNE(B$1);2^1)<(2^1)*(1/2);"A";"B")

Car si on avait 8 questions avec 3 réponses, donc 3 puissance 8 = 6561 possibilités, il faudrait écrire:

En B1: =SI(MOD(LIGNE()-LIGNE(B$1);3^8)<(3^8)*(1/3);"A";SI(MOD(LIGNE()-LIGNE(B$1);3^8)<(3^8)*(2/3);"B";"C"))
En C1: =SI(MOD(LIGNE()-LIGNE(B$1);3^7)<(3^7)*(1/3);"A";SI(MOD(LIGNE()-LIGNE(B$1);3^7)<(3^7)*(2/3);"B";"C"))
En D1: =SI(MOD(LIGNE()-LIGNE(B$1);3^6)<(3^6)*(1/3);"A";SI(MOD(LIGNE()-LIGNE(B$1);3^6)<(3^6)*(2/3);"B";"C"))
Etc...
En I1: =SI(MOD(LIGNE()-LIGNE(B$1);3^1)<(3^1)*(1/3);"A";SI(MOD(LIGNE()-LIGNE(B$1);3^1)<(3^1)*(2/3);"B";"C"))

Et étendre sur les 6560 lignes restantes.



Modifié par Debrief le 26/05/2019 15:47
juju2582
 Posté le 28/05/2019 à 21:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

Merci beaucoup à tous, j'ai réussi à faire mes 256 combinaisons avec votre aide !!!

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
281,43 €Processeur AMD Ryzen 5 5600X à 281,43 € livré
Valable jusqu'au 24 Juillet

Amazon Allemagne fait une promotion sur le processeur AMD Ryzen 5 5600X qui passe à 276,30 € (avec la TVA ajustée). Comptez 5,17 € pour la livraison en France soit un total de 281,43 € livré alors qu'on le trouve ailleurs à partir de 360 €. Le processeur pour PC de bureau AMD Ryzen 5 5600X propose 6 coeurs natifs et 12 coeurs logiques pour un traitement multitâche agréablement fluide. Grâce à sa fréquence native élevée et à son mode Turbo Core ajustant la puissance en fonction des besoins, le CPU AMD Ryzen de nouvelle génération délivre des performances exceptionnelles dans tous les domaines : Jeux vidéo, multitâche intensif, édition vidéo, modélisation 3D et bien plus encore. Le cache L3 de 32 Mo permet en outre le traitement ultrarapide d'un grand nombre d'instructions grâce à des latences réduites. Fourni avec un système de refroidissement.

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douane.


> Voir l'offre
179,99 €Ecran PC incurvé 27 pouces Dell S2721HGF (FHD, 144 Hz) à 179,99 €
Valable jusqu'au 25 Juillet

Amazon fait une promotion sur l'écran PC incurvé 27 pouces Dell S2721HGF qui passe à 179,99 € au lieu de plus de 250 € ailleurs. L'écran à cadre fin dispose d'une dalle VA Full HD (1920x1080) à 144 Hz avec un rayon de courbure de 1500R. Il est compatible Freesync et Gsync et dispose de 2 prises HDMI et 1 prise DP. Son pied est réglable en hauteur.


> Voir l'offre
779,90 €Ultrabook HONOR MagicBook Pro 16.1 (Ryzen 5 4600H, 16Go, 512Go SSD) à 779,90 €
Valable jusqu'au 24 Juillet

Amazon fait une belle promotion sur l'ultrabook HONOR MagicBook Pro 16.1 qui passe à 779,90 € au lieu de 929 €. Cet ordinateur portable possède un écran 16.1 pouces Full HD IPS 100% sRGB, un processeur AMD Ryzen 5 4600H à 6 coeurs (avec chip graphique Vega 6), 16 Go de mémoire DDR4, un SSD 512 Go PCIe NVME, le WiFi5 / Bluetooth 5.0, un lecteur d'empreintes, une webcam, un clavier rétro éclairé, une batterie 56 Wh (jusqu'à 11h d'autonomie et recharge rapide) et ne pèse que 1,7 kg. Il fonctionne sous Windows 10. Une très bonne affaire pour une machine compacte et puissante.


> Voir l'offre

Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique