> Tous les forums > Forum Bureautique
 Valeur de cellule différente de l'affichage
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
cdr
  Posté le 02/07/2019 @ 16:06 
Aller en bas de la page 
Petit astucien

Bonjour,

j'ai des cellules dans lesquelles j'ai deux valeurs numériques possibles : 0.222 ou 0.444.

Je voudrais qu'une cellule qui contient 0.222 affiche "A" plutôt que la valeur 0.222.

Je voudrais qu'une cellule contenant 0.444 affiche "B" plutôt que sa valeur numérique.

C'est possible ?

Merci de votre aide.

Cordialement,

CDR

Publicité
poussebois
 Posté le 02/07/2019 à 16:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Les 0.222 et 0.444, c'est le résultat d'une opération (formule) ?

@ +

cdr
 Posté le 02/07/2019 à 21:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

non, ce sont des valeurs entrées directement.

Pas de formule derrière.

Merci.

CDR

pétard77
 Posté le 02/07/2019 à 22:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir

Sauf erreur de ma part, dans la même cellule ce n'est pas possible.

Sauf peut-être, à écrire une macro que je ne maîtrise absolument pas.

La prise manuelle de l'écriture (0.222 ou 0.444) effacera la formule du style : =SI(A1=0.222;"A";SI(A1=0.444;"B";"?????"))

poussebois
 Posté le 02/07/2019 à 23:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

,

Si les valeurs 0.222 et 0.444 sont rentrées manuellement, alors pourquoi ne pas écrire directement A et B ?

cdr
 Posté le 03/07/2019 à 08:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

merci pour vos réponses.

J'ai besoin qu'il y ait des valeurs numériques en arrières plan car je dois faire des moyennes.

Merci.

CDR

pétard77
 Posté le 03/07/2019 à 09:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour

"J'ai besoin qu'il y ait des valeurs numériques en arrières plan car je dois faire des moyennes"

Dans ce cas tu utilises deux colonnes.

Une première dans laquelle tu rentres tes données.

Une deuxième dans laquelle tu reprends la formule "=SI(A1=0.222;"A";SI(A1=0.444;"B";"?????"))".

De cette manière tu auras tes lettres et tu pourras effectuer tes moyennes.

poussebois
 Posté le 03/07/2019 à 09:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Ce que tu souhaiterais n'est pas possible. Une cellule ne peut contenir qu'une seule valeur : 0.222 ou A ou une formule dont elle affichera le résultat.

Une suggestion : tu gardes les valeurs numériques puisque tu en as besoin par ailleurs et tu mets une Mise en Forme Conditionnelle qui coloriera les cellules contenant 0.222 d'une certaine couleur et celles contenant 0.444 d'une autre couleur.

@ +

cdr
 Posté le 03/07/2019 à 11:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci, c'est clair

a plus,

CDR

Publicité
Debrief
 Posté le 03/07/2019 à 13:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Tu peux mettre A à la place de 0.222 et B à la place de 0.444 si tu en tiens compte dans une formule de SOMME, par exemple:

=SOMME(A1:A5)+SOMMEPROD((A1:A5="A")*0,222)+SOMMEPROD((A1:A5="B")*0,444)

ou

=SOMME(A1:A5)+NB.SI(A1:A5;"A")*0,222+NB.SI(A1:A5;"B")*0,444

Après selon ce que tu cherches à faire...

Cordialement,
D.

Edit: pour une simple moyenne, la somme peut être divisée par le NBVAL(A1:A5) ou le nombre de lignes LIGNES(A1:A5) du range sommé.

Sinon, il faut utiliser une formule matricielle du genre: {=MOYENNE(SI(A1:A5="A";0,222;SI(A1:A5="B";0,444;A1:A5)))} à adapter pour d'autres fonctions.



Modifié par Debrief le 03/07/2019 13:56
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Affichage cellule sur Google Sheets
CELLULE VIDE : CALCUL #VALEUR!
Affichage des jours dans cellule
Excel décalage cellule contenant une valeur donnée
Aditionner valeur de cellules en fonction de leur cellule adjacente
aficher un valeur dan un forme avec le forma personnaliser de cellule
alerte si valeur cellule est précisément -60
Rendre blanche une cellule en fonction de sa valeur
Macro pour saisir une valeur dans une plage de cellule
Ecrire dans cellule si une "valeur" est trouvée dans une autre cellule
Plus de sujets relatifs à Valeur de cellule différente de l''affichage
 > Tous les forums > Forum Bureautique