> Tous les forums > Forum Bureautique
 Extraire données d'un tableau Excel
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
madghis
  Posté le 08/08/2019 @ 18:05 
Aller en bas de la page 
Petit astucien

Bonjour

J'ai un tableau Excel qui me donne la température et l humidité plusieurs fois par jour

Je souhaiterais extraire la température et l humidité mini et maxi pour chaque journée

Avez vous une solution pour cela

Je joins le tableau pour que ce soit plus explicite

https://www.cjoint.com/c/IHiqeR6oKp0

Merci

Publicité
DjiDji59430
 Posté le 08/08/2019 à 19:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour à tous,

Ce n'est pas un tableau excel et je ne sais pas si ça marchera en odt

https://www.cjoint.com/c/IHirXt3BaFY


Crdlmt

Debrief
 Posté le 08/08/2019 à 22:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Hello guys,

La solution TCD est incontestablement la plus élégante. Dommage que je sois incapable de la reproduire .

Sinon en ajoutant une date en colonne D (pour simplifier les formules) -> =DATE(ANNEE(A2);MOIS(A2);JOUR(A2)),

et en bricolant des formules (ex. Max température) -> =SI(D2<>D1;MAX(INDIRECT("B"&LIGNE()&":B"&LIGNE()+SOMMEPROD((D$2:D$1002=D2)*1)-1));"")
ou encore-> =SI(D2<>D1;MAX(INDIRECT("B"&LIGNE()&":B"&LIGNE()+EQUIV(D2;D2:D$1002;1)-1));"")

on obtient aussi une base, ici avec un filtre sur les valeurs non vides pour concentrer les résultats par jour.

https://www.cjoint.com/c/IHiuIHD4e55

Cordialement,
D.

Edit: S'il fallait assouplir les formules pour s'adapter automatiquement au nombre de lignes du tableau initial, il faudrait:

- remplacer: SOMMEPROD((D$2:D$1002
- par : SOMMEPROD((D$2:INDIRECT("D$" & NBVAL($A:$A)-1) ...Le -1 étant dû à cette ligne contenant "Chart" en colonne A

Edit:Une formule ne faisant pas appel aux INDIRECT pourrait être -> =SI(D2<>D1;MAX(DECALER(B:B;LIGNE()-1;0;SOMMEPROD((D:D=D2)*1));1);"")
(Laisser la dernière ligne "Chart" vide de formules) ou encore -> =SI(D2<>D1;MAX(DECALER(B:B;LIGNE()-1;0;EQUIV(D2;D2:D$1048576;1);1));"")



Modifié par Debrief le 10/08/2019 10:38
madghis
 Posté le 09/08/2019 à 21:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

DjiDji59430 Le tableau que j ai inséré c était juste pour l exemple pour être sur d être bien compris, lorsque je saurai faire ce sera bien via un tableau Excel.

Debrief Merci beaucoup, je vais étudier TCD mais les formules que tu me donnent sont vraiment pas mal

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Excel - Filtrage données d'un tableau
Excel 2010 extraire des données
Publipostage données excel dans tableau word
Extraire des données d'un tableau
extraire données identiques excel
importer données d'un tableau xml dans excel
EXTRAIRE DES DONNEES DANS EXCEL
comment avoir les données du haut d'un tableau à double entrée sur chaque p
Excel - figer le cadre mais pas les données
VBA Excel Liste validation des données
Plus de sujets relatifs à Extraire données d''un tableau Excel
 > Tous les forums > Forum Bureautique