> Tous les forums > Forum Bureautique
 Ne pas prendre en compte dans une formule la cellule masquée
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
delta70
  Posté le 23/08/2019 @ 12:53 
Aller en bas de la page 
Petit astucien

Bonjour, à toutes et à tous
J’utilise une simple formule pour déterminer les numéros des pages
La cellule de départ est J51 elle n’est pas verrouillée c’est là que je saisi le n° de la première page les autres (en j202, j153, J204, J306) seront calculés par simple formule
Par exemple : en J306 c’est la formule « =J204+1 » et je veux que la formule en J306 change en fonction du masquage ou affichage de la cellule J204.
Si la cellule J204 n’est pas masquée la formule reste « =J204+1 » mais si J204 est masquée la formule change est sera « =J153+1 »
Merci de votre collaboration.



Modifié par delta70 le 23/08/2019 13:01
Publicité
Debrief
 Posté le 23/08/2019 à 19:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Ton affaire est un peu étrange.

La seule façon que je connaisse de tester si une cellule est masquée est d'utiliser la fonction SOUS.TOTAL(103; <Celllule>) à condition d'être sûr que <Cellule> contient une valeur ou une formule.

Si c'est le cas (ici si J204 contient une valeur ou une formule), tu peux utiliser une formule du type en J306 -> =SI(SOUS.TOTAL(103;J204)>0;J204+1;J153+1)
Ou par sécurité -> =SI(ESTVIDE(J204);"Impossible à déterminer";SI(SOUS.TOTAL(103;J204)>0;J204+1;J153+1))

Mais alors que se passe-t-il si J153 est elle aussi masquée ? Tu ne vas pas remonter toutes les cellules pour les tester !? Il faudra trouver une autre approche.
Si c'est le cas, dis-le et on peut trouver une solution plus simple et plus sûre (*).

Cordialement,
D.

(*) Edit: comme par exemple dédier une colonne X masquée ou hors zone d'impression, où, aux lignes des sauts de page, on place une info quelconque (ex.: "Saut de page") et qui permet de déterminer le n° de la page avec une formule du genre:
=SI(X52 <> "";J$51 + SOUS.TOTAL(103; X$52:X52);"") à étendre de J52 à J<dernière ligne>

Ou pour simplifier / clarifier, placer le n° de la 1ère page hors colonne J (ex. en Y1) et:
=SI(X1 <> "";$Y$1 + SOUS.TOTAL(103; X$1:X1);"") à étendre de J1 à J<dernière ligne>



Modifié par Debrief le 24/08/2019 12:59
delta70
 Posté le 24/08/2019 à 08:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour, Debrief

Merci bien

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
89,99 €Disque dur externe portable Seagate Expansion 4 To USB 3.0 à 89,99 €
Valable jusqu'au 23 Septembre

Boulanger fait une promotion sur le disque dur externe portable Seagate Expansion d'une capacité de 4 To qui passe à 89,99 € alors qu'on le trouve ailleurs à partir de 100 €. Ce disque dur externe portable au format 2,5 pouces dispose d'une interface USB 3.0 compatible USB 2.0. Une excellente affaire pour ce disque dur qui offre des débits de 115 Mo/s. Il n'est pas soudé et est donc démontable si vous souhaitez le réutiliser ailleurs (console, NAS, PC).


> Voir l'offre
89,99 €Clavier mécanique Corsair K60 RGB Pro à 89,99 €
Valable jusqu'au 23 Septembre

Amazon fait une promotion sur le clavier Corsair K60 RGB Pro qui passe à 89,99 € livré gratuitement au lieu de 129 €. Avec son design en aluminium, ce clavier offre une expérience de jeu agréable au quotidien. Il embarque notamment des switches Cherry Viola ainsi qu'un rétroéclairage RGB par touche.


> Voir l'offre
299,99 €Ecran PC 32 pouces incurvé Samsung G5 (WQHD, 144 Hz, 1 ms) à 299,99 €
Valable jusqu'au 23 Septembre

Boulanger fait une promotion sur l'écran PC Samsung 32 pouces incurvé LC32G53TQWUXEN à 299,99 € alors qu'on le trouve ailleurs à partir de 359 €. Cet écran incurvé de 32 pouces offre une définition WQHD de 2560x1440 pixels et est compatible FreeSync Premium avec un taux de réponse de 1 ms et un rafraichissement de 144 Hz.


> Voir l'offre

Sujets relatifs
Changer la formule quand la cellule est masquée
Changer de couleur une cellule avec une maccro
Changement couleur cellule excel / mise en forme conditionnelle / formule
Référence de cellule variable dans une formule Excel
Repérer une cellule "vide" qui contient une formule
Open Office - formule à mettre dans une cellule
Changer un mot dans une cellule
verrouiller ou déverrouiller une cellule avec la formule SI
[LibreOffice] Changer hauteur cellule tableau
Zoom à changer quand on ouvre word 2007
Plus de sujets relatifs à Ne pas prendre en compte dans une formule la cellule masquée
 > Tous les forums > Forum Bureautique