> Tous les forums > Forum Bureautique
 Dissocier une cellule heure en 2 résultats distincts
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Lionel.Lio
  Posté le 15/10/2019 @ 12:38 
Aller en bas de la page 
Nouvel astucien

Bonjour à tous, j'aimerais savoir s'il existe une formule pour dissocier une cellule "heure" quand celle-ci dépasse 25h, et obtenir le résultat dans 2 cellules distinctes.
Je m'explique...

si A3 (format heure []) est inférieur ou égal à 25h00 alors B3=25h00 et C3=00h00 sinon si A3 est supérieur à 25h00 alors B3=25h00 et C3 est égal à la différence. (Comme pour l'exemple de A4).

J'ai joint un petit exemple en tableur.



Merci beaucoup pour votre aide, cela me faciliterait énormément la vie :)

Publicité
Gabrilou
 Posté le 15/10/2019 à 15:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Tu n'as pas besoin de dissocier, il suffit de formater tes cellules de la colonne A qui contiennent des heures (format de cellule) (personnalisée) et dans type, tu tapes [hh:mm]

Tu peux ensuite faire tes calculs sans problème. À moins que je n'ai pas compris la question



Modifié par Gabrilou le 15/10/2019 15:12
Lionel.Lio
 Posté le 15/10/2019 à 15:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

J'ai déjà formaté mes cellules au format [hh:mm].

Ce que je souhaite c'est mettre le surplus d'heures (au delà de 25h) dans une autre colonne.

Exemple :

Si je fais 25:00 ou MOINS (A3<=25:00), je souhaite que ces 25:00 aillent dans B3 et vu qu'il n'y a pas d'heures supp alors C3=00:00

Si je fais au delà de 25:00, par exemple 26:30 (donc A4>25:00), je souhaite dissocier ces heures en 2 colonnes. Les 25:00 toujours dans B4 et les 01:30 de surplus dans C4

Mais comment séparer ces 26:30 en 25:00 d'un coté et 01:30 de l'autre.

J'espère m'être bien exprimé, c'est jamais trop évident de bien l'expliquer . Merci

Gabrilou
 Posté le 15/10/2019 à 16:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Dans une colonne = HEURE(A1)

Dans autre colonne =MINUTE(A1)

IL y a peut-être mieux....

Debrief
 Posté le 15/10/2019 à 20:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

J'aimerais savoir comment tu mets 25:00 en format hh:mm. Moi je n'y arrive pas car en format hh:mm, 25:00 me donne 01:00.

Quel et le format de ta cellule qui contient 25:00 ? [hh]:mm ? Ce n'est sûrement pas [hh:mm] qui est rejeté par Excel !

Ce calcul en heure est un casse-tête. Il faut transformer le format des cellules en nombre pour comprendre que c'est stocké en fraction de temps pour 1 jour (24h = 1, 25h = 1 + 1/24, etc...)

Il suffit donc de placer en B3 =SI(A3 <= (1 + 1/24) ; A3 ; (1 + 1/24))
. . . . . . . .et de placer en C3 =SI(A3 <= (1 + 1/24) ; 0 ; A3 - (1 + 1/24))

Cordialement,
D.



Modifié par Debrief le 15/10/2019 21:14
Lionel.Lio
 Posté le 15/10/2019 à 23:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Oui, le format est [hh]:mm, désolé j'ai décalé le crochet dans mon message plus haut.

Je vais tenter ta formule. Merci encore pour vos réponses, c'est gentil.

Bonne fin de soirée.

pétard77
 Posté le 15/10/2019 à 23:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir

Pour Excel 2002 SP3.

Mais je pense que pour les versions ultérieures c'est également OK.

Qui peut le plus peut le moins.

Dans un premier temps il te faut mettre les colonnes A,B,C au format :[h]:mm:ss. Ce qui te permettra de dépasser 24 heures en durée.

Tu devras donc rentrer les durées selon ce format "xx:xx:xx"

Si la durée ne comporte que des heures il suffit de taper : "25:" pour que le format entier s'affiche. Si tu as des minutes et des secondes il faudra tout rentrer.

Il te faut une cellule supplémentaire (B1 par ex.) dans laquelle tu indiques ton quota d'heures au format ""xx:xx:xx"

Dans B3 tu rentres : =SI(A3<B$1;A3;B$1)

Dans C3 tu rentres : =SI(A3>B$1;A3-B$1;0)

N'oublie pas le symbole "$" lorsqu'il le faut. Celui-ci te permettra de faire des glisser/coller vers le bas pour les colonnes B et C.

Pour vérification de mes écrits.

Bon calcul

Nota bene

Fais attention. On a vite fait de taper ";" au lieu de ":".



Modifié par pétard77 le 16/10/2019 00:24
pétard77
 Posté le 16/10/2019 à 00:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir

Encore moi.

Au lieu du format : "[h]:mm:ss" tu peux rentrer le format "[h]:mm". Ça fonctionne aussi.

Pour cela dans la cellule "type" il faut effacer ":ss".



Modifié par pétard77 le 16/10/2019 00:37
Lionel.Lio
 Posté le 16/10/2019 à 20:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Merci beaucoup pour vos conseils et réponses. Je vais mettre tout ça en pratique.

Bonne soirée à tous.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Ne pas prendre en compte dans une formule la cellule masquée
Mise en forme condittionnelle d'une cellule
Changement de couleur d'une ligne en fonction du texte d'une cellule
Insérer en automatique un mot prédéfini dans une cellule
Comment écrire dans un autre onglet en excel à partird'une cellule
Rendre blanche une cellule en fonction de sa valeur
afficher une cellule en fonction d'une autre cellule
interdire une valeur dans une cellule en fonction d'une autre cellu
récupérer contenu d'une cellule dans en-tête
Convertir une valeur en heure/minute/seconde
Plus de sujets relatifs à Dissocier une cellule heure en 2 résultats distincts
 > Tous les forums > Forum Bureautique