> Tous les forums > Forum Bureautique
 Fonction si pour cellules qui ne constituent pas une plage.Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
ormuzd
  Posté le 07/09/2021 @ 12:59 
Aller en bas de la page 
Petit astucien

Bonjour.

Je voudrai faire une somme de plusieurs nombres dans des cellules qui ne constituent pas une plage, dans la même feuille. Si c'est un plage pas de problème j'y arrive, mais avec des cellules éparses non.

Il faudrait que, si le total de ces cellules est supérieur à 0, faire le total, sinon ne rien inscrire (laisser la cellule résultat vide)

Je me demande si la fonction si, ou somme.si est appropriée ou s'il faut utiliser une autre fonction.

Merci pour vos réponses.

Cordialement.





[Configuration automatique à compléter]
Windows 10
Firefox 91.0

Publicité
poussebois
 Posté le 07/09/2021 à 13:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour ,

Je vais supposer que les cellules éparses à additionner soient B5, D7, F11 et C8 et que tu veuilles mettre le résultat en A1.

En A1, il faudra mettre la formule : =SI((B5+D7+F11+C8)>0; B5+D7+F11+C8;"")

Tu adaptes à ton tableau ...

@ +

ormuzd
 Posté le 07/09/2021 à 14:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci pour votre réponse.

J'ai appliqué cette formule que j'avais utilisée sans succès. Et pour cause. J'ai oublié de signaler que ces cellules sont elles-mêmes le résultat d'une formule.

Je viens donc de comprendre.

La formule contenue dans ces cellules est : =SI(ESTERREUR($F$222*N233/$N$243);"";($F$222*N233/$N$243)) suivant les coordonnées afférentes à chaque cellules.

Si une seule cellule ne contient pas de résultat apparent, j'obtiens dans la cellule résultat : #VALEUR!

Donc comment occulter ces formules pour ne considérer que ce qui est ou pas inscrit, est en faire la somme ?

Merci pour votre aide.

poussebois
 Posté le 07/09/2021 à 15:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

,

En ce cas, la formule devient : =SI(ESTERREUR(B5+D7+F11+C8);"?"; SI((B5+D7+F11+C8)>0; B5+D7+F11+C8;""))

J'ai mis un "?" en cas d'erreur, mais on peut mettre ce que l'on veut ...

DjiDji59430
 Posté le 07/09/2021 à 23:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour à tous,

Théoriquement, en comptabilité, rien n'existe pas, on met 0

=SI(ESTERREUR($F$222*N233/$N$243);0;($F$222*N233/$N$243))


Crdlmt

ormuzd
 Posté le 09/09/2021 à 16:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour.

Je n'ai pas réussi à résoudre complètement ce petit problème de formule. Toutefois vous m'avez fait progresser.

Je mets un lien sur le genre de fichier contenant le problème.

https://grau.freeboxos.fr:53546/share/pCp6Dul7fNAmuSEx/Factures%20eau.xlsx

Il s'agit donc, par exemple, de remplir les cellules de I11 à I21 avec des relevés de compteur d'eau. J'ai volontairement mis sur le côté les relevés de C et G. Soit 410 et 640.

De ce fait les cellules "montant à payer" K13 et K17 sont incomplètes et le récapitulatif des locataires par propriétaire "cellules K25 à K29" est donc incomplet et affiche #VALEURS.

C'est cette mention #VALEURS que je voudrai voir disparaître et remplacée par une cellule qui n'affiche rien.

Merci pour le temps que vous m'avez consacré. Cordialement.

DjiDji59430
 Posté le 09/09/2021 à 19:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour à tous,
T'as essayé ma formule ??

Non ?

C'est dommage

https://www.cjoint.com/c/KIjrZoYvcDY



Modifié par DjiDji59430 le 09/09/2021 19:51
ormuzd
 Posté le 09/09/2021 à 21:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir.

Oui, j'ai utilisé : =SI(ESTERREUR(K11+K14+K17);"incomplet"; SI((K11+K14+K17)>0; K11+K14+K17;"")) pour la cellule k25

=SI(ESTERREUR(K12+K13+K18);"incomplet"; SI((K12+K13+K18)>0; KK12+K13+K18;"")) pour la cellule K26

=SI(ESTERREUR(K15);"incomplet"; SI((K15)>0; K15;"")) pour la cellule K27

=SI(ESTERREUR(K16+K19+K21);"incomplet"; SI((K16+K19+K21)>0; K16+K19+K21;"")) pour la cellule K28

=SI(ESTERREUR(K20);"incomplet"; SI((K20)>0; K20;"")) pour la cellule k29

J'obtiens : cellule K25 incomplet (relevé G non fourni, A et G fournis)

cellule K26 incomplet (relevé C non fourni, Bet H fournis )

cellule K27 total de la seule celulle E founie.

cellule K28 total des cellules F, I, K relevés fournis.

cellule k29 relevé de J non fourni. Rien n'est affiché Il devrait y avoir affiché incomplet ?

cellule K30 le total de 2 valeurs est correct.

Je vais en rester là, toutefois je ne vois pas pourquoi rien n'est marqué dans la cellule K29 alors qu'il devrait y avoir noté incomplet. Encore merci pour votre aide. Lien vers une image externe

ormuzd
 Posté le 09/09/2021 à 21:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Image au cas ou le lien externe ne fonctionne pas.

DjiDji59430
 Posté le 10/09/2021 à 19:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ce n'est pas ma formule !

Il suffit de mettre 0 a la place de "" dans tes formules de la colonne K



Modifié par DjiDji59430 le 10/09/2021 19:53
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
22,88 €Lecteur/graveur de CD/DVD externe USB 3.0 slim à 22,88 €
Valable jusqu'au 23 Mai

Cdiscount fait une promotion sur le lecteur/graveur de CD/DVD externe USB 3.0 slim qui passe à 22,88 €. Ce graveur vous permettra de lire et graver les CD et DVD sur votre ordinateur qui ne dispose pas de lecteur optique (soit la plupart des portables du marché). Branchez-le simplement sur un port USB de votre PC portable grâce à son câble intégré.


> Voir l'offre
94,99 €Disque dur Seagate NAS Iron Wolf 4 To à 94,99 €
Valable jusqu'au 23 Mai

Cdiscount propose le disque dur Seagate IronWolf 4 To à 94,99 €. Ce disque dur 3.5 pouces SATA III est adapté aux NAS et ordinateurs qui fonctionnent 24h/24. On le trouve ailleurs à partir de 105 €. Disque CMR.


> Voir l'offre
34,99 €Intégrale Downtown Abbey édition prestige en Blu-ray à 34,99 €
Valable jusqu'au 23 Mai

Amazon fait une promotion sur l'intégrale Downtown Abbey édition prestige en Blu-ray à 34,99 € au lieu de 48,01 €. Elle contient les saisons 1 à 6 de la série ainsi que le film.


> Voir l'offre

Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique