> Tous les forums > Forum Les mains dans le cambouis
 Changement de carte-mere: probleme UEFI & MBRSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
µstucien
  Posté le 08/09/2018 @ 18:35 
Aller en bas de la page 
Nouvel astucien

Bonjour,

Première contribution de ma part. Merci d'avance à ceux qui donnent leur temps et savoir sans compter. J'ai regardé les fils qui touchent au même sujet, mais même si je suis impressionné par la qualité des réponses, je n'ai rien trouvé qui m'aide directement.

Cet examen contient deux questions indépendantes; vous pouvez les traiter dans l'ordre que vous souhaitez. Vos réponses seront jugées de manière arbitraire et quasi-aléatoire, le critère "ça marche" ayant le plus de poids. Les questions-réponses sont autorisées, du moment que vous ne me demandez pas une manip qui prend des heures.

Introduction: j'essaie de transférer mon disque système (SSD Kingston) d'une carte-mere vieillotte à une nouvelle. Le disque est en MBR avec Windows 10. Il fonctionne sans problème sur l'ancienne carte (Asus P5K, ne connaît pas UEFI).

Première question: Pourquoi la nouvelle carte-mère (Gigabyte H370) ne reconnaît-elle pas mon SSD comme bootable? J'ai mis les options suivantes dans le BIOS:

  • CSM: Activé (autre choix: désactivé)
  • "Windows Features": Windows 8/10 (autres choix: "Other"; "Windows 8/10 WHQL")
  • "Storage boot option": Legacy (autres choix: "UEFI"; "Do not launch"); cette option disparaît si je désactive CSM
  • "Other PCI devices": Legacy (autres choix: "UEFI"; "Do not launch"); cette option disparaît si je désactive CSM

Deuxième question: En fait le problème source est que j'essaie de passer d'une carte-mère qui ne reconnaît pas GPT à une qui semble ne pas reconnaître MBR, et cela sans rien perdre de mon installation et données Windows 10. Quelle serait la bonne démarche? Je ne vois qu'une option, mais peut-être que j'ai raté quelque chose.

  1. L'option conte de fée (voir première question): Il était une fois, je mets mon SSD sur la nouvelle carte mère en mode legacy. Ca boot (c'est là que la réalité refuse de se comporter en conte de fée). Je mets à jour les drivers. Je lance MBR2GPT. Je désactive CSM dans le BIOS (ce qui désactive les deux options suivantes). Et voila, je reboot en UEFI/GPT et je vis très longtemps et ai beaucoup d'enfants (là c'est moins sûr mais bon...).
  2. L'option BSOD (essayée, abandonnée): Je laisse mon SSD sur l'ancienne carte-mère, donc sans les drivers de la nouvelle carte-mère. Je lance MBR2GPT à partir de Windows 10 PE sur clé USB. Je change de carte-mère, et je laisse la nouvelle avec les options du BIOS par défaut. Elle reconnaît le SSD comme bootable, Windows se lance... et BSOD, et BSOD, et reBSOD, et lance Windows RE, qui BSOD, qui me remet dans le BIOS, qui me dit que je n'ai pas l'autorisation de charger certaines pages etc.
  3. L'option prise de tête (pas essayée): J'installe Windows 10 sur le SSD avec la nouvelle carte-mère en écrasant tout (donc en GPT). Puis, à partir d'une sauvegarde, je remplace à la main les dossiers Program Files, Program Files (x86), Users et certains sous-dossiers Windows (mais lesquels?), et le registry. J'essaie d'arriver à un truc vaguement bootable et je réinstalle Windows 10 en gardant mes donnéees. Je n'ose même pas essayer tellement ça me semble casse-gueule.
  4. L'option hasardeuse (pas essayée): Je fais une installation clean de Windows 10 en GPT avec la nouvelle carte-mère (BIOS normal). Je sauvegarde la partition WinRE. Je mets mon SSD avec le Windows 10 actuel (donc en MBR), sans booter. Je lance MBR2GPT. Je reboot. Je le laisse faire ses BSOD jusqu'à ce qu'il lance Windows RE. Et je laisse Windows RE faire son job. Mais à quoi va ressembler mon registry après ça? S'il est écrasé entièrement par Windows RE, je perds l'accès et la configuration de nombreux programmes. S'il ne l'est pas du tout, je ne pourrais peut-être pas rebooter sans BSOD.
  5. L'option patience et longueur de temps (pas essayée): J'achète sur eBay une carte et un processeur d'un âge intermédiaire, qui marche avec MBR et GPT, avec ou sans UEFI. J'essaie de faire tourner le SSD dans sa configuration MBR, de mettre à jour les drivers, de convertir le SSD en GPT, de mettre le BIOS sous UEFI. Si ca marche, je passe le SSD sur la nouvelle carte-mère. Je revends cette carte intermédiaire avec son processeur. Je pense que j'aurai une barbe blanche et fleurie avant d'avoir mon système en ordre de marche, donc je ne suis pas trop tenté.

Des idées, suggestions, icônes?



Modifié par µstucien le 08/09/2018 18:37
Publicité
Hyportatif
 Posté le 08/09/2018 à 19:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Un peu de Lecture ICI

Ta CM

Daneel Olivaw
 Posté le 08/09/2018 à 20:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

H370 c'est le chipset. Quel est le modèle exact de la carte mère ?

  • CSM: Activé (autre choix: désactivé)
  • "Windows Features": Windows 8/10 (autres choix: "Other"; "Windows 8/10 WHQL")
  • "Storage boot option": Legacy (autres choix: "UEFI"; "Do not launch"); cette option disparaît si je désactive CSM
  • "Other PCI devices": Legacy (autres choix: "UEFI"; "Do not launch"); cette option disparaît si je désactive CSM

Le 1 est bon.

Le 2 essaye WHQL.

Le 3 est bon

Le 4 Mets sur UEFI.

Difficile de donner des conseils sans connaitre la carte mère.

µstucien
 Posté le 08/09/2018 à 20:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Merci Daneel. Hyportatif a bien deviné, il s'agit en effet de la H370 Aorus gaming 3 WiFi .

J'ai essayé la configuration que tu me recommandes, sans plus de succès. Pour être sûr, je suis passé par les trois options possibles pour "Windows features".

Daneel Olivaw
 Posté le 08/09/2018 à 23:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Quel est le message d'erreur de la carte mère ? Disque non trouvé ? Secteur de boot pas trouvé ? Autre ?

Tu as bien mis SATA mode sur AHCI et pas autre chose ?

Le SSD est sur SATA 0 ?

Le câble sata es bon ?

Le SSD est bien vu dans le BIOS ?

Tu as changé d'autres options par défaut ?

As-tu essayé de presser F11 (ou 12) pour le menu de boot et de sélectionner le SSD ?

Je mettrai Storage boot option sur UEFI.



Modifié par Daneel Olivaw le 09/09/2018 00:05
µstucien
 Posté le 09/09/2018 à 00:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Tu as bien mis SATA mode sur AHCI et pas autre chose ?

Bingo!

Je n'ai changé que ça et ça marche!

Choisis l'icône qui te plait le plus:



Modifié par µstucien le 09/09/2018 00:23
Daneel Olivaw
 Posté le 09/09/2018 à 00:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

µstucien
 Posté le 09/09/2018 à 01:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

J'ai poussé la recherche un peu plus loin.

En fait, le mode SATA peut être mis en "Intel RST Premium With Intel Optane System Acceleration" plutôt qu'en mode AHCI. Ce mode rajoute le RAID sur le SATA interne... et fait planter le boot.

Quand je choisis l'option Intel RST, j'ai une nouvelle option qui s'affiche: "Use RST Legacy ROM", qui est désactivée par défaut. Quand elle est activée, le système boot sans problème; autrement non. C'est une autre manière de résoudre le problème. Mais je pense qu'il est important de la noter car c'est la seule qui permet l'utilisation du RAID pour les ports SATA... et c'est justement ce qu'il me faut (c'est pour ça que le mode RST était actif et pas le mode AHCI).

A noter que, en principe, selon Intel, le mode RST garde les ports SATA non-RAID en mode AHCI. Dans la pratique, ça n'a pas l'air d'être le cas, puisque le boot sur disque MBR est interrompu immédiatement. Je pense que c'est le bootstrap/bootloader qui ne fonctionne pas. Le BIOS liste le disque dans les options de boot. Mais quand je lance le boot, avant d'avoir le logo Windows 10 qui annonce le chargement, j'ai un message sur écran type DOS qui me dit de mettre un disque bootable. Ce pourrait être un problème de driver manquant. C'est déjà arrivé avec Windows 7... et AHCI justement:

https://support.microsoft.com/en-us/help/922976/error-message-occurs-after-you-change-the-sata-mode-of-the-boot-drive

Quand j'avais installé Windows 7, j'en avait ch... avec le RAID. Il avait fallu que je slipstream le driver dans l'installateur Windows pour m'en sortir. Je ne serais pas surpris que, 8 ans et 2 OS plus tard, Microsoft n'ait toujours pas résolu le problème.

Daneel Olivaw
 Posté le 09/09/2018 à 03:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Intel Optane n'est pas un mode RAID. C'est un cache de mémoire flash qui se monte sur le connecteur M.2 à la place du SSD NVME pour acélérer les HDD. Ce n'est pas utile sur un SSD. Et ça occupe le connecteur du NVME.

https://www.intel.fr/content/www/fr/fr/architecture-and-technology/optane-memory.html

Publicité
µstucien
 Posté le 09/09/2018 à 04:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

En effet, je n'en ai aucune utilité, n'ayant pas de mémoire M2. Mais c'est indissociable du RAID pour les disques SATA...

Je continue a mettre a jour les drivers et lire les docs.Gigabyte livre un DVD de drivers avec la carte-mère. Le manuel de Gigabyte dit d'installer ces drivers après l'OS. C'est incorrect, justement pour le driver Intel RST. Le README de ce driver, qui est très long, spécifie bien qu'il faut charger le driver dans Windows PE avant d'installer Windows. Je suis persuadé que ça aurait complètement résolu mon problème. A voir demain: pour ca il faut que je revienne a W7 sur mon ancienne carte-mère et que je recommence l'installation de W10. Ca ne sera que la troisième fois... Puisse mon expérience service a quelqu'un d'autre.

µstucien
 Posté le 10/09/2018 à 03:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Ca y est, mon système marche, sans que j'aie rien perdu, en mode UEFI, le disque est en GPT et avec le SATA en mode Intel RST. Les trois problèmes sont plus ou moins séparés. Voici la démarche, sans les tatonnements, recherches et copies intégrales du disque système aux points clés:

- Je suis revenu avec l'ancienne carte mère et l'ancien OS (Windows 7).

- J'ai dézippé l'ISO de W10, et mis les drivers Intel RST (isStorAC) dans boot.wim avec DISM. Une des clé du problème, c'est que l'upgrade vers Windows 10 n'installe dans le boot manager que les drivers dont il y a besoin au moment de l'installation. Or comme je ne peux pas installer avec les drivers de ma nouvelle carte mère (puisque Windows 7 ne marche pas avec les processuers 8eme génération), il faut forcer à la main l'installation du driver dans le boot manager. Mais, voir plus loin, ça n'est pas suffisant, autrement ça ne serait pas rigolo (Microsoft veut vraiment qu'on se torde de rire avec Windows).

- J'ai fait une upgrade à Windows 10 en gardant tous mes fichiers. A ce point, mon disque est toujours en MBR.

- J'ai changé la carte mère à la H370 Aorus, en mettant le BIOS en mode Legacy et les SATA en mode AHCI.

- J'ai rebooté sous Windows en rajoutant toute une floppée de drivers du DVD qui vient avec la carte mère, avec quelques reboot au milieu.

- J'ai rebooté de Windows PE sur une clé USB pour lancer MBR2GPT (qui se trouve sur le disque système). J'aurais pu faire ça de mon système normal, mais je ne voulais pas risquer des problèemes. A ce point je suis en GPT et complètement "UEFI-compliant"

- J'ai rebooté en mettant le BIOS en mode UEFI, mais en laissant le SATA sur AHCI.

- J'ai rebooté en Safe Mode, mais j'ai interrompu le process pour passer dans le BIOS et mettre le SATA en more RST, puis j'ai continué le boot. La raison est que le boot manager de Windows ne lance pas les drivers dont il n'a pas eu besoin les fois d'avant, mème si ces drivers sont présents dans le boot manager! Safe mode force la recherche et l'utilisation du bon driver. Voir ici: https://superuser.com/questions/416041/windows-wont-start-after-changing-sata-controller-mode-to-raid-in-bios-intel-x

- J'ai remis Windows en mode normal. Tout va bien.

Dans tout ça, le plus utile a été une clé USB qui boot directement sur Clonezilla!

Maintenant, je n'ai plus qu'a rattacher mes disques RAID... dont un qui a besoin d'être reconstruit.



Modifié par µstucien le 10/09/2018 03:36
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
17,99 €Clé USB Sandisk Ultra 64 Go à double connectique USB 3.1 Type A et C à 17,99 €
Valable jusqu'au 26 Février

Amazon fait une promotion sur la clé USB Sandisk Ultra 64 Go à double connectique USB 3.1 Type A et C qui passe à 17,99 € alors qu'on la trouve ailleurs à plus de 25 €. Cette clé USB  dispose d'un connecteur réversible USB Type C et d'un connecteur classique de type A. Grâce à elle, transférez en toute simplicité et rapidement (jusqu'à 150 Mo/s) vos fichiers entre vos smartphones, tablettes et ordinateurs. 


> Voir l'offre
32,99 €Imprimante multifonction HP DeskJet 2620 + Instant Ink 6 mois à 32,99 €
Valable jusqu'au 23 Février

Cdiscount propose actuellement l'imprimante multifonction HP DeskJet  2620 à 32,99 €. Cette imprimante 3 en 1 fait donc imprimante, photocopieur et scanner. Elle dispose d'un chargeur automatique de documents. Elle fonctionne avec 2 cartouches d'encre (une noire et une 3 couleurs). Avec l'imprimante, vous pouvez également bénéficier de 6 mois d'abonnement gratuit au service HP Instant Ink où vos cartouches sont automatiquement commandées par votre imprimante.  Afin de bénéficier du service vous devrez sélectionner un forfait parmi les quatre forfaits existants (15, 50, 100, 300 pages) en fonction de votre prévision de consommation. HP vous enverra ainsi gratuitement assez d'encre pour imprimer jusqu'à 300 pages / mois pendant 6 mois. Vous pouvez bien sûr résilier ce forfait à la fin des 6 mois (ou bien passer au forfait gratuit qui offre 15 pages / mois). Notez que ce service n'est pas obligatoire et que si vous ne souhaitez pas y souscrire, vous pouvez acheter vous même vos cartouches.


> Voir l'offre
329,90 €Ecran ultra large LG 34 pouces 34WL50S-B à 329,90 €
Valable jusqu'au 28 Février

Amazon propose actuellement l'écran 34 pouces LG 34WL50S-B à 329,90 € livré gratuitement alors qu'on le trouve à partir de 400 € ailleurs. Cet écran ultra large est au format 21/9, possède une dalle IPS et offre une résolution de 2560 x 1080 pixels. Avec lui, vous pourrez bénéficier d'une plus grande immersion dans les jeux et les films. Cet écran est compatible FreeSync.


> Voir l'offre

Sujets relatifs
problème démarrage XP après changement carte mère
probleme apres changement carte mere
Problème de ventilateur suit changement carte mère
problème après changement de carte mère
problème microphone suite changement carte mère
Problème de changement de carte mère
probleme avec changement de carte mere
Problème CPU après changement carte-mère
Problème d'écran après changement de carte mère
problème après changement de carte mère
Plus de sujets relatifs à Changement de carte-mere: probleme UEFI & MBR
 > Tous les forums > Forum Les mains dans le cambouis