> Tous les forums > Forum Les mains dans le cambouis
 Une question technique adaptateur PCIE vers SataSujet résolu
Ajouter un message à la discussion
Pages : 1 [2] ... Fin
Page 2 sur 2 [Fin]
baupierre
 Posté le 11/04/2021 à 16:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour, je comprends que la carte est bien en AHCI mais le problème c'est que le BIOS de la carte mère indique

on board sata mode native ide.

On en revient toujours au même il faudrait que ce soit indiqué on board sata mode AHCI dans le bios de la carte mère

or je n'ai pas accès à cette ligne. C'est un peu pour cela que j'ai compris le natif comme non modifiable

J'ai essayé de démarrer en mode sans échec puis de voir si on pouvait changer la ligne mais elle reste grisée donc rien à faire

Une dernière idée?

Daneel Olivaw
 Posté le 11/04/2021 à 16:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Y a-t-il au moins un disque SATA (HDD ou SSD) sur la carte mère ?

baupierre
 Posté le 11/04/2021 à 17:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Oui, comme je l'ai déjà dit j'ai 2 ports sata sur la carte mère l'un est utilisé par un SSD et l'autre un HDD

c'est la raison pour laquelle je souhaite brancher le lecteur de DVD sur un autre port sata via PCIE.

Est-ce que une carte comme celle ci

qui a un port IDE et 2 ports sata ne serait pas susceptible de fontionner sur un port PCIE en mode IDE?

baupierre
 Posté le 13/04/2021 à 15:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour, bon je pense que je vais arrêter là mes investigations n'ayant aucun moyen de passer en mode AHCI

Une dernière question qui me ramène au sujet que peut-on bien faire avec un port PCIE qui est nativement en mode IDE?

Avec une réponse à cette question je vais clore le sujet

Daneel Olivaw
 Posté le 13/04/2021 à 19:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Encore une fois, c'est l'interface SATA qui est en mode IDE et non le PCIe.

Essaye de mettre un mot de passe Administrateur au BIOS, et regarde si tu peux alors changer le mode en SATA AHCI.

Certaine carte mère exigent un mot de passe pour modifier certains paramètres BIOS.

fgondard
 Posté le 13/04/2021 à 19:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Une dernière question qui me ramène au sujet que peut-on bien faire avec un port PCIE qui est nativement en mode IDE?

Daneel t'a pourtant expliqué. Un port PCIe n'est ni IDE autre chose. Il est PCIE un point c'est tout. Après c'est la carte qu'on monte dessus qui a telle ou tellle propriété.

Si tu montes une carte ethernet sur un port PCIe, c'est elle qui sera en Fast ethernet ou en Gigabit. Le port PCIe n'y est pour rien.

le BIOS de la carte mère indique on board sata mode native ide.

Les ports SATA de ta carte mère sont en mode compatibilité IDE. Ton SSD est bridé puisqu'il travaille au débit de l'IDE : 133 Moctets/s max contre 300 pour le SATA 2. Il doit bien y avoir moyen dans le BIOS de mettre les ports SATA en mode AHCI. Tu te positionnes sur la rubrique et tu fais Entrée. Mais attention il faut d'abord activer le pilotes AHCI standard de Windows (voir ici).

Mais ça n'a rien à voir avec le fonctionnement de ta carte PCie. Toutefois si ton port PCIe est de la première génération les ports SATA de la carte seront eux aussi bridés à 250 Moctets/s. Pour un lecteur optique on s'en tamponne le coquillard.

baupierre
 Posté le 13/04/2021 à 20:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour à tous les 2 et merci d'être là.

OK c'est le port SATA qui est en mode IDE, je suppose que cela ne concerne que le port SATA de la carte PCIE et

non les 2 ports sata de la carte mère qui fonctionnent parfaitement bien.

Ceci étant je me serais volontiers contenté d'un débit d'une cinquantaine de Mo/s qui devrair suffire pour le lecteur alors que je suis autour de 1Mo/s et encore.

Je n'ai aucun problème en utisant un lecteur optique externe sur prise usb

Je ne suis pas très chaud pour mettre un mot de passe dans le BIOS de peur de ne pas savoir l'enlever.

Je suis donc allé voir dans le registre mais 1er problème je n'ai pas de service msahci, je n'ai que le service pciide

donc je suis bloqué. Peut-être que cela s'explique par le côté natif

Daneel Olivaw
 Posté le 13/04/2021 à 21:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Je ne suis pas très chaud pour mettre un mot de passe dans le BIOS de peur de ne pas savoir l'enlever.

Ce n'est pas compliqué. Tu donnes le mot de passe pour rentrer dans le BIOS et tu mets un mots de pass vide.

Je suis donc allé voir dans le registre mais 1er problème je n'ai pas de service msahci, je n'ai que le service pciide

Si c'est IDE dans le BIOS, tu auras beau ajouter, modifier, changer toutes les clés que tu voudras, ça restera en IDE.

Publicité
fgondard
 Posté le 13/04/2021 à 21:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

je suppose que cela ne concerne que le port SATA de la carte PCIE et non les 2 ports sata de la carte mère qui fonctionnent parfaitement bien.

NON ! "onboard" = "sur la carte mère". Le BIOS ignore tout de ta carte additionnelle et de ce à quoi elle sert, à part qu'elle est là. Combien de fois faudra-t-il le dire, ton SSD et ton disque fonctionnent à la vitesse de l'escargot.

un débit d'une cinquantaine de Mo/s qui devrair suffire pour le lecteur

La vitesse de lecture d'un lecteur de DVD 16X est de l'ordre d'une vingtaine de Moctets/s.

Je suis donc allé voir dans le registre mais 1er problème je n'ai pas de service msahci, je n'ai que le service pciide

Cette carte mère ne correspond pas à la description de ta configuration. Sous quel OS tourne-t-elle ? Si la machine qui lui correspond est bien un Aspire X1420 un BIOS peut-être plus récent que le tien est disposnible ici ainsi que les pilotes pour W7. Réinstaller le pilote du jeu de puces permettrait peut être de faire apparaître le contrôleur AHCI dans le gestionnaire de périphériques et dans le registre.

Je ne suis pas très chaud pour mettre un mot de passe dans le BIOS de peur de ne pas savoir l'enlever.

Pour l'enlever il suffit de se rappeler de celui qu'on a mis. Tu mets toto et tu l'écris quelque part.

baupierre
 Posté le 13/04/2021 à 21:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Re, cela m'apparait un peu compliqué en particulier la partie explicative droite

baupierre
 Posté le 13/04/2021 à 22:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Re, fgondard je n'ai pas l'impression que mon SSD et mon HDD soient particulièrement lents. A titre d'exemple mes sauvegardes sytèmes AOMEI sont sur mon HDD

lorsque je fais une restauration système cela prend un petit quart d'heure. Ce n'est peut-être pas très rapide mais tout à fait acceptable

Je suis sous windows 10 20H2

Si effectivement le mode ide concerne tous les ports sata alors la carte est inapropriée puisqu'elle est en AHCI

le PC est un emachine ACER EL1352 qui était initialement sous windows 7

fgondard
 Posté le 13/04/2021 à 22:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Si effectivement le mode ide concerne tous les ports sata alors la carte est inapropriée puisqu'elle est en AHCI

Encore une fois vis à vis de ta carte mère ta carte adidtionnelle est en PCIe. L'ordinateur se moque complètement que ce soit une carte contrôleur SATA, une carte étehernet ou un moulin à café et elle n'a rien à voir avec les ports SATA de ta carte mère.

je n'ai pas l'impression que mon SSD et mon HDD soient particulièrement lents.

Ton SSD est plus rapide que ton disque parce qu'il n'y a pas les temps mécaniques (déplacement du bras et rotation du disque) mais les vitesses de transferts sont celles de l'IDE pour l'un comme pourl'autre. Fais un test avec un produit comme CrystalDiskMark et tu seras fixé.

Daneel Olivaw
 Posté le 13/04/2021 à 23:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

En mode IDE, non seulement la vitesse est bridée (SSD ou HDD), mais le TRIM étant une fonction SATA AHCI, il ne passera pas, ce qui va encore plus brider la vitesse d'un SSD.



Modifié par Daneel Olivaw le 14/04/2021 06:10
baupierre
 Posté le 14/04/2021 à 08:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

je comprends tout à fait ce que vous me dites, mais ce que je ne comprends pas c'est pourquoi il y a près d'un facteur 100 en vitesse entre les Sata de la carte mère et le sata

de la carte PCIE

Daneel Olivaw
 Posté le 14/04/2021 à 10:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Parce que le SATA de la carte mère est bridé en mode IDE.

Mets un mot de passe admin. Ce n'est pas le Pérou !

fgondard
 Posté le 14/04/2021 à 10:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

On ne trouve pas grand chose sur la toile à propos de ce type d'ordinateur. Acer semble même ignorer cette série baptisée "e-machines". La seule documentation que l'on trouve est une notice générique.

Question bête, n'y a-t-il pas quelque part dans les menus de configuration du BIOS une option spécifique pour acticver l'AHCI ? Ceci pourrait expliquer pourquoi tu n'as pas la possibilité de choisir le mode AHCI pour les ports SATA.

Pour moi tu as deux problèmes distincts, le fonctionnement de tes ports SATA et le fonctionnement du contrôleur SATA de ta carte additionnelle. Si j'ai bien vu c'est un contrôleur Asmedia. J'ai toujours eu des problèmes de pilote avec ces puces. As-tu installé le dernier disposnible ?

Publicité
baupierre
 Posté le 14/04/2021 à 11:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

le driver a été d'abord installé automatiquement par windows 10 et je l'ai mis ensuite à jour avec tous les drivers.

Je n'ai rien vu de spécifique autre que la ligne en grisé non modifiable. Je vais laisser tomber, je ne mes sert que très peu du lecteur,

et c'était surtout pour ne pas le laisser débranché. C'était aussi pour moi une occasion d'apprendre et là j'ai appris des choses .

Je reste quand même un peu sur ma faim en me demandant qu'est ce qu'on j'aurais pu mettre sur ce port PCIE , qui accepte de fonctionner en mode IDE même si c'est significativement

moins performant que le mode AHCI.

Merci à vous deux je vais marquer résolu considérant que la carte mère n'est pas faite pour cela.

J'ai d'ailleurs de temps en temps un problème récurrent de BSOD avec ce PC que j'attribuerais à la carte graphique intégrée qui n'est pas/peu adaptée

aux derières versions de Windows 10. J'ouvrirai peu être un post à ce sujet. Il faut savoir que je destine ce PC à une résidence secondaire donc je n'en attends pas la lune.

fgondard
 Posté le 14/04/2021 à 12:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

qu'est ce qu'on j'aurais pu mettre sur ce port PCIE , qui accepte de fonctionner en mode IDE

Tu es têtu. Un port PCIe ne fonctionne pas en mode IDE ni en mode SATA mais en mode PCIe point final. Ce qu'il y a derrière il s'en moque complètement.

Ta carte additionnelle intègre un contrôleur SATA et un contrôleur IDE. Elle fonctionne mal puisque apparemment le débit est bien inférieur à ce qu'on paut attendre d'un port IDE. Mais tester avec un lecteur optique n'est pas forcément significatif.

Deux hypothèses :
- carte défectueuse (chinoiserie douteuse) ou pilote inadapté pour la puce Asmedia 106x) .
- port PCIe défectueux ou pilote inadapté (difficile de trouver un pilote Windows 10 spécifique à ce jeu de puces).

Dans le Gestonnaire de périphériques, développe la ligne "contrôleur de stockage" et mets une copie d'écran.

En lisant le fichier readme.txt accompagnant ce pilote on découvre des choses intéressantes, notamment qu'un script install.cmd doit être exécuté afin de pouvoir installer le pilote si l'on est en IDE. J'ai regardé dans mon propre pilote (09/21/2011,1.3.1.000) qui est pour la même puce mais je n'ai pas ce script. Je ne sais donc pas ce qu'il fait mais je le soupçonne d'ajouter les entrées manquantes dans le registre.



Modifié par fgondard le 14/04/2021 15:03
baupierre
 Posté le 14/04/2021 à 22:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Effectivement je m'exprime mal concernant la carte PCIE puisque c'est le mode sata qui est IDE ou AHCI je pense avoir compris.

Comme je l'avais expliqué précédemment je ne voulais pas faire le test avec le lcteur mais avec le 2ème HDD puisque c'estcela que je voulais rajouter.

et comme la vitesse de transfert était plusieurs dizaine de fois plus basse que celle d'une prise usb j'ai inversé le connecteur sata du lecteur avec celui du HDD

et donc le lecteur est devenu quasi inutilisable.

J'essayerai de mettre un mot de passe supervisor dans le BIOS mais comme je l'ai dit je me bas aussi avec des BSOD à gogo bsod qui sont apparus depuis 2004 et 20H0

là je viens de revenir à 1709 et je n'ai aucun problème de BSOD

Pages : 1 [2] ... Fin
Page 2 sur 2 [Fin]

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
274,10 €Lego Technic 42115 Lamborghini Sian FKP 37 à 274,10 € livré
Valable jusqu'au 14 Mai

Amazon Allemagne fait une promotion sur le Lego Technic 42115 Lamborghini Sian FKP 37 qui passe à 261,18 € (avec la TVA ajustée). Comptez 12,92 € pour la livraison en France soit un total de 274,10 € livré. On le trouve ailleurs à 350 €. 

Vous pouvez utiliser votre compte Amazon FR sur Amazon DE. Pas de douane.


> Voir l'offre
50,02 €SSD Crucial MX500 500 Go à 50,02 € livré
Valable jusqu'au 12 Mai

Amazon Allemagne propose actuellement le SSD Crucial MX500 500 Go à 45,37 €. Comptez 4,65 € pour la livraison en France soit un total de 50,02 € livré. On le trouve ailleurs à partir de 65 €. Ce SSD salué par la critique par son rapport qualité prix imbattable offre des débits de 560 Mo/s en lecture et 510 Mo/s en écriture. Il est garanti 3 ans.

Rappelons que vous pouvez utiliser votre compte Amazon France sur Amazon DE et qu'il n'y a pas de douane.


> Voir l'offre
163,94 €SSD Corsair Force MP600 1 To (NMVe M.2 Gen4, 4950/4250 Mo/s) à 163,94 € livré
Valable jusqu'au 13 Mai

Amazon Allemagne fait une promotion sur le SSD Corsair Force MP600 1 To (NMVe M.2 Gen4) qui passe à 159,23  € (avec la TVA ajustée). Comptez 4,61 € pour la livraison en France soit un total de 163,94 € livré alors qu'on le trouve ailleurs à partir de 180 €. Ce SSD utilise une interface M.2 NVMe PCIe Gen4 x 4 pour une connexion simple et des performances exceptionnelles : jusqu’à 4950 Mo/s en lecture séquentielle et jusqu’à 4250 Mo/s en écriture séquentielle. Le SSD est doté de la technologie 3D TLC NAND haute densité offrant une endurance d’écriture durable et assorti d’une garantie de cinq ans. Il est accompagné d'un dissipateur thermique.

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douane. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre

Sujets relatifs
Une question technique relative au MBR
Adaptateur SATA vers USB3
adaptateur ide vers disque sata
adaptateur disque dur sata vers usb
fabriquer une nappe: adaptateur 2,5'' vers 3,5''
Adaptateur SATA vers IDE
Question technique de compatibilité
Adaptateur USB pour Crucial P1 NVMe, PCIe, M.2
Clonage d'un SSD M2 pcie nvme vers un autre SSD M2 pcie
SSD sata vers NVME pcie4
Plus de sujets relatifs à Une question technique adaptateur PCIE vers Sata
 > Tous les forums > Forum Les mains dans le cambouis