> Tous les forums > Forum Internet et Réseaux
 Erreur de connexion : serveur ftp
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Evangelius
  Posté le 13/12/2008 @ 13:45 
Aller en bas de la page 
Petit astucien

Bonjour,

j'ai configuré un serveur ftp en suivant differents tuto avec le logiciel TYPSoft FTP Serveur.

j'ai laissé le serveur sur le port par défaut a sa voir 21

quand je test le serveur sur : http://www.g6ftpserver.com/fr/ftptest

j'obtiens cela :

* About to connect() to **.*.***.*** port 21
* Trying **.*.***.***... connected
* Connected to **.*.***.*** (**.*.***.***) port 21
* FTP response reading failed
* Closing connection #0

Si j'essaye avec un url de chez moi avec :

ftp://login:mdp@Monip:21

Sur firefox j'ai bien le truc qui s'affiche mais je n'ai aucun repertoire qui apparait, aucun arbre rien...

Sur IE ça fonctionne même pas

Donc voila si quelqu'un pourrai m'expliquer pourquoi ça ne fonctionne pas ça serai génial héhé


Pour info j'ai ouvert le port 21 sur ma livebox donc ça ne vient pas de la ;)

Merci d'avance, Arthur.


Publicité
tiobilout
 Posté le 13/12/2008 à 14:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Quand tu dis que tu as "ouvert" le port 21 c'est bien d'une redirection de ce port sur l'adresse ip privée ( genre 192.168.1.xxx ) de ton PC.

Quand tu testes avec g6ftpserveur c'est bien ton adrese ip publique ( celle la LB sur le net en fait ) que tu mets ?

Enfin as-tu bien déclaré un ou des orts pour le mode passif ( Et redirigé aussi celui dans la LB ? )

C'est une Sagem ou une Inventel ?

Evangelius
 Posté le 13/12/2008 à 14:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

du tout

j'ai juste mis dans la table de routage de la livebox ( une sagem ) le port 21 en udp + tcp sur mon ip ( pour l'ip j'ai été voir sur ce lien : http://www.ip.free.fr )

90.3.***

ce n'est pas celle la ?

Si j'ai bien suivi sur le table de routage je dois mettre l'ip qui apparait dans ipconfig du type 192.168....

et pour me connecter au ftp j'utilise celle du type 90.3... ?

Pour l'histoire des port en mode passif je n'ai rien fais de tel je vais regarder tout de suite dans la config de TYPSoft

Evangelius
 Posté le 13/12/2008 à 14:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Evangelius a écrit :

du tout

j'ai juste mis dans la table de routage de la livebox ( une sagem ) le port 21 en udp + tcp sur mon ip ( pour l'ip j'ai été voir sur ce lien : http://www.ip.free.fr )

90.3.***

ce n'est pas celle la ?

Si j'ai bien suivi sur le table de routage je dois mettre l'ip qui apparait dans ipconfig du type 192.168....

et pour me connecter au ftp j'utilise celle du type 90.3... ?

Pour l'histoire des port en mode passif je n'ai rien fais de tel je vais regarder tout de suite dans la config de TYPSoft

edit : J'ai fais ce que tu m'as dit a a l'air de fonctionner test du serveur. Par contre je me suis pas occupé de cette histoire de port passif. Et de chez moi toujours aucune arborescence de fichier, je vais attendre l'ami avec qui je veux echanger des fichiers voir si lui ça s'affiche.

tiobilout
 Posté le 13/12/2008 à 15:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien
Evangelius a écrit :

du tout

j'ai juste mis dans la table de routage de la livebox ( une sagem ) le port 21 en udp + tcp sur mon ip ( pour l'ip j'ai été voir sur ce lien : http://www.ip.free.fr )

Table de routage ...? Les serveurs LAN tu veux dire ?

90.3.***

ce n'est pas celle la ? Non

Si j'ai bien suivi sur le table de routage je dois mettre l'ip qui apparait dans ipconfig du type 192.168....Oui

et pour me connecter au ftp j'utilise celle du type 90.3... ?Oui de l'extérieur ou avec g6ftpserveur

Pour l'histoire des port en mode passif je n'ai rien fais de tel je vais regarder tout de suite dans la config de TYPSoft



Modifié par tiobilout le 13/12/2008 15:48
Evangelius
 Posté le 13/12/2008 à 15:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Oui les serveurs LAN pardon. Plus qu'a attendre que mon pote soit la pour lui faire tester on verra bien.

tiobilout
 Posté le 13/12/2008 à 15:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Attendre quoi ? tu peux tester avec g6ftpserveur comme tu l'as deja fait

( Au passage, router le port udp 21 est inutile )



Modifié par tiobilout le 13/12/2008 15:50
Evangelius
 Posté le 13/12/2008 à 18:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Sur g6ftpserveur tout fonctionne mais en réalité ça ne fonctionne pas un ami essaye de s'y connecter la page reste blanche.

Quand je le test de chez moi aucun dossier n'apparait

dans le log de TYPSOFT :

13:25] - [14] Connecté à 83.114.xx.xxx. Collecte du Nom d'Utilisateur.
[18:13:26] - [14] Utilisateur XXXXXX [83.114.xx.xxx] connecté
[18:13:26] - [14]
XXXXXX : Répertoire en Cours : C:\FTP\
[18:13:27] - [14]
XXXXXX : Début du Téléchargement de : C:\FTP\
[18:13:27] - [14]
XXXXXX : Echec du Téléchargement du Fichier : C:\FTP\ (4 326,20 K/S - 10 461 776 bytes)
[18:13:27] - [14]
XXXXXX : Répertoire en Cours : C:\FTP\
[18:13:28] - [14] Utilisateur
XXXXXX [83.114.xx.xxx] déconnecté (00:00:02 Min)
[18:13:44] - [15] Connecté à
83.114.xx.xxx. Collecte du Nom d'Utilisateur.
[18:13:44] - [15] Utilisateur
XXXXXX [83.114.xx.xxx] connecté
[18:13:44] - [15]
XXXXXX : Répertoire en Cours : C:\FTP\
[18:13:46] - [15]
XXXXXX : Début du Téléchargement de : C:\FTP\
[18:13:46] - [15]
XXXXXX : Echec du Téléchargement du Fichier : C:\FTP\ (4 326,20 K/S - 10 449 048 bytes)
[18:13:47] - [15]
XXXXXX : Répertoire en Cours : C:\FTP\
[18:13:47] - [15] Utilisateur
XXXXXX [83.114.xx.xxx] déconnecté (00:00:02 Min)

Evangelius
 Posté le 13/12/2008 à 18:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Apperemment chez un autre ami lu ça fonctionne il voit bien l'arborescence de fichier mais pas la personne avec qui ej veux faire des échanges ? Quelqu'un aurai une idée du pourquoi ça marche chez certain et pas d'autre ?

Publicité
Evangelius
 Posté le 13/12/2008 à 21:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Personne n'aurai une idée de la source du problème ?

Au faites merci tiobilout tu m'as deja bien aidé.



Modifié par Evangelius le 13/12/2008 22:00
tiobilout
 Posté le 14/12/2008 à 08:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Quels droits as-tu donné à cet utilisateur ?

Quel client FTP utilise-t'il ?

Evangelius
 Posté le 14/12/2008 à 12:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

En droit uniquement le droit : Upload, Download, et l'option pour activez ses même droits dans les sous repertoires inclus. Mais mon ami chez qui sa fonctionne se connecte avec les même identifiants et donc les même droit d'utilisateurs que la personne qui n'arrive pas a acceder aux fichiers du ftp. Les deux utilisent tout simplemet Firefox comme client FTP.

tiobilout
 Posté le 14/12/2008 à 12:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Firefox ou FireFTP ?

( Au fait tu as paramètré le mode passif dans ton serveur et dans la LB ( ports à router ? )

Evangelius
 Posté le 14/12/2008 à 13:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Firefox

Pour cette histoire de mode passif non je n'ai rien fais, je doute que ça peut regler le problème qui fait que certain voit et d'autre pas les fichiers sur le ftp mais je n'ai rien a perdre je vais essayer héhé.

Dans les options du ftp j'ai : IP for PASV mode le champ est vide, quel ip je suis censé mettre ?

J'ai aussi un passive port range avec deux champs pour dire de quel port a quel port, je dois la aussi y toucher ?

Arthur.

tiobilout
 Posté le 14/12/2008 à 14:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

1 - Firefox n'est pas un client FTP, tes amis feraient bien d'installer l'add-on Firefox, qui se nomme FireFTP qui est un vrai client FTP.

2 - C'est extraordinaire, ton truc ne marche pas mais tu sais que le paramètrage du port passif n'y changera rien ...

Dans les options du ftp j'ai : IP for PASV mode le champ est vide, quel ip je suis censé mettre ?

J'ai aussi un passive port range avec deux champs pour dire de quel port a quel port, je dois la aussi y toucher ?

Deja répondu dans ma première réponse.



Modifié par tiobilout le 14/12/2008 14:16
Evangelius
 Posté le 14/12/2008 à 14:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'ai ajouté le port 23 a 25 en PASV pour voir.

Par contre sur FIREFTP dans host je mets quoi ?

Par url ça donne : ftp://login:password@ip:port

Host je met ip:port

Pour login et mot de passe la je me doute ce qu'il faut mettre héhé.

En tout cas avec ip:port en host quand j'essaye de me connecter cela donne :

Unable to make a connection. Please try again.

tiobilout
 Posté le 14/12/2008 à 15:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien
Evangelius a écrit :

J'ai ajouté le port 23 a 25 en PASV pour voir.Pas bon, le 25 est uitilisé pour le mail, mets plutot 30 000 à 30 500

tu les as routés dans la LB ?

Par contre sur FIREFTP dans host je mets quoi ? ben le host, si tu es chez toi, ton ip locale, si c'est pour tes potes l'ip publique de ta LB

Par url ça donne : ftp://login:password@ip:port

Host je met ip:port Non, rien

Pour login et mot de passe la je me doute ce qu'il faut mettre héhé.

En tout cas avec ip:port en host quand j'essaye de me connecter cela donne : Normal

Unable to make a connection. Please try again.

Publicité
Evangelius
 Posté le 14/12/2008 à 17:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'ai fais tout ce que tu m'as dis.

Elle arrive enfin a se connecter, mais ou bien il n'y a toujours rien qui s'affiche dans sa fenetre alors que je la vois bien connecter sur TYPSoft ou bien j'ai des 550 permission denied. Alors que sur la racine j'ai en droit download, upload, modif, renommer, creer etc, et sous dossier inclus

EDIT :

Je met en racine D:

je donne tous les accès dedans repertoire inclus, je me co a Fireftp tout fonctionne de chez moi. Elle le fait chez elle a le D qui s'affiche mais quand elle fait double clique dessus rien ne se passe elle ne voit pas osn contenu grrr

EDIT 2 : un pote a testé lui aussi il est connecter il voit la partition D mais ne peut pas naviguer dedans grrrr

501 Invalid PORT command



Modifié par Evangelius le 14/12/2008 17:43
tiobilout
 Posté le 14/12/2008 à 17:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Essaie de partager autre chose que la racine ( jamais recommandé )

Crée un repertoire d:\ftp par exemple et déclare le pour ton user.

Quand tu parles de droits, c'est bien dans typsoft FTPserver que tu déclares ces droits ?



Modifié par tiobilout le 14/12/2008 17:47
Evangelius
 Posté le 14/12/2008 à 17:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

j'ai D:/dossier1/dossier2/dossier3/

un esnsemble de fichier que je veux partager dans dossier 3

sous TYPSOFT je met en dossier racine directement D:/dossier1/dossier2/dossier3/ et je donne tous les accès.

Je me connect j'ai directement une erreur 550 type permission non accordé, je peux pas entrer dans le dossier 3.

tiobilout
 Posté le 14/12/2008 à 18:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Vous n'êtes pas plusieurs à vous connecter en même temps avec le même user ?

Quand tu dis "je me connecte" tu le fais en local ?

Evangelius
 Posté le 14/12/2008 à 18:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ya deux cas en faites :

Ou bien je mets une partition entiere en racine sur TYPSOFT et moi quand je me connecter en local avec FIRETP sur ma machine donc, sur ma propre machine, tout fonctionne. Quand c'est quelqu'un d'autre qui le fait donc par internet, ils n'ont pas accès au contenu de D et ils ont une erreur de type 501 Invalid PORT command

Ou bien alors je mets le dossier que je veux partager directement en racine a savoir D:/dossier1/dossier2/dossier3/ , et la que ça soit moi en local ou quelqu'un par internet : 550 permission denied

Et oui j'ai bien crée des users differents pour que je suis tester en même temps qu'eux.



Modifié par Evangelius le 14/12/2008 18:50
tiobilout
 Posté le 14/12/2008 à 19:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Le port 20 est bien ouvert dans ta box ? Tu as un parefeu sur le PC ?



Modifié par tiobilout le 14/12/2008 19:15
tiobilout
 Posté le 14/12/2008 à 19:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

J'ai installé typsoft sur un Pc de test.

En local que cela soit la racine du disque ou une arborescence à trois niveaux ca roule.

Je n'ai mis que download et upload comme droit.

Evangelius
 Posté le 14/12/2008 à 20:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

oui ... les ports sont bien ouverts.... j'abandonne j'en ai marre des heures que je bidouille ce truc sans que ça veuille fonctionner.

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Incredimail ?? erreur de la connexion au serveur
Erreur connexion
Connexion serveur proxi !!!
erreur de connexion SSL
Erreur de connexion SSL
[FileZilla serveur erreur]
Courrielleur :plus de connexion au serveur smtp de mon FAI
Connexion au serveur réinitialisée
Problème de connexion : erreur 106
cONNEXION REFUSEEpar le serveur proxy
Plus de sujets relatifs à Erreur de connexion : serveur ftp
 > Tous les forums > Forum Internet et Réseaux