> Tous les forums > Forum Linux
 Différence en MintUpdate et apt-get update/upgrade
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 19/12/2010 @ 11:51 
Aller en bas de la page 
Astucien

Bonjour,

Je suis actuellement sous Linux Mint 9 (Isadora).

Je lance les mises à jour en cliquant sur l'icône de MintUpdate dans la barre des tâches et au bout de quelques instants, MintUpdate annonce qu'il y a 93 mises à jour disponibles.

Je les installe toutes puis je clique à nouveau sur l'icône de MintUpdate qui me dit "votre système est à jour" ce qui est normal :

J'ouvre ensuite une console et j'exécute les classiques apt-get update puis apt-get upgrade et voilà ce que j'obtiens :

et si je fait : apt-get dist-upgrade, c'est encore mieux :

Pourquoi MintUpdate néglige-t'il tous ces paquetages et mises à jour ???

Merci d'avance pour vos réponses.

Cordialement,



Modifié par Mimile le 19/12/2010 12:03
Publicité
Tasgarth
 Posté le 19/12/2010 à 20:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Mimile,

De mémoire,( mais avec 'puppy linux 5.15' je n'utilise plus apt-get. et encore moins Synaptic)..

Pour Synaptic cela dépendra du paramétrage.... et on ne peut pas 'vider' totalement la base installée (apt-get clean ou autoclean ne le font pas).



apt-get upgrade installe les dernières versions de TOUS les paquets du système (qqs la dâte).
Il n'installe JAMAIS un paquet qui n'est pas déja installé.

apt-get dist-upgrade :
Cette commande installe la dernière version des paquets et peut donc rajouter des paquets jugés nécessaires. Il gère aussi les nouvelles dépendances. Il permet de configurer les paquets après une installation interrerompue.

Il le signale "Les nouvaux paquets suivants seront installés...du 2.6.32-26"

Pour le 'upgrade' seulement les paquets déja installés (sans tenir compte des versions) : 'Les paquets suivant ont été conservés....''

C'est ma lecture...mais bon...

Il est conseillé (je pense) d'utiliser apt-get dist-upgrade.
Mais tout cela de mémoire

A+



Modifié par Tasgarth le 19/12/2010 21:58
Logicien
 Posté le 19/12/2010 à 22:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Allo,

Mimile, peut-être que la configuration de l'applet que tu utilises sous Mint est différente de celle de apt-get. Le sources.list est peut être différent. Il se pourrait aussi que cet applet utilise aptitude ou autre gestionnaire de paquets plutôt qu'apt-get, à vérifier. En tous cas, cet applet ne semble pas mettre à jour le noyau Linux. C'est peut-être un élément de configuration et/ou de droits.

Tasgarth, il est connu que l'option upgrade ne désinstalle aucun paquet. Elle met à jour tous les paquets dont toutes les dépendances sont satistaites par les nouvelles versions. Elle conserve inchangés les paquets et leurs dépendances lorsque toutes les nouvelles versions ne peuvent être installées.

L'option dist-upgrade elle, met à jour tous les paquets qui peuvent l'être et désinstalle les paquets dont toutes les dépendances de sont pas satistaites par la mise-à-jour. On se retrouve ainsi avec des paquets installés toujours à jour, au côut de la désinstallation de paquets explicitement installés (par l'utilisateur) si nécessaire. Je ne pense pas toutefois que cela s'applique aux paquets critiques du système de base, pour ceux-ci, je pense que paquets et dépendances sortent de façon synchrone.

Exemple, une librairie est mise à jour par dist-upgrade, mais une application qui n'est pas mise à jour par dist-upgrade, faute de nouvelle version utilisant la nouvelle librairie, nécessite la version antérieure de la librairie qui vient d'être mise à jour. dist-upgrade désinstalle le paquet de l'application pour dépendance manquante. Il faut réinstaller l'application quand la nouvelle version pourra utiliser la nouvelle librairie.

Dans les deux cas, il est nécessaire de faire apt-get autoremove si on veut supprimer les paquets orphelins, ou utiliser apt-mark pour rendre leurs installations explicites et les conserver. Cela ne les protègent quand même pas contre une éventuelle désinstallation par dist-upgrade.

Il se peut que les choses se passent différemment de ce que je dis, mais c'est la façon dont je comprend upgrade et dist-upgrade.



Modifié par Logicien le 19/12/2010 23:22
Mimile
 Posté le 20/12/2010 à 13:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour à tous deux et merci pour vos explications.

J'ai vérifié avec ps : MintUpdate est un programme écrit en python qui fait 1422 lignes et que je ne reproduirai donc pas ici.

Je l'ai survolé et apparemment, il semblerait qu'il utilise apt-get mais le langage python m'est trop étranger et le programme est tellement long que je n'ai pas vu quelle éventuelle option est utilisée avec apt-get.

Amicalement,

NB J'ai installé Seamonkey 2.0.11 sur ma Debian (quand je dis installé, j'ai simplement extrait de l'archive tar.bz2 un dossier complet dans lequel il y a l'exécutable et tout ce qui va avec).

Ensuite, heureuse surprise au premier lancement : sans aucune intervention de ma part, j'y ai retrouvé tous mes signets et mes plugins Firefox ainsi que tous mes comptes mail et carnets d'adresse Thunderbird !!

Par ailleurs, je suis épaté par la vitesse avec laquelle il affiche les page web. C'est peut-être dû au fait qu'il y a moins d'extension que Firefox n'en possède.

Ca me rappelle l'époque où j'utilisais Netscape sous Windows.

Un concurrent sérieux pour Firefox et Thunderbird en tout cas.



Modifié par Mimile le 20/12/2010 16:49
Logicien
 Posté le 20/12/2010 à 16:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour savoir quel gestionnaire de paquets utilise MintUpdate, quand cet applet travaille, regarde avec les commandes htop, top et ps quel gestionnaire de paquets est appelé par Python.

Une des seules raisons pour lesquelles je suis passé à Debian Sid, c'est que Seamonkey est dans ce dépôt. Je suis moi aussi avec la version 2.0.11 installée par apt-get. J'ai toujours utilisé Mozilla/Seamonkey depuis mes débuts en logiciels libres.Je ne suis pas prêt de changer. Même sous Windows 7 c'est lui que je préfère.

Mimile
 Posté le 20/12/2010 à 17:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

La prochaine fois que je repasserai sous Mint, je ferai les observations que tu suggères.

La commande "ps" m'avait déjà renseigné sur le nom du programme (MintUpdate.py).

C'est vrai que j'aurais dû penser à top par moi-même (j'avoue que je suis un grand distrait - mon défunt père me disait souvent : "un jour, tu oublieras de respirer ...").

Au risque d'être taxé de faire de l'humour noir , je dois malheureusement constater que lui aussi n'était pas à l'abri de ce type d'oubli ...

Quant à Seamonkey, il n'était pas dans mes dépôts mais son installation en utilisant l'archive a été un jeu d'enfant (tout comme d'ailleurs, Firefox et Thunderbird).

A bientôt

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
Kit évolution PC : AMD Ryzen 7 5800X + carte mère B550 AORUS Elite V2 à 379,90 €
379,90 € 420 € -10% @RueDuCommerce
Ecran 32 pouces incurvé KTC H32S17 (QHD, 165 Hz, 1 ms, HDR10) à 239 €
239 € 350 € -32% @RueDuCommerce
Mini PC Beelink Mini S (Celeron N5095, 8 Go RAM, SSD 256Go, Windows 11 Pro) à 179,56 €
179,56 € 259 € -31% @Amazon
Batterie externe OUKITEL P2001 Ultimate 2000Wh, 2000W, LifePOE4 à 1226,34 €
1226,34 € 2199 € -44% @Geekbuying
Boîtier COOLER MASTER MasterBox Q300L (mATX, fenêtre) à 42,56 €
42,56 € 69 € -38% @Cdiscount
Batterie portable Charmast 10400 mAh 18W PD charge rapide à 17,28 €
17,28 € 26,99 € -36% @Amazon
Processeur AMD Ryzen 7 5700G (8 coeurs, Vega 8, AM4) à 188,98 €
188,98 € 250 € -24% @Amazon
Kit de 16 Go (2x8 Go) de mémoire DDR4 Corsair Vengeance RGB Pro SL 3200 MHz à 68,99 €
68,99 € 100 € -31% @RueDuCommerce
Jeu PC Star Wars Squadrons gratuit
0 € 39,99 € -100% @Epic Games
Ecran PC 24.5 pouces BenQ EX2510S (FHD, IPS, FreeSync,165Hz, 2xHP, réglable en hauteur) à 179 €
179,00 € 249 € -28% @Amazon

Sujets relatifs
Sortie de l'update 6 de Mint LMDE
LMDE Update 5 est sorti
Premières ISO de LMDE update 4 RC
Sortie de l'update 4 de LMDE
upgrade to version 11.04
Debian Lenny (5) et apt-get dist-upgrade
Problème d'update sur 10.10
probleme upgrade ubuntu 10.4
M2009.1 update for x86-64 & 586 (pour information)
problème avec apt-get update
Plus de sujets relatifs à Différence en MintUpdate et apt-get update/upgrade
 > Tous les forums > Forum Linux