> Tous les forums > Forum Linux
 Problème avec WIneSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 20/09/2015 @ 14:30 
Aller en bas de la page 
Astucien

Bonjour,

Puisque je n'obtiens pas de réponse sur le forum Linux Mint, je pose ma question ici :

Bonjour,

J'ai LinuxMintDebian 2 (64 bits) installée en invitée de Linux Mint 17.1 (64 bits) avec virtualbox.

Les additions invité sont installées et l'option USB 2 est activée après installation du pack complémentaire.

J'ai installé wine sous Linux Mint 17.1 pour faire tourner quelques petits programmes *.exe (portables) et ils fonctionnent très bien.

J'ai aussi installé wine sous LMDE2 avec synaptic et j'ai transféré des copies des programmes *.exe dans un répertoire de ma /home (comme c'est d'ailleurs le cas aussi pour LM 17.1).

Au premier démarrage d'une commande wine, un message apparaît disant qu'il faut installer mono (?), ce qui se fait automatiquement si on clique sur "installer".

Tout semble se passer correctement mais voici ce que j'obtiens systématiquement :

okapi@lmde2 ~ $ wine /home/okapi/Téléchargements/popcorn/popcorn.exe
wine: Mauvais format EXE pour Z:\home\okapi\Téléchargements\popcorn\popcorn.exe.


1°) je ne sais d'où vient ce répertoire Z: (je crois avoir lu que cela correspondait à la partition /
2°) je ne vois pas en quoi EXE a un mauvais format puisqu'il fonctionne correctement sous LM 17.1
3°) quand je clique (bouton droit) sur l'*.EXE dans son dossier, l'option "ouvrir avec " ne me propose pas wine mais bien "Mono Runtime (terminal)" ; si j'accepte, il ne se passe rien.
4°) si je choisis "ouvrir avec une autre application", je trouve "a wine application" mais ça ne donne rien.

Voyez-vous une explication à cet étrange comportement ?

Je précise que j'ai arpenté le net dans tous les sens et les quelques postes sur lesquels je suis tombé ne m'ont été d'aucun secours.

Merci d'avance.

Publicité
Logicien
 Posté le 20/09/2015 à 14:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

j'ai transféré des copies des programmes *.exe dans un répertoire de ma /home.

Bonjour,

es-tu certain que les copies des programmes sont identiques aux originaux?

Mimile
 Posté le 20/09/2015 à 15:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Paul

Bien content de te rencontrer à nouveau.

En résumé, je suis sous Linux Mint 17.1 - 64 bits qui est une distribution bien agréable qui pose peu de problèmes.

Par curiosité, j'ai installé Linux Mint Debian 2 en virtuel (avec virtualbox) et c'est là que les problèmes ont commencé : l'installation des additions invités, l'activation des périphériques USB, etc..

Pour en revenir à ta question : a priori, je suppose que quand on fait un copier/coller, à l'arrivée, on a une copie conforme de l'original. En tout cas, ils pèsent tous deux le même poids.

J'ajouterai que j'ai copié/collé ces petits programmes (portables) sur plusieurs OS (Archlinux, Debian Jessie, en 64 bits aussi) où ils fonctionnent correctement.

Je pense que le problème vient de wine lui-même (installé avec le gestionnaire synaptic ce qui donne à penser que les dépendances sont installées en même temps).

Se pourrait-il que ce soit dû au fait que je suis sur une installation virtuelle (Linux Mint Debian 2) ?

reivillo
 Posté le 20/09/2015 à 15:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Mimile, Logicien & Autres.

En Terminal essaye:
winecfg
Puis onglet Lecteurs > Détection automatique > Appliquer > Ok
Et là, tu verras que dans wine le Lecteur Z, correspond bien au répertoire racine /
Tu peux aussi tenter de lancer les Exécutable depuis le Terminal avec:
wine "chemin/vers/le/fichier.exe" ( sans oublier les guillemets )

Reivillo.



Modifié par reivillo le 20/09/2015 16:17
Logicien
 Posté le 20/09/2015 à 15:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je pense au fait que la version installée de Wine sous Linux Mint 17.1 - 64 bits n'est probablement pas la même que celle installée sous Linux Mint Debian 2. En utilisant les dépôts testing sous Linux Mint Debian 2, tu pourras peut-être utiliser la même version que sous Mint 17.1 - 64 bits.

Qu'en est-il également de la configuration de Wine entre les deux systèmes? Sont-elles identiques? S'appliquent-elles aux mêmes binaires de Winwind (ma contribution aux surnoms de Windows )?

Il se peut effectivement que faire tourner une émulation système (Wine) dans une émulation matérielle (VirtualBox) crée un problème comme l'accès à la mémoire vive par les binaires Windows. Assure-toi que le système émulé par VirtualBox est Debian 64 bits plutôt que Ubuntu 64 bits. Essai les deux.

Il faudrait que tu exécutes les binaires Windows sous une installation virtuelle autre que Linux Mint Debian 2, comme Manjaro, afin de voir si le problème existe également ou non. Cela va t'orienter un peu plus à savoir si c'est le système virtualisé qui a un problème et/ou la virtualisation depuis Mint 17.1 - 64 bits elle-même.

Sous Mint Debian 2, vérifie que tous les modules du noyau Linux nécessaires pour faire tourner Wine sont bien chargés en mémoire vive. Il se peut aussi que la version du noyau Linux uitlisée ait une influence sur le problème. Essayer une autre version à la limite peut se concevoir.

Avec la commande file, vérifie que les binaires Windows sont perçus de la même manière entre les deux systèmes Mint.

Plusieurs idées sont passées dans ma masse cérébrale. Je trouve ce problème essentiellement technique intéressant à comprendre comme la plupart de ceux que tu nous soumet. Bonne journée Mimile.



Modifié par Logicien le 20/09/2015 16:41
Mimile
 Posté le 20/09/2015 à 17:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

@ reivillo : winecfg > lecteurs >

Donc, problème ...

Autre problème :

okapi@lmde2 ~ $ wine "/home/okapi/Téléchargements/popcorn/popcorn.exe"
wine: Mauvais format EXE pour Z:\home\okapi\Téléchargements\popcorn\popcorn.exe.

@ Logicien :

Ma sources.list est ... vide !

Pour le surplus, je suis incapable de répondre aux questions que tu me poses ...

Quand j'aurais un peu de temps, j'installerai avec virtualbox une autre distro (Manjaro, Debian Jessie ?) pour voir si je rencontre les mêmes problèmes

Je reviens dès que possible.

En tout cas, merci à tous deux de vous être intéressé à mon problème.

Amicalement



Modifié par Mimile le 20/09/2015 17:24
reivillo
 Posté le 20/09/2015 à 20:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

@ Mimile.

okapi@lmde2 ~ $ wine "/home/okapi/Téléchargements/popcorn/popcorn.exe"
wine: Mauvais format EXE pour Z:\home\okapi\Téléchargements\popcorn\popcorn.exe.

Sûrement les Caractères accentués " é ", de Téléchargement qui pose problème.
Donc, Renommer momentanément pour teste, Téléchargement en Telechargement...



Modifié par reivillo le 20/09/2015 20:20
aug
 Posté le 20/09/2015 à 21:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Bonsoir à tous, J'ai eu un problème identique sur Handylinux (Jessie)par rapport à la question 3. Je l'ai réglé après avoir fait ce qui est indiqué au dernier paragraphe. http://forum.handylinux.org/viewtopic.php?id=920 A toute fin utile.
reivillo
 Posté le 20/09/2015 à 22:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

@ aug, bonsoir.

Exact... J'avais zappé les questions 3/4.
Merci, pour ce rappel...

Reivillo.

Publicité
Mimile
 Posté le 21/09/2015 à 09:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

@ reivillo : j'ai remplacé les "é" par des "e" dans ~/Téléchargements mais ça ne change rien : toujours ce satané message : mauvais format pour EXE ....

@ aug : j'ai évidemment essayé la méthode indiquée : clic droit sur l'exe, qui propose "ouvrir avec mono runtime (terminal) en premier choix. Je passe alors sur "ouvrir avec" qui propose une fois de plus mono runtime, gestionnaire d'archives (?) et "autres" ; une série de logiciels apparaît avec au centre de la fenêtre "aucune application trouvée".

Dans la barre du dessous, j'indique wine que j'ajoute à la liste ; je ferme la fenêtre, je clique droit sur l'*.exe et le menu déroulant "ouvrir avec" a en tête : wine ; je clique dessus et il ne se passe rien.

C'est l'impasse sauf à faire ce que Logicien suggère mais aujourd'hui je n'aurai pas beaucoup de temps à y consacrer.

Merci quand même pour vos interventions.

A+

Mimile
 Posté le 22/09/2015 à 14:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut, problème résolu

Avec le gestionnaire de paquets synaptic, j'ai supprimé tout ce qui avait trait à wine64 (que j'avais cru bon d'installer vu que LMDE est en 64 bits).

Puis j'ai réinstallé wine (tout court) qui m'a installé dans la foulée une kyrielle de librairies et de dépendances.

Essai en console : wine "......" et bingo, ça marche.

Je suppose qu'il y avait une incompatibilité entre les programmes *.exe (plutôt anciens) qui ne pouvait pas fonctionner en 64 bits.

Mais peut-être me trompé-je ? Ce ne serait pas la première fois

Quoi qu'il en soit, merci à tous ceux qui se sont penchés sur mon problème.

Cordialement

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
109,99 €Ecrans 24 pouces Philips 242V8A (Full HD, IPS, 75 Hz) à 109,99 €
Valable jusqu'au 24 Avril

RueDuCommerce fait une promotion sur l'écran 24 pouces Philips 242V8A qui passe à 109,99 € alors qu'on le trouve les écrans habituellement autour de 129 €. Cet écran possède une dalle IPS Full HD (1920x1080), offre un temps de réponse de 4 ms, une vitesse de rafraîchissement de 75 Hz (compatible FreeSync) et dispose d'une entrée HDMI et de haut-parleurs intégrés.


> Voir l'offre
129,99 €Smartphone 6,8 pouces Motorola G9 Power (HD+, Snapdragon 662, 4 Go RAM, 128 Go) à 129,99 € (via ODR)
Valable jusqu'au 25 Avril

Cdiscount fait une promotion sur le smartphone 6,8 pouces Motorola Moto G7 Power qui passe à 229,99 €. Or Motorola rembourse actuellement 100 € pour l'achat de cet appareil qui vous reviendra à 129,99 € après remboursement. Ce smartphone possède un écran 6,8 pouces HD+ (1640x720 pixels), un processeur octo-coeur Snapdragon 662, 4 Go de RAM, 128 Go de stockage extensible à 1 To via MicroSD, un lecteur d'empreintes digitales, un APN de 64 MP et un APN frontal de 16 MP avec flash intégré, le WiFi, le bluetooth, le NFC, le GPS. Le tout tourne sous Android 10. Avec sa batterie de 6000 mAh, le smartphone est très endurant et vous permettra de tenir jusqu'à 3 jours avant de le recharger. Une coque de protection, un adaptateur secteur 20W USB C et un kit mains libres sont fournis.

Prenez la version proposée par Cdiscount pour être certains de bénéficier de l'ODR (marchand partenaire)


> Voir l'offre
31,44 €Hub Aukey USB C 8 en 1 (USB 3.0, HDMI 4K, RJ45, lecteur SD et MicroSD, USB C PD 100W) à 31,44 €
Valable jusqu'au 24 Avril

Amazon fait une promotion sur le Hub Aukey USB C 8 en 1 qui passe à 31,44 €. Ce Hub à brancher sur un port USB C vous permettra d'ajouter 2 ports USB 3.0, un port USB 2.0, un lecteur de cartes mémoire SD et MicroSD, un port Ethernet Gigabit RJ45 et un port HDMI 4K à votre ordinateur portable ou votre smartphone. Et vous pourrez même recharger votre ordinateur avec la prise USB-C PD 100W intégrée.


> Voir l'offre

Sujets relatifs
Problème pour installer fichier msi. avec Wine
probleme avec wine/sopcast
Problème avec wine
probleme avec NTFS et Wine
Problème de boot avec handy linux
freeBSD : problème avec bash
Problème Clavier avec Linux Mint 17.1
Problème avec LinuxMint.
probleme d'affichage avec mozilla sous manjaro
problème avec gparted
Plus de sujets relatifs à Problème avec WIne
 > Tous les forums > Forum Linux