> Tous les forums > Forum Linux
 Non démarrage de Linux
Ajouter un message à la discussion
Pages : Début ... 1 2 [3] 4 5 ... Fin
[Début] Page 3 sur 6 [Fin]
Ikewdu_
 Posté le 16/05/2019 à 23:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

C'est surtout "Acer, honte à toi ! " qu'il faut dire.

Idem pour HP. C'est encore pire. Et certains Toshiba W8 étaient aussi plombés. Tout est centralisé sur le forum Ubuntu par malbo qui fait une liste depuis au moins 5 ou 6 ans. Un boulot de titan. Voir ce lien juste pour les portables Acer :

https://doc.ubuntu-fr.org/liste_portables_acer



Modifié par Ikewdu_ le 16/05/2019 23:23
Amanite44
 Posté le 16/05/2019 à 23:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Je n'y arrive pas. Je n'ai vraiment que windows et quand je fais F6 il indique :

microsoft recommends executing Windows 8 and the version above under UEFI boot mode to enjoy the full features.

Amanite44
 Posté le 16/05/2019 à 23:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Merci pour tout. Je retenterai tout ça mardi. D'ici là ... weekend !

en tout cas votre aide a été précieuse !

16mai1956
 Posté le 17/05/2019 à 00:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ikewdu_ a écrit :

C'est surtout "Acer, honte à toi ! " qu'il faut dire.

Idem pour HP. C'est encore pire. Et certains Toshiba W8 étaient aussi plombés. Tout est centralisé sur le forum Ubuntu par malbo qui fait une liste depuis au moins 5 ou 6 ans. Un boulot de titan. Voir ce lien juste pour les portables Acer :

https://doc.ubuntu-fr.org/liste_portables_acer

Ikewdu_ et salut à Amanite44 et à tous les intervenants,

Avant de te demander où était centralisé ce boulot de titan, j'ai cherché un peu et je crois que j'ai trouvé.
https://doc.ubuntu-fr.org/portable

À garder sous la main. Quelle mine !

Ikewdu_
 Posté le 17/05/2019 à 06:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Amanite44 a écrit :

Je n'y arrive pas. Je n'ai vraiment que windows et quand je fais F6 il indique :

microsoft recommends executing Windows 8 and the version above under UEFI boot mode to enjoy the full features.

Essaie alors de faire la procédure complète de gebuku qui est indiquée dans mon lien. Sinon, à part faire des photos du BIOS pour qu'on y voie clair, je ne peux rien te proposer.

Slyvester
 Posté le 17/05/2019 à 08:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Vive Linux .. Ce problème est-il seulement qu'avec ( Acer ) ?

Malheureusement, non. En cas de Dualboot Windows + Linux, il arrive souvent qu'une mise à jour de Windows crée le "beans" ==> suppression du Grub ==> impossibilité de démarrer sur la distribution Linux puisque n'apparaît que Windows. Comme j'ai vécu ce problème (trop) souvent, je n'ai plus installé que des Linux en multiboot.

Je vous laisse avec Ikewdu_ : la solution - comme il le suggère - est de démarrer/booter sur Ubuntu (via touche F12) et de réinstaller le Grub :

sudo grub-install /dev/sda ou autre possibilité ==>

sudo os-prober

sudo update-grub

Ikewdu_
 Posté le 17/05/2019 à 12:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Slyvester a écrit :

Je vous laisse avec Ikewdu_ : la solution - comme il le suggère - est de démarrer/booter sur Ubuntu (via touche F12) et de réinstaller le Grub :

sudo grub-install /dev/sda ou autre possibilité ==>

sudo os-prober

sudo update-grub

Salut,

En fait, non. Ca ne changerait absolument rien. Grub est parfaitement installé (dans la partition efi) et il est opérationnel (pour preuve, il se lance via F12 : Ubuntu ne démarrerait pas du tout sans lui). Le seul problème (propre à plusieurs marques), c'est que la NVram est plombée pour booter exclusivement sur bootmgr.efi et non shimx64.efi (et ce n'est pas un problème de "secure-boot", ceci dit à ceux qui envisageraient cette piste).

Acer permet sur certains modèles (dont celui-ci) de modifier l'ordre et de l'enregistrer "définitivement" via le bios, mais ni avec bcdedit (ce que j'ai tenté) ni efibootmgr. L'argument du SAV, c'est soi-disant par "sécurité". Donc, il faut entrer dans le bios par F2, passer la ligne "ubuntu" en tête de liste. Et si elle n'est pas présente, il faut la recréer "à la main" en suivant la procédure de Gebuku qui est très connue des "Ubuntistes". Des dizaines de soucis de ce genre sur Acer ont été résolus comme cela.

Pour info, les derniers modèles Acer sont pires, car on ne peut même plus écrire du tout dans la NVram sans passer par le bios, ce qui plante l'installateur de certaines distributions comme Ubuntu qui ne vont pas jusqu'à leur terme. Là, à l'heure où j'écris, personne à ma connaissance ne sait comment contourner le souci.



Modifié par Ikewdu_ le 17/05/2019 12:24
m_n
 Posté le 17/05/2019 à 16:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Amanite44 a tombée sur le bon gars pour venir a son aide ( Ikewdu_ ) ..

Bonne journée les amis ..

Publicité
Slyvester
 Posté le 17/05/2019 à 17:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

En fait, non. Ca ne changerait absolument rien. Grub est parfaitement installé ...

J'ai été trop vite et sans relire le lien d'ubuntu.org (shame on me ! ). On en apprend tous les jours comme par exemple que Windows + Linux ne font pas bon ménage en dualboot, mais cela, je le savais déjà !

viloque
 Posté le 17/05/2019 à 19:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à tous.

Jamais eu (ou très peu ) de problèmes avec mon Acer V3-771G de 2013 64 bits en multi boot Win 10, Win 8.1, Mint 18.3 Cinnamon depuis 3 ou 4 ans.

De même avec le Acer 9410Z 32 bits de 2007 en dual boot Vista, Ubuntu 16.04 qui tourne maintenant le plus souvent sur Ubuntu.

A+

Ikewdu_
 Posté le 18/05/2019 à 09:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

https://www.manualslib.com/manual/440323/Acer-Aspire-V3-571g.html#manual

Sans vouloir te vexer, tu n'apportes rien au sujet par ton intervention. Le plus récent des deux PC cités est encore livré avec un BIOS classique.... Donc très loin des UEFI d'aujourd'hui, qui ont eux-mêmes évolué entre 2014 et 2019.... On installe plus facilement un dual boot sur un Acer de 2015 que sur un Acer de 2019, car ce constructeur plombe actuellement sa NVram probablement par accord avec M$. Chez Toshiba ou HP, c'est plutôt le contraire : les strategies de boot on changé ou des options se sont ajoutées dans les UEFI basiques pour permettre le démarrage sur autre chose que l'OS préinstallé.

Pour info, le seul constructeur qui a "joué le jeu" depuis le début de l'UEFI, c'est Asus.

R136a1
 Posté le 18/05/2019 à 22:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Ikewdu_ a écrit : Pour info, le seul constructeur qui a "joué le jeu" depuis le début de l'UEFI, c'est Asus.

Il y a les assembleurs chinois aussi ...

Amanite44
 Posté le 21/05/2019 à 21:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonsoir à tous,

J'ai donc repris le process indiqué par gebuku. Tout se passe bien sauf quand je retourne sur l'onglet boot, je n'ai que 3 versions de windows et pas ubuntu. Si je recommence la procédure, il me dit que UbuntuShimx64 que j'ai créé existe déjà !

Comme si ce n'était pas visible.

Je vais essayer de faire des photos d'écran (je n'arrive pas à faire des copies quand je suis dans ce menu).

Ikewdu_
 Posté le 21/05/2019 à 21:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Fais des photos...

Amanite44
 Posté le 21/05/2019 à 21:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Amanite44
 Posté le 21/05/2019 à 21:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Publicité
Ikewdu_
 Posté le 21/05/2019 à 22:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

C'est bien l'onglet boot que tu affiches ?

Amanite44
 Posté le 21/05/2019 à 22:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

oui

Ikewdu_
 Posté le 22/05/2019 à 06:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Et avec f12, l'entrée apparait toujours ?

Si c'est le cas, je n'aurai pas de solution de secours à te proposer et ton PC entrera dans la longue listes des Acer qui posent problème. En ce qui me concerne, en tout cas.

Logicien
 Posté le 22/05/2019 à 07:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

La situation semble simple à comprendre, le démarrage par défaut sur Ubuntu est défait par une mise-à-jour de Windows qui rétablit le démarrage par défaut sur Windows, défaut ou automatique. Le microcode UEFI va même jusqu'à interdire le démarrage automatique sous Ubuntu ou un autre SE que Windows.

Si la touche F12 permet de choisir Ubuntu à la volée, on peut se consoler de pouvoir accéder à autre chose que Windows. Ma médecine a toujours été de mettre à zéro le disque dur principal où est Windows pour n'installer que Linux. Ici, si le démarrage en mode UEFI pose problème à Ubuntu avec Windows et Ubuntu en dualboot on peut essayer de tout réinstaller en mode BIOS si l'option existe et dire adieu à la partition UEFI et au démarrage en mode UEFI.

N'étant pas sous aucun Windows je ne sais pas si celui-ci, avec une version récente (Windows 10), accepterait de s'installer en mode BIOS et si oui, là encore une mise-à-jour de Windows le remettrait comme SE par défaut au démarrage. Peut-être avez-vous des précisions?

Le problème de changement de chargeur de démarrage existe aussi entre systèmes Linux. Debian réinstalle automatiquement Grub après une mise-à-jour de celui-ci ce qui fait que mon Grub installé de la ArchLinux est écrasé par celui de Debian. La ArchLinux ne réinstalle pas Grub automatiquement après une mise-à-jour, je dois le faire manuellement. En tous cas je n'ai jamais rien vu de tel pendant une mise-à-jour de la ArchLinux.

Sous Debian (et ses dérivées selon toute vraisemblance) oui. J'utilise maintenant le chargeur de Debian pour m'éviter d'avoir à réinstaller celui de la ArchLinux manuellement. La version de Grub de Debian est près sinon la même que celle de la ArchLinux.

En conséquence, il peut être difficile de savoir quel chargeur de démarrage s'est installé en dernier au fil du temps. C'est au démarrage lui-même qu'on le sait à moins d'utiliser des outils qui le disent.



Modifié par Logicien le 22/05/2019 07:55
Amanite44
 Posté le 22/05/2019 à 07:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

@Ikewu : non.

Amanite44
 Posté le 22/05/2019 à 07:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

@Logicien, Je ne suis pas opposée à n'avoir que Linux. Mais pour cela il faut que je trouve un logiciel de road trip qui accepte linux. Car j'utilise TYRE qui ne fonctionne pas sous linux... Et j'ai besoin de ce logiciel, ou d'un équivalent.

Logicien
 Posté le 22/05/2019 à 07:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

je comprend très bien Amanite44. N'utilisant pas de logiciel de road trip je ne peux t'aider sous aucun SE sauf si je fais la recherche à ta place.



Modifié par Logicien le 22/05/2019 07:46
Sil33
 Posté le 22/05/2019 à 07:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour.

À tout hasard: ici.

Application fonctionnant sous java ou équivalent (Iced Tea - Open JDK sous Linux).

Ou bien émuler Tyre sous Wine.

m_n
 Posté le 22/05/2019 à 12:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Amanite44 a écrit :

@Logicien, Je ne suis pas opposée à n'avoir que Linux. Mais pour cela il faut que je trouve un logiciel de road trip qui accepte linux. Car j'utilise TYRE qui ne fonctionne pas sous linux... Et j'ai besoin de ce logiciel, ou d'un équivalent.

Ou peut-etre --> Windows 7 avec Linux ..

Mais moi, j'utiliserais boot-Repair .. ( tres utile pour tout Linuxien ) ..

https://sourceforge.net/projects/boot-repair-cd/files/



Modifié par m_n le 22/05/2019 14:27
Publicité
Pages : Début ... 1 2 [3] 4 5 ... Fin
[Début] Page 3 sur 6 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
DualBoot - Pas de démarrage auto sur W10 après suppression de Linux
Linux - Palabres au démarrage
Gestion du menu du chargeur de démarrage UEFI sous GNU/Linux
[TUTO]Linux Mint 17, et l'affichage du Menu Grub au Démarrage.
démarrage multiboot linux et xp
Crée une partition pour installer Linux et ne pas la proposer au démarrage
linux se plante en erreur 1 au démarrage
pas de linux au démarrage
Linux bloque au démarrage
Changer l'ordre de démarrage grub linux Mint 7
Plus de sujets relatifs à Non démarrage de Linux
 > Tous les forums > Forum Linux