× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Linux
 dual boot w10 linux manjaro absence de grub au démarrageSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 3 4 5 ... Fin
Page 1 sur 7 [Fin]
maxfélix
  Posté le 03/04/2020 @ 00:31 
Aller en bas de la page 
Petit astucien

Bonsoir

J'ai installé Linux Manjaro en dual boot avec Windows 10; mais lorsque je démarre le pc, je n'ai pas de grub et le démarrage se fait sur Manjaro; je peux démarrer sur Windows tout de même avec le boot menu et la touche F11. Mais cela est fastidieux et j'aimerai bien pouvoir démarrer avec grub.

Merci de votre attention.

Publicité
m_n
 Posté le 03/04/2020 à 07:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

essaie en terminal

sudo grub-install /dev/sda

sudo grub-mkconfig -o /boot/grub/grub.cfg

ou

sudo grub2-mkconfig -o /boot/grub2/grub2.cfg

Ikewdu_
 Posté le 03/04/2020 à 08:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

Tente les commandes proposées par m_n, mais si l'installation n'a pas détecté Windows une première fois, il y a fort à parier que la mise à jour de grub ne fasse pas mieux.

Tu as les symptômes d'une installation ratée. En deux mots, il n'est pas impossible qu'un de tes OS soit installé en Legacy, et l'autre en UEFI. Et donc, ils ne se voient pas. Le mieux serait de donner un rapport boot-info depuis un liveCD ou liveUSB Ubuntu ou Mint. Tu as ici les détails pour faire ce rapport : https://doc.ubuntu-fr.org/tutoriel/boot-info#installation

Si tu n'y parviens pas, on devra taper les commandes à la main de Fedora, ce qui sera plus fastidieux.

enigma7
 Posté le 03/04/2020 à 08:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

J'espère qu'il avait enlevé le sécure boot au niveau de Windows ... sinon ça lagg .....

Sinon on sait pas si son bios est en UEFI ...

Sinon il y avait déjà des problèmes ici:

https://forum.pcastuces.com/tester_manjaro-f8s16099.htm

Pour mes test en bios legacy Mbr cela avait marché parfaitement

Ikewdu_
 Posté le 03/04/2020 à 09:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Dans ce sujet, maxfelix a tenté un dual boot avec Mint, mais il a été confronté à des soucis de carte graphique : https://forum.pcastuces.com/impossible_de_booter_sur_live_cd_ou_cle_usb_bootable-f8s16108.htm?page=2

Je devine que le passage à Fedora (qui possède une signature reconnue par secure boot) est lié à ce problème. On sait en tout cas que W10 est installé en uefi.

Pour avoir testé cette distribution en dual-boot uefi avec W10, je sais qu'elle pose deux problèmes :

http://ikewdu.free.fr/dual-boot-windows-8-fedora-20-en-uefi/ (désolé pour les captures, mais l'hébergeur a pris sa retraite)

1. Elle tend à créer une 2e partition efi, ce qui pose souci au moment du dual-boot avec Windows.

2. Le fonctionnement de GRUB diffère des dérivées de debian, et on peut avoir des surprises à ce niveau.

Je pense qu'un rapport boot-info montrera clairement le souci et évitera les tâtonnements.



Modifié par Ikewdu_ le 03/04/2020 09:49
enigma7
 Posté le 03/04/2020 à 09:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Ikewdu_ a écrit :

Je devine que le passage à Fedora (qui possède une signature reconnue par secure boot) est lié à ce problème. On sait en tout cas que W10 est installé en uefi.

Si c'est le même PC que l'autre post ... il ferait bien de mettre son profil à jour ou de préciser dans le texte

maxfélix
 Posté le 03/04/2020 à 19:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir et merci pour les réponses .

Je fais dans l'ordre:

@m_n réponse des commandes:

[max@max-manjaro ~]$ sudo grub-install /dev/sda
[sudo] Mot de passe de max :
Installation pour la plate-forme x86_64-efi.
Installation terminée, sans erreur.
[max@max-manjaro ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe : attention : type de périphérique nvme1n1 inconnu.
done
[max@max-manjaro ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg

m_n
 Posté le 03/04/2020 à 19:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je ne voie pas ton Windows

redemarre ton ordi pour voir si le Grub s'est installer ..

sinon .. suis la suggestion de notre ami Ikewdu_ pour faire un rapport de boot-info



Modifié par m_n le 03/04/2020 19:54
Ikewdu_
 Posté le 03/04/2020 à 20:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
m_n a écrit :

sinon .. suis la suggestion de notre ami Ikewdu_ pour faire un rapport de boot-info

Je pense que c'est le plus sage... car je maîtrise beaucoup moins les commandes sous Manjaro que sous Ubuntu pour obtenir les mêmes informations.

Publicité
maxfélix
 Posté le 03/04/2020 à 21:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Les commandes n'ont pas rétabli grub et meme donnent un menu "grub version 2 02 avec message "minimal bash etc...et grub>_

A noter que les commandes ne reconnaissent pas le type de périphérique nvme1n1 qui n'est qu'un SSD_M2 sur lequel est Manjaro.

J'ai donc dû passer par la touche F11 pour choisir le boot manjaro ou le boot windows. les deux démarrages sont possibles.

Je vais donc appliquer les propositions d'ikwedu pour avoir un boot info.

@Ikwedu :

Si je comprends bien Manjaro ne permet pas de faire un boot info de manière simple?

m_n
 Posté le 03/04/2020 à 21:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

le type de périphérique nvme1n1 qui n'est qu'un SSD_M2 sur lequel est Manjaro.

As-tu mis une partition ( swap ) un ( /boot ) , sur ton partitionnement de ton Linux ?

je serais curieux de voir ton GParted ..



Modifié par m_n le 03/04/2020 22:15
maxfélix
 Posté le 03/04/2020 à 22:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Voici la copie de gpartes pour les deux ssd m 2:

Lien vers une image externe

Lien vers une image externe

m_n
 Posté le 03/04/2020 à 23:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

tes liens ne fonctionne pas chez-moi

utilise la petite camera ( kodac ) au haut ici :

maxfélix
 Posté le 03/04/2020 à 23:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

m_n
 Posté le 03/04/2020 à 23:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Well ... cela me depasse .. tes partitions et tes drapeaux me depasse

je ne comprend pas pourquoi que ton /boot/efi sois sur le dev de Windows et qu'il ne sois pas sur ton ssd 2 de Linux

je te laisse avec notre ami Ikewdu_



Modifié par m_n le 04/04/2020 00:06
maxfélix
 Posté le 03/04/2020 à 23:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ok merci tout de même.

Le boot info depuis son lien m'apparait compliqué; la commande m'indique qu'elle n'est pas opérationnelle "not found"; je vais essayer avec l'iso de boot repair sur clé usb mais ce n'est pas gagné.

m_n
 Posté le 03/04/2020 à 23:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Pour boot-info :

As-tu reussi a faire tes updates avec Manjaro ?

Publicité
maxfélix
 Posté le 04/04/2020 à 00:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

oui c'est fait; une chose curieuse manjaro dans le système de fichier en plus de ma clé usb, il m'indique un volume de 105 Mo avec boot, efi, system volume info, boot mgr, bootmgr.efi. aquelle partition ce la renvoie t il?

m_n
 Posté le 04/04/2020 à 00:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Si tu as reussi a faire tes updates

sudo pacman -S boot-info

ou

sudo pacman -Sy boot-info

ou en root ( # ) ;

yay -S boot-info



Modifié par m_n le 04/04/2020 00:28
Ikewdu_
 Posté le 04/04/2020 à 00:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Peux-tu donner le retour des commandes suivantes (c'est moins bien qu'un boot-info, mais bon) :

su - (Pour passer en super-utilisateur)

[ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"

efibootmgr -v

od -tx1z -Ax -N 512 /dev/nvme0n1 | grep -i rub

od -tx1z -Ax -N 512 /dev/nvme1n1 | grep -i rub

ls -lR /boot/efi/EFI/*/*.efi

cat /boot/grub/grub.cfg

cat /boot/efi/EFI/fedora/grub.cfg

blkid

cat /etc/fstab

df -H

fdisk -l

Je ne suis pas sûr que toutes répondent. Tu places le tout dans un fichier texte, tu mets sur cjoint et tu donnés un lien. Je regarderai démain...



Modifié par Ikewdu_ le 04/04/2020 00:43
maxfélix
 Posté le 04/04/2020 à 00:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Il se fait tard; j’essaierai demain tes propositions.

En attendant je poste pour ikwedu le boot info visible à:

http://paste.ubuntu.com/p/dHgyNBHq4j/

maxfélix
 Posté le 04/04/2020 à 00:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

petite erreur de transcription:

http://paste.ubuntu.com/p/dHgyNhbq4j/

Ikewdu_
 Posté le 04/04/2020 à 00:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ton lien ne fonctionne pas.

maxfélix
 Posté le 04/04/2020 à 00:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Ikewdu_
 Posté le 04/04/2020 à 00:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je regarderai demain.

Mon hypothèse n'était pas bonne. Fedora est bien installée. Mais il reste des traces de GRUB ubuntu de ta Mint. Ce sont elles qui mettent le bazar.



Modifié par Ikewdu_ le 04/04/2020 00:51
maxfélix
 Posté le 04/04/2020 à 01:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bien et bonne nuit en ces temps confinés

Publicité
Pages : [1] 2 3 4 5 ... Fin
Page 1 sur 7 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
109,90 €Disque dur Western Digital Red 4 To à 109,90 €
Valable jusqu'au 08 Juin

RueDuCommerce propose actuellement le disque dur Western Digital Red 4 To à 109,90 € avec le code WDRED4 alors qu'on le trouve ailleurs autour de 125 €. Ce disque dur 3.5 pouces SATA III est adapté aux NAS et ordinateurs qui fonctionnent 24h/24.


> Voir l'offre
25,95 €Clé USB Sandisk Ultra 128 Go à double connectique USB 3.1 Type A et C à 25,95 €
Valable jusqu'au 08 Juin

Amazon fait une promotion sur la clé USB Sandisk Ultra 128 Go à double connectique USB 3.1 Type A et C qui passe à 25,95 €. Cette clé USB  dispose d'un connecteur réversible USB Type C et d'un connecteur classique de type A. Grâce à elle, transférez en toute simplicité et rapidement (jusqu'à 150 Mo/s) vos fichiers entre vos smartphones, tablettes et ordinateurs. On la trouve ailleurs à plus de 40 €.


> Voir l'offre
-15 €15 € de réduction à partir de 99 € d'achats chez Rakuten avec le code RAKUTEN15
Valable jusqu'au 07 Juin

Rakuten propose un nouveau un code de réduction permettant d'obtenir 15 € de réduction dès 99 € d'achats sur son site. Pour profiter de cette offre, saisissez le code RAKUTEN15  dans votre panier. 


> Voir l'offre

Sujets relatifs
absence de grub au dual boot Mint W10 19 09:
pas de démarrage sur linux mint dans le grub w10/linux mint
Démarrage d'un prog. au boot de Linux [résolu]
DualBoot - Pas de démarrage auto sur W10 après suppression de Linux
Dual boot W10 - Ubuntu : Démarrage uniquement sur W10
[TUTO]Linux Mint 17, et l'affichage du Menu Grub au Démarrage.
Au secours : j'ai écrasé Windows XP en installant Linux dual boot
pas de linux au démarrage
Message d'erreur BIOS au boot de Linux
Changer l'ordre de démarrage grub linux Mint 7
Plus de sujets relatifs à dual boot w10 linux manjaro absence de grub au démarrage
 > Tous les forums > Forum Linux