× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Linux
 dual boot w10 linux manjaro absence de grub au démarrageSujet résolu
Ajouter un message à la discussion
Pages : 1 [2] 3 4 5 ... Fin
Page 2 sur 7 [Fin]
maxfélix
 Posté le 04/04/2020 à 01:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bien et bonne nuit en ces temps confinés

Ikewdu_
 Posté le 04/04/2020 à 07:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
maxfélix a écrit :

décidement :

http://paste.ubuntu.com/p/dHgyNHBq4j/

Salut,

Ton absence de dual-boot reste un mystère qu'on va devoir résoudre. Je n'ai pour l'instant pas d'explication certaine (mais une petite idée) à ta situation de départ. Mais on va trouver.

On va essayer de prendre les choses dans l'ordre (en espérant que des apprentis bidouilleurs... croisés sur une autre section du forum... ne viennent pas mettre le bazar).On va déjà tenter de régler ton souci de grub rescue>. On a une indication ici :

=================== efibootmgr -v
BootCurrent: 0011
Timeout: 1 seconds
BootOrder: 0006,000E,0000,0011,000B,000F,0010
Boot0000* manjaro	HD(2,GPT,fa2ea4cf-b055-4e7b-a817-5900b7c2e2b2,0x109000,0x31800)/File(EFIMANJAROGRUBX64.EFI)
Boot0006* ubuntu	HD(2,GPT,fa2ea4cf-b055-4e7b-a817-5900b7c2e2b2,0x109000,0x31800)/File(EFIUBUNTUSHIMX64.EFI)
Boot000B* Hard Drive	BBS(HD,,0x0)/VenHw(5ce8128b-2cec-40f0-8372-80640e3dc858,0200)..GO..NO..........S.a.m.s.u.n.g. .S.S.D. .8.6.0. .Q.V.O. .1.T.B....................,.@.r.d.=.X..........A.................................>..Gd-.;.A..MQ..L.4.S.Z.C.F.N.M.0.8.5.9.4.0.9. .W. . . . ........BO..NO..........S.a.m.s.u.n.g. .S.S.D. .8.6.0. .E.V.O. .1.T.B....................,.@.r.d.=.X..........A.................................>..Gd-.;.A..MQ..L.3.S.9.Z.B.N.K.0.8.C.9.9.0.0. .M. . . . ........BO..NO..........S.T.4.0.0.0.D.M.0.0.4.-.2.C.V.1.0.4....................,.@.r.d.=.X..........A.................................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .F.Z.2.N.4.N.G.T........BO..NO..........S.a.m.s.u.n.g. .S.S.D. .9.7.0. .E.V.O. .P.l.u.s. .5.0.0.G.B....................,.@.r.d.=.X..........A...........................%8X.........4..Gd-.;.A..MQ..L.S.4.E.V.N.F.0.M.8.5.0.4.0.0.M........BO..NO..........L.D.L.C. .F.8.+.M...2. .4.8.0....................,.@.r.d.=.X..........A...................................................0..Gd-.;.A..MQ..L.1.0.2.3.2.2.1.9.J.0.2.2.1........BO
Boot000E* Windows Boot Manager	HD(2,GPT,fa2ea4cf-b055-4e7b-a817-5900b7c2e2b2,0x109000,0x31800)/File(EFIMICROSOFTBOOTBOOTMGFW.EFI)..BO

L'ordre de démarrage en Nvram est fait pour booter sur Ubuntu (ce qui est très étonnant après les commandes passées grâce à m_n. On pourrait changer l'ordre directement, mais je pense qu'on a plus intérêt à supprimer les fichiers Ubuntu présents en partition efi au préalable. Et pour ça j'ai besoin que tu passes une série de commandes depuis Windows depuis powershell (tu l'auras par clic droit sur le menu démarrer) en mode admin (c'est le plus simple) :

cmd
mountvol s: /s
dir /a s:\efi

La première commande (qui monte la partition efi) ne doit rien retourner, mais la seconde doit renvoyer une série de plusieurs dossiers. Si tu vois dans le résultat de cette commande apparaître un dossier /ubuntu (ça devrait être le cas), tu passes cette commande :

rd /s s:\efi\ubuntu

Ca supprimera la trace des fichiers grub d'Ubuntu. Et on démonte la partition efi :

mountvol s: /d

A ce stade, tu ne devrais plus avoir de grub rescue>, même si l'entrée Ubuntu (qu'on supprimera ensuite) est encore présente en NVram. Après ça, j'aurai besoin de plusieurs réponses de commandes depuis Fedora pour comprendre ce qui pose ce problème de reconnaissance de Windows.

Edit. Tu devrais même en profiter pour désactiver provisoirement l'hibernation de Windows :

powercfg -h off



Modifié par Ikewdu_ le 04/04/2020 08:11
enigma7
 Posté le 04/04/2020 à 08:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Ikewdu_ a écrit :

Edit. Tu devrais même en profiter pour désactiver provisoirement l'hibernation de Windows :

powercfg -h off

Ca c'est la partie la plus importante. Pas normal que le grub ne nettoie pas les OS qui ont été retirés

Ikewdu_
 Posté le 04/04/2020 à 09:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Tu n'as pas compris (à nouveau). On ne parle pas d'OS. Et Ubuntu a bien été retiré. La commande powercfg a juste la fonction de permettre à Fedora de pouvoir monter la partition Windows, ce qui actuellement n'est pas le cas.

Mais cette fois, je ne vais pas re-polémiquer. Tu veux prendre le sujet selon ton idée, fais-le. Et moi, je laisse tomber. Bye.

enigma7
 Posté le 04/04/2020 à 09:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Ikewdu_ a écrit :

Re,

Tu n'as pas compris (à nouveau). On ne parle pas d'OS. Et Ubuntu a bien été retiré. La commande powercfg a juste la fonction de permettre à Fedora de pouvoir monter la partition Windows, ce qui actuellement n'est pas le cas.

Mais cette fois, je ne vais pas re-polémiquer. Tu veux prendre le sujet selon ton idée, fais-le. Et moi, je laisse tomber. Bye.

Oula ne prends pas la mouche ...

J'avais écrit au début qu'il fallait retirer le serure boot au niveau de Windows, mais t'as du 'sauter' dessus.

J'ai écrit également au début que je n'étais pas en UEFI donc, t'inquitte pas, je te 'laisse' le sujet. Si on a plus le droit de faire des commentaires, je savais pas que t'étais suceptible à ce point .Je ferai attention à l'avenir



Modifié par enigma7 le 04/04/2020 09:13
Ikewdu_
 Posté le 04/04/2020 à 09:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Alors tais-toi.

Et si on ne trouve pas la cause et donc la solution, ce qui est très possible, (je ne prétends pas tout connaître et tout pouvoir résoudre), tu pourras mener toutes les expériences hasardeuses que tu veux . Mais la cacophonie qui domine sur PCA depuis quelques jours commence vraiment à me saouler. Je vois que tu l'as bien compris. Faire des commentaires est une chose, brouiller les pistes en est une autre. Je n'ai pas interrompu m_n dans sa tentative de réécrire les fichiers GRUB. La piste était bonne et devait être tentée.

Quant à la question du boot-secure, j'y ai répondu. Il fallait lire.



Modifié par Ikewdu_ le 04/04/2020 09:24
enigma7
 Posté le 04/04/2020 à 09:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Amen et termines .

Moi aussi Il y a des choses qui m'énervent mais je ne les déballes pas, je me concentre sur le sujet



Modifié par enigma7 le 04/04/2020 09:57
maxfélix
 Posté le 04/04/2020 à 15:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à tous deux.

Pas la peine de s'énerver; la vraie cause de tout ceci c'est moi ; j'ai comme l'intuition que je n'ai pa

Publicité
m_n
 Posté le 04/04/2020 à 15:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Moi, je bouge pour me calmer les nerfs ..

maxfélix
 Posté le 04/04/2020 à 16:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

(suite) pas fait mes installations de Mint et/ou de Manjaro comme il faut.

Lors de ma dernière installation de Manjaro je pense que j'ai affublé la partition efi de mon ssd_m2 windows d'un mauvais paramétrage(sans doute grub boot mais je ne me souviens plus très bien) si cela peut éclairer le problème.

Une autre observation me vient aussi du logiciel aomei backupper pro; alors qu'auparavant lors des sauvegardes système il reconnaissait dans les sources , la partition efi du meme ssd, il ne la reconnaît plus maintenant et renvoie l'erreur 4098; donc il n'y a plus de sauvegarde possible. Peut être est ce lié au problème d'absence de grub correct.

Que faut il faire? suivre la démarche d'ikwedu en premier?

Tenter le début d’une installation de Manjaro pour repérer ce que j'ai pu inscrire comme paramètre sur la partition efi; il me semble que c'est possible de le faire avant d'embarquer l'installation définitive; ceci permettrait peut etre de voir ce qui a flanché.

S'il faut refaire une installation Manjaro correcte pour solutionner le problème je suis pret à la refaire si nécessaire après m'este informé dans un forum manjaro de tout ce qui est correct à faire.

Ikewdu_
 Posté le 04/04/2020 à 16:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je te donne mon opinion.

Réinstaller ne fera qu'ajouter une couche au problème. Je t'ai donné une première série de commandes à faire pour virer les traces de GRUB d'Ubuntu (qui demeurera là si tu réinstalles). A toi de voir si tu veux le faire ou non.

Après, on pourra voir ce dual-boot avec sérénité. Et s'il faut réinstaller, il sera toujours temps. Pour le reste, tu as mis, je pense, le doigt sur le problème, (c'est aussi ce à quoi je pensais). La partition efi est associée au type bios-grub (c'est un type de partition qu'on utilise pour faire booter un Linux en Legacy sur un disque gpt ; linux a cette souplesse). De là à déduire que ta Manjaro boote en legacy, il n'y a qu'un pas. La version de GRUB détectée étant grub-pc, on peut presque en être certain. La bizarrerie, chez toi, c'est qu'elle est liée à la partition efi. La partition 3 pose aussi problème avec son format fat32. Tout est ici :

BYT;
/dev/nvme0n1:500GB:unknown:512:512:gpt:Unknown:;
1:1049kB:556MB:555MB:ntfs:Basic data partition:hidden, diag;
2:556MB:660MB:104MB:fat32:EFI system partition:bios_grub;
3:660MB:676MB:16.8MB:fat32:Microsoft reserved partition:msftres;
4:676MB:500GB:499GB:ntfs:Basic data partition:msftdata;


Modifié par Ikewdu_ le 04/04/2020 16:42
maxfélix
 Posté le 04/04/2020 à 19:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

résultats des deux premières commandes:

Microsoft Windows [version 10.0.18363.720]
(c) 2019 Microsoft Corporation. Tous droits réservés.

C:\Users\grand>cmd
Microsoft Windows [version 10.0.18363.720]
(c) 2019 Microsoft Corporation. Tous droits réservés.

C:\Users\grand>mountvol s: /s
Le fichier spécifié est introuvable.

C:\Users\grand>

maxfélix
 Posté le 04/04/2020 à 19:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

et en plus complet:

Windows PowerShell
Copyright (C) Microsoft Corporation. Tous droits réservés.

Testez le nouveau système multiplateforme PowerShell https://aka.ms/pscore6

PS C:\Users\grand> mountvol s: /s
Le fichier spécifié est introuvable.
PS C:\Users\grand> dir /a s:\efi
dir : Impossible de trouver le chemin d'accès « C:\a », car il n'existe pas.
Au caractère Ligne:1 : 1
+ dir /a s:\efi
+ ~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (C:\a:String) [Get-ChildItem], ItemNotFoundException
+ FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.GetChildItemCommand

PS C:\Users\grand>

maxfélix
 Posté le 04/04/2020 à 19:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Windows PowerShell
Copyright (C) Microsoft Corporation. Tous droits réservés.

Testez le nouveau système multiplateforme PowerShell https://aka.ms/pscore6

PS C:\Users\grand> mountvol s: /s
Le fichier spécifié est introuvable.
PS C:\Users\grand> dir /a s:\efi
dir : Impossible de trouver le chemin d'accès « C:\a », car il n'existe pas.
Au caractère Ligne:1 : 1
+ dir /a s:\efi
+ ~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (C:\a:String) [Get-ChildItem], ItemNotFoundException
+ FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.GetChildItemCommand

PS C:\Users\grand

Ikewdu_
 Posté le 04/04/2020 à 20:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ton erreur est ici :

PS C:\Users\grand>

Tu n'as pas lancé Powershell en mode admin. Donc, c'est forcément refusé.

maxfélix
 Posté le 04/04/2020 à 21:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ce sont les memes réponses:

Windows PowerShell
Copyright (C) Microsoft Corporation. Tous droits réservés.

Testez le nouveau système multiplateforme PowerShell https://aka.ms/pscore6

PS C:\Windows\system32> cmd
Microsoft Windows [version 10.0.18363.720]
(c) 2019 Microsoft Corporation. Tous droits réservés.

C:\Windows\system32>mountvol s: /s
Le fichier spécifié est introuvable.

C:\Windows\system32>dir /a s:\ef
Le chemin d’accès spécifié est introuvable.

C:\Windows\system32>

Publicité
Ikewdu_
 Posté le 04/04/2020 à 21:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Lance dans la zone de recherche la commande

msinfo32

Dis-moi si tu vois apparaître mode hérité ou uefi. Comme ici :

https://www.easyuefi.com/images/resource/msinfo32-uefi-bios-mode.png



Modifié par Ikewdu_ le 04/04/2020 21:45
maxfélix
 Posté le 04/04/2020 à 21:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

c'est mode UEFI

Ikewdu_
 Posté le 04/04/2020 à 21:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Alors, il y a vraiment quelque chose qui cloche sur ta partition efi. On va faire autrement :

diskpart
sel disk 0
sel part 2
assign letter=S
exit

dir s:\efi

Et tu ne fermes pas l'invite de commandes.

maxfélix
 Posté le 04/04/2020 à 21:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Microsoft Windows [version 10.0.18363.720]
(c) 2019 Microsoft Corporation. Tous droits réservés.

C:\Users\grand>diskpart

C:\Users\grand>dir s:\efi
Le chemin d’accès spécifié est introuvable.

C:\Users\grand>

Ikewdu_
 Posté le 04/04/2020 à 21:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Tu loupes quelques lignes... et tu n'es plus en mode admin.... On est mal partis...

Si tu n'y arrives pas, on va agir depuis Manjaro.



Modifié par Ikewdu_ le 04/04/2020 22:01
maxfélix
 Posté le 04/04/2020 à 22:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Voilà pour diskpart:

Windows PowerShell
Copyright (C) Microsoft Corporation. Tous droits réservés.

Testez le nouveau système multiplateforme PowerShell https://aka.ms/pscore6

PS C:\Windows\system32> diskpart

Microsoft DiskPart version 10.0.18362.1

Copyright (C) Microsoft Corporation.
Sur l’ordinateur : DESKTOP-JB35V9R

DISKPART> sel disk 0

Le disque 0 est maintenant le disque sélectionné.

DISKPART> sel part 2

La partition 2 est maintenant la partition sélectionnée.

DISKPART> assign letter=S

Aucun volume n’est spécifié.
Sélectionnez un volume et essayez à nouveau.

DISKPART>

Ikewdu_
 Posté le 04/04/2020 à 22:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bon, on n'arrivera à rien depuis Windows. Tu vas démarrer sur ta Manjaro.

Tu vas lancer gparted, et tu cliques droit sur la partition efi du premier disque Nvme0n1 (c'est la partition 2, d'après gparted). Tu modifies les drapeaux pour attribuer à cette partition les drapeaux boot et esp .

Puis tu lances un terminal. Tu me donnes le retour des commandes

ls /boot/efi/efi/*/*.efi

cat /etc/fstab

cat /boot/grub/grub.cfg



Modifié par Ikewdu_ le 04/04/2020 22:11
maxfélix
 Posté le 04/04/2020 à 22:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

[max@max-manjaro ~]$ ls /boot/efi/efi/*/*.efi
ls: impossible d'accéder à '/boot/efi/efi/*/*.efi': Permission non accordée
[max@max-manjaro ~]$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
UUID=4C19-BBC8 /boot/efi vfat umask=0077 0 2
UUID=15f1970f-2dd3-4df6-9c54-e5ef9a12b024 / ext4 defaults,noatime 0 1
UUID=6dcdaf45-694d-471e-9e32-4f1ea85946b7 /home ext4 defaults,noatime 0 2
[max@max-manjaro ~]$ cat /boot/grub/grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
load_env
fi
if [ "${next_entry}" ] ; then
set default="${next_entry}"
set next_entry=
save_env next_entry
set boot_once=true
else
set default="${saved_entry}"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
menuentry_id_option="--id"
else
menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
set saved_entry="${prev_saved_entry}"
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z "${boot_once}" ]; then
saved_entry="${chosen}"
save_env saved_entry
fi
}

function load_video {
if [ x$feature_all_video_module = xy ]; then
insmod all_video
else
insmod efi_gop
insmod efi_uga
insmod ieee1275_fb
insmod vbe
insmod vga
insmod video_bochs
insmod video_cirrus
fi
}

set menu_color_normal=light-gray/black
set menu_color_highlight=green/black

if [ x$feature_default_font_path = xy ] ; then
font=unicode
else
insmod part_gpt
insmod ext2
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
else
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
fi
font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
set gfxmode=auto
load_video
insmod gfxterm
set locale_dir=$prefix/locale
set lang=fr_FR
insmod gettext
fi
terminal_input console
terminal_output gfxterm
insmod part_gpt
insmod ext2
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
else
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
fi
insmod gfxmenu
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_12.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_14.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_16.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_24.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_48.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_bold_16.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_mono_12.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-12.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-14.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-16.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-18.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-b12.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-b14.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-b16.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-b18.pf2
insmod png
set theme=($root)/usr/share/grub/themes/manjaro/theme.txt
export theme
if [ x$feature_timeout_style = xy ] ; then
set timeout_style=hidden
set timeout=10
# Fallback hidden-timeout code in case the timeout_style feature is
# unavailable.
elif sleep --interruptible 10 ; then
set timeout=0
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-15f1970f-2dd3-4df6-9c54-e5ef9a12b024' {
savedefault
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
else
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
fi
linux /boot/vmlinuz-5.4-x86_64 root=UUID=15f1970f-2dd3-4df6-9c54-e5ef9a12b024 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
}
submenu 'Advanced options for Manjaro Linux' $menuentry_id_option 'gnulinux-advanced-15f1970f-2dd3-4df6-9c54-e5ef9a12b024' {
menuentry 'Manjaro Linux (Kernel: 5.4.28-1-MANJARO x64)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.4.28-1-MANJARO x64-advanced-15f1970f-2dd3-4df6-9c54-e5ef9a12b024' {
savedefault
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
else
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
fi
linux /boot/vmlinuz-5.4-x86_64 root=UUID=15f1970f-2dd3-4df6-9c54-e5ef9a12b024 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
}
menuentry 'Manjaro Linux (Kernel: 5.4.28-1-MANJARO x64 - fallback initramfs)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.4.28-1-MANJARO x64-fallback-15f1970f-2dd3-4df6-9c54-e5ef9a12b024' {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
else
search --no-floppy --fs-uuid --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
fi
linux /boot/vmlinuz-5.4-x86_64 root=UUID=15f1970f-2dd3-4df6-9c54-e5ef9a12b024 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/initramfs-5.4-x86_64-fallback.img
}
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f ${config_directory}/custom.cfg ]; then
source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f $prefix/custom.cfg ]; then
source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

### BEGIN /etc/grub.d/60_memtest86+ ###
if [ "${grub_platform}" == "pc" ]; then
menuentry "Memory Tester (memtest86+)" --class memtest86 --class gnu --class tool {
search --fs-uuid --no-floppy --set=root 15f1970f-2dd3-4df6-9c54-e5ef9a12b024
linux16 /boot/memtest86+/memtest.bin
}
fi
### END /etc/grub.d/60_memtest86+ ###
[max@max-manjaro ~]$

Ikewdu_
 Posté le 04/04/2020 à 22:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Essaie :

sudo ls /boot/efi/efi/*/*.efi

Publicité
Pages : 1 [2] 3 4 5 ... Fin
Page 2 sur 7 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
72,10 €Kit de 16 Go (2 x 8 Go) de mémoire DDR4 Corsair Vengeance LPX 3000 MHz à 72,10 € livré
Valable jusqu'au 09 Juin

Amazon Allemagne fait une promotion sur le kit de 16 Go (2x8 Go) de mémoire DDR4 Corsair Vengeance LPX 3000 MHz qui passe à 67,46 € (avec la TVA ajustée). Comptez 4,64 € pour la livraison en France soit un total de 72,10 € livré alors qu'on le trouve ailleurs à plus de 95 €.

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douanes. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre
-15%15% de réduction sur les écrans ViewSonic chez Materiel.net
Valable jusqu'au 07 Juin

Materiel.net offre actuellement 15% de remise immédiate sur tous les écrans ViewSonic de son catalogue. Utilisez pour cela le code BUTIN dans votre panier.


> Voir l'offre
101,20 €Lot de 2 disques durs Western Digital Blue 2 To à 101,20 € livré
Valable jusqu'au 08 Juin

Amazon Allemagne propose actuellement le lot de 2 disques durs Western Digital Cavier Blue 2 To à 95,10 € (avec la TVA ajustée). Comptez 6,10 € pour la livraison en France soit un total de 101,20 € livré. On les trouve ailleurs à l'unité à plus de 72 € pièce. Pour profiter de l'offre, ajoutez 2 disques durs vendus par Amazon à votre panier. Les remises sont automatiquement appliquées sur la page de confirmation de commande.


> Voir l'offre

Sujets relatifs
absence de grub au dual boot Mint W10 19 09:
pas de démarrage sur linux mint dans le grub w10/linux mint
Démarrage d'un prog. au boot de Linux [résolu]
DualBoot - Pas de démarrage auto sur W10 après suppression de Linux
Dual boot W10 - Ubuntu : Démarrage uniquement sur W10
[TUTO]Linux Mint 17, et l'affichage du Menu Grub au Démarrage.
Au secours : j'ai écrasé Windows XP en installant Linux dual boot
pas de linux au démarrage
Message d'erreur BIOS au boot de Linux
Changer l'ordre de démarrage grub linux Mint 7
Plus de sujets relatifs à dual boot w10 linux manjaro absence de grub au démarrage
 > Tous les forums > Forum Linux