> Tous les forums > Forum Linux
 Installation de logiciel
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mikevive
  Posté le 28/07/2005 @ 16:51 
Aller en bas de la page 
Petit astucien
Bonjour, Je n'arrive pas a installer des programmes compatibles avec Linux,j'ai toujours un message d'erreur. Cela est-il du a ma version gratuite de Mandriva Linux 2005,ce n'est pas facile aprés pas mal d'années avec Windows.J'ai beau cherché je ne trouve pas... Merci à ceux qui peuvent m'éclairer. @ +
Publicité
palace
 Posté le 28/07/2005 à 17:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Salut Mikevive Va voir la,sur PCAstuces. [url]https://forum.pcastuces.com/sujet.asp?SUJET_ID=156853[/url] A+
deejill
 Posté le 29/07/2005 à 00:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
luteola
 Posté le 29/07/2005 à 00:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
allez tien le mien aussi :-) http://www.guidelinux.org/articles.php?lng=fr&pg=70 c'est pas très dur tu verras. et une fois fait, c'est fini les embrouilles... a+
Mikevive
 Posté le 01/08/2005 à 23:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Bonsoir les linuxiens Pour les fichiers *.*.rpm j'ai réussi a en installer deux : emiclock-1.0.4-1.src.rpm et IglooFTP-PRO-1.2.4-1.i386.rpm je ne sais pas ou? mais je n'ai pas eu de message d'erreurs. Par contre pour ce fichier ça ne marche pas : jre-1_5_0_04-linux-i586-rpm.bin Ce message:KWrite - Le gestionnaire de panne de KDE.Mais j'insiste à fond. @ + et merci
luteola
 Posté le 02/08/2005 à 00:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Bjour, Pour le java, c'est normal, ce n'est pas un fichier rpm mais rpm.bin. Il est encapsulé, si tu préfères. Pour le 'libérer', il faut avant faire en console : cd /chemin_vers_le_fichier sh nom_du_fichier (sert toi de la touche TAB pour l'autocomplétion du nom du fichier dès que quelques lettres sont écrites) Tu réponds alors au blabla légal de Sun (yes) et tu obtient le rpm. Que tu peux alors installer facilement. Bon, sinon, as-tu configuré urpmi en lui ajoutant des sources Internet ? C'est tellement simple après pour installer des logiciels. Peux tu s'il te plait, taper dans une console cat /etc/urpmi/urpmi.cfg et me coller le résultat. On verra bien. Si tu ne l'a pas fait, je te recommande le passage de mon [url="http://www.guidelinux.org/articles.php?lng=fr&pg=70"]article[/url] qui parle de l'ajout de sources Internet à Urpmi. Tu comprendras vite qu'après, les embrouille sont finies... Je crois que tu le record de sagesse sur ce forum. Bravo, je trouve ca extraordinaire que des gens de ta génération se mettent à Linux. Mon père lui fait toujours de la résistance :-) a+
Shaika-Dzari
 Posté le 02/08/2005 à 00:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Bonsoir Mikevive, Pour installer ton plugins java, tu vas devoir suivre ces étapes: 1- ouvre une console (tv noir) 2- met toi en root (commande su + mot de passe) 3- Rend toi ou est ton java télécharger ( cd /home/mikevive/ s'il est dans ton /home/user) 4-tape: chmod a+x jre-1_5_0_04-linux-i586-rpm.bin 5-tape: ./jre-1_5_0_04-linux-i586-rpm.bin 6- termine avec: rpm -iv jre-1_5_0_04-linux-i586-rpm Info: [url]http://java.sun.com/j2se/1.5.0/install-linux.html[/url] Cela dit, si tu as configurer tes sources pour urpmi selon les conseils nommé plus haut, tu pourrait tout simplement essayer ceci en console (toujours root): urpmi jre @+ Edit: grilled [pleurer]

Modifié par Shaika-Dzari le 02/08/2005 00:21
luteola
 Posté le 02/08/2005 à 00:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Shaika-Dzari a écrit : Edit: grilled [pleurer]
[langue] Ca fait du bien de te revoir ici shaika-dzari... Si ca peut te consoler, ton explication était meilleure... Tu rend le truc executable et tout et tout en console... [bierre] a+
chtijean
 Posté le 02/08/2005 à 17:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir! Pouvez vous m'otez d'un doute: j'ai fait la manip urpmi jre et ca m'affiche d'installer les dependances suivantes: -kaffe-1.1.4-3 mdki586 -libgmp3-4.1.3-2 mdk i586 est ce normal car jusqu'a maintenant je faisais l'install suivant la methode de sun? par contre est ce que libjavaplugin_so s'installe automatiquement ou je dois faire manuellement un lien vers ff? (je suis penible hein[rougir]) Merci et bonne soiree!!
Mikevive
 Posté le 02/08/2005 à 18:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
bonjour luteola En tapant ta commande dans la console j'ai ceci: [michel@Mon_pc ~]$ cat/etc/urpmi/urpmi.cfg bash: cat/etc/urpmi/urpmi.cfg: No such file or directory [michel@Mon_pc ~]$ Peut être que le i586 ne peut s'installer vu que j'ai un AMD d'après ce que j'ai lu sur ton site .Comment voit-on la version de Linux ? En administrateur: [michel@Mon_pc ~]$ su Password: [root@Mon_pc michel]# @ +

Modifié par Mikevive le 02/08/2005 18:44
deejill
 Posté le 02/08/2005 à 18:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Bonjour Mikevive tape en konsole
uname -a
ou
uname -r
pour la version succinte...

Modifié par deejill le 02/08/2005 19:07
webby
 Posté le 02/08/2005 à 21:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
salut .. pour installer quelque chose , il faut que tu te mettre , en root ( # ) qui veut dire (super administrateur), et non en simple utilisateur ( $ ) comme t'a vu , quand tu ecrit , su > enter password > enter tu voie ton (#) c'est-a-dire, ton (root) , apparaitre .. et la, tu peux ecrire ( urpmi nom_d'un_logiciel_désiré) a + + .. [clindoeil]
luteola
 Posté le 02/08/2005 à 21:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
salut tout le monde, mikevive, désolé pour la commande inexacte, j'ai l'impression que les fichiers ont changé... Ca devait s'appeller /etc/urpmi/list.cfg je crois (maintenant c'est /etc/urpmi/urpmi.cfg). donc fait cat /etc/urpmi/list.cfg. Au pire, rend toi dans ce dossier (konqueror) et inspecte les fichiers. Bref, cette commande affiche la liste des sources dans lesquels urpmi (l'installateur automatique de paquetages) recherche. C'était donc pour savoir si tu avait ajouté ces fameux serveurs internet. Je le répète, le but est d'ajouter des serveurs qui contiennent des milliers d'applications pour ta distro et ton processeur. C'est donc absolumment nécessaire pour ne plus s'embeter... Tu dis avoir un AMD mais il faut que tu nous dises si c'est un AMD 64 bits (x86_64) ou 32 bits (i686). Dans ce dernier cas, tu peux ajouter des serveurs pour i386, i486, i586, ce serat compatible dans ce sens. Par contre pour 64 bit, il faut prendre les serveurs adhoc. Voila, lis bien mon tuto sur l'ajour de serveur. Va sur le site d'easyurpmi, ajoute tes serveurs et tu seras un homme heureux :-) En attendant, la commande # urpmi nom_soft n'ira rechercher que sur des disques d'installations. C'est bien mais les serveurs sont plus complets et bien plus à jour. Esperant t'avoir aidé ;-) a+
Mikevive
 Posté le 02/08/2005 à 23:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Bonsoir tout le monde Oui vous m'aidez de toute façon,je sais ou chercher avec vos conseils,ma version est correct car mon processeur est bien un AMD 32 bits [michel@Mon_pc ~]$ uname -a Linux Mon_pc 2.6.11-6mdk #1 Tue Mar 22 16:04:32 CET 2005 i686 AMD Athlon(tm) XP3000+ unknown GNU/Linux Encore merci et à bientot
Mikevive
 Posté le 02/08/2005 à 23:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Rebonsoir Avec la manip de luteola j'ai enfin réussi à installer le fichier jre [michel@Mon_pc ~]$ su Password: [root@Mon_pc michel]# /home/michel bash: /home/michel: is a directory [root@Mon_pc michel]# sh jre-1_5_0_04-linux-i586-rpm.bin Sun Microsystems, Inc. Binary Code License Agreement for the JAVA 2 PLATFORM STANDARD EDITION RUNTIME ENVIRONMENT 5.0 SUN MICROSYSTEMS, INC. ("SUN") IS WILLING TO LICENSE THE SOFTWARE etc............. @ +

Modifié par Mikevive le 02/08/2005 23:24
Poupine
 Posté le 03/08/2005 à 19:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien
[boom]Je craque.[boom] J'essaie d'installer le package tk v 8.3.3 et quand je tape make, il m'affiche ca: {standard input}: Assembler messages: {standard input}:653: Error: symbol `cosine' is already defined as "*COM*"/8 {standard input}:671: Error: symbol `dy' is already defined {standard input}:677: Error: symbol `dx' is already defined {standard input}:724: Error: symbol `q' is already defined {standard input}:730: Error: symbol `p' is already defined {standard input}:736: Error: symbol `q' is already defined {standard input}:742: Error: symbol `q' is already defined make: *** [tk3d.o] Erreur 1 Aidez moi svp paskeu la jcrois ke ma tete va exploser [bombe] En plus, c pas le 1er truc ke j'arrive pas a installer. J'essaier d'installer terminatorx (platine dj virtuelle), et il me dit x11-libs not installed or broken.[pleurer] Aidez moi svp, sinon je sens que jvais faire un "ordicide" [enerve] Merci d'avance.
Shaika-Dzari
 Posté le 03/08/2005 à 20:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Bonjour/bonsoir poupine. Je veux bien t'aider mais tu vas devoir me fournir plus de détails. Ton profil d'ordi (carte mère, hdd, cg etc...), ta distribution linux que tu utilise... Et je crois que pour de meilleur résultats un nouveau poste juste pour toi serait mieux. Normalement tk est disponible pour tout les distributions qui utilise les paquetage donc, tu n'auras pas besoin de te casser la tête avec une compilation... Une simple commande devrait pouvoir t'installer ça... @+
Poupine
 Posté le 03/08/2005 à 21:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien
Euh alors j'utilise mandrake 10.1, par contre pour tout ski est hardware c mon frere ki a choisi et il est pas chez moi :/ (il revient dans 6 mois). En fait je peux lancer mes applications tk avec wish mais le truc la c ke jveux rajouter un paquet (snack >>>>> c pour rajouter du son à tcl/tk) et i fo les paquets tcl (ke jai reussi a installer sans blem) et tk ki me met le message d'erreur :/. Et puis pour x11-libs, j'ai regardé et il est bien installé :/. J'espere ke tu pourras maider. @++
Shaika-Dzari
 Posté le 04/08/2005 à 01:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Poupine a écrit :
Euh alors j'utilise mandrake 10.1, par contre pour tout ski est hardware c mon frere ki a choisi et il est pas chez moi :/ (il revient dans 6 mois). En fait je peux lancer mes applications tk avec wish mais le truc la c ke jveux rajouter un paquet (snack >>>>> c pour rajouter du son à tcl/tk) et i fo les paquets tcl (ke jai reussi a installer sans blem) et tk ki me met le message d'erreur :/. Et puis pour x11-libs, j'ai regardé et il est bien installé :/. J'espere ke tu pourras maider. @++
Bon, premièrement mandrake est une distribution à base de rpm, donc tu ne devrait pas passer par la compilation de logiciels car ton systême va rapidement devenir instable. Pour installer tk (dans l'ordre): 1- ouvre une console 2- met toi en root (commande su + mot de passe) 3- tape: urpmi tk Voilà! C'est tout... Si ça marche pas avec ces commande va faire un tour ici et suis les étape: [url]http://easyurpmi.zarb.org[/url] C'est pour configurer comme il le faut ton urpmi(installeur) comme il le faut. Avec ces miroirs d'ajouter, un simple urpmi nom_du_logiciel suffit à l'installer. Il faut évidemment que tu sois branché à internet... Maintenant si ça marche pas, refait un autre post juste pour ton problême car c'est le topic de notre ami Mikevive[smile] ha! Sans être méchant, essais de te forcer un peu pour l'écriture...c'est dur à lire...n'oublie pas que le langage sms est interdit sur ce forum. @+
Poupine
 Posté le 04/08/2005 à 19:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien
Merci pour le tuyau Shaika-Dzari :). Je pense que maintenant, je vais pouvoir me débrouiller. [merci] @+++ PS: Tu as vu, j'ai bien écrit cette fois [bigsmile]. PS²: Heureusement que tu n'es pas à côté de moi, sinon je t'aurais embrassé [smack][lol]
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
51,99 €Barre de son bluetooth Philips TAB5105 à 51,99 €
Valable jusqu'au 22 Janvier

Cdiscount fait une promotion sur la barre de son bluetooth Philips TAB5105 qui passe à 51,99 € alors qu'on la trouve ailleurs à partir de 80 €. Cette barre de son intègre 2 haut-parleurs 2x15W et peut lire vos musiques sans fil via Bluetooth. Une entrée audio jack 3.5 mm et optique TOSLINK sont également présentes. Compatible HDMI ARC, vous pourrez contrôler la barre de son à l'aide de la télécommande de votre téléviseur. Elle est suffisamment fine pour se glisser sous la plupart des téléviseurs. Vous pouvez également la fixer au mur à l'aide des supports intégrés.


> Voir l'offre
399 €Smartphone 6.67 pouces Xiaomi Mi 11i (5G, 256Go, 8Go) à 399 €
Valable jusqu'au 22 Janvier

Boulanger fait une superbe promotion sur le smartphone 6.67 pouces Xiaomi Mi 11i qui passe à 399 € au lieu de 499 €. Ce smartphone très bien équipé est compatible 5G, possède un processeur Snapdragon 888 à 8 coeurs, un écran FHD+ (2400x1080) à 120 Hz, 256 Go de stockage extensible par microSD, 8 Go de ram, 4 capteurs photos 108 mégapixels + 20 mégapixels + 8 mégapixels + 5 mégapixels et une caméra avant à 20 mégapixels. Le tout tourne sous Android 11.


> Voir l'offre
259,99 €Ecran PC 27 pouces Gigabyte M27Q (QHD, IPS, 0.5 ms, 170 Hz) à 259,99 €
Valable jusqu'au 24 Janvier

RueDuCommerce solde l'écran PC 27 pouces Gigabyte M27Q qui passe à 259,99 € au lieu de 340 €. Cet écran possède une dalle 27 pouces QHD (2560x1440) à 0.5 ms et à 170 Hz (FreeSync Premium et Adaptive Sync). Son pied est réglable en hauteur et en inclinaison.


> Voir l'offre

Sujets relatifs
Installation logiciel sous ubuntu
probleme installation de logiciel ubuntu 8.04
Installation d'un logiciel
installation logiciel
installation logiciel
installation de logiciel
Installation de Logiciel sous Linux
installation logiciel rpm
installation de nouveau logiciel
probleme d installation logiciel ramboost xp
probleme d'installation de logiciel
Plus de sujets relatifs à Installation de logiciel
 > Tous les forums > Forum Linux