> Tous les forums > Forum Bureautique
 Supprimer le 0 pour rendre la cellule vide
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Labougie
  Posté le 11/04/2013 @ 00:58 
Aller en bas de la page 
Groupe Sécurité

Bonsoir,

Je me gratte la tête pour trouver la formule qui rend une cellule vide avec les heures.

si j'utilise cette formule =SI(E5>=("5:"*1);1;)

La cellule affichera un joli 0

Et je n'aime pas le 0, je trouve plus joli quand la cellule est vide.

Il en est de même pour celle-ci

=SOMME.SI.ENS(BDD!E:E;BDD!$B:$B;'Récap Mois'!$B5;BDD!$A:$A;'Récap Mois'!$A5)

Cette formule somme des heures (hh:mm:ss) en se basant sur le mois (pour référence).

BDD = base de données

Mon tableau est joli, mais il est rempli de 00:00:00 est ce n'est pas très séduisant et surtout très lourd à regarder

Merci

Labougie

Publicité
Magnan
 Posté le 11/04/2013 à 05:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

tu as lapossibilité de ne pas afficher les 0 en décochant dans OPTIONS, mais on aparfois besoin de 0 dans une feuille.

Sinon dans ta formaule : =SI(E5>=("5:"*1);1;) tu peux la completer : =SI(E5>=("5:"*1);1;"")

et dans la 2 iéme : =si(SOMME.SI.ENS(BDD!E:E;BDD!$B:$B;'Récap Mois'!$B5;BDD!$A:$A;'Récap Mois'!$A5)="00:00:00";"";SOMME.SI.ENS(BDD!E:E;BDD!$B:$B;'Récap Mois'!$B5;BDD!$A:$A;'Récap Mois'!$A5))

A+

qmike549
 Posté le 11/04/2013 à 06:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

oui une solution masquer la cellule

http://michel.vergriete.perso.sfr.fr/62excel.html

Labougie
 Posté le 11/04/2013 à 10:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

Magnan,

Tes 2 propositions ne fonctionnent pas

La 1ere, ta proposition est la mienne sont identiques.

La scde retourne une erreur.

Je rapelle qu'ici je travaille sur des hh:mm:ss rien à voir avec des cellules contenant des nombre, qui eux sont facilement dissimulables

QMike,

Je vais regarder ta proposition et te dis quoi ensuite.

labougie

vieuxmonsieur
 Posté le 11/04/2013 à 10:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonjour,

catte formule =SI(E5>=("5:"*1);1;"") fonctionne parfaitement bien et repond a ta demande

Labougie
 Posté le 11/04/2013 à 10:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

Qmike,

Cette méthode

Première solution- Masquez tous les zéros de la feuille

  • Sélectionnez Menu Outils Options
  • Sélectionnez l'onglet Affichage
  • Décochez la zone Valeurs zéro

Fonctionne à merveille

VieuxMonsieur,

Je vais retester suivant ta remarque .

labougie

Labougie
 Posté le 11/04/2013 à 10:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

vieuxmonsieur a écrit :

bonjour,

catte formule =SI(E5>=("5:"*1);1;"") fonctionne parfaitement bien et repond a ta demande

Je viens de refaire mon test,

Je n'ai pas donnée toutes les infos, oui elle fonctionne pour supprimer le 0, autant pour moi.

Mais les cellules sont liés à une MFC, du coup si ma cellule est vide, (pas de chiffre) elle se colorie, alors qu'elle ne devrait se colorier qu'avec => 1 .

En revanche c'est plus compliqué pour les cellules dont la composition est de la forme [h]:mm:ss

Labougie

DjiDji59430
 Posté le 11/04/2013 à 11:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Labougie a écrit :

Mais les cellules sont liés à une MFC, du coup si ma cellule est vide, (pas de chiffre) elle se colorie, alors qu'elle ne devrait se colorier qu'avec => 1 .

Labougie

C'est que tes conditions sont mauvaises !

"qu'avec => 1", c'est seulement 1 et pas 1 ou ""

De plus, un vieux briscard comme toi, je suis étonné que tu ne joignes pas ton fichier pour qu'on puisse t'aider efficacement dessus !



Modifié par DjiDji59430 le 11/04/2013 11:58
Labougie
 Posté le 11/04/2013 à 11:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

DjiDJi,

le document

Pour remplir ce document, il faut utiliser l'onglet BDD.

L'on rempli seulement les cellules

  • Heures et trajet "pour chaques auteurs"
  • Pour donner un nom remplir les cellules E2 H2 K2 ...

Je planche sur la synthèse annuelle, qui pourrait être simple, si les recopies se faisaient comme je le souhaite.

En plus j'ai du changer la présentation de l'onglet Annuel

Labougie

/!\ le fichier est lourd

Publicité
DjiDji59430
 Posté le 11/04/2013 à 19:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

http://cjoint.com/13av/CDltQsXxRcG.htm



Modifié par DjiDji59430 le 14/04/2013 17:38
cebe
 Posté le 12/04/2013 à 06:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Une mise en forme conditionnelle que j'utilise volontiers : si la valeur de la cellule est zéro, j'écris les valeurs en blanc sur fond blanc (ou autre couleur) ; ainsi je ne vois pas les zéros, et si d'aventure une formule utilise cette cellule, cela se fera sans problème (l'absence de valeur peut créer une erreur).

À toi de voir la meilleure solution !

Labougie
 Posté le 14/04/2013 à 10:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

DjiDji,

Je ne peux accèder à ton lien, il est out.

Cebe,

Ta solution, ne me sied pas dans le sens ou dans plusieurs semaines, je ne me souviendrai jamais de ce principe blanc sur blanc.

Et, comme indiqué plus haut, je sais supprimer les "Zéros", ici c'était pour les 00:00:00 soit hh:mm:ss ce qui est différent (un peu). La méthode de solution utilisée est donnée plus haut.

Regarde là, elle franchement ultra simpliste.

Labougie

Magnan
 Posté le 14/04/2013 à 17:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour

Pour le blanc sur blanc il suffit de selctionner une zone pour voir apparaitre en surimpression le contenu de la cellule.

A+

DjiDji59430
 Posté le 14/04/2013 à 17:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

http://cjoint.com/13av/CDltQsXxRcG.htm

Il fallait interpreter !



Modifié par DjiDji59430 le 14/04/2013 17:40
qmike549
 Posté le 14/04/2013 à 19:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

tu peux attribuer ce format personnalisé

  • électionnez la ou les cellules à rendre invisible
  • Clic droit de la souris, Format cellule
  • Sélectionnez l'onglet Nombre
  • Sélectionnez l'option Personnalisée dans la zone Catégorie
  • Tapez ;;; dans la zone type

source : http://michel.vergriete.perso.sfr.fr/60excel.html

Labougie
 Posté le 14/04/2013 à 20:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

Qmike,

Je regarderai ton lien dans la semaine

DjiDJi,

Je viens de regarder ta mise en oeuvre pour les formules

Somme Index et prod.

Je vais dégrossir cela dans la semaine également, car somme prod demande à bien comprendre l'emboitement des formules, somme.si et somme.si.ens dito avec Nb

Somme index, je ne connais pas du tout, je vais chercher des docs pour savoir ce que cette fonction peut apporter.

Plus les calculs, dans la base de données, c'est plus léger avec ceci, onglet récap mois F9/F10

=SOMMEPROD((BDD!$B$5:$B$6000=4)*(BDD!H5:H$6000)) ta formule

=SOMME.SI.ENS(BDD!H:H;BDD!$B:$B;'Récap Mois'!$B10;BDD!$A:$A;'Récap Mois'!$A10) la mienne

Car le pc qui va utiliser est moins performant que le mien .

Du coup, j'vais rechercher la performance

Labougie

Labougie
 Posté le 18/04/2013 à 18:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

Je viens de créer des listes sur ce principe

Données/Validation
- Choisir Liste puis
=INDIRECT(cellule)

Pour avoir dans la cellule de droite un nouveau choix, ainsi de suite 3 fois.

Jusque là, aucun souci, en revanche je ne peux pas modifier à ma guise mes listes . Ou ai je commis l'erreur?

-------

J'ai un onglet liste

Une catégorie "Générale" et son contenu

par exemple Course Réparation Santé ....

J'ai nommé chaque cellule par un nom et donné la plage de cette sous liste à la cellule correspondante

Comment puis-je modifier la liste ainsi que la sous liste à ma guise?

labougie

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
30,99 €Clé USB 3.0 et Micro USB Sandisk Ultra OTG 256 Go à 30,99 €
Valable jusqu'au 03 Mars

Amazon fait une promotion sur la nouvelle version de la clé USB 3.0 SanDisk Dual Drive 256 Go qui passe à 30,99 € livrée gratuitement. La particularité de cette clé USB réside dans le fait qu'elle dispose à la fois d'un connecteur USB pour la brancher sur votre ordinateur ou votre TV, mais également d'un connecteur micro USB pour la brancher sur votre smartphone ou votre tablette. Compatible USB 3.0 (et 2.0), cette clé USB offre des débits jusqu'à 150 Mo/s. 


> Voir l'offre
16,77 €Lecteur/graveur de CD/DVD externe USB à 16,77 €
Valable jusqu'au 03 Mars

Amazon fait une promotion sur le lecteur/graveur de CD/DVD externe USB Rodzon qui passe à 16,77 € au lieu de 22,99 €. Ce graveur vous permettre de lire et graver les CD et DVD sur votre ordinateur qui ne dispose pas de lecteur optique (soit la plupart des portables du marché). Branchez-le simplement sur un port USB de votre PC portable ou de votre MacBook pour en profiter. 


> Voir l'offre
139,99 €NAS QNAP TS-251+ 2 baies (quad core, 2 Go RAM) à 139,99 €
Valable jusqu'au 03 Mars

Amazon propose actuellement le NAS QNAP TS-230 2 baies à 139,99 € livré gratuitement. On le trouve ailleurs à partir de 185 €. Ce NAS est parfait pour sauvegarder vos données. Vous pouvez accéder à distance à vos fichiers, et disposez même d'un cloud privé pour partager facilement vos documents avec vos proches. Grâce à ses 2 baies, vous pourrez étendre votre capacité de stockage ou bien sécuriser vos données en mettant en place un RAID.  Reposant sur un processeur quad-core Realtek 1.4 GHz et 2 Go de RAM, le TS-230 délivre de bonnes performances multitâches exceptionnelles (jusqu'à 113 Mo/s) et prend en charge le décodage matériel 4K (H.264) et le transcodage en temps réelCe NAS intègre en outre 2 ports USB 3.0 et deux ports Ethernet Gigabit et offre la possibilité d'un chiffrement matériel.


> Voir l'offre

Sujets relatifs
Rendre une cellule vide
formule pour supprimer les blanc en fin de cellule
copier ligne si cellule vide
Une feuille blanche pour une ligne vide en fin de document
probleme format de cellule pour les nombres
Supprimer la ligne de la cellule active sauf une cellule
Copier cellule (pour Ferrand SVP !)
sélectionner la première cellule vide d'une colonne
selectionner derniere cellule non vide.
Supprimer une ligne vide
Plus de sujets relatifs à Supprimer le 0 pour rendre la cellule vide
 > Tous les forums > Forum Bureautique