> Tous les forums > Forum Internet et Réseaux
 Telnet sur vieille Livebox Inventel
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
fgondard
  Posté le 09/06/2014 @ 17:30 
Aller en bas de la page 
Grand Maître astucien

Bonjour,

Il existe de nombreux guides pour implanter un serveur telnet sur cette Livebox, tous donnant la même recette. Celui-ci par exemple.

Juste pour le plaisir, je viens de tenter l'expérience et bien sûr ... ça ne fonctionne pas, même pare-feu arrêté et agents Avast suspendus temporairement.

Tout se faisant en aveugle on a aucun retour sur le bon déroulement des commandes passées. Comme dans le guide mentionné, et suivi scrupuleusement pas à pas, j'ai utilisé IIS comme serveur FTP avec tous ses paramètres par défaut mais aucun journal n'est créé. J'en déduis que la commande wget n'a pas fonctionné mais c'est tout.

Mon expérience de Linux est très limitée mais au premier abord les commandes indiquées me semblent bonnes.

Dans la première on écrase le contenu de etc/passwd par une ligne indiquant pour l'utilisateur root le shell à utiliser. Ne faudrait-il pas redémarrer la Livebox pour que ceci soit pris en compte ?

FG

Publicité
ZenJP
 Posté le 09/06/2014 à 21:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

fgondard

Peut-être ce tuto est plus explicite ?

http://forum.ubuntu-fr.org/viewtopic.php?pid=1979175

fgondard
 Posté le 10/06/2014 à 10:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

J'ai dû voir à peu près tous les guides disponibles sur la toile dont celui que tu cites et qui ne dit rien de plus que les autres.

Il m'a d'ailleurs fallu par mal de temps pour en trouver un proposant un lien valide pour télécharger utelnetd. Sinon quand on cherche ce programme sur la toile on ne trouve soit qu'un simple fichier texte de description, soit que le source et le fichier make associé.

Y'a-t-il un linuxien dans l'avion ou faut-il que je demande le transfert de cette question dans le forum Linux ?

FG

ZenJP
 Posté le 10/06/2014 à 11:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Re,

déjà je pense que ce serait mieux dans le forum Linux, mais ce qui est sûr c'est que même si Orange dit avoir verrouillé seulement ses nouvelles box sur ce sujet, il s'avèrerait que pour les anciennes box, il y en a sur lesquelles on peut tenter quelque chose et d'autres non...

Vaut peut-être mieux un vieux routeur paramétrable qui ne soit pas Orange pour faire le test

fgondard
 Posté le 10/06/2014 à 12:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Cette Livebox, dont je me sers au quotidien bien que je sois chez SFR, est déjà dévérouillée par l'autre méthode que j'indique sur mon site. Ce qui prouve que les commandes sont bien transmises au shell par le serveur http embarqué.

Mais la commande wget semble ne pas fonctionner. Peut-être à cause d'IIS ? Il faudrait que j'installe un autre serveur FTP pour voir.

Je voulais expérimenter l'implantation d'un serveur Telnet pour tenter de supprimer ce stupide filtrage des adresses MAC qui ne sert à rien sinon qu'à s'enquiquiner soi-même. Je viens encore de me faire piéger il y a quelques jours, et ce n'est pas la première fois, par ce bidule auquel je ne pensais plus.

FG

fgondard
 Posté le 10/06/2014 à 14:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

J'avance un brin. J'ai viré IIS et mis Typsoft-FTP. Il me dit que le port 21 est déjà occupé !

J'ai parcouru la toile et je ne suis pas le seul à rencontrer ce problème qui ne semble pas avoir de solution. Quel que soit le serveur FTP par ailleurs, ce qui expliquerait l'échec avec IIS.

Ni netstat ni Commodo ne voient ce port occupé. Il n'est pas bloqué par un pare-feu puisque celui de Windows est désactivé et que l'arrêt de Commodo ne change rien.

Il faut que je regarde si j'ai la place d'ajouter un n° de port différent dans la commande wget.

FG

fgondard
 Posté le 10/06/2014 à 20:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Suite du feuilleton.

J'avais un portable sous la main et j'ai donc changé de PC pour tenter la manip. Sur celui-le le port 21 fonctionne.

Cette fois je vois bien, grâce à la fenêtre de Typsoft, que la commande wget est bien prise en compte (en fait c'est au redémarage de la Livebox que tout se passe). Plusieurs tentatives semblent être faites d'accéder au fichier, suivies à chaque fois d'une déconnexion/reconnexion, mais rien n'est transféré.

Donc statu quo.

FG

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Migration Livebox Inventel ---> Nouvelle livebox
Livebox INVENTEL version : v5.08 - problème
Livebox Inventel ou Thomson?
Livebox mini Inventel
mon pc ne detecte plus ma livebox inventel
config livebox inventel pour connexion wifi iphone
Problème WIFI Livebox INVENTEL
Livebox Inventel
Connection internet livebox inventel
pb connexion wifi avec livebox inventel
Plus de sujets relatifs à Telnet sur vieille Livebox Inventel
 > Tous les forums > Forum Internet et Réseaux