> Tous les forums > Forum Linux
 temps du grub
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
haddadou
  Posté le 17/11/2013 @ 19:34 
Aller en bas de la page 
Astucien

bonsoir

comment modifier le temps du grub (boot) pour le solydxk ??

Publicité
m_n
 Posté le 17/11/2013 à 20:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

nano /etc/default/grub

Code:
GRUB_TIMEOUT=5

pour finir :

update-grub2

ou :

update-grub



Modifié par m_n le 17/11/2013 20:42
haddadou
 Posté le 18/11/2013 à 15:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

dois-je mettre update-grub a la fin dans le terminal ??

ou ouvrir un autre terminal pour faire les modifs

exusez je suis encore bleu

m_n
 Posté le 18/11/2013 à 18:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

[[ dois-je mettre update-grub a la fin dans le terminal ??

ou ouvrir un autre terminal pour faire les modifs ]]

------------------------------------------------------------------------

l'un ou l'autre , c'est pareille ..

pourvu que c'est apres avoir modifié le fichier /etc/default/grub ..

----------------------------------------------------------------

en passant .. sais-tu comment ( enregistrer ) avec nano ..

sinon ,

après la modification , tu fais :

Ctrl+o , Enter, Ctrl+x

(( Ctrl+o --> c'est avec la lettre o , non avec le chiffre (zero ) .. )) ..



Modifié par m_n le 18/11/2013 18:08
Logicien
 Posté le 18/11/2013 à 18:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

c'est effectivement dans le fichier /etc/default/grub que tu peux changer le temps d'attente de Grub avant qu'il démarre l'entrée du menu par défaut. GRUB_TIMEOUT=-1 signifie attendre sans arrêt. Le chiffre donné se compte en secondes.

Pour éditer et surtout pour pouvoir sauvegarder les modifications apportées au fichier, tu dois avoir les droits administratifs du super utilisateur root. La commande sudo te les donne. Dans un terminal graphique tu exécutes la commande

sudo nano /etc/default/grub

qui ouvre l'éditeur texte Nano avec les droits root. Tu modifies la ligne GRUB_TIMEOUT= selon tes désirs, puis pour sauvegarder, tu tapes Ctrl+x, ce à quoi Nano te demandera si effectivement tu veux sauvegarder. Tu tapes o ou y selon que le message est en français ou en anglais. Puis encore Entrée (Enter) quand Nano affiche le nom du fichier, soit /etc/default/grub.

Voilà, les modifications sont faites.

Revenu à l'invite de commandes, il te reste à dire à Grub d'appliquer les modifications à son fichier de configuration. Tu exécutes la commande

sudo update-grub

Voilà, au prochain démarrage, Grub va attendre le temps choisi avant de démarrer l'entrée du menu par défaut.

Note, la commande sudo peut te demander un mot de passe, celui de l'utilisateur connecté au système. Si la commande sudo n'est pas installée, il faut installer le paquet sudo avec Synaptic par exemple. Sinon, il faut ouvrir une session root avec mot-de-passe root. Je ne connais pas solydxk, mais bien Debian.



Modifié par Logicien le 18/11/2013 18:28
haddadou
 Posté le 18/11/2013 à 18:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

j'ai changé le temps en 30 s,mais erreur de lecture avec permission non accordée

haddadou
 Posté le 18/11/2013 à 18:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

et je n'ai qu'au grub timeout en modifiant le 5 vers 30,c'est tout et en appuyant sur ctrl o,enter et controle x

je crois que je suis sur le bon chemin

Logicien
 Posté le 18/11/2013 à 18:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Qu'est ce que te retourne la commande

whereis sudo

Tu dois utiliser cette commande pour que tu puisses enregistrer les modifications, sinon tu dois ouvrir une session root. Lors de l'installation, as-tu donné un mot-de-passe root? Si oui, tu peux ouvrir une session root avec la commande

su -

suivi du mot-de-passe root. En session root, tu n'as pas besoin de la commande sudo, tu est déjà root. En session utilisateur normal, soit non root, pour avoir les droits root, il faut utiliser la commande sudo.



Modifié par Logicien le 18/11/2013 18:35
m_n
 Posté le 18/11/2013 à 18:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

update-grub

et

redemarre ..



Modifié par m_n le 18/11/2013 18:40
Logicien
 Posté le 18/11/2013 à 18:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

m_n, tu sais comment faire la mofification que cherche à faire haddadou, mais tu ne sais pas comment lui expliquer dans un ordre qui peut réussir.

Les choses simples sont très compliquées à réaliser lorsqu'on part de zéro. Répondre à ce message me le fait comprendre encore une fois.



Modifié par Logicien le 18/11/2013 18:39
haddadou
 Posté le 18/11/2013 à 18:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

le grub timeout modifié à 30 s,je n'ai touché qu'a ça

mais update grub

je l'ecris a la fin du terminal ? sinon ou ?

pleaaaase

m_n
 Posté le 18/11/2013 à 19:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

je l'ecris a la fin du terminal ?

-----------------------------------------

yesssssssssssssssss

et

redemarre ton ordi ..



Modifié par m_n le 18/11/2013 19:24
haddadou
 Posté le 18/11/2013 à 19:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

au fait logicien,je n'ai pas sudo ,il n'est pas installé

et j'ai remarqué que même en faisant update grub ,le fichier n'est pas enregistré ,et redémarrant le pc,j'ai toujours les 5 s

m_n
 Posté le 18/11/2013 à 20:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

cé pas important d'être en sudoer

car si tu as entrer dans l'éditeur ( Nano ) ..

il falais être en root ( # ) ..

une petite question ,

refait :

su

passwd

nano /etc/default/grub

et regarde si le changement de ta modification a bel et bien été bien modifié ?

si oui ..

redemarre

ou ferme ton ordi et rallume-le ( certaine distro exige de fermer que de redemarrer ) ..



Modifié par m_n le 18/11/2013 20:24
haddadou
 Posté le 18/11/2013 à 20:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

j'ai beau tapé dans la ligne password,rien n'a faire aucune lettre ne s'ecrit dessus ,meme avec copier coller,rien ne passe

la ligne apres mot de passe reste bloquée,sourde a toute commande

m_n
 Posté le 18/11/2013 à 20:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

ah ah .. le mot de passe est invisible tout simplement .. je pense

cela doit fonctionner quand même ..

ps/ désolé, je ne connais pas l'astuce pour le rendre visible .. peut-être dans ( help ) ..



Modifié par m_n le 18/11/2013 20:32
Logicien
 Posté le 18/11/2013 à 21:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Est-ce que tu connais ton mot-de-passe root? Sans connaître ton mot-de-passe root et sans avoir sudo, tu ne peux rien faire comme administrateur.

La commande su - ou su - root te permet d'ouvrir une session root à partir d'une session utilisateur. Tu dois fournir un mot-de-passe à moins que celui-ci soit désactivé, ce qui n'est jamais le cas pour root. C'est normal que rien ne s'affiche quand tu entres un mot-de-passe, c'est une mesure de sécurité. Quand le mot-de-passe est entré, tu fais Entrée ou Enter en anglais pour valider.

Pour installer sudo ou un autre logiciel, il faut les droits root. As-tu le logiciel Synaptic dans le menu des programmes? Tu peux peut-être l'installer en utilisant ce programme. Même installée, la commande sudo ne permet pas toujours à un utilisateur de l'exécuter. Il faut que le super-utilisateur root edite le fichier de configuration de cette commande /etc/sudoers avec la commande vigr pour le permettre. Je ne pense pas que tu puisses le faire pour le moment.

Pour changer le mot-de-passe root à partir d'une session utilisateur tu exécutes la commande

sudo passwd root

Si tu réussies à ouvrir une session root, tu pourras modifier la configuration de Grub comme expliqué plus haut. Si tu veux changer le mot-de-passe root dans une session root, tu fais simplement

passwd

ou

passwd root

Pour changer le mot-de-passe d'un utilisateur dans une sesson root, tu exécutes la commande

passwd nom-de-l'utilisateur



Modifié par Logicien le 18/11/2013 21:28
haddadou
 Posté le 19/11/2013 à 09:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

le mot que je possede en ce moment est celui pour acceder a linux; comme pour le mot de passe admin de windows

autres mots de passe,wellou ,rien

m_n
 Posté le 19/11/2013 à 15:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

perso, j'utilise toujours le meme passwd pour root et l'utilisateur ..

er

Notre ami ( Logicien ) viens de très très bien de t'expliquer comment changé ton mot de passe ..



Modifié par m_n le 20/11/2013 20:37
haddadou
 Posté le 20/11/2013 à 10:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonjour

voila j'a changé le time out a 30 s;c'est enregistré

mais en rebootant c'est toujours ces fameux 5 s qui priment

ou est encore l'erreur

voici le texte sur mon terminal

If you change this file, run 'update-grub' afterwards to update

# /boot/grub/grub.cfg.

# For full documentation of the options in this file, see:

# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0

GRUB_TIMEOUT=30

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=80$

GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs

# This works with Linux (no patch required) and with any kernel that obtains

# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

Logicien
 Posté le 20/11/2013 à 11:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

À ce que tu dis, tu as obtenu les droits root. As-tu pu vraiment sauvegarder les modifications apportées au fichier /etc/default/grub ?

As-tu exécuté la commande

update-grub

avant de redémarrer?



Modifié par Logicien le 20/11/2013 11:43
m_n
 Posté le 20/11/2013 à 23:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ton ( /etc/default/grub ) est bien modifié ..

il ne te reste qu'à faire ce que notre ami ( Logicien ) viens de te dire :

update-grub

et redemarrer ..



Modifié par m_n le 20/11/2013 23:51
haddadou
 Posté le 21/11/2013 à 17:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

je viens de mettre update grub completement a la fin du terminal

# Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

# The resolution used on graphical terminal

# note that you can use only modes which your graphic card supports via VBE

# you can see them in real GRUB with the command `vbeinfo'

#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start

#GRUB_INIT_TUNE="480 440 1"

update-grub

est-ce le bon chemin ?? sans ce fameux dièse!!!!

m_n
 Posté le 21/11/2013 à 20:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

apt-get update

et redémarre ..



Modifié par m_n le 21/11/2013 20:34
haddadou
 Posté le 22/11/2013 à 11:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir

je suis le plus malchanceux du monde

rien ne tiens

hido
 Posté le 22/11/2013 à 15:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

salut

il y a confusion :

- update-grub est une commande à taper, il ne faut pas l'inscrire dans le fichier /etc/default/grub

apt-get update

et redémarre ..

apt-get ça concerne la gestion des paquets donc inutile ici

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
Ecran PC 27 pouces KTC H27V13 (VA, Full HD, 100 Hz) à 99,99 €
99,99 € 149 € -33%
@Geekbuying
Carte TP-Link Archer AXE5400 PCIe WIFI 6E + Bluetooth 5.3 avec dissipateur à 35,99 €
35,99 € 75 € -52%
@Amazon
Mini PC AOOSTAR MN57 (Ryzen 7 5700U, 32 Go RAM, SSD 1 To, Windows 11 Pro) à 349,99 €
349,99 € 480 € -27%
@Geekbuying
32 Go de mémoire SO-DIMM DDR4 Crucial 3200 MHz à 69,61 €
69,61 € 85 € -18%
@Amazon
Drone DEERC D40 (caméra FHD, contrôle gestuel, maintien d'altitude, 2 batteries) à 34,99 €
34,99 € 69,99 € -50%
@Amazon
Perforateur Bosch Professional GBH 2-21 SDS+ à 99,99 €
99,99 € 125 € -20%
@Amazon

Sujets relatifs
modifier le temps du grub
Entrée du Grub qui mène à la mauvaise version de Linux
Le Grub de Jessie est capricieux !
PC-BSD : grub.cfg gigantesque
Erreur unknown filesystem grub rescue après desinstallation ubuntu
Booter sur un cd avec GRUB
Configurer le menu de grub sous debian
[TUTO]Linux Mint 17, et l'affichage du Menu Grub au Démarrage.
Grub Customizer
Recherche Grub 2 désespérement.
Plus de sujets relatifs à temps du grub
 > Tous les forums > Forum Linux