> Tous les forums > Forum Linux
 Ubuntu 16.04 dans Oracle VM VirtualBoxSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
Sainthelens
  Posté le 04/06/2016 @ 14:50 
Aller en bas de la page 
Astucien

Bonjour,

On m'a installé Ubuntu 16.04 dans Oracle VM VirtualBox.

Le problème, c'est que je ne peux me connecter à Firefox " Adresse Introuvable ".

Auriez vous déjà rencontré ce problème ?

Merci



Modifié par Sainthelens le 04/06/2016 14:51
Publicité
Banzaiii
 Posté le 04/06/2016 à 15:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

SLt

Vaste question

D'abord vérifier dans la config de la machine virtuelle que la carte réseau est bien configurée en accès par pont et pas en NAT



Si ok, mettre, machine démarrée, une copie d'écran du résultat de la commande ifconfig lancée dans un terminal

Sainthelens
 Posté le 04/06/2016 à 15:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour Banzaiii

oui accès par pont

nom : Controleur Realtek PCIe GBE family

" commande ifconfig lancée dans un terminal " Peux tu préciser ? Merci

Logicien
 Posté le 04/06/2016 à 15:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

au contraire Banzaiii, quand la carte réseau filiaire de VirtualBox est configurée en NAT, Ubuntu peut configurer la carte automatiquement pour accéder à Internet dans la machine virtuelle, sans aucune intervention de l'administateur. Alors que, si la carte est configurée en Accès par pont, l'administrateur doit configurer la carte réseau filiaire manuellement dans la machine virtuelle et s'il ne sait pas le faire ... il n'a pas d'Internet.



Modifié par Logicien le 04/06/2016 15:44
Banzaiii
 Posté le 04/06/2016 à 15:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Pas du tout, c'est le contraire



Modifié par Banzaiii le 04/06/2016 15:43
Logicien
 Posté le 04/06/2016 à 15:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

J'utilise l'accès par pont. Il faut donner soi-même l'adresse IP à la carte, la passerelle par défaut et les serveurs DNS.Tout ça se fait automatiquement par NAT. C'est comme ça pour moi avec VirtualBox quand Linux est l'hôte de la machine virtuelle invitée.



Modifié par Logicien le 04/06/2016 15:55
Banzaiii
 Posté le 04/06/2016 à 15:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Sainthelens a écrit :

Bonjour Banzaiii

oui accès par pont

nom : Controleur Realtek PCIe GBE family

" commande ifconfig lancée dans un terminal " Peux tu préciser ? Merci

Il faut que tu trouves l'icone Terminal (on va dire l'équivalent de l’invite de commande sous Windows) et que tu tapes dedans la commande ifconfig

Il est possible aussi que l'on ne t'ait pas installé les add ons invités et qu'il te manque le pilote de la carte réseau mais ça, on verra après



Modifié par Banzaiii le 04/06/2016 15:58
Banzaiii
 Posté le 04/06/2016 à 15:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Logicien a écrit :

J'utilise l'accès par pont. Il faut donner soi-même l'adresse IP à la carte, la passerelle par défaut et les serveurs DNS.Tout ça se fait automatiquement par NAT. C'est comme ça pour moi avec VirtualBox sous Linux.

Ce n'est pas VirtualBox sous Linux, c'est Linux sous VirtualBox









Modifié par Banzaiii le 04/06/2016 15:56
Logicien
 Posté le 04/06/2016 à 16:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Dans le cas qu'on parle je pense que l'hôte est Windows et l'invité est Linux Ubuntu. Je n'ai pas utilisé VirtualBox sous Windows depuis très longtmeps mais le logiciel est très semblable à sa version Linux. Si Ubuntu 32 ou 64 bits selon le cas a été bien choisi dans Géneral, les marques de cartes réseaux filiaires devraient être supportées par l'invité Ubuntu.

Publicité
Banzaiii
 Posté le 04/06/2016 à 16:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bon, Sainthelens tu vois avec mes copies d'écran qu'en Accès par pont et config auto ça marche sans souci

Le doute étant levé ne perds pas ton temps avec une config en NAT

Toutes mes machines virtuelles (Windows, Linux, OS X) sont en Accès par pont et en DHCP, aucune config manuelle nécéssaire

Tu t'en sors pour trouver le terminal ?



Modifié par Banzaiii le 04/06/2016 16:08
enfermedehors
 Posté le 04/06/2016 à 16:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Toutes mes VM, Linux ou Windows sont configurées en Nat.
Je n'ai jamais eu de problème de connexion.

Logicien
 Posté le 04/06/2016 à 16:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Le fait qu'il faut ouvrir le terminal Windows Banzaiii pour connaître la configuration IP de Windows démontre que le tout ne se fait pas automatiquement et que l'administrateur doit intervenir. Si en plus enfermedehors nous dit que le NAT fonctionne automatiquement autant sous les hôtes Linux que Windows alors, ce que je dis doit être vrai.

Banzaiii
 Posté le 04/06/2016 à 16:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Tu mélanges tout

Je lui ai demandé d'ouvrir un terminal sous Linux pour faire un ifconfig !

La moindre des choses quand on a un problème d'accès Internent sous Linux !

En outre, si tu regardes mes copies d'écran sous Linux (assez grosses je pense) tu verras qu'au contraire ça fonctionne bien en auto (DHCP si tu connais)



Modifié par Banzaiii le 04/06/2016 16:34
Sainthelens
 Posté le 04/06/2016 à 16:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

J'ai pas mal de difficultés car je suis souvent déconnecté. Sans doute, un manque d'habitude.

Je n'ai pas trouvé le terminal : sans doute, tout n'a pas été configuré. Je n'ai donc pas pu tester la solution de Banzaiii à qui, de plus, je n'ai peut-être pas transmis tous les éléments d'appréciation qui lui étaient nécessaires. Qu'il m'en excuse et qu'il soit remercié de sa gentillesse à m'avoir proposé son aide.

En désespoir de cause, j'ai essayé Nat et ai obtenu Firefox.

Merci à Tous.

J'aurai peut-être d'autres occasions de solliciter votre aide à propos de Linux.

Banzaiii
 Posté le 04/06/2016 à 16:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Tant mieux pour toi mais pour moi c'est inexplicable

Il eût été intéressant de vérifier d'autres points

Il serait bon que tu trouves le terminal sous Linux car c'est quelque chose qui sert beaucoup



Modifié par Banzaiii le 04/06/2016 17:02
Sainthelens
 Posté le 04/06/2016 à 17:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
Banzaiii a écrit :

Tant mieux pour toi mais pour moi c'est inexplicable

Il eût été intéressant de vérifier d'autres points

Il serait bon que tu trouves le terminal sous Linux car c'est quelque chose qui sert beaucoup

Je vais continuer de me familiariser avec Linux.

Notamment, voir s'il y a d'autres applications proposées, tel que Thunderbird (ou une autre messagerie) qui ne figure pas sur le bureau.

Bonne Soirée.



Modifié par Sainthelens le 04/06/2016 17:05
Banzaiii
 Posté le 04/06/2016 à 17:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Ok bonne continuation

Publicité
Logicien
 Posté le 04/06/2016 à 17:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je m'excuse, je me suis trompé entre l'hôte Windows et l'invité Ubuntu pour le terminal dont tu parles. J'ai mal lu.

Si tu dis que l'accès par pont dans VirtualBox sous l'hôte Windows permet configuration automatique de la carte réseau filiaire dans l'invité, je te crois sur parole, mais je suis surpris. Sous l'hôte Linux, VirtualBox en accès par pont n'a jamais permis à aucun système d'exploitation que j'ai utilisé comme invité d'avoir une configuration IP automatique.

Avec le NAT, VirtualBox sert de serveur Dhcp quand l'invité fait une requête Dhcp (en mode automatique ou manuel). Avec l'accès par pont, il n'y a aucun serveur Dhcp pour répondre à la requête. C'est pourquoi l'invité doit faire la configuration IP manuellement. Je parles de VirtualBox sous l'hôte Linux évidemment.

D'après l'image que tu fournis de la configuration réseau de VirtualBox sous l'hôte Windows, quand tu choisis l'accès par pont, tu n'as pas à choisir une carte réseau hôte en plus. Sous l'hôte Linux VirtualBox doit choisir une des cartes réseaux de l'hôte comme pont. C'est peut-être ça la différence qui fait que la configuration automatique de l'invité se fait sous l'hôte Windows et non sous l'hôte Linux quand on choisit l'accès par pont.

J'avoue que si tu connais bien VirtualBox sous l'hôte Windows, tu es mieux placé que moi pour aider notre ami Sainthelens et c'est ça le plus important. Je n'ai aucun Windows réel ou virtuel d'installé.



Modifié par Logicien le 04/06/2016 17:29
Banzaiii
 Posté le 04/06/2016 à 17:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Sainthelens a écrit :
Banzaiii a écrit :

Tant mieux pour toi mais pour moi c'est inexplicable

Il eût été intéressant de vérifier d'autres points

Il serait bon que tu trouves le terminal sous Linux car c'est quelque chose qui sert beaucoup

Je vais continuer de me familiariser avec Linux.

Notamment, voir s'il y a d'autres applications proposées, tel que Thunderbird (ou une autre messagerie) qui ne figure pas sur le bureau.

Bonne Soirée.

En cliquant sur l’icône tout en haut à gauche, tu as la fonction Rechercher qui te permet de trouver facilement ce que tu cherches en en tapant les premières lettres

Exemple pour Terminal et Thunberbird ci-dessous








Modifié par Banzaiii le 05/06/2016 06:46
Sainthelens
 Posté le 04/06/2016 à 17:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Merci

Pour l'instant, j'ai une mise à jour du système en train de s'installer : pas très rapide.

Logicien
 Posté le 04/06/2016 à 17:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Avec la méthode que montre en images Banzaiii, si tu cherches une application ou un type d'application que tu ne trouves pas, il faut que tu cherches de la même manière Synaptic et apprendre à l'utiliser. Synaptic est un gestionnaire de paquets sous Ubuntu. Il doit être installé déjà. Tu peux rechercher à l'aide de Synaptic des logiciels que veux et les installer s'ils ne le sont pas. Synaptic a besoin d'un accès Internet fonctionnel pour le faire.



Modifié par Logicien le 04/06/2016 20:44
Sainthelens
 Posté le 04/06/2016 à 17:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Voilà j'ai réussi

PS : je suis revenu à Pont

Logicien
 Posté le 04/06/2016 à 17:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

ensp0s3 est la carte réseau filiaire qui te permet d'avoir accès à Internet. Elle n'a pas d'adresse IP. Sans configuration IP de cette carte, tu ne peux pas accéder à Internet. Tu peux avoir plus de détails sur la conaifuration IP de Ubuntu en exécutant dans ce même terminal la commande

ip route list

De toutes façons tu devrais pouvoir accéder à Internet en utilisant l'applet réseau qui doit être visible sur le bureau quelque part. Sinon, tu as effectivement besoin du terminal.



Modifié par Logicien le 04/06/2016 18:02
Banzaiii
 Posté le 04/06/2016 à 17:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Logicien a écrit :

Je m'excuse, je me suis trompé entre l'hôte Windows et l'invité Ubuntu pour le terminal dont tu parles. J'ai mal lu.

Si tu dis que l'accès par pont dans VirtualBox sous l'hôte Windows permet configuration automatique de la carte réseau filiaire dans l'invité, je te crois sur parole, mais je suis surpris.

Je suis aussi surpris que toi par l'inverse

Ca fonctionne effectivement aussi en NAT (Hôte Windows 10 en 192.168.1.xxx et Invité Ubuntu 16.04 en live CD en 10.0.2.xxx)


J'ai accès au net, je vois et ai accès au réseau Windows

Je suis certain que, dans le temps ( version 3 ou 4.xx de VB sous windows ), le NAT ne fonctionnait pas ce qui m'a amené à toujours configurer en Accès par Pont

Ps : En Accès par Pont, Hôte windows, c'est le serveur DHCP du LAN (en l’occurrence ma Livebox), qui répond à la requête DHCP et attribue bien l'ip réservée à l'adresse MAC de la VM Linux)



Modifié par Banzaiii le 04/06/2016 18:23
Banzaiii
 Posté le 04/06/2016 à 18:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Sainthelens a écrit :

Voilà j'ai réussi

PS : je suis revenu à Pont

??? Ton ifconfig c'est en Accès par Pont ou en NAT ?

Si ça marche en NAT pourquoi es-tu revenu à Accès par Pont ?

Sur ta copie d'écran, en haut à droite, à coté de Fr on voit le symbole Wifi ?

Tu as une clé Wifi en USB ?

Apparemment elle n'est pas connectée à un réseau Wifi



Modifié par Banzaiii le 04/06/2016 18:34
Sainthelens
 Posté le 06/06/2016 à 11:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour Banzaiii,

1) J'étais, au moment de ma demande, en Accès par Pont puis, compte tenu des avis exprimés sur le forum, je suis allé sur Nat où j'ai pu accéder à FFox.

Mais, pour que tu puisses te rendre compte de la situation de départ, quand j'ai (enfin) trouvé le terminal, je suis revenu temporairement en Accès par Pont.

Car (si j'ai bien compris) lorsque tu m'as conseillé la commande ifconfig lancée dans un terminal, c'était parce que j'étais en Accès par Pont :

" Si ok, mettre, machine démarrée, une copie d'écran du résultat de la commande ifconfig lancée dans un terminal"

Désormais, je suis en Nat et tout marche (sauf une mise à jour du système d'exploitation proposée qui ne marche pas) (même chose pour l'installation d'un logiciel).

Capture :

La mise à jour ne va pas plus loin.

2) "Tu as une clé Wifi en USB ?"

Non

Je précise que c'est un ami qui m'a installé Ubuntu 16.04 dans Oracle VM VirtualBox (en même temps que W10). Pour ce faire, il a emporté chez lui mon pc portable, car il avait un débit plus important pour accélérer la migration vers W10. Je n'étais pas présent lors de la migration et de l'installation.

Peut-être a-t-il oublié de modifier les réglages lorsqu'il m'a rendu mon PC.

Voilà, tu sais tout.



Modifié par Sainthelens le 06/06/2016 11:58
Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Ubuntu dans virtualbox ?..
Fichier ppd manquant dans HPLIP (ubuntu 14.04)
Aucun son dans Ubuntu ?
ubuntu sur virtualbox
Où est "Source des logiciels" dans Ubuntu 11.04 ?
Problème de langue ubuntu dans menu
impossible de copier un fichier dans Ubuntu
virtualbox ou dual boot avec ubuntu?
Oracle VM VirtualBox 3.2.8 vers 4.4
chrome os dans virtualbox
Plus de sujets relatifs à Ubuntu 16.04 dans Oracle VM VirtualBox
 > Tous les forums > Forum Linux