> Tous les forums > Forum Linux
 Vivaldi, que dois je installer en plus de Flash Player ?Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Yaxx
  Posté le 21/01/2018 @ 19:54 
Aller en bas de la page 
Petit astucien

Bonjour,

Pour le navigateur Vivaldi, j'ai installer Flash Player, mais je n'arrive pas a lire toute les vidéos comme d'autres navigateurs. Exemple, sur ce site:

https://fr.sports.yahoo.com/news/video-le-phenomenal-de-plus-de-60-metres-dun-gardien-espagnol-134127118.html

je n'arrive pas à lire la vidéo, j'ai le message suivant: Le média n'a pas pu être lu.

Pouvez vous me dire ce que je dois installer en plus de Flash Player ?

Voici le déroulement d'installation de Flash Player, dites moi si il manque quelque chose:

yaourt flash player

1 extra/flashplugin 28.0.0.137-1 [installed]

Adobe Flash Player NPAPI

2 extra/pepper-flash 28.0.0.137-1 [installed]

Adobe Flash Player PPAPI

3 community/minitube 2.9-3

A native YouTube client in Qt. Watch YouTube videos without Flash Player

4 multilib/lib32-flashplugin 28.0.0.137-1

Adobe Flash Player for 32-bit Mozilla-based browsers

5 aur/cherrymusic 0.41.1-1 (12) (0,38)

A standalone HTML5 (with Flash fallback) music streaming server based on CherryPy and jPlayer.

6 aur/cherrymusic-devel-git 20160210-1 (3) (0,00)

A standalone HTML5 (with Flash fallback) music streaming server based on CherryPy and jPlayer. Git devel-branch.

7 aur/flashplayer-projector 28.0.0.126-1 (0) (0,00)

Standalone (a.k.a. projector) version of Adobe's Flash Player

8 aur/flashplayer-standalone 28.0.0.126-2 (138) (1,53)

Adobe Flash Player (Standalone)

9 aur/flashplayer-standalone-debug 28.0.0.137-1 (16) (0,17)

Standalone, debug version of Adobe Flash Player

10 aur/flashplugin-beta 25-1 (28) (0,00)

Adobe Flash Player Beta

11 aur/flashplugin-focusfix 1:1.0-1 (12) (0,00)

Multi-monitor full-screen fix for Adobe Flash Player

12 aur/lightspark-git 0.8.0.r45.g06d58822-1 (121) (0,54)

An open source flash player implementation

13 aur/pianobar-git 711.b534a3b-1 (52) (0,01)

A free/open-source, console-based replacement for Pandora's Flash player

14 aur/swfdec-gnome 2.30.1-2 (65) (0,03)

Standalone Flash player and thumbnailer for the GNOME desktop

==> Numéro(s) des paquets à installer (ex: 1 2 3 ou 1-3)

==> ----------------------------------------------------

==> 1-3

[sudo] Mot de passe de gaz:

gazavertissement : pepper-flash-28.0.0.137-1 est à jour -- réinstalle

avertissement : flashplugin-28.0.0.137-1 est à jour -- réinstalle

résolution des dépendances...

recherche des conflits entre paquets...

Paquets (3) flashplugin-28.0.0.137-1 minitube-2.9-3 pepper-flash-28.0.0.137-1

Taille totale du téléchargement : 0,79 MiB

Taille totale installée : 42,58 MiB

Taille de mise à jour nette : 2,85 MiB

:: Procéder à l’installation ? [O/n] O

:: Récupération des paquets...

minitube-2.9-3-x86_64 805,2 KiB 3,37M/s 00:00 [############################################################] 100%

(3/3) vérification des clés dans le trousseau [############################################################] 100%

(3/3) vérification de l’intégrité des paquets [############################################################] 100%

(3/3) chargement des fichiers des paquets [############################################################] 100%

(3/3) analyse des conflits entre fichiers [############################################################] 100%

(3/3) vérification de l’espace disque disponible [############################################################] 100%

:: Traitement des changements du paquet...

(1/3) réinstallation pepper-flash [############################################################] 100%

(2/3) réinstallation flashplugin [############################################################] 100%

(3/3) installation de minitube [############################################################] 100%

:: Exécution des crochets de post-transaction...

(1/3) Updating icon theme caches...

(2/3) Arming ConditionNeedsUpdate...

(3/3) Updating the desktop file MIME type cache...

[gaz@gaz88-pc ~]$

Publicité
Yaxx
 Posté le 22/01/2018 à 18:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Help me por favor !

top-city
 Posté le 22/01/2018 à 22:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir.

Enregistrer sur votre ordi et ensuite visionner.

Slyvester
 Posté le 23/01/2018 à 16:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Comment veux-tu obtenir de l'aide ? Tu utilises - selon ta configuration - Windows 10, 64Bits. La première chose serait sans doute de nous faire part de quelle distribution Linux il s'agit et de mettre à jour ensuite ta configuration ...

top-city
 Posté le 23/01/2018 à 17:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir.

Une fois enregistré, visionner avec VLC pour les vidéos normales.

Taras_Boulba
 Posté le 23/01/2018 à 19:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Message original par Yaxx

Bonjour,

Pour le navigateur Vivaldi, j'ai installer Flash Player, mais je n'arrive pas a lire toute les vidéos comme d'autres navigateurs. Exemple, sur ce site:

https://fr.sports.yahoo.com/news/video-le-phenomenal-de-plus-de-60-metres-dun-gardien-espagnol-134127118.html

je n'arrive pas à lire la vidéo, j'ai le message suivant: Le média n'a pas pu être lu.

Pouvez vous me dire ce que je dois installer en plus de Flash Player ?

Voici le déroulement d'installation de Flash Player, dites moi si il manque quelque chose:

yaourt flash player

salut
tu es sous arch ou une dérivée d'arch je suppose puisque tu utilises yaourt
installe pepper-flash, vivaldi-ffmpeg-codecs et vivaldi-snapshot-ffmpeg-codecs (à partir d'AUR pour les 2 paquets codecs), ça devrait le faire

https://wiki.archlinux.org/index.php/Vivaldi
n'hésite pas consulter la doc d'arch quand tu as un soucis, c'est une des meilleures



Modifié par Taras_Boulba le 23/01/2018 19:45
Yaxx
 Posté le 27/01/2018 à 15:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

chuckydoll, ça ne fonctionne pas toujours le même message, et il y'a pas que ce site ou je ne peux lire les vidéos.

Télécharger puis visionner avec vlc. Je ne veux pas télécharger à chaque fois que je veux regarder une vidéo.

Taras_Boulba, je essayé d'installé: vivaldi-ffmpeg-codecs, j'ai rencontré un premier problème à l'installation yaourt vivaldi-ffmpeg-codecs

______________________________________________________________________________________________

ERREUR : L’extraction de chromium-62.0.3202.97.tar.xz a échoué

Abandon...

==> ERREUR : Makepkg n'a pas pu construire vivaldi-ffmpeg-codecs.

==> Relancer la compilation de vivaldi-ffmpeg-codecs ? [o/N]

==> --------------------------------------------------------

==> o

==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)

==> ------------------------------------------

==> n

/usr/lib/yaourt/pkgbuild.sh: ligne 219: impossible de créer un fichier temporaire pour le « here-document » : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 74 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

cat: erreur d'écriture: Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 76 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 77 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 78 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 79 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 80 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 81 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 82 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 83 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 84 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

/usr/lib/yaourt/pkgbuild.sh: ligne 85 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique

==> ERREUR : n’est pas disponible pour l’architecture « x86_64 ».

==> ERREUR : pkgrel ne peut pas être vide.

==> ERREUR : pkgver ne peut pas être vide.

==> ERREUR : An unknown error has occurred. Exiting...

Impossible de lire le PKGBUILD

________________________________________________________________________________________________________

Alors, j'ai taper la commande suivante:

yaourt -G vivaldi-ffmpeg-codecs

cd vivaldi-ffmpeg-codecs/

makepkg -si

____________________________________________________________________________________________________________

La encore un problème, ça a duré 1H, puis j'ai eu le message d'erreur suivant (j'ai pas tout mis, impossible, mais juste la fin):

==> Quitte l’environnement fakeroot.

==> Création finie : vivaldi-ffmpeg-codecs 62.0.3202.97-1 (sam. janv. 27 01:21:18 CET 2018)

==> Installation du paquet vivaldi-ffmpeg-codecs avec pacman -U...

[sudo] Mot de passe de jax :

==> ATTENTION : Échec à l’installation des paquets.

[jax@jax8-pc vivaldi-ffmpeg-codecs]$

__________________________________________________________________________________________________________________

Existe t-il une autre solution ?

Merci.



Modifié par Yaxx le 27/01/2018 15:59
Taras_Boulba
 Posté le 27/01/2018 à 18:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

t'as visiblement un problème d'espace avec le répertoire temporaire /tmp utilisé pour la compilation par yaourt

fais un df -h pour confirmer

si c'est le cas vide ton répertoire temporaire rm -rf /tmp/* ou change le temporairement avec l'argument --tmpdir passé à yaourt

ou de façon permanente dans le fichier de configuration de yaourt /etc/yaourtrc

TMPDIR="/tmp" change le pour /home/ton_identifiant/tmp par exemple si ton / est saturé



Modifié par Taras_Boulba le 27/01/2018 18:54
Yaxx
 Posté le 28/01/2018 à 01:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'aimerais faire un rm -rf /tmp/* mais j'ai j'obtiens ce message:

df -h

Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur

dev 1,9G 0 1,9G 0% /dev
run 1,9G 1,3M 1,9G 1% /run
/dev/sda1 908G 783G 80G 91% /
tmpfs 1,9G 8,1M 1,9G 1% /dev/shm
tmpfs 1,9G 0 1,9G 0% /sys/fs/cgroup
tmpfs 1,9G 8,0K 1,9G 1% /tmp
tmpfs 389M 12K 389M 1% /run/user/1000
[jax@jax8-pc ~]$ rm -rf /tmp/*
rm: impossible de supprimer '/tmp/sddm-:0-lEhScR': Opération non permise
rm: impossible de supprimer '/tmp/sddm-authced07743-da09-4b1b-8ac3-9a5d3d4ab0
c5': Opération non permise
rm: impossible de supprimer '/tmp/systemd-private-fda4f4005b884c36b0204e17d07
a0674-colord.service-bH57Jw': Opération non permise
rm: impossible de supprimer '/tmp/systemd-private-fda4f4005b884c36b0204e17d07
a0674-ntpd.service-5HIDxx': Opération non permise

Alors je l'ai fait en sudo, mais rien ne se passe:

[jax@jax8-pc ~]$ sudo rm -rf /tmp/*
[sudo] Mot de passe de jax :
[jax@jax8-pc ~]$

Le résultat de df -h est toujours le meme:

df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
dev 1,9G 0 1,9G 0% /dev
run 1,9G 1,2M 1,9G 1% /run
/dev/sda1 908G 783G 79G 91% /
tmpfs 1,9G 23M 1,9G 2% /dev/shm
tmpfs 1,9G 0 1,9G 0% /sys/fs/cgroup
tmpfs 1,9G 8,0K 1,9G 1% /tmp
tmpfs 389M 12K 389M 1% /run/user/1000

et toujours le même message lorsque je fais yaourt vivaldi-ffmpeg-codecs



Modifié par Yaxx le 28/01/2018 10:53
Publicité
Taras_Boulba
 Posté le 28/01/2018 à 12:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

donne le retour de free -m
depuis systemd, /tmp est automatiquement monté comme tmpfs sous arch même s'il n'y a aucune ligne correspondante dans fstab
fais voir aussi ton fstab cat /etc/fstab
tu peux allouer un plus grand espace à tmpfs dans le fstab si nécessaire, par défaut la taille de tmpfs est égale à la moitié de la quantité de ram

sinon, pourquoi tu ne changes pas le répertoire temporaire de yaourt comme je te l'ai dit ?
pour changer de façon temporaire, crée un répertoire sur ton home puis tape
yaourt --tmp /home/ton_user/dossier_temporaire -S vivaldi-ffmpeg-codecs

si c'est bon, pour changer de façon permanente, modifie la cible de TMPDIR= dans yaourtrc

quand on te donne plusieurs solutions, essaye les toutes stp avant de faire un retour



Modifié par Taras_Boulba le 28/01/2018 13:51
Taras_Boulba
 Posté le 28/01/2018 à 12:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

il veut utiliser vivaldi et puis on est sous linux et sous cet os on aime ben comprendre ce qui déconne. les solutions simplistes, c'est pour windows. surtout que je ne pense pas qu'il soit idiot au point de ne pas y avoir pensé lui même.

par ailleurs, s'il ne peut pas compiler avec yaourt des paquets AUR, il a un soucis qui ne se limite pas qu'à l'installation des codecs en question. il aura ce problème à chaque fois que yaourt devra compiler des paquets qui dépassent une certaine taille ou qu'il voudra compiler lui même donc il doit résoudre ce soucis qui évidemment a une solution.



Modifié par Taras_Boulba le 28/01/2018 13:25
Taras_Boulba
 Posté le 28/01/2018 à 14:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

tu fais semblant ou vraiment tu comprends pas ? yaourt n'arrive pas à compiler, c'est ça son problème maintenant. tu es sous linux au moins ?? je parie que non, vu tes commentaires. son problème avec vivaldi a mis en évidence un autre problème, plus embêtant. ça tu captes pas parce que tu ne comprends ce qu'il se passe. encore une fois on est pas sous windows. il est sous arch ou une dérivée d'arch, s'il n'arrive pas à compiler, il n'ira pas loin.

même un enfant aurait pu lui conseiller d'utiliser un autre navigateur mais ça ne résoudra pas son erreur avec yaourt. alors dis nous comment résoudre le problème yaourt ou arrête d'intervenir juste pour balancer des liens qui ne résoudront pas son problème avec le répertoire temporaire de yaourt. merci



Modifié par Taras_Boulba le 28/01/2018 15:01
R136a1
 Posté le 28/01/2018 à 17:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir

Vivaldi est un navigateur récent qui supporte le html5 comme tout navigateur qui se respecte

https://www.linuxtricks.fr/news/10-logiciels-libres/205-comparatif-html5-css3-js-de-firefox-chrome-opera-vivaldi-qupzilla-et-epiphany/

Il y a de forte chance que les ennuis de Yaxx proviennent de codecs non installés. Et même si ce n'est pas le cas, l'installation du navigateur n'est pas finalisé.

Yaxx
 Posté le 28/01/2018 à 18:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

C'est ok, c'est installé, à pressent je peux lire les vidéos sur différents sites, merci beaucoup

Mais j'ai pas très bien compris, maintenant j'ai deux répertoire tmp ?

Les commandes que tu m'a demandé, réalisé avant d'avoir crée le nouveau répertoire tmp de façon permanente, je ne sais plus si c'est encore utile:

free -m

total utilisé libre partagé tamp/cache disponible

Mem: 3875 1150 1436 128 1288 2413

Partition d'échange: 8542 0 8542

[watoz@plugzin8-pc ~]$ cat /etc/fstab

# /etc/fstab: static file system information.

#

# Use 'blkid' to print the universally unique identifier for a device; this may

# be used with UUID= as a more robust way to name devices that works even if

# disks are added and removed. See fstab(5).

#

# <file system> <mount point> <type> <options> <dump> <pass>

UUID=73cb6304-ced3-418f-8741-34bacf82cda3 / ext4 defaults,noatime 0 1

UUID=dfb359a4-ae8b-4d42-aa7b-ebb9af745fe2 swap swap defaults,noatime 0 0



Modifié par Yaxx le 28/01/2018 18:20
Taras_Boulba
 Posté le 28/01/2018 à 18:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

si tu as modifié yaourtrc, yaourt utilisera dorénavant le répertoire temporaire que tu as indiqué. mais ce n'est que yaourt qui utilisera se répertoire (pense à le vider régulièrement par contre, il ne le sera pas automatiquement comme /tmp). tu peux bien sûr toujours revenir à l'ancien paramétrage de yaourt quand tu veux.

pour free -m, c'était pour voir si ce n'était pas un problème de mémoire saturée puisque /tmp est monté comme tmpfs. pour cat /etc/fstab, c'était pour voir si il n'y avait pas un argument limitant la taille de tmpfs dans le fstab. ce sont seulement deux petite commande qui donnent des infos, elles ne modifient pas les fichiers systèmes.

Yaxx
 Posté le 28/01/2018 à 19:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'ai réussi a vider le répertoire tmp. j'ai fais comme ceci:

je suis allé dans le répertoire tmp clic droit > action> ouvrir un terminal ici

puis: sudo rm -rf /tmp/*

je suis retourné dans le répertoire tmp, il y avait des truc dedans, il est vide à présent:

https://image.noelshack.com/fichiers/2018/04/7/1517166346-screenshot-20180128-200358.png

Le répertoire tmp crée dans mon home me sert plus

Pour revenir à l' ancien paramétrage, je fais : yaourt --tmp/* ?

J’édite le fichier le fichier yaourtrc et je remets: TMPDIR="/tmp" ok

Si je reviens à l' ancien paramétrage, ca va pas virer le codec ?



Modifié par Yaxx le 28/01/2018 20:07
Taras_Boulba
 Posté le 28/01/2018 à 20:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

ce sera plutôt rm -rf /home/jax/tmp/* mais tu peux aussi vider /home/jax/tmp/ avec ton gestionnaire de fichier, tout simplement
/tmp est vidé à chaque redémarrage sous linux

pour revenir à l'ancien paramétrage de yaourt, tu as juste à remettre TMPDIR="/tmp"
et non ça ne virera rien.

par contre, je ne comprends pas pourquoi tu as ce problème d'espace quand yaourt compile en utilisant /tmp. tu as assez de ram et tmpfs peut utiliser ton swap si nécessaire.
faudrait que tu saches pourquoi tu as ce soucis, la solution que je t'ai donnée ne fait que contourner le problème, elle ne le résout pas. peut être que si Logicien passe par là...

edit : tu devrais poster sur le forum manjaro.fr pour savoir pourquoi tu as eu ce message signifiant que /tmp est saturé. ils y a des personnes très compétentes qui connaissent sur le bout des doigts manjaro : http://www.manjaro.fr/forum/index.php



Modifié par Taras_Boulba le 29/01/2018 20:19
Publicité
Yaxx
 Posté le 29/01/2018 à 22:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

En tout cas merci beaucoup Taras_Boulba

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
installer adobe flash player firefox
comment installer macromedia flash player
Installer flash player 7
replay et flash player
Debian - Iceweasel - Disposer de Flash Player 17 (avec Pipelight)
jeu demandant adobe flash player- quelle version 10.04 LTS ??
Que dois-je installer
flash player ubuntu 12.04
Adobe Flash Player ralenti sous Ubuntu ...
Flash player sous ubuntu 10.04
Plus de sujets relatifs à Vivaldi, que dois je installer en plus de Flash Player ?
 > Tous les forums > Forum Linux