> Tous les forums > Forum Linux
 Wine ne fonctionne qu'en SUSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 05/10/2014 @ 11:35 
Aller en bas de la page 
Astucien

Bonjour,

Je tourne sous Archlinux 64 bits + gnome (3.12.1) et j'ai installé multilib dans mon pacman.conf

J'ai installé wine (version 64 bits = pour faire tourner quelques programmes Windows (version de wine mise à jour avant-hier : -rw-r--r-- 1 root root 38856216 3 oct 17:18 wine-1.7.28-1-x86_64.pkg.tar.xz)

Vérification faite, je trouve bien /usr/bin/wine qui appartient à root :

-rwxr-xr-x 1 root root 9728 3 oct 16:08 wine

J'ai créé des lanceurs avec la commande : par exemple : gnome-desktop-item-edit ~/.local/share/applications/poppeeper.desktop

Puis, j'ai fait un copier/coller de poppeeper.desktop pour qu'il apparaisse sur mon bureau gnome sous le nom de Pop Peeper (la petite boîte-aux-lettres) :

Image

Ensuite, j'ai configuré l'icône pour que la commande wine pointe vers l'exécutable.exe qui se trouve donc dans ~/.local/share/applications/.

Problème : ça ne marche que si je fais précéder wine par sudo (j'ai modifié sudoers en sorte que je ne doive pas fournir mon mot de passe (NOPASSWD:).

Si je ne mets pas sudo devant wine, rien ne se passe.

Avez-vous une explication à cela car, selon le wiki, il n'est pas nécessaire de lancer wine en SU.

Merci d'avance.

Publicité
Mori
 Posté le 05/10/2014 à 22:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

non, je n'ai aucune explication à cela...

sinon dans ton schéma impeccable sur le tout sécuritaire, il manque une dernière étape : carrément supprimer le compte utilisateur et te connecter directement en root... plus de problème de sudo et de saisie de mot de passe.

tu joues un peu avec le feu là non ?

Mimile
 Posté le 06/10/2014 à 10:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Mori,

Merci pour ton message.

Pour tout dire, j'avais tout d'abord posté mon problème sur le forum Archlinuxfr.

N'obtenant pas de réponses valides, j'ai aussi posté ici.

J'ai finalement obtenu la solution (sur le forum Arch) consistant simplement à supprimer le fichier ~/.wine (ou à le renommer, ce que j'ai fait pour conserver les programmes qui s'y trouvaient).

Au redémarrage de wine, ce fichier absent a été recréé et j'y ai recopié les programmes en question.

Dès lors, plus besoin de sudo pour le faire fonctionner.

Si tu veux en savoir davantage, voici le lien sur Arch : https://forums.archlinux.fr/topic15953.html

Amicalement

PS : il est vrai que permettre l'utilisation de sudo sans devoir mettre le mot de passe présente un certain risque mais c'est beaucoup plus confortable.

En outre, qui pourrait bien s'intéresser à moi pour y puiser Dieu sait quelle information ? Je précise que je fonctionne ainsi sous Linux depuis des années sans avoir jamais rencontré de problème.



Modifié par Mimile le 06/10/2014 10:40
Logicien
 Posté le 06/10/2014 à 17:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Moi aussi les utilisateurs dans le groupe wheel fonctionnent sans mot-de-passe en utilisant sudo. Il n'y a aucune mise-en-garde dans le fichier /etc/sudoers. Je n'ai jamais eu connaissance de problème sécurité avec mes systèmes Linux à ce sujet.

En survolant la page de manuel sudoers, je vois que le fichier /etc/sudoers peut être configuré de façon très sophistiquée. On décrit les impacts sur la sécurité.

Pour obtenir les droits root, un pirate a la tâche facilité s'il n'a pas à fournir de mot-de-passe pour utiliser sudo après avoir s'être rendu maître d'un compte utilisateur non root.

C'est pourquoi, du point de vue de la sécurité, il ne faut permettre qu'à des utilisateurs de confiance d'utiliser sudo et à plus forte raison sans mot-de-passe. En toute logique, ces utilisateurs doivent avoir les mêmes intérêts que root en matière de sécurité.

Bonne journée.



Modifié par Logicien le 07/10/2014 18:42
Mimile
 Posté le 07/10/2014 à 17:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Paul

Etant le seul utilisateur de mon PC et ne pouvant démarrer Arch ou Wheezy que moyennant indication de mon mot de passe, je pense ne courir aucun risque du point de vue sécurité.

Même mon épouse ne connaît pas ce mot de passe et de toute façon, elle ne s'intéresse pas du tout à Linux (elle a déjà du mal avec Win XP qu'elle utilise pourtant depuis des années )

Amitiés

Mimile

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
Ecran PC 27 pouces KTC H27V13 (VA, Full HD, 100 Hz) à 99,99 €
99,99 € 149 € -33%
@Geekbuying
Station de charge portable ECOFLOW Delta Max 2016Wh/2400W à 699 €
699 € 1299 € -46%
@Amazon
PC portable 15.6 pouces Dell Inspiron G15 (FHD 120Hz, Core i7, 16 Go DDR5, SSD 512 Go, GeForce RTX 4060) à 999 €
999,00 € 1349 € -26%
@Amazon
Smartphone 6.7 pouces Apple iPhone 14 Plus 128 Go 5G à 664,05 €
664,05 € 799 € -17%
@Amazon
Tondeuse à gazon électrique Bosch ARM 32 (+lame supplémentaire) à 88,99 €
88,99 € 109,99 € -19%
@Amazon
Montre GPS Multisports Garmin Fenix 7 Pro Solar à 519,99 €
519,99 € 749,99 € -31%
@Amazon

Sujets relatifs
Le serveur X11VNC fonctionne bien !
Problème pour installer fichier msi. avec Wine
PCRegdit ne fonctionne pas.
[Newbie] Live USB ne fonctionne pas :'(
Wine : comportement bizarre
Est-ce que la sortie audio Hdmi fonctionne?
Wine et dll absentes ? (K-12.04)
LibreOffice ne fonctionne plus sous Arch
javac ne fonctionne pas sous ubuntu 10.04
faire tourner paint shop pro 10 dans wine
Plus de sujets relatifs à Wine ne fonctionne qu''en SU
 > Tous les forums > Forum Linux