> Tous les forums > Forum Bureautique
 Word, publipostage et mise en forme des données excel
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Lui
  Posté le 27/10/2013 @ 11:51 
Aller en bas de la page 
Petit astucien

Bonjour,

Le résultat d'une cellule excel, s'affiche dans word après publipostage sous la forme 1.123456789
Ne souhaitant que 4 chiffres après la virgule, j'ai trouvé l'astuce sur le net de modifier le code comme tel:
L'ajout de \##0,#### produit bien ce que je souhaite.

Ma question est de savoir si on peut dire à word de faire ça pour toutes les autres données.
Car si je modifie et que je souhaite insérer le résultat d'une autre cellule, je dois refaire le formatage.

Merci

Publicité
gilbert_rgi
 Posté le 27/10/2013 à 16:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour

Pourquoi ne pas modifier le format des cellules du Classeur Excel?

selectionner la ou les colonnes puis faire Format personnalisé 0,0000



Modifié par gilbert_rgi le 27/10/2013 16:27
Lui
 Posté le 27/10/2013 à 18:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Hello ,

Dans excel, le format est correct. Une fois arrivé dans word, l'arrondi à 4 chiffres ne se fait plus, word prend toute la chaîne
de caractères sans se soucier du format mis dans excel.
D'où l'astuce du \##0,#### .

Mais c'est gonflant de le faire à chaque fois, j'aurais aimé que word le retienne une fois pour toutes.

Kerlouan
 Posté le 27/10/2013 à 18:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Merci pour les conseils Sujet résolu et à fermer mais je n'ai pas vu comment on fait pour fermer le sujet

Modifié par Kerlouan le 27/10/2013 18:22
Lui
 Posté le 27/10/2013 à 18:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Kerlouan a écrit :
Merci pour les conseils Sujet résolu et à fermer mais je n'ai pas vu comment on fait pour fermer le sujet

Héhé, normal, c'est ton sujet que tu dois mettre en "résolu" et pas le mien

Gabrilou
 Posté le 27/10/2013 à 19:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Vérifier si la case est cochée dans :

Outils, Options, Général, "Confirmer les conversions à l'ouverture"

A+

Lui
 Posté le 27/10/2013 à 19:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Gabrilou a écrit :

Vérifier si la case est cochée dans :

Outils, Options, Général, "Confirmer les conversions à l'ouverture"

A+

Merci, oui la case est bien cochée.


Gabrilou
 Posté le 27/10/2013 à 19:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Voir le site de m@rina :

La première solution consiste à utiliser non plus le protocole OLE, mais le protocole DDE :

Word 2002-2003
Word 2007
Word 2010

Dans le menu Outils, Options, Général, cocher la case "Confirmer les conversions à l'ouverture"

  • Bouton Office, Options Word
  • A gauche : Options avancées
  • A droite : dans la rubrique Général (en bas), cocher l'option "Confirmer la conversion du format de fichier lors de l'ouverture"

  • Atteindre le BackStage à l'aide de l'Onglet Fichier
  • Options
  • A gauche : Options avancées
  • A droite : dans la rubrique Général (en bas), cocher l'option "Confirmer la conversion du format de fichier lors de l'ouverture"

Lors de l'ouverture de la source de donnée, il sera alors proposé de confirmer la conversion : choisir "via DDE".

Sur Excel, la base de données doit être sur la première feuille du fichier.

http://www.faqword.com/index.php/word/faq-word/publipostage/412-lors-dune-fusion-et-publipostage-avec-word-et-excel-versions-a-partir-de-xp-word-transforme-les-champs-date-en-format-americain-par-ailleurs-le-resultat-fusionne-des-champs-numeriques-donne-un-nombre-important-de-decimales

Lui
 Posté le 27/10/2013 à 20:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci d'avoir chercher pour moi, mais ça ne convient pas, "choisir base DDE", enlève le libellé des cellules, et je me retrouve avec des résultats qui ne correspondent plus
à la feuille excel
.
Dans le lien que tu donnes, il est dit :
"Une autre solution consiste à imposer des formats dans les champs du document Word, en ajoutant des commutateurs d'image numérique ou de date :
Affichez les codes de champ en appuyant sur les touches ALT + F9
Ajouter un commutateur de format tel que :
\@ "dd MM yyyy" (pour une date)
\# "# ###,00" (pour afficher un nombre avec 2 décimales)
*100\# "#,00 %" (pour afficher un pourcentage)"

Je pense que je vais continué comme ça, il ne semble pas y avoir de meilleur solution.
Bonne soirée


Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Coller des données brutes de mise en forme dans Excel/Word
Publipostage Données Excel 2003 vers Word 2003 SOS
Mise en forme conditionnelle Excel 2010
Excel 2007 extraction feuille 1 dans feuille 2 avec mise en forme
Transfert de données Excel/Word sur tablette Samssung
publipostage avec liste de données sous excel
Mise en forme conditionnelle Excel
Excel 2007 mise en forme conditionnelle
Word reveler mise en forme
Mise en forme conditionnelle excel 2013 ne marche pas
Plus de sujets relatifs à Word, publipostage et mise en forme des données excel
 > Tous les forums > Forum Bureautique